15:30:21 <fao89> #startmeeting Pulp Triage 2020-01-14
15:30:21 <fao89> #info fao89 has joined triage
15:30:21 <fao89> !start
15:30:21 <pulpbot> Meeting started Tue Jan 14 15:30:21 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:21 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:21 <pulpbot> The meeting name has been set to 'pulp_triage_2020-01-14'
15:30:21 <pulpbot> fao89: fao89 has joined triage
15:30:40 <dawalker> #info dawalker has joined triage
15:30:40 <dawalker> !here
15:30:40 <pulpbot> dawalker: dawalker has joined triage
15:30:48 <fao89> !next
15:30:49 <pulpbot> fao89: 10 issues left to triage: 5982, 5981, 5977, 5976, 5973, 5968, 5967, 5966, 5965, 5964
15:30:49 <fao89> #topic https://pulp.plan.io/issues/5982
15:30:50 <pulpbot> RM 5982 - osapryki - NEW - Race condition in RepositoryVersion.new_version()
15:30:51 <pulpbot> https://pulp.plan.io/issues/5982
15:30:59 <daviddavis> #info daviddavis has joined triage
15:30:59 <daviddavis> !here
15:30:59 <pulpbot> daviddavis: daviddavis has joined triage
15:31:23 <ttereshc> #info ttereshc has joined triage
15:31:23 <ttereshc> !here
15:31:23 <pulpbot> ttereshc: ttereshc has joined triage
15:31:30 <fao89> #idea Proposed for #5982: Leave the issue as-is, accepting its current state.
15:31:30 <fao89> !propose accept
15:31:30 <pulpbot> fao89: Proposed for #5982: Leave the issue as-is, accepting its current state.
15:31:35 <bmbouter> #info bmbouter has joined triage
15:31:35 <bmbouter> !here
15:31:35 <pulpbot> bmbouter: bmbouter has joined triage
15:31:38 <ppicka> #info ppicka has joined triage
15:31:38 <ppicka> !here
15:31:38 <pulpbot> ppicka: ppicka has joined triage
15:31:54 <dawalker> +1
15:32:43 <daviddavis> hmm I wonder if we should also add to sprint
15:33:05 <dawalker> if anyone's got capacity, it's important
15:33:39 <daviddavis> although bmbouter's comment seems to make it less urgent
15:33:57 <ttereshc> what is the use case? when does user run into this issue?
15:34:03 <dawalker> good point
15:34:16 <daviddavis> ttereshc: I think if the plugin writer doesn't properly serialize and lock tasks on repo
15:34:32 <daviddavis> when creating repo versions
15:34:35 <ttereshc> yeah
15:34:40 <ttereshc> that makes sense
15:34:43 <daviddavis> let's accept I think but not add it to sprint
15:34:48 <dawalker> +1
15:34:51 <ttereshc> +1
15:34:59 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:34:59 <fao89> !accept
15:35:01 <fao89> #topic https://pulp.plan.io/issues/5981
15:35:01 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:35:02 <pulpbot> fao89: 9 issues left to triage: 5981, 5977, 5976, 5973, 5968, 5967, 5966, 5965, 5964
15:35:03 <pulpbot> RM 5981 - ttereshc - NEW - Migration fails if the same repo is migrated again with different name in pulp3
15:35:04 <pulpbot> https://pulp.plan.io/issues/5981
15:35:24 <ttereshc> we can skip it, I'llmove it to the migration plugin project
15:35:37 <ttereshc> I plan to create it after the meeting
15:35:44 <fao89> !next
15:35:45 <pulpbot> fao89: 8 issues left to triage: 5977, 5976, 5973, 5968, 5967, 5966, 5965, 5964
15:35:46 <fao89> #topic https://pulp.plan.io/issues/5977
15:35:46 <dawalker> +1
15:35:47 <pulpbot> RM 5977 - ipanova@redhat.com - NEW - Migrated Content counters are wrong
15:35:48 <pulpbot> https://pulp.plan.io/issues/5977
15:35:51 <ttereshc> same
15:35:56 <fao89> !next
15:35:57 <pulpbot> fao89: 7 issues left to triage: 5976, 5973, 5968, 5967, 5966, 5965, 5964
15:35:57 <fao89> #topic https://pulp.plan.io/issues/5976
15:35:58 <pulpbot> RM 5976 - ipanova@redhat.com - NEW - Migrate only content from the specified repositories
15:35:59 <pulpbot> https://pulp.plan.io/issues/5976
15:36:04 <ttereshc> same :)
15:36:10 <fao89> hahaha
15:36:14 <fao89> !next
15:36:15 <pulpbot> fao89: 6 issues left to triage: 5973, 5968, 5967, 5966, 5965, 5964
15:36:16 <fao89> #topic https://pulp.plan.io/issues/5973
15:36:16 <ipanova> #info ipanova has joined triage
15:36:16 <ipanova> !here
15:36:17 <pulpbot> RM 5973 - toffe - NEW - pulp-python causes ansible-pulp to fail at "RUNNING HANDLER [pulp : Collect static content]"
15:36:18 <pulpbot> https://pulp.plan.io/issues/5973
15:36:19 <pulpbot> ipanova: ipanova has joined triage
15:36:46 <dalley> #info dalley has joined triage
15:36:46 <dalley> !here
15:36:46 <pulpbot> dalley: dalley has joined triage
15:37:13 <dalley> pulp python issue
15:37:30 <daviddavis> #idea Proposed for #5973: move to pulp_python
15:37:30 <daviddavis> !propose other move to pulp_python
15:37:30 <pulpbot> daviddavis: Proposed for #5973: move to pulp_python
15:37:41 <fao89> #agreed move to pulp_python
15:37:41 <fao89> !accept
15:37:42 <pulpbot> fao89: Current proposal accepted: move to pulp_python
15:37:43 <fao89> #topic https://pulp.plan.io/issues/5968
15:37:43 <pulpbot> fao89: 5 issues left to triage: 5968, 5967, 5966, 5965, 5964
15:37:44 <pulpbot> RM 5968 - gmbnomis - NEW - Actually implement filters for PublicationViewset
15:37:45 <pulpbot> https://pulp.plan.io/issues/5968
15:37:55 <daviddavis> accept
15:38:12 <daviddavis> or actually convert to task
15:38:42 <fao89> #idea Proposed for #5968: convert to a task
15:38:42 <fao89> !propose other convert to a task
15:38:42 <pulpbot> fao89: Proposed for #5968: convert to a task
15:39:01 <fao89> #agreed convert to a task
15:39:01 <fao89> !accept
15:39:01 <pulpbot> fao89: Current proposal accepted: convert to a task
15:39:02 <fao89> #topic https://pulp.plan.io/issues/5967
15:39:03 <pulpbot> fao89: 4 issues left to triage: 5967, 5966, 5965, 5964
15:39:04 <pulpbot> RM 5967 - daviddavis - NEW - Nightly builds of pulp_file are broken
15:39:05 <pulpbot> https://pulp.plan.io/issues/5967
15:39:16 <daviddavis> accept and add to sprint
15:39:25 <ttereshc> +1
15:39:40 <fao89> #idea Proposed for #5967: accept and add to sprint
15:39:40 <fao89> !propose other accept and add to sprint
15:39:40 <pulpbot> fao89: Proposed for #5967: accept and add to sprint
15:39:43 <fao89> #agreed accept and add to sprint
15:39:43 <fao89> !accept
15:39:43 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:39:44 <pulpbot> fao89: 3 issues left to triage: 5966, 5965, 5964
15:39:45 <fao89> #topic https://pulp.plan.io/issues/5966
15:39:45 <pulpbot> RM 5966 - gmbnomis - NEW - Documented workflows need to be updated
15:39:47 <pulpbot> https://pulp.plan.io/issues/5966
15:40:05 <ttereshc> accept
15:40:12 <daviddavis> +1
15:40:15 <ttereshc> I ran into it today and wanted to file an issue :)
15:40:27 <fao89> #idea Proposed for #5966: Leave the issue as-is, accepting its current state.
15:40:27 <fao89> !propose accept
15:40:27 <pulpbot> fao89: Proposed for #5966: Leave the issue as-is, accepting its current state.
15:40:42 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:40:42 <fao89> !accept
15:40:42 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:40:44 <fao89> #topic https://pulp.plan.io/issues/5965
15:40:44 <pulpbot> fao89: 2 issues left to triage: 5965, 5964
15:40:45 <pulpbot> RM 5965 - gmbnomis - NEW - FileContentFilter defines a "digest" filter, but there is no "digest" field in the API
15:40:46 <pulpbot> https://pulp.plan.io/issues/5965
15:41:16 <daviddavis> definitely accept. maybe add to sprint too?
15:41:33 <dalley> easyfix also?
15:41:34 <ttereshc> daviddavis, +1 but what to do with it?
15:41:59 <daviddavis> remove it I think
15:42:23 <fao89> #idea Proposed for #5965: accept and add to sprint
15:42:23 <fao89> !propose other accept and add to sprint
15:42:23 <pulpbot> fao89: Proposed for #5965: accept and add to sprint
15:42:29 <ttereshc> is it ok according to semver? It doesn't work anyway though
15:42:53 <daviddavis> I think so. semver allows backwards incompatible changes in order to fix bugs.
15:42:54 <bmbouter> if it was already broken it'll be a bugfix and removal is an ok bugfix
15:43:03 <bmbouter> what daviddavis said :)
15:43:16 <ttereshc> +1
15:43:25 <fao89> #agreed accept and add to sprint
15:43:25 <fao89> !accept
15:43:25 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:43:26 <pulpbot> fao89: 1 issues left to triage: 5964
15:43:27 <fao89> #topic https://pulp.plan.io/issues/5964
15:43:27 <pulpbot> RM 5964 - gmbnomis - NEW - pulpcore.plugin.repo_version_utils.remove_duplicates does not handle base_version != None correctly.
15:43:28 <pulpbot> https://pulp.plan.io/issues/5964
15:43:55 <daviddavis> this would be a nice fix for 3.1
15:44:46 <dalley> we should also probably add a test for ^^
15:44:56 <ttereshc> did we have something similar filed already? I thought we had
15:45:56 <ttereshc> can't find it
15:45:57 <daviddavis> I've filed and seen so many pulp 3 issues that I've given up hope of ever trying to match them against new issues
15:46:47 <ttereshc> +1 to accept the issue
15:46:54 <fao89> accept and add 3.1 milestone?
15:46:55 <daviddavis> +1
15:47:11 <daviddavis> err, let's just accept and I can go over it with bmbouter
15:47:16 <fao89> #idea Proposed for #5964: Leave the issue as-is, accepting its current state.
15:47:16 <fao89> !propose accept
15:47:16 <pulpbot> fao89: Proposed for #5964: Leave the issue as-is, accepting its current state.
15:47:21 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:47:21 <fao89> !accept
15:47:21 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:47:22 <pulpbot> fao89: No issues to triage.
15:47:34 <fao89> Open floor!
15:48:21 <fao89> !pulp
15:48:21 <pulpbot> 🍊 Yay, Pulp! 🍊 Go team go! 🍊
15:48:22 <bmbouter> 3.0.1 is on schedule to go out today, I'll announce to pulp-list when it does
15:48:55 <bmbouter> it would be cool if we can get the meetings part of the website more up to date
15:49:43 <daviddavis> I agree
15:49:59 <dkliban> i had an action item to move all our meetings to #pulp-meeting and i have not finished doing that
15:50:11 <bmbouter> that would also be cool
15:50:58 <bmbouter> I've been debugging a lot of authN stuff w/ jsherrill and their use of REMOTE_USER and I think it's pretty screwed up
15:51:15 <dkliban> which part is screwed up?
15:51:47 <jsherrill> bmbouter: i did just find this:  https://code.djangoproject.com/ticket/28699  curious if you've tried any of those suggestions, had to join a mtg right after i found it but it seems promising ?
15:52:13 <bmbouter> the RemoteUserAuthentication requires csrf but we're an API not forms so you never have a CSRF to submit
15:52:43 <bmbouter> wow that does look compelling jsherrill
15:52:56 <jsherrill> its describing our exact problem
15:52:58 <bmbouter> anyway this is more like an FYI
15:53:15 <jsherrill> it seems like it got more hairy recently
15:53:26 <dkliban> jsherrill: bmbouter: this is exactly our problem
15:53:31 <dkliban> and it looks like a simple fix
15:54:22 <bmbouter> what is the simple fix?
15:54:42 <dkliban> bmbouter: lol ... now that i scrolled down all the way, i don't know of one
15:54:55 <dkliban> i thought we needed to rearange the order of middleware
15:55:14 <bmbouter> so the investigation continues
15:55:21 <bmbouter> I wanted to let others know about this area of issue
15:55:31 <dkliban> thank you
15:55:37 <bmbouter> when I need more input or if we reach a resolution I'll also email the list
15:55:55 <bmbouter> speaking of emailing the list I was hoping we could put this into 3.1 https://pulp.plan.io/issues/5974
15:56:02 <bmbouter> if gmbnomis acks the design
16:00:04 <dkliban> that looks like a good story
16:01:26 <dkliban> bmbouter: i was looking at this comment when i said there is an easy fix https://code.djangoproject.com/ticket/28699#comment:7
16:01:44 <dkliban> but i would want to know why this change in order ocurred
16:04:56 <dkliban> anyway, i am curious to hear what you learn from your debugging
16:05:04 <bmbouter> I will share
16:05:19 <fao89> #endmeeting
16:05:19 <fao89> !end