15:31:41 <fao89> #startmeeting Pulp Triage 2020-01-17
15:31:41 <fao89> #info fao89 has joined triage
15:31:41 <fao89> !start
15:31:41 <pulpbot> Meeting started Fri Jan 17 15:31:41 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:41 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:31:41 <pulpbot> The meeting name has been set to 'pulp_triage_2020-01-17'
15:31:41 <pulpbot> fao89: fao89 has joined triage
15:31:46 <bmbouter> #info bmbouter has joined triage
15:31:46 <bmbouter> !here
15:31:46 <pulpbot> bmbouter: bmbouter has joined triage
15:31:48 <ggainey-wfh> #info ggainey-wfh has joined triage
15:31:48 <ggainey-wfh> !here
15:31:48 <pulpbot> ggainey-wfh: ggainey-wfh has joined triage
15:31:51 <fao89> !next
15:31:52 <pulpbot> fao89: 8 issues left to triage: 5998, 5996, 5995, 5994, 5993, 5991, 5989, 5985
15:31:52 <fao89> #topic https://pulp.plan.io/issues/5998
15:31:53 <pulpbot> RM 5998 - daviddavis - NEW - Workflow docs should better advise users they need httpie and jq
15:31:54 <pulpbot> https://pulp.plan.io/issues/5998
15:32:08 <fao89> #idea Proposed for #5998: Leave the issue as-is, accepting its current state.
15:32:08 <fao89> !propose accept
15:32:08 <pulpbot> fao89: Proposed for #5998: Leave the issue as-is, accepting its current state.
15:32:36 <dkliban> #info dkliban has joined triage
15:32:36 <dkliban> !here
15:32:36 <pulpbot> dkliban: dkliban has joined triage
15:32:48 <dkliban> +1
15:33:02 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:33:02 <fao89> !accept
15:33:02 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:33:03 <pulpbot> fao89: 7 issues left to triage: 5996, 5995, 5994, 5993, 5991, 5989, 5985
15:33:03 <fao89> #topic https://pulp.plan.io/issues/5996
15:33:04 <pulpbot> RM 5996 - mdepaulo@redhat.com - NEW - As a user, I can easily stop/start/restart all Pulp services on a box via a systemd multi-service app
15:33:05 <pulpbot> https://pulp.plan.io/issues/5996
15:33:44 <fao89> #idea Proposed for #5996: convert to a task
15:33:44 <fao89> !propose other convert to a task
15:33:44 <pulpbot> fao89: Proposed for #5996: convert to a task
15:34:01 <bmbouter> convert to story?
15:34:05 <dkliban> +1
15:34:08 <fao89> #idea Proposed for #5996: convert to a story
15:34:08 <fao89> !propose other convert to a story
15:34:08 <pulpbot> fao89: Proposed for #5996: convert to a story
15:34:13 <fao89> #agreed convert to a story
15:34:13 <fao89> !accept
15:34:13 <pulpbot> fao89: Current proposal accepted: convert to a story
15:34:14 <fao89> #topic https://pulp.plan.io/issues/5995
15:34:14 <pulpbot> fao89: 6 issues left to triage: 5995, 5994, 5993, 5991, 5989, 5985
15:34:15 <pulpbot> RM 5995 - evgeni - NEW - filecontext conflict with pulp2
15:34:16 <pulpbot> https://pulp.plan.io/issues/5995
15:34:47 <fao89> #idea Proposed for #5995: Leave the issue as-is, accepting its current state.
15:34:47 <fao89> !propose accept
15:34:47 <pulpbot> fao89: Proposed for #5995: Leave the issue as-is, accepting its current state.
15:34:51 <bmbouter> +1
15:35:10 <bmbouter> I'm doing some groundwork on these 3 SELinux issues so I think we should just acccept and not add to sprint ATM
15:35:17 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:35:17 <fao89> !accept
15:35:17 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:35:18 <pulpbot> fao89: 5 issues left to triage: 5994, 5993, 5991, 5989, 5985
15:35:18 <fao89> #topic https://pulp.plan.io/issues/5994
15:35:19 <pulpbot> RM 5994 - evgeni - NEW - Name clash with the SELinux policy for Pulp2
15:35:20 <pulpbot> https://pulp.plan.io/issues/5994
15:35:21 <bmbouter> same
15:35:25 <dkliban> +1
15:35:28 <fao89> #idea Proposed for #5994: Leave the issue as-is, accepting its current state.
15:35:28 <fao89> !propose accept
15:35:28 <pulpbot> fao89: Proposed for #5994: Leave the issue as-is, accepting its current state.
15:35:35 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:35:36 <fao89> !accept
15:35:36 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:35:37 <pulpbot> fao89: 4 issues left to triage: 5993, 5991, 5989, 5985
15:35:37 <fao89> #topic https://pulp.plan.io/issues/5993
15:35:38 <pulpbot> RM 5993 - evgeni - NEW - SELinux policy does not compile on CentOS7
15:35:39 <pulpbot> https://pulp.plan.io/issues/5993
15:35:41 <bmbouter> same
15:35:52 <fao89> #idea Proposed for #5993: Leave the issue as-is, accepting its current state.
15:35:52 <fao89> !propose accept
15:35:52 <pulpbot> fao89: Proposed for #5993: Leave the issue as-is, accepting its current state.
15:35:53 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:35:53 <fao89> !accept
15:35:54 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:35:54 <fao89> #topic https://pulp.plan.io/issues/5991
15:35:55 <pulpbot> fao89: 3 issues left to triage: 5991, 5989, 5985
15:35:56 <pulpbot> RM 5991 - jsherril@redhat.com - NEW - Sync fails with  TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
15:35:57 <pulpbot> https://pulp.plan.io/issues/5991
15:36:20 <bmbouter> without a clear reproducer I don't think we can continue on 5991
15:36:27 <bmbouter> from an effort perspective
15:36:49 <bmbouter> I'd like to hear what daviddavis thinks tho so I propose we skip for now
15:37:43 <dkliban> seems like  a networking problem to me ... but it's just a guess
15:37:54 <dkliban> and it's being poorly handled by the libraries
15:38:06 <bmbouter> agreed it's going to be some intermittent failure scenario
15:38:10 <fao89> !skip
15:38:11 <pulpbot> fao89: 2 issues left to triage: 5989, 5985
15:38:11 <fao89> #topic https://pulp.plan.io/issues/5989
15:38:12 <pulpbot> RM 5989 - toffe - NEW - Issue when syncing from Pulp to Pulp
15:38:13 <pulpbot> https://pulp.plan.io/issues/5989
15:38:21 <dkliban> oooo
15:38:56 <dkliban> let's accept and add to sprint
15:39:02 <bmbouter> this is a great file!
15:39:08 <bmbouter> open source ftw
15:39:10 <bmbouter> +1
15:39:34 <fao89> #idea Proposed for #5989: accept and add to sprint
15:39:34 <fao89> !propose other accept and add to sprint
15:39:35 <pulpbot> fao89: Proposed for #5989: accept and add to sprint
15:39:36 <daviddavis> #info daviddavis has joined triage
15:39:36 <daviddavis> !here
15:39:37 <pulpbot> daviddavis: daviddavis has joined triage
15:39:41 <fao89> #agreed accept and add to sprint
15:39:41 <fao89> !accept
15:39:41 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:39:42 <daviddavis> should this be a pulp_rpm issue?
15:39:42 <fao89> #topic https://pulp.plan.io/issues/5985
15:39:43 <pulpbot> fao89: 1 issues left to triage: 5985
15:39:44 <pulpbot> RM 5985 - bmbouter - NEW - Status API reports incorrect versions installed for dev environments
15:39:45 <pulpbot> https://pulp.plan.io/issues/5985
15:39:47 <bmbouter> it should be
15:39:54 <bmbouter> 5989 should be pulp_rpm
15:40:00 <dkliban> eah
15:40:05 <fao89> I will change to RPM
15:40:12 <bmbouter> ty
15:40:35 <bmbouter> 5989 I filed, its low prio so I propose accept only
15:40:43 <daviddavis> does 5985 affect prod envs?
15:40:52 <daviddavis> or is it just for dev envs
15:40:53 <bmbouter> my testing suggested it does not
15:40:55 <bmbouter> just dev envs
15:40:58 <daviddavis> ok, I agree then
15:41:33 <fao89> #idea Proposed for #5985: Leave the issue as-is, accepting its current state.
15:41:33 <fao89> !propose accept
15:41:33 <pulpbot> fao89: Proposed for #5985: Leave the issue as-is, accepting its current state.
15:41:38 <daviddavis> 461050
15:41:42 <daviddavis> oops
15:41:43 <bmbouter> 539291
15:41:47 <daviddavis> hah
15:42:45 <fao89> accept?
15:42:49 <daviddavis> yes
15:42:53 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:42:53 <fao89> !accept
15:42:53 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:42:55 <pulpbot> fao89: No issues to triage.
15:43:07 <daviddavis> want to go back to 5991?
15:43:09 <fao89> !issue 5991
15:43:10 <fao89> #topic https://pulp.plan.io/issues/5991
15:43:10 <pulpbot> RM 5991 - jsherril@redhat.com - NEW - Sync fails with  TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
15:43:12 <pulpbot> https://pulp.plan.io/issues/5991
15:43:12 <bmbouter> daviddavis: did you want to comment on 5991?
15:43:18 <bmbouter> haha yeah
15:43:31 <daviddavis> I don't know I have anything other to add than that I did dig through the code and didn't find anything
15:43:34 <daviddavis> anything obvious
15:43:54 <daviddavis> I am concerned that there's been 4 reports in the past month though
15:44:20 <bmbouter> I agree
15:44:30 <dkliban> daviddavis: my search of the web tells me it's a connection problem. most likely due to trying to connect over ip v 6
15:44:39 <daviddavis> oh interesting
15:44:43 <bmbouter> but with so much work that we can reproduce I don't think we can afford to spend time randomly trying to reproduce
15:44:46 <dkliban> https://github.com/pypa/pip/issues/4779
15:45:04 <daviddavis> bmbouter: agreed
15:45:04 <bmbouter> nice find
15:45:20 <bmbouter> can we respond to the foreman thread with that info?
15:45:33 <bmbouter> and ask them to come back with additional details about a reproducer?
15:45:49 <dkliban> the additional details we want ot know is what python packages they have installed
15:46:19 <bmbouter> that would be good, but without a reproduction steps that info won't get us far
15:46:21 <dkliban> i think requests is messed up on those boxes
15:46:32 <dkliban> python-requsts that is
15:46:46 <bmbouter> let's give them that info also on the foreman thread
15:46:58 <daviddavis> I asked for requests version info here but never got a response https://community.theforeman.org/t/foreman-proxy-content-not-synchronising/16774/3?u=daviddavis
15:47:33 <daviddavis> I can follow up and ask again
15:47:39 <daviddavis> and post the thread
15:47:41 <dkliban> yeah ... that's important information
15:48:34 <bmbouter> daviddavis: that sounds good. and we skip for now to wait and see for a few weeks?
15:49:21 <daviddavis> +1
15:49:47 <fao89> !skip
15:49:48 <pulpbot> fao89: No issues to triage.
15:49:54 <fao89> Open floor!
15:51:18 <fao89> #endmeeting
15:51:18 <fao89> !end