15:30:05 <fao89> #startmeeting Pulp Triage 2020-01-21
15:30:05 <fao89> #info fao89 has joined triage
15:30:05 <fao89> !start
15:30:05 <pulpbot> Meeting started Tue Jan 21 15:30:05 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:05 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:05 <pulpbot> The meeting name has been set to 'pulp_triage_2020-01-21'
15:30:05 <pulpbot> fao89: fao89 has joined triage
15:30:32 <fao89> !next
15:30:33 <pulpbot> fao89: 3 issues left to triage: 6025, 6016, 5991
15:30:33 <fao89> #topic https://pulp.plan.io/issues/6025
15:30:34 <pulpbot> RM 6025 - binlinf0 - NEW - Pulp 3.0 remote cert sha256 value doesn't match the input or the cert
15:30:35 <pulpbot> https://pulp.plan.io/issues/6025
15:30:45 <dkliban> #info dkliban has joined triage
15:30:45 <dkliban> !here
15:30:45 <pulpbot> dkliban: dkliban has joined triage
15:30:51 <daviddavis> #info daviddavis has joined triage
15:30:51 <daviddavis> !here
15:30:51 <pulpbot> daviddavis: daviddavis has joined triage
15:31:05 <fao89> #idea Proposed for #6025: Leave the issue as-is, accepting its current state.
15:31:05 <fao89> !propose accept
15:31:05 <pulpbot> fao89: Proposed for #6025: Leave the issue as-is, accepting its current state.
15:31:37 <dkliban> #idea Proposed for #6025: accept and add to sprint
15:31:37 <dkliban> !propose other accept and  add to sprint
15:31:37 <pulpbot> dkliban: Proposed for #6025: accept and add to sprint
15:31:45 <daviddavis> +1
15:31:53 <fao89> #agreed accept and add to sprint
15:31:53 <fao89> !accept
15:31:53 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:31:54 <fao89> #topic https://pulp.plan.io/issues/6016
15:31:54 <pulpbot> fao89: 2 issues left to triage: 6016, 5991
15:31:55 <pulpbot> RM 6016 - daviddavis - ASSIGNED - pulp_file nightly builds are failing
15:31:56 <pulpbot> https://pulp.plan.io/issues/6016
15:32:10 <daviddavis> accept and add to sprint. this is being worked on already.
15:32:10 <dkliban> is this about to be resolved daviddavis ?
15:32:14 <dkliban> sweet
15:32:18 <daviddavis> yea actually
15:32:18 <dkliban> +1
15:32:20 <fao89> #idea Proposed for #6016: accept and add to sprint
15:32:20 <fao89> !propose other accept and  add to sprint
15:32:21 <pulpbot> fao89: Proposed for #6016: accept and add to sprint
15:32:28 <fao89> #agreed accept and add to sprint
15:32:28 <fao89> !accept
15:32:28 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:32:29 <fao89> #topic https://pulp.plan.io/issues/5991
15:32:29 <pulpbot> fao89: 1 issues left to triage: 5991
15:32:30 <pulpbot> RM 5991 - jsherril@redhat.com - NEW - Sync fails with  TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
15:32:31 <pulpbot> https://pulp.plan.io/issues/5991
15:32:52 <dkliban> daviddavis: did we ever hear about python requests version?
15:33:06 <daviddavis> no https://community.theforeman.org/t/foreman-proxy-content-not-synchronising/16774/6
15:33:07 <bmbouter> #info bmbouter has joined triage
15:33:07 <bmbouter> !here
15:33:07 <pulpbot> bmbouter: bmbouter has joined triage
15:33:26 <daviddavis> it's only been 4 days though. maybe wait a bit longer?
15:33:34 <dkliban> yeah ... we can wait till friday
15:33:45 <dawalker> #info dawalker has joined triage
15:33:45 <dawalker> !here
15:33:45 <pulpbot> dawalker: dawalker has joined triage
15:33:47 <fao89> +1 to wait
15:33:52 <daviddavis> #idea Proposed for #5991: Skip this issue for this triage session.
15:33:52 <daviddavis> !propose skip
15:33:52 <pulpbot> daviddavis: Proposed for #5991: Skip this issue for this triage session.
15:33:55 <dkliban> +1
15:33:59 <fao89> #agreed Skip this issue for this triage session.
15:33:59 <fao89> !accept
15:33:59 <pulpbot> fao89: Current proposal accepted: Skip this issue for this triage session.
15:34:00 <pulpbot> fao89: No issues to triage.
15:34:07 <fao89> Open floor!
15:35:53 <bmbouter> FYI the plugin_template is moving towards all bindings based tests thanks to fao89
15:36:14 <fao89> I was thinking, after we start to use bindings on functional tests, we should provide bindings on installer
15:36:54 <fao89> I opened this issue #6032 for it
15:36:58 <fao89> !issue 6032
15:36:59 <fao89> #topic https://pulp.plan.io/issues/6032
15:36:59 <pulpbot> RM 6032 - fabricio.aguiar - NEW - As a user I can run functional tests locally
15:37:00 <pulpbot> https://pulp.plan.io/issues/6032
15:37:02 <dkliban> fao89: just for developers ?
15:37:37 <bmbouter> fao89: cool, yeah we want to make it easy to use, but in user installations the system with the pulp server components (targetted by the installer) and the place the bindings run (the user's local machine) are usually different
15:37:51 <bmbouter> still having the installer able to build them would be prbably helpful
15:37:59 <daviddavis> also I think we have to [re]generate bindings on the fly too
15:38:03 <dkliban> yeah ... i think we want this in our dev environments
15:38:16 <bmbouter> yes we do!
15:38:24 <dkliban> daviddavis: what about a bash function like pstart for doing tihs?
15:38:28 <daviddavis> +1
15:38:31 <fao89> I just thought that because what I had to do to test pulp_catdog locally
15:39:19 <dkliban> yeah ... we definiely want to easily test locally
15:39:21 <fao89> as pulp_catdog isn't on pypi, I had to do all the steps for generating the bindings
15:39:37 <bmbouter> yeah let's make that easier
15:39:47 <dkliban> yeah ... we should add the ability for a developer to easily generate python bindings
15:40:11 <dkliban> right now we have a repo called pulp-openapi-generator that enables this
15:40:33 <bmbouter> yup and I see the CI fail for that regularly I was concerned about that
15:40:41 <bmbouter> I'm not sure what the fialure causes are
15:41:30 <dkliban> bmbouter: it was fixed and then broke agian
15:41:44 <dkliban> anyway, fao89, i'll comment on the issue again with what we just discussed
15:41:58 <bmbouter> dkliban: ty and ty
15:42:07 <fao89> thanks!
15:42:19 <bmbouter> fao89: ty for filing!
15:44:55 <dkliban> https://pulp.plan.io/issues/6032#note-3
15:45:23 <fao89> dkliban++
15:45:23 <pulpbot> fao89: dkliban's karma is now 411
15:45:44 <daviddavis> I think we should maybe add this to this/a sprint soon
15:46:02 <daviddavis> if we start writing bindings tests, it's going to be hard to run them without this
15:46:20 <dkliban> i agree
15:46:41 <daviddavis> I'll mark as a sprint candidate but I'm also happy to add it to this sprint
15:47:16 <bmbouter> I also agree
15:47:19 <bmbouter> +1
15:47:36 <bmbouter> add to sprint because we need to reach that goal of bindings tests
15:47:41 <bmbouter> (is my opinion)
15:48:21 <daviddavis> ok, let's add to the sprint
15:48:45 <fao89> !propose add to sprint
15:48:45 <pulpbot> fao89: Error: "propose" is not a valid command.
15:48:54 <dalley> might it be worthwhile to put totally-generic bindings test functions in pulpcore.app.tests.utils instead of a separate package
15:48:56 <fao89> #idea Proposed for #6032: add to sprint
15:48:56 <fao89> !propose other add to sprint
15:48:56 <pulpbot> fao89: Proposed for #6032: add to sprint
15:49:20 <fao89> #agreed add to sprint
15:49:20 <fao89> !accept
15:49:20 <pulpbot> fao89: Current proposal accepted: add to sprint
15:49:21 <pulpbot> fao89: No issues to triage.
15:49:47 <dkliban> dalley: like the one that does the task monitoring?
15:49:53 <dalley> exactly
15:50:03 <dalley> that's the one I specifically had in mind :)
15:50:24 <dkliban> dalley: we can do that for now ... but i would like to just add it to the bindings when we are generating them
15:51:01 <dkliban> so the Python bindings at least would come with the helper method
15:51:19 <dalley> that makes sense too, that would go into the pulpcore bindings?
15:51:24 <dkliban> yeah
15:51:40 <dkliban> we should file an issue for this
15:51:41 <dalley> probably a better long-term solution to do that, yeah
15:52:02 <dkliban> bmbouter: did you file anything like that? i know we talked about it before
15:53:07 <fao89> I put monitor_task on plugin.tests.functional.utils here - https://github.com/pulp/plugin_template/pull/175
15:54:27 <dkliban> that's good for right now
15:56:00 <dkliban> i'll write up an issue to improve the python bindings
15:57:57 <dkliban> jsherrill: does katello test this https://pulp.plan.io/issues/6025 ?
15:58:21 <fao89> any other issue for open floor?
16:00:05 <fao89> #endmeeting
16:00:05 <fao89> !end