15:30:21 <fao89> #startmeeting Pulp Triage 2020-02-21
15:30:21 <fao89> !start
15:30:21 <fao89> #info fao89 has joined triage
15:30:21 <pulpbot> Meeting started Fri Feb 21 15:30:21 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:21 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:21 <pulpbot> The meeting name has been set to 'pulp_triage_2020-02-21'
15:30:21 <pulpbot> fao89: fao89 has joined triage
15:30:24 <bmbouter> #info bmbouter has joined triage
15:30:24 <bmbouter> !here
15:30:24 <pulpbot> bmbouter: bmbouter has joined triage
15:30:25 <ggainey-wfh> #info ggainey-wfh has joined triage
15:30:25 <ggainey-wfh> !here
15:30:25 <pulpbot> ggainey-wfh: ggainey-wfh has joined triage
15:30:28 <dkliban> #info dkliban has joined triage
15:30:28 <dkliban> !here
15:30:28 <pulpbot> dkliban: dkliban has joined triage
15:30:28 <ppicka> #info ppicka has joined triage
15:30:28 <ppicka> !here
15:30:29 <pulpbot> ppicka: ppicka has joined triage
15:30:30 <fao89> !next
15:30:31 <pulpbot> fao89: 4 issues left to triage: 6210, 6203, 6189, 6187
15:30:31 <fao89> #topic https://pulp.plan.io/issues/6210
15:30:32 <pulpbot> RM 6210 - mdepaulo@redhat.com - NEW - pulp_rpm_prerequisites is no longer automatically importing to ansible galaxy
15:30:33 <pulpbot> https://pulp.plan.io/issues/6210
15:30:41 <mikedep333> #info mikedep333 has joined triage
15:30:41 <mikedep333> !here
15:30:41 <pulpbot> mikedep333: mikedep333 has joined triage
15:30:46 <bmbouter> I think needs to go on sprint
15:30:51 <mikedep333> it does
15:30:51 <ttereshc> #info ttereshc has joined triage
15:30:51 <ttereshc> !here
15:30:51 <pulpbot> ttereshc: ttereshc has joined triage
15:30:55 <daviddavis> #info daviddavis has joined triage
15:30:55 <daviddavis> !here
15:30:56 <pulpbot> daviddavis: daviddavis has joined triage
15:30:57 <dawalker> #info dawalker has joined triage
15:30:57 <dawalker> !here
15:30:57 <pulpbot> dawalker: dawalker has joined triage
15:31:03 <daviddavis> +1
15:31:03 <fao89> #idea Proposed for #6210: accept and add to sprint
15:31:03 <fao89> !propose other accept and add to sprint
15:31:03 <pulpbot> fao89: Proposed for #6210: accept and add to sprint
15:31:06 <ppicka> +1 to accept
15:31:09 <dkliban> +1
15:31:09 <ggainey-wfh> +1
15:31:12 <fao89> #agreed accept and add to sprint
15:31:12 <fao89> !accept
15:31:12 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:31:13 <fao89> #topic https://pulp.plan.io/issues/6203
15:31:13 <pulpbot> fao89: 3 issues left to triage: 6203, 6189, 6187
15:31:14 <pulpbot> RM 6203 - daviddavis - NEW - Can't run tests in development without first running a few steps
15:31:15 <pulpbot> https://pulp.plan.io/issues/6203
15:32:01 <fao89> I didn't follow this, bindings are automatically installed
15:32:07 <bmbouter> yes bindings are
15:32:09 <dkliban> not if the plugin is installed later
15:32:10 <bmbouter> I agree
15:32:21 <dkliban> i think that's what happened here
15:32:22 <bmbouter> true but you can run `pbindings pulp_ansible python`
15:32:32 <dkliban> yep
15:32:43 <bmbouter> the fixtures tho...
15:33:08 <daviddavis> do the bindings have to be regenerated though?
15:33:21 <daviddavis> like if I make an api change
15:33:25 <bmbouter> that command does it regenerates and installs over
15:33:35 <bmbouter> the previous intalled ones
15:33:36 <fao89> you have to prestart if you make some change
15:33:43 <daviddavis> ok, but I still have to call a few commands before running my tests
15:34:04 <daviddavis> it'd be nice to have like a ptestsetup command
15:34:08 <daviddavis> or ptest
15:34:10 <bmbouter> I agree
15:34:12 <bmbouter> ptest
15:34:19 <fao89> +1
15:34:25 <ttereshc> task or story?
15:34:25 <ggainey-wfh> oooh, I get it
15:34:36 <bmbouter> but wait we need to offer this to non developer installs
15:34:36 <fao89> #idea Proposed for #6203: Leave the issue as-is, accepting its current state.
15:34:36 <fao89> !propose accept
15:34:39 <pulpbot> fao89: Proposed for #6203: Leave the issue as-is, accepting its current state.
15:34:46 <bmbouter> like a downstream packager they won't use pulp-devel from ansible
15:34:54 <bmbouter> but they want to run the tests
15:34:59 <fao89> why non developer would run the tests?
15:35:08 <bmbouter> because they are applying patches from upstream
15:35:39 <daviddavis> so for now, only handle this in development installs?
15:35:53 <bmbouter> I'm saying it might be better to try to have the tests themselves do it
15:35:58 <bmbouter> because then you get it in two places
15:36:03 <bmbouter> instead of building it twice
15:36:24 <daviddavis> ah ok
15:36:27 <fao89> makefile to run the tests?
15:36:37 <bmbouter> yeah or a pre-test step the tests express
15:36:57 <bmbouter> for example we carry custom code on travis to "build them there" that's another place we're maintaining it again
15:36:58 <fao89> #idea Proposed for #6203: change to story
15:36:58 <fao89> !propose other change to story
15:36:58 <pulpbot> fao89: Proposed for #6203: change to story
15:37:12 <daviddavis> that makes sense to me
15:37:22 <daviddavis> I can convert the issue to a story and add this
15:37:58 <fao89> #agreed change to story
15:37:58 <fao89> !accept
15:37:58 <pulpbot> fao89: Current proposal accepted: change to story
15:37:59 <fao89> #topic https://pulp.plan.io/issues/6189
15:37:59 <pulpbot> fao89: 2 issues left to triage: 6189, 6187
15:38:00 <pulpbot> RM 6189 - dkliban@redhat.com - NEW - ansible-pulp should not upgrade pulpcore if any plugins can't work with the newer version
15:38:01 <pulpbot> https://pulp.plan.io/issues/6189
15:38:23 <fao89> #idea Proposed for #6189: Leave the issue as-is, accepting its current state.
15:38:23 <fao89> !propose accept
15:38:23 <pulpbot> fao89: Proposed for #6189: Leave the issue as-is, accepting its current state.
15:38:32 <dkliban> +1
15:38:43 <dawalker> +1
15:38:50 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:38:50 <fao89> !accept
15:38:50 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:38:51 <pulpbot> fao89: 1 issues left to triage: 6187
15:38:51 <fao89> #topic https://pulp.plan.io/issues/6187
15:38:52 <pulpbot> RM 6187 - jdjeffers - NEW - provide pulp_rpm content list options for filtering by checksum
15:38:53 <pulpbot> https://pulp.plan.io/issues/6187
15:39:03 <daviddavis> accept and add to sprint. I think lmjachky is working on this
15:39:09 <dkliban> sweet
15:39:24 <lmjachky> well, yes
15:39:32 <fao89> #idea Proposed for #6187: accept and add to sprint
15:39:32 <fao89> !propose other accept and add to sprint
15:39:33 <pulpbot> fao89: Proposed for #6187: accept and add to sprint
15:39:48 <fao89> #agreed accept and add to sprint
15:39:48 <fao89> !accept
15:39:48 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:39:49 <pulpbot> fao89: No issues to triage.
15:39:55 <fao89> Open floor!
15:40:08 <daviddavis> !friday
15:40:08 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
15:41:18 <bmbouter> !friday!
15:41:18 <pulpbot> bmbouter: Error: "friday!" is not a valid command.
15:41:46 <dkliban> lol
15:41:59 <dkliban> do we want to discuss importers/exporters
15:42:01 <dkliban> ?
15:42:22 <dkliban> or do we want to have a video call for that daviddavis ?
15:42:28 <daviddavis> let's keep it on the mailing list
15:42:50 <dkliban> that's fine ... i'll write another note to there
15:45:43 <fao89> #endmeeting
15:45:43 <fao89> !end