15:32:19 <fao89> #startmeeting Pulp Triage 2020-02-28
15:32:19 <fao89> !start
15:32:19 <fao89> #info fao89 has joined triage
15:32:19 <pulpbot> Meeting started Fri Feb 28 15:32:19 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:32:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:32:19 <pulpbot> The meeting name has been set to 'pulp_triage_2020-02-28'
15:32:19 <pulpbot> fao89: fao89 has joined triage
15:32:24 <daviddavis> #info daviddavis has joined triage
15:32:24 <daviddavis> !here
15:32:24 <pulpbot> daviddavis: daviddavis has joined triage
15:32:25 <ppicka> #info ppicka has joined triage
15:32:25 <ppicka> !here
15:32:25 <pulpbot> ppicka: ppicka has joined triage
15:32:29 <ggainey> #info ggainey has joined triage
15:32:29 <ggainey> !here
15:32:29 <pulpbot> ggainey: ggainey has joined triage
15:32:35 <fao89> !next
15:32:35 <dalley> !here
15:32:36 <fao89> #topic https://pulp.plan.io/issues/6232
15:32:36 <dalley> #info dalley has joined triage
15:32:36 <pulpbot> fao89: 6 issues left to triage: 6232, 6231, 6230, 6224, 6223, 6221
15:32:37 <pulpbot> RM 6232 - mdepaulo@redhat.com - NEW - Apache support for pulp-webserver is not tested in CI
15:32:38 <pulpbot> https://pulp.plan.io/issues/6232
15:32:39 <pulpbot> dalley: dalley has joined triage
15:32:45 <bmbouter> #info bmbouter has joined triage
15:32:45 <bmbouter> !here
15:32:45 <pulpbot> bmbouter: bmbouter has joined triage
15:32:47 <daviddavis> task I think
15:33:00 <fao89> #idea Proposed for #6232: change to task
15:33:00 <fao89> !propose other change to task
15:33:00 <pulpbot> fao89: Proposed for #6232: change to task
15:33:04 <dkliban> +1
15:33:05 <bmbouter> +1
15:33:06 <ppicka> +1
15:33:07 <ggainey> +1
15:33:14 <dkliban> #info dkliban has joined triage
15:33:14 <dkliban> !here
15:33:15 <pulpbot> dkliban: dkliban has joined triage
15:33:48 <fao89> #agreed change to task
15:33:48 <fao89> !accept
15:33:48 <pulpbot> fao89: Current proposal accepted: change to task
15:33:49 <pulpbot> fao89: 5 issues left to triage: 6231, 6230, 6224, 6223, 6221
15:33:49 <fao89> #topic https://pulp.plan.io/issues/6231
15:33:50 <pulpbot> RM 6231 - mdepaulo@redhat.com - NEW - No functional tests at all run at the end of ansible-pulp CI
15:33:51 <pulpbot> https://pulp.plan.io/issues/6231
15:34:00 <daviddavis> task
15:34:02 <dkliban> +!
15:34:04 <ggainey> aye same
15:34:08 <fao89> #idea Proposed for #6231: change to task
15:34:08 <fao89> !propose other change to task
15:34:08 <pulpbot> fao89: Proposed for #6231: change to task
15:34:12 <fao89> #agreed change to task
15:34:12 <fao89> !accept
15:34:12 <pulpbot> fao89: Current proposal accepted: change to task
15:34:13 <pulpbot> fao89: 4 issues left to triage: 6230, 6224, 6223, 6221
15:34:14 <fao89> #topic https://pulp.plan.io/issues/6230
15:34:14 <pulpbot> RM 6230 - mdepaulo@redhat.com - NEW - Ansible Check Mode does not work with ansible-pulp
15:34:15 <pulpbot> https://pulp.plan.io/issues/6230
15:34:44 <dkliban> let's accept
15:34:52 <daviddavis> +1
15:34:59 <ggainey> concur
15:35:00 <fao89> #idea Proposed for #6230: Leave the issue as-is, accepting its current state.
15:35:00 <fao89> !propose accept
15:35:00 <pulpbot> fao89: Proposed for #6230: Leave the issue as-is, accepting its current state.
15:35:09 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:35:09 <fao89> !accept
15:35:09 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:35:10 <pulpbot> fao89: 3 issues left to triage: 6224, 6223, 6221
15:35:10 <fao89> #topic https://pulp.plan.io/issues/6224
15:35:11 <pulpbot> RM 6224 - daviddavis - NEW - Syncing against a pulp with S3 set up causes SSL error
15:35:12 <pulpbot> https://pulp.plan.io/issues/6224
15:35:25 <daviddavis> probably should be a task unless anyone thinks the behavior we currently have is wrong
15:35:34 <bmbouter> yeah I think this is docs
15:35:38 <bmbouter> docs only
15:35:56 <bmbouter> and I think it should go on sprint because it's not going to be a lot of docs
15:36:06 <daviddavis> that's fine with me
15:36:09 <dkliban> cool ... let's do that
15:36:11 <fao89> #idea Proposed for #6224: change to task
15:36:11 <fao89> !propose other change to task
15:36:11 <pulpbot> fao89: Proposed for #6224: change to task
15:36:26 <fao89> #agreed change to task
15:36:26 <fao89> !accept
15:36:26 <pulpbot> fao89: Current proposal accepted: change to task
15:36:27 <fao89> #topic https://pulp.plan.io/issues/6223
15:36:27 <pulpbot> fao89: 2 issues left to triage: 6223, 6221
15:36:28 <pulpbot> RM 6223 - chouseknecht - NEW - Pulp configured with S3 doesn't include file type extension in Content-Disposition header
15:36:29 <pulpbot> https://pulp.plan.io/issues/6223
15:36:50 <dkliban> accept and add to sprint
15:37:10 <fao89> #idea Proposed for #6223: accept and add to sprint
15:37:10 <fao89> !propose other accept and add to sprint
15:37:10 <pulpbot> fao89: Proposed for #6223: accept and add to sprint
15:37:15 <daviddavis> I think this bug might be wrong but we can work on it
15:37:25 <daviddavis> I think the import code is not setting the extension
15:37:42 <daviddavis> but +1 to accepting and adding to sprint to find out
15:37:59 <dkliban> cool
15:38:02 <fao89> #agreed accept and add to sprint
15:38:02 <fao89> !accept
15:38:02 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:38:03 <fao89> #topic https://pulp.plan.io/issues/6221
15:38:03 <pulpbot> fao89: 1 issues left to triage: 6221
15:38:04 <pulpbot> RM 6221 - CodeHeeler - NEW - Bindings Issues at Install, Undocumented Fix
15:38:05 <pulpbot> https://pulp.plan.io/issues/6221
15:38:15 <daviddavis> skip, still waiting on dawalker's feedback
15:38:20 <dkliban> +1
15:38:38 <bmbouter> +1
15:38:38 <ttereshc> +1
15:38:44 <ppicka> +1
15:38:49 <fao89> !skip
15:38:50 <pulpbot> fao89: No issues to triage.
15:38:59 <fao89> Open floor!
15:39:04 <daviddavis> !friday
15:39:04 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
15:39:10 <ggainey> tgif indeed
15:39:36 <daviddavis> I have something
15:39:50 <daviddavis> there's an open question around importers/exporters that ggainey just emailed about
15:39:53 <daviddavis> we need feedback
15:40:01 <ggainey> daviddavis: ah, good point :)
15:40:32 <ggainey> it's the lastest post on the "Importers/Exporters" thread
15:40:32 <daviddavis> https://www.redhat.com/archives/pulp-dev/2020-February/msg00092.html
15:41:28 <bmbouter> I don't see the distinction between pulp-to-pulp and pulp-to-human-user
15:41:31 <bmbouter> personally
15:41:40 <bmbouter> here are the terms my brain uses
15:41:54 <bmbouter> an exporter means: content that exists outside of pulp
15:42:08 <bmbouter> well exporter is the mechanism to get content out of pulp
15:42:31 <ggainey> bmbouter: but there is one - pulp-to-pulp is creating pulp artifacts to be used in another pulp-instance, pulp-to-user is creating artifacts that are used by not-pulp Things (whether that's humans or dnf or http or whatever)
15:42:32 <bmbouter> the data formats will vary wildly but I see they all have that one thing in common
15:42:48 <bmbouter> how is that distinction useful to a user?
15:42:48 <ggainey> bmbouter: sure - but "the data formats" and the use-case are kind of a big deal
15:43:15 <ggainey> an airplane and a car are both "transport mechanisms", but very much not the same thing
15:44:27 <dkliban> i always envisioned that each type of exporter would do it's own thing
15:44:35 <bmbouter> me too
15:44:45 <bmbouter> they are all going to vary hugely
15:44:47 <dkliban> and the only commonality between the exporters is that they get data out of pulp
15:44:54 <bmbouter> agreed
15:44:55 <ggainey> dkliban: yes - which is why they're defined at the plugin level. import/export, that we are currently designing, lives at pulpcore level
15:45:11 <bmbouter> we had talked about shipping some in pulpcore also
15:45:14 <dkliban> ggainey: that's ok ... pulpcore can provide an exproter
15:45:15 <bmbouter> and those would vary wildly too
15:45:38 <bmbouter> rsync exporter, local exporter, export and install, export so I can later import, export to bittorrent, etc etc
15:45:53 <ttereshc> what are the variations of pulp-to-pulp exporters? will we have more than one?
15:46:16 <daviddavis> I don't think so. there are really no exporters for export/import
15:46:34 <bmbouter> but with the same thinking each exporter could be called it's on special name
15:46:38 <bmbouter> and that doesn't also make sense to do
15:47:00 <ggainey> ttereshc: the goal (at least as I understand it) is, at pulpcore level, /export will take a repo-version, package up the core-content for that version, figure out what type that repo is, and ask the implicated plugin to export its data
15:47:24 <bmbouter> let me state my concern: pulp is already shipping a lot of object types so I'm concerned that if we're going to make more types we need a great reason
15:48:08 <bmbouter> people who are even paid to learn about pulp (like other integrators not on our team), their eyes glaxy over on about the 5th object type
15:48:29 <ggainey> I'm not sure I agree that "we have a lot of types' is an important consideration, honestly - pulp3 does a lot of things, so yeah, it's going to have a lot of types.
15:48:30 <ttereshc> daviddavis, if there are no exporters for export/import, maybe we can just refer to this case in some other way, not to overload the export term?
15:48:34 <ggainey> I'm not sure how to prevent that
15:48:44 <ggainey> ttereshc: that's exactly what we're trying to do
15:49:02 <bmbouter> exporters get data out of pulp so to me it's not overloaded
15:49:21 <ggainey> if someone can come up with another pairing other than export/import for this functionality, that would work as well - just couldn't think of one that didn't carry more connotations than were useful
15:49:44 <daviddavis> I think once you pick at the idea that import/export is just another type of exporter, it is not a good reason
15:49:59 <ggainey> bmbouter: if the word exporter lives in two diff places in the API, it's confusing (at least to me)
15:50:45 <dkliban> ggainey: i am not sure what you mean about the two place
15:50:58 <bmbouter> me neither
15:51:14 <daviddavis> exporters vs an /export api endpoint in pulp
15:51:17 <daviddavis> pulpcore
15:51:17 <ttereshc> bmbouter, I'm not suggesting to rename Exporter object, just if there are no exporters involved in export/import we might rename those, to avoid confusion. When I talk about export, the first question I get which one, and I agree to the extent that pulp-to-pulp is somewhat different from the rest.
15:51:44 <bmbouter> I hear that
15:51:53 <bmbouter> but by that same thinking they are all different
15:51:59 <bmbouter> and yet all but this would be called Exporter
15:52:34 <bmbouter> like take exporters that are just for backing up to cold storage
15:52:48 <dkliban> i have another question related to this
15:52:50 <bmbouter> I wouldn't want to call that a Backup I want to call it a BackupExporter
15:53:00 <ggainey> bmbouter: actuaslly, I agree with you - which is part of why I proposed that the current Exporter be a Publisher, because that feels (to me, anyway) like the common thread of what they're all doing today
15:53:03 <dkliban> what would a user use to import the exported archive?
15:53:22 <daviddavis> dkliban: they'd call an /import endpoint
15:53:27 <ggainey> dkliban: the othe rhalf of the API, which is (currently) /import
15:53:48 <ggainey> which takes as a parameter the tarfile coughed up by /export
15:53:59 <ggainey> and a mapping/config file, that we're still hashing out :)
15:54:26 <daviddavis> part of the problem is that today Exporters are Master/Detail models (their format is defined in pulpcore) while for this export/import feature, the format and endpoints live in core.
15:54:28 <dkliban> are both of these endpoints on the exporter?
15:54:29 <bmbouter> ggainey: if we renamed all of them i'm open to that, the concern Ihave with publisher is a) pulp2 confusion and b) confusion with pulisher and publications which have 0 to do with each other
15:54:58 <ggainey> bmbouter: yeah, I don't disagree
15:55:02 <ttereshc> bmbouter, that was my concern as well, both of your points
15:55:22 <daviddavis> we struggled to come up with a better name, so suggestions are welcome
15:56:18 <bmbouter> so if everything is still one Master/Detail object, what is the motivation to rename what we already have?
15:56:32 <bmbouter> I'm trying to understand only not be controversial
15:56:33 <daviddavis> bmbouter: the importer/exporter stuff isn't master/detail
15:56:38 <ggainey> yeah that
15:56:38 <dkliban> can't we have a detail model in pulpcore?
15:56:45 <dkliban> oh
15:57:04 <dkliban> i was confused ... i thought you kept saying that it was master/detail
15:57:19 <ggainey> 'export', in this context, is a thing you *do*, not a thing you *are* - daviddavis , does that make sense to you?
15:57:22 <bmbouter> I also think it's supposed to be master detail wiht pulpcore providing th detail object
15:57:48 <daviddavis> that's an option I'm not opposed to but it feels wrong since we really don't need to use master/detail
15:58:23 <ggainey> aiui, master/detail lets core define a base and plugins extend - why would you do that when everything lives in core?
15:58:58 <dkliban> exporters could be their own plugin
15:59:01 <bmbouter> ggainey: because if two plugins want the same detail object they wold both have to carry it or put it into a third package and that third package might as well be the plugin API or pulpcore
15:59:30 <ggainey> dkliban: in this xontext, export/import needs to know about All The Plugins - that sounds like something that belongs in pulpcore to me
15:59:58 <bmbouter> I have to drop at top of hour
16:00:09 <bmbouter> can we pick another time to continue?
16:00:11 <ggainey> i feel like we're talking about two completely different things here
16:00:19 <daviddavis> yea, I can set up a face to face meeting on monday?
16:00:25 <dkliban> that would be great
16:00:26 <bmbouter> that would be ideal I think
16:00:38 <fao89> face_to_face++
16:00:38 <pulpbot> fao89: face_to_face's karma is now 1
16:00:43 <dkliban> lol
16:00:43 <ggainey> sure - or we can piggyback on the mtg we have this afternoon?
16:00:46 <ggainey> ok
16:00:53 <daviddavis> ggainey: taht's fine with me too
16:01:01 <bmbouter> I don't see a meeting
16:01:12 <ggainey> bmbouter: because you're not on it, "we" was "me and david" :)
16:01:17 <daviddavis> hehe
16:01:26 <ggainey> I will add folk to today's meeting - if ppl can't come, we'll schedule another for Monday
16:02:10 <bmbouter> timezone wise I don't think everyone could come today either way
16:02:36 <ggainey> yeah, ttereshc I didn't add you because you shouldn't be thinking about this at 2100 on a Friday :)
16:04:11 <fao89> #endmeeting
16:04:11 <fao89> !end