14:30:23 <fao89> #startmeeting Pulp Triage 2020-03-17
14:30:23 <fao89> !start
14:30:23 <fao89> #info fao89 has joined triage
14:30:23 <pulpbot> Meeting started Tue Mar 17 14:30:23 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:23 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:23 <pulpbot> The meeting name has been set to 'pulp_triage_2020-03-17'
14:30:23 <pulpbot> fao89: fao89 has joined triage
14:30:30 <fao89> !next
14:30:30 <fao89> #topic https://pulp.plan.io/issues/6347
14:30:31 <pulpbot> fao89: 4 issues left to triage: 6347, 6346, 6339, 6335
14:30:31 <ppicka> #info ppicka has joined triage
14:30:31 <ppicka> !here
14:30:32 <pulpbot> RM 6347 - sajha - NEW - File content list does not return all unique content units
14:30:33 <pulpbot> https://pulp.plan.io/issues/6347
14:30:34 <pulpbot> ppicka: ppicka has joined triage
14:30:39 <daviddavis> #info daviddavis has joined triage
14:30:39 <daviddavis> !here
14:30:39 <pulpbot> daviddavis: daviddavis has joined triage
14:30:46 <bmbouter> #info bmbouter has joined triage
14:30:46 <bmbouter> !here
14:30:46 <pulpbot> bmbouter: bmbouter has joined triage
14:30:50 <daviddavis> is this an ordering issue?
14:31:02 <ttereshc> #info ttereshc has joined triage
14:31:02 <ttereshc> !here
14:31:02 <pulpbot> ttereshc: ttereshc has joined triage
14:31:06 <bmbouter> yes I think so
14:31:12 <daviddavis> accept and add to sprint I think
14:31:15 <bmbouter> agreed
14:31:21 <bmbouter> also we should generally order based on creation time
14:31:32 <bmbouter> that way your N itesm will never change their order even as N+1 is added
14:31:35 <fao89> #idea Proposed for #6347: accept and add to sprint
14:31:35 <fao89> !propose other accept and add to sprint
14:31:36 <pulpbot> fao89: Proposed for #6347: accept and add to sprint
14:31:48 <ttereshc> +1
14:31:51 <ppicka> +1
14:31:53 <fao89> #agreed accept and add to sprint
14:31:53 <fao89> !accept
14:31:53 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:31:54 <fao89> #topic https://pulp.plan.io/issues/6346
14:31:54 <pulpbot> fao89: 3 issues left to triage: 6346, 6339, 6335
14:31:55 <pulpbot> RM 6346 - daviddavis - NEW - Remote fields username and password not showing up in REST docs
14:31:56 <pulpbot> https://pulp.plan.io/issues/6346
14:32:13 <daviddavis> accept and add to sprint I think
14:32:15 <fao89> #idea Proposed for #6346: accept and add to sprint
14:32:15 <fao89> !propose other accept and add to sprint
14:32:15 <pulpbot> fao89: Proposed for #6346: accept and add to sprint
14:32:17 <bmbouter> agreed
14:32:22 <ggainey> #info ggainey has joined triage
14:32:22 <ggainey> !here
14:32:22 <pulpbot> ggainey: ggainey has joined triage
14:32:40 <fao89> #agreed accept and add to sprint
14:32:40 <fao89> !accept
14:32:40 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:32:41 <pulpbot> fao89: 2 issues left to triage: 6339, 6335
14:32:41 <fao89> #topic https://pulp.plan.io/issues/6339
14:32:42 <pulpbot> RM 6339 - dkliban@redhat.com - NEW - tests that use bindings don't load pulp-smash config
14:32:43 <pulpbot> https://pulp.plan.io/issues/6339
14:32:52 <fao89> #idea Proposed for #6339: accept and add to sprint
14:32:52 <fao89> !propose other accept and add to sprint
14:32:52 <pulpbot> fao89: Proposed for #6339: accept and add to sprint
14:32:58 <bmbouter> oh yeah this was a big problem for me recently
14:33:15 <daviddavis> +1
14:33:19 <bmbouter> and pulp_ansible has an issue that it's tests always have to run on the pulp box itself and this would fix that
14:33:33 <fao89> #agreed accept and add to sprint
14:33:33 <fao89> !accept
14:33:33 <fao89> #topic https://pulp.plan.io/issues/6335
14:33:34 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:33:35 <pulpbot> fao89: 1 issues left to triage: 6335
14:33:36 <pulpbot> RM 6335 - daviddavis - NEW - Users can export to any file path
14:33:37 <pulpbot> https://pulp.plan.io/issues/6335
14:34:00 <ggainey> ugh, nice catch daviddavis
14:34:21 <fao89> #idea Proposed for #6335: Leave the issue as-is, accepting its current state.
14:34:21 <fao89> !propose accept
14:34:21 <pulpbot> fao89: Proposed for #6335: Leave the issue as-is, accepting its current state.
14:34:38 <ttereshc> is it a bug? or a story?
14:35:21 <dkliban> it's a feature?
14:35:54 <mikedep333> #info mikedep333 has joined triage
14:35:54 <mikedep333> !here
14:35:54 <pulpbot> mikedep333: mikedep333 has joined triage
14:35:58 <dkliban> #info dkliban has joined triage
14:35:58 <dkliban> !here
14:35:58 <pulpbot> dkliban: dkliban has joined triage
14:36:12 <ggainey> from a security POV< it's a bug
14:36:17 <bmbouter> agreed
14:36:26 <dkliban> let's add to the sprint
14:36:31 <ttereshc> ok
14:36:35 <fao89> #idea Proposed for #6335: accept and add to sprint
14:36:35 <fao89> !propose other accept and add to sprint
14:36:35 <pulpbot> fao89: Proposed for #6335: accept and add to sprint
14:36:38 <bmbouter> it needs a bit more planning tho
14:37:06 <bmbouter> +1 to getting it on there but it needs a name and description for the setting
14:37:07 <ggainey> yeah, I don't think it should be added to this sprint, but 'soon'
14:37:39 <dkliban> if we are not adding to the sprint we need someone to own it
14:37:46 <dkliban> and make sure it gets groomed and added to the sprint
14:37:47 <ttereshc> do you plan to release it as a part of z stream?
14:38:04 <bmbouter> it's a feature a new setting so I think y stream
14:38:23 <ttereshc> maybe converting it to a story will make it easier to track?
14:38:30 <fao89> #idea Proposed for #6335: skip to get more info for the next triage
14:38:30 <fao89> !propose other skip to get more info for the next triage
14:38:30 <pulpbot> fao89: Proposed for #6335: skip to get more info for the next triage
14:38:30 <ttereshc> it can be groomed and be a sprint candidate
14:38:38 <dkliban> +1
14:38:45 <ggainey> concur, +1
14:38:48 <bmbouter> +1
14:39:03 <dawalker> #info dawalker has joined triage
14:39:03 <dawalker> !here
14:39:03 <pulpbot> dawalker: dawalker has joined triage
14:39:17 <fao89> all these +1 is for ttereshc proposal or mine?
14:39:19 <mikedep333> Yeah, I have some thoughts and research to do on #6335 from an operational perspective.
14:40:18 <ggainey> fao89: heh, good point - mine was for ttereshc ' proposal
14:40:38 <dkliban> let's skip right now
14:40:45 <dkliban> that's the main thing i got from this
14:41:00 <bmbouter> this is kind of what open floor is for
14:41:03 <bmbouter> loose feature planning
14:41:13 <bmbouter> +1 to skip for this part either way
14:41:16 <daviddavis> what does skipping buy us?
14:41:26 <daviddavis> we'll just discuss it on friday?
14:41:35 <dkliban> no ... it gives us time to see other issues
14:41:36 <bmbouter> I mean skip until open floor
14:41:40 <dkliban> and then come back to it
14:41:43 <daviddavis> oh ok
14:41:54 <fao89> !skip
14:41:56 <pulpbot> fao89: No issues to triage.
14:42:02 <bmbouter> ha no more even
14:42:03 <fao89> Open floor!
14:42:05 <fao89> hahaha
14:42:14 <daviddavis> :)
14:42:23 <fao89> !issue #6335
14:42:23 <pulpbot> fao89: Error: '#6335' is not a valid positive integer.
14:42:28 <fao89> !issue 6335
14:42:29 <fao89> #topic https://pulp.plan.io/issues/6335
14:42:29 <pulpbot> RM 6335 - daviddavis - NEW - Users can export to any file path
14:42:30 <pulpbot> https://pulp.plan.io/issues/6335
14:42:32 <bmbouter> so it needs to become a story
14:42:35 <dkliban> this is definitely a story
14:42:39 <bmbouter> and I'm rewriting mine as
14:42:45 <bmbouter> 'as a user, yada yada' these days
14:42:57 <bmbouter> so I recommend retitling also
14:42:57 <fao89> #idea Proposed for #6335: convert to story and add to sprint candidate
14:42:57 <fao89> !propose other convert to story and add to sprint candidate
14:42:57 <pulpbot> fao89: Proposed for #6335: convert to story and add to sprint candidate
14:43:16 <daviddavis> I feel like somebody needs to drive this forward and get it groomed
14:43:29 <bmbouter> it'll be a new setting I agree, what would it be named, what is its defualt, and what are some example configs
14:43:36 <daviddavis> yup
14:43:53 <bmbouter> I can write all this on the issue today and send it to someone for grooming
14:44:02 <bmbouter> I can at least take it that far
14:44:09 <daviddavis> cool, I can groom it
14:44:16 <bmbouter> write all this meaning answer these questions not write the questions
14:44:39 <dkliban> cool
14:45:04 <ggainey> +1
14:45:21 <fao89> #agreed convert to story and add to sprint candidate
14:45:21 <fao89> !accept
14:45:21 <pulpbot> fao89: Current proposal accepted: convert to story and add to sprint candidate
14:45:22 <pulpbot> fao89: No issues to triage.
14:46:26 <bmbouter> I'm in a bit of an awkward test scenario I wanted to talk about
14:46:45 <bmbouter> it's related to bindings tests and bindings themselves and webserver configs
14:47:30 <bmbouter> so first I want to confirm that everyone is seeing what I am seeing, which is: our smash and bindings tests reach to ports 24816 and 24817 directly
14:47:36 <bmbouter> is that right?
14:47:53 <fao89> I believe so
14:48:34 <fao89> https://github.com/pulp/pulpcore/blob/master/.travis/pulp-smash-config.json#L10
14:48:36 <bmbouter> so the awkward thing I'm experiencing is that when these tests go to download content it goes through the webserver
14:49:20 <bmbouter> download_content_unit() receives it's url from the distribution.base_url
14:49:42 <bmbouter> and pulplift configs set that for both user and dev installs https://github.com/pulp/pulplift/blob/master/example.dev-config.yml#L37
14:50:18 <dkliban> uh huh
14:50:47 <bmbouter> and that is a problem because if we continue doing that we'll have to make all installations ssl for tests to pass
14:51:15 <bmbouter> because for this section of tests I have to perform TLS w/ the webserver if that's who my test is going to talk to
14:51:16 <dkliban> bmbouter: what's the problem with making all installs using ssl?
14:51:32 <bmbouter> that's part of the question I keep asking myself
14:51:42 <bmbouter> first off it would be done in a rush because it's blocking certguard
14:51:45 <dkliban> i would prefer if our dev environments also used ssl
14:51:45 <bmbouter> which isn't great
14:51:55 <bmbouter> second now our tests have an ssl requirement
14:51:59 <bmbouter> that doesnt' seem good exactly
14:52:16 <dkliban> bmbouter: that's not exactly true
14:52:18 <bmbouter> third, we're not testing nginx we're testing Pulp so overall the best practice suggests to test just pulp
14:52:33 <bmbouter> dkliban: the test I write would not be runnable in non-ssl environments
14:52:57 <dkliban> so i think that you are just simply retelling this https://pulp.plan.io/issues/6339
14:53:13 <dkliban> and if we fix ^ we will be able to tell our tests to use ssl or not
14:53:19 <bmbouter> I'm not actually
14:53:25 <bmbouter> this is the subtle thing to realize
14:53:47 <bmbouter> even after you fix 6339 the bindings tests will still get their download urls from the server side
14:53:59 <bmbouter> and those configs say to ues the webserver so you'll be once again not on 24817 24816
14:54:17 <dkliban> bmbouter: the pulp-smash config is very detailed about this
14:54:42 <bmbouter> dkliban: yes but all the test code we have wouldn't use that even if the bindings were correctly configured to do so
14:55:00 <bmbouter> let me get the link for an example
14:55:07 <dkliban> the tests are doing wrong
14:55:28 <dkliban> the tests need to get the scheme for the content app from the pulp-smash config
14:56:14 <bmbouter> https://github.com/pulp/pulp_file/blob/master/pulp_file/tests/functional/api/test_download_content.py#L122
14:56:28 <bmbouter> dkliban: this is the clarity I was looking for
14:56:34 <bmbouter> confirmation the tests are doing it wrong
14:56:41 <bmbouter> and that 100% of testing is to use 24816 and 24817
14:56:47 <bmbouter> and it's really this latter point that matters more
14:57:22 <bmbouter> and if we make both points ^ true then we won't have the ssl requirement
14:57:26 <dkliban> give me sec ... i will share a pulp-smash config that should make this info available
14:57:39 <dkliban> and the tests just need to use that info
14:58:13 <bmbouter> daviddavis: as a fellow pulp smasher also what do you think? ^
14:58:37 <bmbouter> dkliban: yeah we could switch the download_content_unit in pulp smash itself to reform the download url ignoring the distribution's base_url field
14:59:02 <bmbouter> and that switch would affect all plugins, I believe that it should continue to work but that's kind of a fundamental change
14:59:05 <bmbouter> hence the open floor
14:59:15 <bmbouter> which btw I have to go to a meeting now
14:59:45 <dkliban> bmbouter: https://paste.centos.org/view/f2c77056
15:00:04 <dkliban> the scheme for both the content and app and rest api is specified
15:00:28 <dkliban> so we need to file a task to fix the tests
15:00:34 <dkliban> to use the pulp-smash config
15:01:10 <dkliban> any other thoughts?
15:03:26 <fao89> we are in another meeting, ending open floor for now
15:03:28 <ttereshc> no :)
15:03:29 <fao89> #endmeeting