14:30:03 <fao89> #startmeeting Pulp Triage 2020-05-15
14:30:03 <fao89> !start
14:30:03 <pulpbot> Meeting started Fri May 15 14:30:03 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:03 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:03 <pulpbot> The meeting name has been set to 'pulp_triage_2020-05-15'
14:30:03 <fao89> #info fao89 has joined triage
14:30:04 <pulpbot> fao89: fao89 has joined triage
14:30:10 <fao89> !next
14:30:11 <pulpbot> fao89: 8 issues left to triage: 6748, 6735, 6730, 6724, 6723, 6720, 6716, 6714
14:30:11 <fao89> #topic https://pulp.plan.io/issues/6748
14:30:12 <pulpbot> RM 6748 - ipanova@redhat.com - POST - Add TaskReservedResourceRecord to the plugin api
14:30:13 <pulpbot> https://pulp.plan.io/issues/6748
14:30:27 <fao89> #idea Proposed for #6748: accept and add to sprint
14:30:27 <fao89> !propose other accept and add to sprint
14:30:27 <pulpbot> fao89: Proposed for #6748: accept and add to sprint
14:30:52 <fao89> #idea Proposed for #6748: Leave the issue as-is, accepting its current state.
14:30:52 <fao89> !propose accept
14:30:52 <pulpbot> fao89: Proposed for #6748: Leave the issue as-is, accepting its current state.
14:30:55 <bmbouter> #info bmbouter has joined triage
14:30:55 <bmbouter> !here
14:30:55 <pulpbot> bmbouter: bmbouter has joined triage
14:31:15 <x9c4> #info x9c4 has joined triage
14:31:15 <x9c4> !here
14:31:15 <pulpbot> x9c4: x9c4 has joined triage
14:31:34 <ipanova> #info ipanova has joined triage
14:31:34 <ipanova> !here
14:31:34 <pulpbot> ipanova: ipanova has joined triage
14:31:46 <dkliban> #info dkliban has joined triage
14:31:46 <dkliban> !here
14:31:46 <pulpbot> dkliban: dkliban has joined triage
14:31:49 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:31:49 <fao89> !accept
14:31:49 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:31:50 <fao89> #topic https://pulp.plan.io/issues/6735
14:31:50 <pulpbot> fao89: 7 issues left to triage: 6735, 6730, 6724, 6723, 6720, 6716, 6714
14:31:51 <pulpbot> RM 6735 - bmbouter - NEW - Docs incorrectly recommend to users they escape newlines from their ca_cert and client_cert
14:31:52 <pulpbot> https://pulp.plan.io/issues/6735
14:32:03 <dkliban> #idea Proposed for #6735: accept and add to sprint
14:32:03 <dkliban> !propose other accept and add to sprint
14:32:03 <pulpbot> dkliban: Proposed for #6735: accept and add to sprint
14:32:11 <bmbouter> +1
14:32:12 <ipanova> +1
14:32:17 <x9c4> +1
14:32:19 <fao89> #agreed accept and add to sprint
14:32:19 <fao89> !accept
14:32:19 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:32:20 <pulpbot> fao89: 6 issues left to triage: 6730, 6724, 6723, 6720, 6716, 6714
14:32:20 <fao89> #topic https://pulp.plan.io/issues/6730
14:32:21 <pulpbot> RM 6730 - dkliban@redhat.com - NEW - WARNING: Please provide either 'view_name' or 'view_name_pattern' for DetailRelatedField on FilePublicationSerializer.
14:32:22 <pulpbot> https://pulp.plan.io/issues/6730
14:32:27 <dkliban> #idea Proposed for #6730: accept and add to sprint
14:32:27 <dkliban> !propose other accept and add to sprint
14:32:27 <pulpbot> dkliban: Proposed for #6730: accept and add to sprint
14:32:34 <ipanova> +1
14:32:47 <x9c4> +1
14:32:53 <fao89> #agreed accept and add to sprint
14:32:53 <fao89> !accept
14:32:53 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:32:54 <pulpbot> fao89: 5 issues left to triage: 6724, 6723, 6720, 6716, 6714
14:32:54 <fao89> #topic https://pulp.plan.io/issues/6724
14:32:55 <pulpbot> RM 6724 - hyu - NEW - Some consumer profiles are missed when calculating batch regenerate applicability for repo
14:32:56 <pulpbot> https://pulp.plan.io/issues/6724
14:33:28 <dkliban> #idea Proposed for #6724: accept and add to sprint
14:33:28 <dkliban> !propose other accept and add to sprint
14:33:28 <pulpbot> dkliban: Proposed for #6724: accept and add to sprint
14:33:33 <mikedep333> #info mikedep333 has joined triage
14:33:33 <mikedep333> !here
14:33:33 <pulpbot> mikedep333: mikedep333 has joined triage
14:33:33 <ipanova> +1
14:33:37 <fao89> #agreed accept and add to sprint
14:33:37 <fao89> !accept
14:33:37 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:33:38 <pulpbot> fao89: 4 issues left to triage: 6723, 6720, 6716, 6714
14:33:38 <fao89> #topic https://pulp.plan.io/issues/6723
14:33:39 <pulpbot> RM 6723 - dkliban@redhat.com - NEW - latest docs are not getting updated when a new pulpcore release is published to PyPI
14:33:40 <pulpbot> https://pulp.plan.io/issues/6723
14:33:46 <dkliban> #idea Proposed for #6723: accept and add to sprint
14:33:46 <dkliban> !propose other accept and add to sprint
14:33:47 <pulpbot> dkliban: Proposed for #6723: accept and add to sprint
14:33:50 <dkliban> it's a task really
14:33:56 <dkliban> but it's a bug in our release process
14:34:09 <dkliban> CI bug
14:34:20 <fao89> #agreed accept and add to sprint
14:34:20 <fao89> !accept
14:34:20 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:34:21 <fao89> #topic https://pulp.plan.io/issues/6720
14:34:21 <pulpbot> fao89: 3 issues left to triage: 6720, 6716, 6714
14:34:22 <pulpbot> RM 6720 - mdellweg - NEW - Pulpbot does not revisit a pr if the commit message changes
14:34:23 <pulpbot> https://pulp.plan.io/issues/6720
14:34:45 <dkliban> #idea Proposed for #6720: accept and add to sprint
14:34:45 <dkliban> !propose other accept and add to sprint
14:34:45 <pulpbot> dkliban: Proposed for #6720: accept and add to sprint
14:35:04 <ipanova> +1
14:35:04 <fao89> #agreed accept and add to sprint
14:35:04 <fao89> !accept
14:35:04 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:35:05 <pulpbot> fao89: 2 issues left to triage: 6716, 6714
14:35:05 <fao89> #topic https://pulp.plan.io/issues/6716
14:35:06 <pulpbot> RM 6716 - sivel - ASSIGNED - 3 in One Container fails on Docker
14:35:07 <pulpbot> https://pulp.plan.io/issues/6716
14:35:20 <dkliban> this is actually already released
14:35:37 <dkliban> i merged the changes to the pulp-oci-images repo and pushed a new container
14:35:42 <ipanova> let's then change the issue status?
14:35:46 <dkliban> i will
14:35:53 <ipanova> cool
14:36:04 <ipanova> !propose other accept and add to sprint
14:36:13 <ipanova> #idea Proposed for #6716: accept and add to sprint
14:36:13 <ipanova> !propose other accept and add to sprint
14:36:13 <pulpbot> ipanova: Proposed for #6716: accept and add to sprint
14:36:13 <fao89> #agreed accept and add to sprint
14:36:13 <fao89> !accept
14:36:14 <fao89> #topic https://pulp.plan.io/issues/6714
14:36:14 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:36:15 <pulpbot> fao89: 1 issues left to triage: 6714
14:36:16 <pulpbot> RM 6714 - alikins - NEW - drf builtin manage.py 'generateschema' command fails on pulp base viewsets
14:36:17 <pulpbot> https://pulp.plan.io/issues/6714
14:37:10 <dkliban> do we know why the user needs to use this command?
14:37:31 <dkliban> bmbouter: do you know?
14:37:39 <dkliban> let's skip for now and i'll comment on the issue
14:37:43 <bmbouter> please do I don't know
14:38:15 <fao89> I guess he is talking about the schema that is generated at root
14:38:25 <fao89> but it is not clear
14:38:41 <fao89> #idea Proposed for #6714: skip to get more info
14:38:41 <fao89> !propose other skip to get more info
14:38:41 <pulpbot> fao89: Proposed for #6714: skip to get more info
14:38:44 <fao89> #agreed skip to get more info
14:38:45 <fao89> !accept
14:38:45 <pulpbot> fao89: Current proposal accepted: skip to get more info
14:38:46 <pulpbot> fao89: No issues to triage.
14:38:53 <fao89> Open floor!
14:38:56 <fao89> !pulp
14:38:56 <pulpbot> 🍊 Yay, Pulp! 🍊 Go team go! 🍊
14:39:33 <fao89> bmbouter, bring your open floor list
14:39:40 <bmbouter> ha you know
14:39:55 <dkliban> lol
14:40:07 <bmbouter> I want to talk about how to wrap up the write_only work
14:40:40 <bmbouter> we've got the secretCharFields removed, and username + password are now usable
14:40:46 <dkliban> https://pulp.plan.io/issues/6421
14:40:47 <bmbouter> and certguard no longer uses write_only
14:40:56 <dkliban> that is the next step i think
14:41:11 <bmbouter> I agree
14:41:43 <bmbouter> is someone able to perform that audit and write up a summary for us to discuss at the next open floor?
14:42:49 <ipanova> bmbouter: this audit should extend to plugins as well not only core
14:42:59 <bmbouter> yes I believe so
14:43:08 <dkliban> yes, cause the plugins have the Sync serializers
14:43:18 <dkliban> and they use the write_only fields and shouldn't
14:43:20 <ipanova> right, the title even says so, have not noticed
14:45:04 <x9c4> Is the file field on the upload serializers still a valid uese?
14:45:54 <dkliban> x9c4: it is valid there
14:46:02 <bmbouter> I expect there to be two cases where write_only is used
14:46:27 <bmbouter> 1) pulp only receives the data on submission and therefore cannot return it. for this I believe we'll use a split serializers solution
14:46:44 <dkliban> that's the content serializer use case
14:46:50 <bmbouter> yes exactly
14:47:11 <bmbouter> then 2) all other cases, and those should have write_only removed and have read/write both include said field
14:47:49 <x9c4> I'll make a list.
14:47:59 <dkliban> x9c4: thank you
14:48:19 <bmbouter> x9c4: ty!
14:49:03 <bmbouter> next topic? I yield
14:49:54 <fao89> pulp_file CI is broken for performance tests
14:50:12 <dkliban> fao89: do you know what is causing the failure?
14:50:28 <fao89> no, I just notice it is breaking
14:52:56 <fao89> next topic?
14:53:15 <dkliban> ggainey: there is a PR in pulpcore for import/export tests
14:53:32 <bmbouter> oh yeah I just commented with this: https://github.com/pulp/pulpcore/pull/702#issuecomment-629276394
14:53:34 <dkliban> ggainey: i was hoping you oculd take a look https://github.com/pulp/pulpcore/pull/702
14:53:45 <dkliban> cool
14:54:52 <bmbouter> next topic?
14:55:35 <fao89> 3.4.0?
14:56:21 <dkliban> we will discuss it on tuesday when more people are here
14:56:39 <dkliban> fao89: or did you have something you wanted to discuss withregard to 3.4?
14:57:28 <fao89> I saw a comment on my PR, bmbouter saying he would bring it to open floor
14:57:44 <fao89> but I didn't realize it would be the next one
14:58:05 <bmbouter> which PR?
14:58:48 <fao89> https://github.com/pulp/pulpcore/pull/695#issuecomment-629188716
14:59:05 <bmbouter> ah yes
14:59:24 <bmbouter> we wanted to discuss the timeline when more folks were around
14:59:33 <bmbouter> we thought tuesday's open floor would be a good one
14:59:35 <fao89> sounds good
14:59:50 <ggainey> dkliban: sorry, too much code and too many DMs today, checking
15:00:09 <ggainey> yeah, "review ddavis' pr" is on my list for today
15:00:28 <dkliban> awesome
15:01:03 <fao89> I would link to bring this PR: https://github.com/pulp/pulp_installer/pull/287
15:01:29 <fao89> it is the first step for having pulp_installer as collection on galaxy
15:01:57 <dkliban> we should do this before we release 3.4 and include notes that instruct users to update their playbooks
15:02:02 <fao89> please review it soon, as it get high chances to need rebases
15:02:16 <dkliban> mikedep333: it looks like you were the one that requested changes on it
15:03:01 <mikedep333> fao89 will do very shortly
15:03:42 <bmbouter> I believe we need to do ^ change in a major release of pulpcore
15:04:15 <bmbouter> so if we miss 3.4.0 we'll be not able to publish to galaxy for prob 2 months
15:05:05 <fao89> other high chances on conflicts PR: https://github.com/pulp/pulpcore/pull/577
15:05:29 <bmbouter> fao89: ah yes dkliban and I want to get to that for 3.4.0 also
15:05:43 <bmbouter> this came up at the pulpcore meeting just now
15:05:45 <bmbouter> also
15:06:34 <fao89> cool
15:06:37 <bmbouter> next topic?
15:07:33 <dkliban> what's for lunch?
15:07:58 <bmbouter> I have a process question/idea (well two really)
15:08:09 <dkliban> that's a better topic than mine
15:08:34 <dkliban> i yield
15:08:37 <bmbouter> can we move triage to the #pulp-meeting channel to allow for this channel to continue to be discussion as needed during this time?
15:08:58 <dkliban> yeah ... we were supposed to do that a while ago and i never followed through
15:09:15 <bmbouter> what needs to happen to do that?
15:09:20 <dkliban> this requires updating the website and sending an email announcement of the change
15:09:35 <dkliban> pulpbot is already present in that channel
15:09:35 <pulpbot> dkliban: Error: "is" is not a valid command.
15:09:39 <partha> croberts: jsherrill jturel ggainey I happened to notice this feature today in katello -> https://projects.theforeman.org/issues/27374
15:09:39 <dkliban> lol
15:09:43 <fao89> dkliban, you need to change it on calendar event
15:09:50 <bmbouter> yup
15:09:52 <dkliban> i can do that
15:10:05 <croberts> partha: yeah mccun934 wanted that for a customer
15:10:12 <croberts> we just do a rsync
15:10:39 <bmbouter> dkliban: when do you think?
15:11:03 <dkliban> we can start next tuesday. i can make the website change right now and send an email to pulp-list and pulp-dev
15:11:10 <bmbouter> +1
15:11:19 <bmbouter> I appreciate it
15:11:25 <bmbouter> and calendar invites
15:11:28 <dkliban> yep
15:11:30 <partha> sounds like that just gets a dump of everything in -> rsync -aL '/var/lib/pulp/published/yum/https/repos/'  #{export_dir}
15:11:51 <bmbouter> ok next process topic: for open floor I propose we have an agenda
15:12:02 <bmbouter> I made one here https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:12:18 <croberts> partha: yep it does, it does not check if rpms are missing though, so it assumes the user has everything set to immediate
15:12:19 <bmbouter> anyone can add to it, it'll let us know topics ahead of time, and the order
15:12:21 <partha> croberts: jsherrill jturel In pulp3 the directory structure doesnt really align to cdn format ?
15:12:40 <croberts> if there are repos that are not set to immediate it dumps a bunch of rsync errors
15:12:44 <bmbouter> aaaaand we can write the summarized outcome of each item on it and send it out
15:12:55 <bmbouter> because the recorded long chat long in the triage minutes is not really usable
15:12:58 <croberts> partha: that i dont know, i have not touched pulp3
15:13:07 <bmbouter> for example folks not reading this right now would have no idea about what was discussed or decided
15:13:14 <ggainey> croberts: partha : that doesn't have any interasection with PulpExport - as croberts notes, it's just packaging the on-desk published distributions
15:13:14 <croberts> im still waiting on pulp-admin to be made for pulp 3 ;)
15:13:27 <fao89> bmbouter, pulpbot already provides meetings notes
15:13:35 <ggainey> ^desk^disk
15:13:41 <bmbouter> it does and we should use it if we can
15:13:45 <croberts> pulp-admin imho is a p1 for 7.0
15:13:47 <bmbouter> fao89: it does not provide an agenda though
15:14:12 <bmbouter> fao89: as we go through topics we would have to use the puuulpbot commands, would that be an option to record the minutes with pulpbooot?
15:15:03 <ggainey> croberts: CLI work is in progress right now, as it turns out
15:15:12 <partha> ggainey: In pulp3 the directory structure has no resemblance to cdn structure right ?
15:15:29 <croberts> ggainey: nice!
15:15:38 <dkliban> bmbouter: we would need to extend pulpbot to do that
15:16:01 <fao89> we can share the agenda topics, with the link to the minutes, so if anyone is interested in some topic, will go through the minutes
15:16:16 <jsherrill> croberts: counter point,katello doesn't ship candlepin-admin :)
15:16:30 <jsherrill> partha: no, it has not similar directory structure on disk
15:16:31 <bmbouter> dkliban, fao89: I'm getting conflicting info
15:16:47 <dkliban> bmbouter: i personally don't have capacity to extend pulpbot, but if someone else has te time i am all for it
15:16:54 <croberts> jsherrill: ha fair point :)
15:17:17 <bmbouter> as a group I don't think we have time for that so I'm proposing manual process but I believe fao89 is saying "it already does what we need" (paraphrase)
15:17:29 <partha> jsherrill: but do you see this as something  worth pursuing
15:18:01 <fao89> bmbouter, I'm proposing to just send the agenda topics with the pulpbot minutes
15:18:31 <fao89> bmbouter, so if anyone is interested in one topic of the agenda, could dig into the meeting minutes
15:19:44 <bmbouter> fao89: how will the minutes not be one long chat log?
15:20:07 <fao89> bmbouter, https://pulpadmin.fedorapeople.org/triage/pulp-dev/2020/pulp-dev.2020-05-12-14.30.html and you can click on full log to have the entire chat
15:20:19 <bmbouter> yup I'm saying an entire chat log is not valuable
15:20:27 <bmbouter> that's the problem I want to improve actually
15:20:50 <bmbouter> both having an agenda and after the meeting to easily see what the outcome was for each meeting (not read an hours worth of chat log)
15:21:57 <dkliban> we should jsut start with an agenda
15:22:08 <dkliban> that will be a good frist step
15:22:25 <fao89> +1
15:22:32 <bmbouter> +0
15:24:30 <dkliban> fao89: the concern that bmbouter has is that it's hard to read that whole chat log
15:24:48 <dkliban> fao89: it's too verbose
15:25:09 <dkliban> it would be much better for interested parties if each topic had a summary
15:25:58 <bmbouter> yeah that's the concern, especially since it's increasingly becoming a venue for significant decisions
15:26:06 <fao89> I agree
15:26:32 <dkliban> bmbouter: were you proposing that we manually write summaries at the end of open floor?
15:26:41 <bmbouter> as we go as subbullets
15:26:52 <dkliban> we can try to do that
15:27:06 <dkliban> i am terrible at keeping notes, but i am all for keeping notes
15:27:45 <dkliban> where should the link to the agenda live?
15:27:51 <dkliban> i was thining we could link to it from our website
15:27:59 <dkliban> and in our calendar invites
15:27:59 <bmbouter> that would be great
15:28:07 <bmbouter> advertising the agenda I think is the main thing we need to do now
15:28:27 <bmbouter> how we take notes and record decisions we can probably sort out later (even though I keep focusing on that)
15:28:48 <dkliban> that's exactly what i meant by 'let's start with an agenda'
15:29:06 <bmbouter> yeah I keep wanting to move too fast
15:29:18 <dkliban> alright ... we need to update the website with information about Open Floor
15:29:24 <ggainey> jsherrill: croberts partha : sorry, being distracted today - Pulp3 supports exporting file and rpm distributions, which puts the published repo "onto disk" where you tell it to go
15:29:26 <dkliban> it only mentions bug triage
15:29:33 <bmbouter> yup, we need to
15:29:45 <bmbouter> dkliban: can your update include that or how can I help?
15:29:50 <ggainey> jsherrill: croberts partha : this is a seaprate thing from "pulpexport", which is pulp-to-pulp metadata exchange
15:30:04 <fao89> #action have an open floor agenda - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:30:04 <fao89> !action have an open floor agenda - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:30:05 <ggainey> separate, even
15:30:24 <dkliban> bmbouter: my update is alrady merged
15:30:32 <dkliban> and email is already sent
15:30:33 <bmbouter> dkliban: shall I make one?
15:30:40 <dkliban> bmbouter: that would be great
15:30:43 <bmbouter> I will it's easy
15:30:48 <dkliban> i agree
15:30:50 <bmbouter> aaaand that's our time
15:31:05 <dkliban> thank you everyone!
15:31:27 <fao89> #action have an open floor agenda - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:31:27 <fao89> !PulpTriage action have an open floor agenda - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:31:44 <fao89> trying to figure out the command to record AI
15:32:02 <dkliban> fao89: we need to make pulpbot smarter
15:32:08 <dkliban> but you can end it for now
15:32:17 <fao89> dkliban, we already have it: https://github.com/pulp/supybot-pulptriage/blob/d50a594bc494b0ab4e7b83ec1a2bb000e16bfc53/plugin.py#L120-L126
15:32:26 <fao89> just don't know how to use it
15:33:00 <dkliban> #action have an open floor agenda - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:33:00 <dkliban> !action have an open floor agenda - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:33:06 <dkliban> maybe not
15:33:31 <fao89> #endmeeting
15:33:31 <fao89> !end