14:30:49 <fao89> #startmeeting Pulp Triage 2020-05-19
14:30:49 <fao89> !start
14:30:49 <fao89> #info fao89 has joined triage
14:30:49 <pulpbot> Meeting started Tue May 19 14:30:49 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:49 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:49 <pulpbot> The meeting name has been set to 'pulp_triage_2020-05-19'
14:30:49 <pulpbot> fao89: fao89 has joined triage
14:30:59 <ppicka> #info ppicka has joined triage
14:30:59 <ppicka> !here
14:30:59 <pulpbot> ppicka: ppicka has joined triage
14:31:17 <fao89> !next
14:31:18 <pulpbot> fao89: 6 issues left to triage: 6767, 6762, 6756, 6755, 6750, 6714
14:31:18 <fao89> #topic https://pulp.plan.io/issues/6767
14:31:19 <pulpbot> RM 6767 - daviddavis - NEW - Tests are failing sometimes due to 500 for pulp-fixtures
14:31:20 <pulpbot> https://pulp.plan.io/issues/6767
14:31:21 <daviddavis> #info daviddavis has joined triage
14:31:21 <daviddavis> !here
14:31:22 <pulpbot> daviddavis: daviddavis has joined triage
14:31:27 <bmbouter> #info bmbouter has joined triage
14:31:27 <bmbouter> !here
14:31:27 <pulpbot> bmbouter: bmbouter has joined triage
14:31:40 <fao89> #idea Proposed for #6767: accept and add to sprint
14:31:40 <fao89> !propose other accept and add to sprint
14:31:40 <pulpbot> fao89: Proposed for #6767: accept and add to sprint
14:31:46 <dalley> #info dalley has joined triage
14:31:46 <dalley> !here
14:31:46 <pulpbot> dalley: dalley has joined triage
14:32:33 <x9c4> #info x9c4 has joined triage
14:32:33 <x9c4> !here
14:32:33 <pulpbot> x9c4: x9c4 has joined triage
14:32:50 <daviddavis> I think I had an AI to do this a while ago
14:32:55 <daviddavis> so +1 to accept and add to sprint
14:32:55 <dkliban> #info dkliban has joined triage
14:32:56 <dkliban> !here
14:32:56 <pulpbot> dkliban: dkliban has joined triage
14:33:05 <fao89> #agreed accept and add to sprint
14:33:05 <fao89> !accept
14:33:05 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:33:06 <pulpbot> fao89: 5 issues left to triage: 6762, 6756, 6755, 6750, 6714
14:33:06 <fao89> #topic https://pulp.plan.io/issues/6762
14:33:07 <pulpbot> RM 6762 - david.macneil@actual-experience.com - NEW - Cannot sync a remote that's using a x509 content guard
14:33:08 <pulpbot> https://pulp.plan.io/issues/6762
14:33:24 * bmbouter reads
14:33:50 <dkliban> it's because of the header thing
14:33:52 <bmbouter> yup
14:34:00 * bmbouter is real glad we switched to TLS submission
14:34:12 <dkliban> bmbouter: can you reply tot he issue?
14:34:22 <bmbouter> yes and can we move to certguard project
14:34:31 <dkliban> and we should accept and not add to the sprint at ths time. what do you think bmbouter?
14:34:40 <bmbouter> yes accept not add to sprint
14:34:48 <fao89> #idea Proposed for #6762: Leave the issue as-is, accepting its current state.
14:34:48 <fao89> !propose accept
14:34:48 <pulpbot> fao89: Proposed for #6762: Leave the issue as-is, accepting its current state.
14:34:50 <bmbouter> this is going to work if he uses the newest version, but we need to also add a test
14:34:52 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:34:52 <fao89> !accept
14:34:52 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:53 <pulpbot> fao89: 4 issues left to triage: 6756, 6755, 6750, 6714
14:34:53 <fao89> #topic https://pulp.plan.io/issues/6756
14:34:53 <bmbouter> and move to certguard
14:34:54 <pulpbot> RM 6756 - deepthireddy21 - NEW - Pulp celery with Mongodb replica sets
14:34:55 <pulpbot> https://pulp.plan.io/issues/6756
14:35:51 <dkliban> #idea Proposed for #6756: Leave the issue as-is, accepting its current state.
14:35:51 <dkliban> !propose accept
14:35:51 <pulpbot> dkliban: Proposed for #6756: Leave the issue as-is, accepting its current state.
14:36:00 <bmbouter> wait we won't fix tho
14:36:18 <daviddavis> yea, I thought we were going to either fix or close for pulp 2
14:37:16 <dkliban> #idea Proposed for #6756: close- won't fix
14:37:16 <dkliban> !propose other close- won't fix
14:37:16 <pulpbot> dkliban: Proposed for #6756: close- won't fix
14:37:25 <bmbouter> also invite user to switch to pulp3
14:37:32 <daviddavis> +1
14:37:33 <dkliban> yeah ... i'll comment on it and do the closing
14:37:40 <daviddavis> dkliban++
14:37:40 <pulpbot> daviddavis: dkliban's karma is now 471
14:37:43 <fao89> #agreed close- won't fix
14:37:43 <fao89> !accept
14:37:43 <pulpbot> fao89: Current proposal accepted: close- won't fix
14:37:44 <pulpbot> fao89: 3 issues left to triage: 6755, 6750, 6714
14:37:44 <fao89> #topic https://pulp.plan.io/issues/6755
14:37:45 <pulpbot> RM 6755 - swisscom - NEW - pulpcore-manager error "You must specify the CONTENT_ORIGIN setting"
14:37:46 <pulpbot> https://pulp.plan.io/issues/6755
14:38:09 <bmbouter> oh this error is by design to instruct the user they have to set this
14:38:17 <daviddavis> the user says we can close it out
14:38:23 <daviddavis> s/user/reporter/
14:38:29 <dkliban> yep ... gerrod filed a similar issue yesterday
14:38:29 <fao89> #idea Proposed for #6755: close it as notabug
14:38:29 <fao89> !propose other close it as notabug
14:38:29 <pulpbot> fao89: Proposed for #6755: close it as notabug
14:38:38 <dkliban> and we will close that one today alos
14:39:00 <bmbouter> we need a better error message for that I think
14:39:07 <bmbouter> that would be a good way to transition the bug
14:39:16 <bmbouter> https://github.com/pulp/pulpcore/blob/master/pulpcore/app/settings.py#L233
14:39:29 <bmbouter> actually I'll file it
14:39:33 <daviddavis> +1
14:39:35 <dkliban> bmbouter: and i'll comment
14:39:35 <bmbouter> I have specific ideas on how to resolve this
14:39:47 <dkliban> it's usually a permissions problem
14:39:53 <dkliban> with the /etc/pulp/settings.py
14:40:08 <fao89> for this issue, what should I do? Close it?
14:40:45 <dkliban> i think so. bmbouter? ^
14:41:02 <bmbouter> use says close it +1 to that
14:41:06 <bmbouter> I'm filing a new issue now
14:41:20 <fao89> #agreed close it as notabug
14:41:20 <fao89> !accept
14:41:20 <pulpbot> fao89: Current proposal accepted: close it as notabug
14:41:23 <fao89> #topic https://pulp.plan.io/issues/6750
14:41:23 <pulpbot> fao89: 2 issues left to triage: 6750, 6714
14:41:24 <pulpbot> RM 6750 - dkliban@redhat.com - NEW - CI doesn't show output of container build logs
14:41:25 <pulpbot> https://pulp.plan.io/issues/6750
14:42:03 <fao89> #idea Proposed for #6750: accept and add to sprint
14:42:03 <fao89> !propose other accept and add to sprint
14:42:03 <pulpbot> fao89: Proposed for #6750: accept and add to sprint
14:42:06 <dkliban> +1
14:42:32 <fao89> #agreed accept and add to sprint
14:42:32 <fao89> !accept
14:42:32 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:42:33 <fao89> #topic https://pulp.plan.io/issues/6714
14:42:33 <pulpbot> fao89: 1 issues left to triage: 6714
14:42:34 <pulpbot> RM 6714 - alikins - NEW - drf builtin manage.py 'generateschema' command fails on pulp base viewsets
14:42:35 <x9c4> +1 Ill comment on it,
14:42:36 <pulpbot> https://pulp.plan.io/issues/6714
14:43:01 <dkliban> let's skip it and i'll reach out to the filer
14:43:06 <dkliban> i commented but he didn't notice
14:43:12 <fao89> !skip
14:43:13 <dkliban> !propose skip
14:43:14 <pulpbot> fao89: No issues to triage.
14:43:15 <pulpbot> dkliban: Error: No current issue, proposal ignored.
14:43:21 <dkliban> lol
14:43:27 <fao89> Open floor - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:43:52 <dkliban> pulpcore 3.4.0 release date proposal: May 27th
14:44:19 <dkliban> this is a Wednesday after the Memorial day holiday in the US
14:45:13 <bmbouter> yes giving a business day in the US is the thinking
14:45:30 <bmbouter> if we accept this, we would want to advertise this timleine on pulp-dev
14:45:54 <daviddavis> that all sounds good to me
14:46:35 <bmbouter> any concerns w/ this timeline or counterproposal?
14:47:38 <dkliban> none from me
14:47:47 <daviddavis> I have one
14:47:52 <daviddavis> who's going to do it
14:48:00 <bmbouter> oh yeah good question
14:50:22 <dkliban> well, it's been a while since i've done it
14:51:15 <dkliban> i will do it
14:51:22 * daviddavis cheers wildly
14:51:24 <dkliban> lol
14:52:21 <daviddavis> next topic?
14:52:33 <dkliban> What should block this release?
14:53:06 <fao89> #action dkliban will do the 3.4.0 on May 27th
14:53:06 <fao89> !action dkliban will do the 3.4.0 on May 27th
14:53:28 <dkliban> i'll send a note to pulp-dev list announcing this date also
14:53:35 <bmbouter> I was thinking we could approach this as "should block" the release and then as we get closer make a final decision
14:53:49 <bmbouter> dkliban: thank you and we want a call for blocker in that announcement
14:53:49 <dkliban> sounds good to me
14:54:30 <bmbouter> I was hoping we could have all the write_field issues resolved w/ this release
14:54:40 <dkliban> +1
14:54:47 <bmbouter> the audit one mdellweg was looking at and another if there is one
14:54:51 <bmbouter> but I don't have issue numbers unfortuantely
14:55:02 <dkliban> https://pulp.plan.io/issues/6421
14:55:18 <dkliban> and the other one needs to still be filed i think
14:55:56 <bmbouter> ok 6421 and the yet-to-be-filed fixes for pulpcore's use of write_only (which is also our next topic btw)
14:56:00 <dkliban> and i would characterize it as 'bindings can't be used to upload Content in a single api call'
14:56:15 <bmbouter> how do folks feel about those to be tagged with 3.4.0?
14:56:23 <bmbouter> which is the mechanism I think we'll use
14:56:38 <dkliban> i would love it if we finally resolved this
14:58:26 <dkliban> so i feel good
14:58:42 <bmbouter> ok please bring up any concerns if there are any
14:59:36 <bmbouter> #action tag 6421 and yet-to-be-filed pulpcore write_only issue as 3.4.0 blocker
14:59:36 <bmbouter> !action tag 6421 and yet-to-be-filed pulpcore write_only issue as 3.4.0 blocker
14:59:42 <bmbouter> fao89: I wonder if ^ worked
15:00:03 <bmbouter> here's a blocker that is already set but it won't be ready  https://pulp.plan.io/issues/6460
15:00:11 <fao89> it is a matter of faith, haha
15:00:25 <bmbouter> I propose we remove the blocker tag from it, katello has a workaround already so I think that is ok
15:00:44 <fao89> last time it worked, unfortunately pulpbot does not send any message for this command
15:00:50 <bmbouter> np
15:03:39 * bmbouter falls alseep
15:04:17 <bmbouter> ok let's move on sounds like there are no concerns
15:04:26 <x9c4> next topic?
15:04:28 <bmbouter> #action remove 6460 as blocker, katello has a workaround and the patch isn't ready
15:04:28 <bmbouter> !action remove 6460 as blocker, katello has a workaround and the patch isn't ready
15:04:33 <bmbouter> almost
15:04:45 <bmbouter> this is the last blocker we talked about https://pulp.plan.io/issues/6369
15:04:53 <bmbouter> the last one I had at least
15:05:03 <dkliban> yep ... i think we need to resolve this also
15:05:40 <fao89> +1
15:05:56 <bmbouter> #action add 3.4.0 blocker tag to https://pulp.plan.io/issues/6369
15:05:56 <bmbouter> !action add 3.4.0 blocker tag to https://pulp.plan.io/issues/6369
15:06:38 <bmbouter> those are the only blockers I was thinking of so I'm good to move on
15:07:13 <dkliban> #action dkliban to file a bug about not being able to upload content in single call using bindings
15:07:13 <dkliban> !action dkliban to file a bug about not being able to upload content in single call using bindings
15:08:41 <dkliban> next topic:
15:08:44 <dkliban> review write_field usage audit
15:08:46 <x9c4> https://pulp.plan.io/issues/6421#note-9
15:10:29 <bmbouter> so I'm focusing on the pulpcore ones only here
15:10:54 <dkliban> i am a bit confused about the pulpcore ones
15:10:58 <dkliban> relative_path on the SingleArtifactContentSerializer OK, since there is no relative_path in the database model. Also it is dynamically deactivated.
15:11:23 <dkliban> it sounds like we should keep this field as write_only
15:11:27 <x9c4> If the content decides to have a relative_path write_only is set to False.
15:11:42 <dkliban> gotcha
15:11:56 <dkliban> i think we can keep this one
15:11:58 <bmbouter> so to me we need to remove write_only entirely because the openapi schema we use does not allow it
15:12:19 <bmbouter> I intepret 'OK' as a legitimate use for a write-only-like-behavior
15:12:31 <dkliban> bmbouter: did you see the latest discussion ont he write_only thread?
15:12:47 <bmbouter> I don't think I did
15:12:48 * dkliban pulls it up
15:13:24 <dkliban> bmbouter: https://www.redhat.com/archives/pulp-dev/2020-April/msg00101.html
15:14:25 <bmbouter> oh yes I did read this
15:14:55 <bmbouter> to recap my understanding on this solution: the effect is that the bindings will two serializers is that right?
15:15:07 <bmbouter> s/will two/will get two/
15:15:10 <dkliban> yes, that's right
15:15:30 <dkliban> even if dont' do it automatically, we will still need to provide 2 serializers
15:15:46 <bmbouter> agreed this matches what I think is the path forward also
15:16:21 <bmbouter> and how many models does that make for an object w/ 2 serializers?
15:16:40 <dkliban> Content models
15:16:59 <dkliban> PulpExportSerializer
15:17:19 <dkliban> UploadChunkSerializer
15:17:21 <bmbouter> so for one of those examples... does it get two models?
15:17:39 <dkliban> FileContent and FileContentWrite
15:17:54 <x9c4> Actually FileContent and FileContentRead
15:17:55 <dkliban> PulpExport and PulpExportWrite
15:18:00 <dkliban> oops
15:18:02 <dkliban> thank you x9c4
15:18:10 <bmbouter> great this is making sense to me, ty both
15:18:15 <dkliban> PulpExport and PulpExportRead
15:18:36 <bmbouter> so they get two models and ^ are their names
15:18:42 <dkliban> yep
15:18:44 <bmbouter> just like the email says
15:18:56 <bmbouter> ok I'm ready to go back to the content from https://pulp.plan.io/issues/6421#note-9
15:19:06 <x9c4> And no user ever instanciates the secon one by hand.
15:19:10 <bmbouter> yup
15:19:29 <bmbouter> so let me ask this: if we continue to have write_only ... that won't ever make it into the openapischema itself?
15:20:03 <dkliban> that's right ... we will always split it up into two serializers
15:20:16 <dkliban> and fields won't be marked as write_only in the schema
15:20:37 <bmbouter> great
15:20:44 <x9c4> because that does not exist in the schema?
15:20:49 <dkliban> yep
15:20:52 <bmbouter> yes it's not allowed in V2
15:21:01 <bmbouter> which is one of my main concerns, but this plan addresses that
15:21:02 <x9c4> fine.
15:21:32 <dkliban> bmbouter: at some point we will need to transition to v3, but we can discuss that later down the road
15:22:05 <dkliban> but i don't want to rush that right now
15:22:15 <bmbouter> agreed
15:22:27 <bmbouter> dkliban: so I'm back to the question you asked...
15:23:02 <dkliban> you have to repeat it cause i forgot
15:23:30 <bmbouter> I don't understand "relative_path on the SingleArtifactContentSerializer OK, since there is no relative_path in the database model. Also it is dynamically deactivated."
15:23:46 <dkliban> oh yes, i understand it now
15:24:01 <dkliban> this concerns the Content serializers
15:24:14 <dkliban> and we allow users to upload content directly into a repository
15:24:35 <dkliban> even wihtout the repository part, we allow users to upload a file and create content out of it
15:24:46 <dkliban> that content needs a relative path for the content artifact
15:24:51 <daviddavis> yes
15:25:12 <x9c4> Not necessarily.
15:25:24 <dkliban> so we allow users to specify the relative path at creation time, but we don't always return it. unless it's like FileContent which does have a relative_path field
15:25:37 <dkliban> x9c4: please explain
15:25:45 <x9c4> Only if the path to publish it is not determined by other menas while publishing.
15:26:19 <daviddavis> even for those units currently, don't they have a relative path set on content artifact?
15:26:34 <x9c4> I think it can be None/Nil
15:26:37 <daviddavis> oh ok
15:27:21 <x9c4> This does not work with passthrough publishing for obvious reasons.
15:27:41 <daviddavis> actually we don't allow null right now https://git.io/JfzkW
15:28:12 <dkliban> time check
15:28:20 <dkliban> i have a hard stop at 11:3-
15:28:23 <bmbouter> me also
15:28:25 <daviddavis> me too
15:28:36 <bmbouter> so let's revisit on friday I can push it to the agenda there as prep
15:29:02 <bmbouter> but for the fields that have write_only we'll need the serizlier splitter
15:29:08 <bmbouter> do we have a POC PR w/ that implementaiton?
15:29:15 <bmbouter> fao89: maybe you had it at one point?
15:29:47 <fao89> I closed a PR that did that
15:30:30 <bmbouter> fao89: would you be able to open that back up so we can look at on friday?
15:30:32 <fao89> https://github.com/pulp/pulpcore/pull/600
15:30:53 <bmbouter> it needs secretCharField stuff removed
15:31:00 <fao89> yep
15:31:00 <dkliban> fao89: i'll file a new issue to associate with that PR
15:31:04 <fao89> I'll do it
15:31:07 <bmbouter> ty and ty
15:31:10 <bmbouter> that's our time
15:31:16 <dkliban> thank you all
15:31:20 <fao89> #endmeeting
15:31:20 <fao89> !end