14:30:09 <fao89> #startmeeting Pulp Triage 2020-05-22
14:30:09 <fao89> #info fao89 has joined triage
14:30:09 <fao89> !start
14:30:09 <pulpbot> Meeting started Fri May 22 14:30:09 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:09 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:09 <pulpbot> The meeting name has been set to 'pulp_triage_2020-05-22'
14:30:09 <pulpbot> fao89: fao89 has joined triage
14:30:16 <ggainey> #info ggainey has joined triage
14:30:16 <ggainey> !here
14:30:16 <pulpbot> ggainey: ggainey has joined triage
14:30:18 <ppicka> #info ppicka has joined triage
14:30:18 <ppicka> !here
14:30:18 <pulpbot> ppicka: ppicka has joined triage
14:30:26 <fao89> !next
14:30:27 <fao89> #topic https://pulp.plan.io/issues/6775
14:30:27 <pulpbot> fao89: 6 issues left to triage: 6775, 6773, 6771, 6770, 6768, 6714
14:30:28 <pulpbot> RM 6775 - dkliban@redhat.com - POST - bindings can't be used to create Content with a single call
14:30:29 <pulpbot> https://pulp.plan.io/issues/6775
14:30:44 <fao89> #idea Proposed for #6775: accept and add to sprint
14:30:44 <fao89> !propose other accept and add to sprint
14:30:44 <pulpbot> fao89: Proposed for #6775: accept and add to sprint
14:30:55 <dkliban> #info dkliban has joined triage
14:30:55 <dkliban> !here
14:30:55 <pulpbot> dkliban: dkliban has joined triage
14:31:22 <daviddavis> #info daviddavis has joined triage
14:31:22 <daviddavis> !here
14:31:22 <pulpbot> daviddavis: daviddavis has joined triage
14:31:30 <ggainey> fao89: this is just one of the write_only set, yeah?
14:31:44 <fao89> yep, it is a blocker
14:31:46 <ggainey> oh nm, already has a PR - accept-and-add, aye
14:31:53 <fao89> #agreed accept and add to sprint
14:31:53 <fao89> !accept
14:31:53 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:31:54 <pulpbot> fao89: 5 issues left to triage: 6773, 6771, 6770, 6768, 6714
14:31:54 <fao89> #topic https://pulp.plan.io/issues/6773
14:31:54 <daviddavis> +1
14:31:54 <dkliban> +1
14:31:55 <pulpbot> RM 6773 - bmbouter - NEW - Document in plugin writer guide tasks are not safe to wait on other tasks
14:31:56 <pulpbot> https://pulp.plan.io/issues/6773
14:32:00 <ttereshc> #info ttereshc has joined triage
14:32:00 <ttereshc> !here
14:32:00 <pulpbot> ttereshc: ttereshc has joined triage
14:32:23 <ggainey> heh, despair :)
14:32:31 <fao89> #idea Proposed for #6773: Leave the issue as-is, accepting its current state.
14:32:31 <fao89> !propose accept
14:32:31 <pulpbot> fao89: Proposed for #6773: Leave the issue as-is, accepting its current state.
14:32:39 <ggainey> is this a task?
14:32:40 <ttereshc> +1 to accept and convert to a task
14:32:46 <ggainey> yeah same
14:32:48 <bmbouter> #info bmbouter has joined triage
14:32:48 <bmbouter> !here
14:32:48 <pulpbot> bmbouter: bmbouter has joined triage
14:32:56 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:32:56 <fao89> !accept
14:32:56 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:32:57 <fao89> #topic https://pulp.plan.io/issues/6771
14:32:57 <pulpbot> fao89: 4 issues left to triage: 6771, 6770, 6768, 6714
14:32:58 <pulpbot> RM 6771 - bmbouter - NEW - Users not setting CONTENT_ORIGIN receive an error message that is not the most helpful
14:32:59 <pulpbot> https://pulp.plan.io/issues/6771
14:33:15 <ggainey> accept and add
14:33:23 <fao89> #idea Proposed for #6771: accept and add to sprint
14:33:23 <fao89> !propose other accept and add to sprint
14:33:23 <pulpbot> fao89: Proposed for #6771: accept and add to sprint
14:33:48 <ttereshc> task/story?
14:33:56 <ttereshc> it's not a bug per se
14:34:29 <bmbouter> agreed
14:34:35 <bmbouter> task I think
14:34:40 <bmbouter> it's not new functionality, just something to do
14:34:41 <fao89> #idea Proposed for #6771: convert to task and add to sprint
14:34:41 <fao89> !propose other convert to task and add to sprint
14:34:41 <pulpbot> fao89: Proposed for #6771: convert to task and add to sprint
14:34:46 <dkliban> +1
14:34:49 <ttereshc> +1
14:34:50 <ggainey> aye, concur
14:34:52 <fao89> #agreed convert to task and add to sprint
14:34:52 <fao89> !accept
14:34:52 <pulpbot> fao89: Current proposal accepted: convert to task and add to sprint
14:34:53 <fao89> #topic https://pulp.plan.io/issues/6770
14:34:53 <pulpbot> fao89: 3 issues left to triage: 6770, 6768, 6714
14:34:54 <pulpbot> RM 6770 - ttereshc - NEW - pfixtures/pbindings don't work on pulp2-nightly-pulp3-source-centos7 box
14:34:55 <pulpbot> https://pulp.plan.io/issues/6770
14:35:31 <fao89> #idea Proposed for #6770: Leave the issue as-is, accepting its current state.
14:35:31 <fao89> !propose accept
14:35:31 <pulpbot> fao89: Proposed for #6770: Leave the issue as-is, accepting its current state.
14:35:35 <dkliban> this is a problem for the migration plugin
14:35:44 <daviddavis> was this the quay issue?
14:35:56 <mikedep333> #info mikedep333 has joined triage
14:35:56 <mikedep333> !here
14:35:57 <pulpbot> mikedep333: mikedep333 has joined triage
14:36:01 <ttereshc> daviddavis, no
14:36:04 <dkliban> i don't think so ... i think it's something to do with the version of podamn/docker
14:36:04 <daviddavis> oh ok
14:36:19 <daviddavis> +1 to accept
14:36:33 <daviddavis> or even add to sprint
14:36:37 <ttereshc> if someone has time to look at it, it would be helpful
14:36:44 <dkliban> yeah ... let's add to sprint
14:36:50 <ggainey> +1 to accept-and-add
14:36:50 <ttereshc> it's very inconvenient for development that those don't work
14:36:56 <ggainey> yus
14:36:58 <daviddavis> yea
14:37:06 <fao89> #idea Proposed for #6770: accept and add to sprint
14:37:06 <fao89> !propose other accept and add to sprint
14:37:06 <pulpbot> fao89: Proposed for #6770: accept and add to sprint
14:37:09 <fao89> #agreed accept and add to sprint
14:37:09 <fao89> !accept
14:37:09 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:37:10 <fao89> #topic https://pulp.plan.io/issues/6768
14:37:10 <pulpbot> fao89: 2 issues left to triage: 6768, 6714
14:37:11 <pulpbot> RM 6768 - fao89 - NEW - whitenoise expects /var/lib/pulp/assets on single container
14:37:12 <pulpbot> https://pulp.plan.io/issues/6768
14:37:12 <ttereshc> ty
14:37:26 <dkliban> we don't run collectstatic when building the single container
14:37:32 <dkliban> i'll comment with that
14:37:39 <dkliban> #idea Proposed for #6768: accept and add to sprint
14:37:39 <dkliban> !propose other accept and add to sprint
14:37:39 <pulpbot> dkliban: Proposed for #6768: accept and add to sprint
14:37:50 <fao89> #agreed accept and add to sprint
14:37:50 <fao89> !accept
14:37:50 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:37:51 <fao89> #topic https://pulp.plan.io/issues/6714
14:37:51 <pulpbot> fao89: 1 issues left to triage: 6714
14:37:52 <pulpbot> RM 6714 - alikins - NEW - drf builtin manage.py 'generateschema' command fails on pulp base viewsets
14:37:53 <pulpbot> https://pulp.plan.io/issues/6714
14:38:16 <daviddavis> I can ping alikins
14:38:40 <ttereshc> skip?
14:38:43 <daviddavis> +1
14:38:46 <ggainey> kk
14:38:49 <fao89> !skip
14:38:50 <pulpbot> fao89: No issues to triage.
14:39:01 <fao89> Open floor!
14:39:24 <fao89> https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:39:51 <bmbouter> the first topic says review write_field, but really it's about reviewing the PR to split the serializers
14:40:29 <dkliban> i am already reviewing this PR
14:40:36 <dkliban> i should have feedback this afternoon
14:40:38 <fao89> dkliban++
14:40:38 <pulpbot> fao89: dkliban's karma is now 473
14:41:00 <bmbouter> I think that's probably all we need to know in terms of our time here at open floor
14:41:23 <bmbouter> dkliban: one of my quesitons was if there were any write_only field usages that needed to be removed based on the audit from x9c4
14:42:02 <dkliban> i think so
14:42:14 <daviddavis> yes
14:42:22 <dkliban> https://pulp.plan.io/issues/6421#note-9
14:42:30 <dkliban> RepositoryAddRemoveContentSerializer
14:42:40 <dkliban> that serializer is only used for POST
14:42:52 <dkliban> so we need to remove the write_only designation on those fields
14:42:57 <bmbouter> that makes sense +1
14:43:22 <dkliban> and i think that's all
14:43:24 <daviddavis> ggainey: full and versions on the PulpExportSerializer. Should those values be persisted?
14:43:34 <daviddavis> I think the answer is that they are already persisted in params
14:43:44 <ggainey> daviddavis: they are, because everything used on the cmd are in params
14:43:46 <ggainey> yeah that
14:43:54 <ggainey> I am adding a comment to the issue right now
14:44:05 <daviddavis> dkliban: what about the pulp_container write_only fields?
14:44:11 <daviddavis> ggainey: thanks
14:44:18 <ggainey> np
14:44:38 <dkliban> daviddavis: all those need to be cleaned up also. they are all for POST operations
14:44:47 <daviddavis> dkliban: awesome, can you comment?
14:44:53 <dkliban> yea
14:44:58 <daviddavis> thanks
14:45:45 <daviddavis> anything else for write_only?
14:46:35 <bmbouter> what about "full and versions on the PulpExportSerializer. Should those values be persisted?"
14:46:42 <daviddavis> bmbouter: scroll up
14:47:23 <dkliban> daviddavis: so they should not be write_only
14:47:32 <dkliban> correct?
14:47:44 <ggainey> they are write-only as incoming params - they are not individually-persisted
14:48:01 <dkliban> oh ok
14:48:12 <daviddavis> Export has a generic params field that stores any one-time options
14:48:14 <ggainey> the 'params' json is persisted
14:48:15 <ggainey> yah
14:48:43 <dkliban> that's confusing
14:48:51 <dkliban> so can a user pass in 'params' ?
14:49:00 <dkliban> or is the user passing in individual params?
14:49:00 <bmbouter> daviddavis: ack I missed it ty
14:49:19 <ggainey> individual args, params is historic-record-of-cmd-line-options, if you will
14:49:31 <ggainey> and is read-only
14:49:57 <dkliban> ok
14:50:21 <dkliban> so in this case the write_only designation on those fields is correct
14:50:25 <ggainey> yus
14:50:43 <ggainey> it's Write On! :)
14:50:44 <dkliban> alright. i am satisfied
14:50:48 <ggainey> :D
14:50:53 <dkliban> we can move on to the next topic
14:51:10 <ggainey> dkliban: keepin you happy is what I live for , honestly :)
14:51:16 <dkliban> lol
14:51:22 * daviddavis hands the microphone to fao89
14:51:47 <daviddavis> ok next topic
14:51:49 <daviddavis> minutes not being recorded https://pulp.plan.io/issues/6791
14:51:50 <fao89> me? why?
14:52:03 <daviddavis> fao89: I thought you're running triage
14:52:52 <daviddavis> bmbouter: did you want to say something about https://pulp.plan.io/issues/6791
14:52:54 * bmbouter sings friday friday into the microphone
14:52:54 <ggainey> also, didn't pulpbot change $TOPIC as well? or am I dreaming that?
14:52:58 <daviddavis> !friday
14:52:58 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:53:05 <dkliban> so the problem here is that we have a cron job that rsyncs the triage meeting logs to fedorapeople
14:53:09 <fao89> on open floor I let people bring their points, so everyone runs it
14:53:26 <dkliban> and that cron job does not know to rsync the new directory
14:53:37 <dkliban> however, this brings me to a question ....
14:53:52 <dkliban> why are we even rsyncing the files to fedora people?
14:54:10 <dkliban> their original location is pulpproject.org ... we should just make them available on that web server
14:54:22 <dkliban> and not do any sort of rsync
14:54:27 <dkliban> what do others think?
14:54:43 <ggainey> as long as they are publicly-available, I don't think it matters where
14:54:51 <fao89> where this rsync happen? pulp-ci?
14:54:58 <ttereshc> +1 to that. I wonder why we didn't do it initially?
14:55:06 <daviddavis> +1 from me
14:55:06 <ggainey> also, pulp-meeting looks like it was only being rsync
14:55:15 <ggainey> 'd to fedorapeople in Dec-2019
14:55:21 <ggainey> I don't see any other archives there
14:55:54 <ggainey> nm, looking in the wrong place
14:55:55 <bmbouter> +1 to this
14:56:06 <ggainey> anyway, +1 to pulpproject.org
14:56:12 <bmbouter> originally we didn't have a webserver on pulproject.org like we do now
14:56:35 <ttereshc> thx
14:56:53 <bmbouter> can this ticket be repruposed to handle all that?
14:57:10 <dkliban> ggainey: i manually rsynced pulp-meeting in 2019
14:57:22 <ggainey> ahh, gotcha
14:59:08 <dkliban> alright .... i'll update this ticket with the new information about keeping things on pulpproject.org
14:59:17 <daviddavis> excellent
14:59:19 <ggainey> dkliban++
14:59:19 <pulpbot> ggainey: dkliban's karma is now 474
15:00:22 <ttereshc> next topic?
15:00:34 <ttereshc> discuss moving requirements out of setup.py to a dedicated file?
15:00:50 <bmbouter> yes I wanted to highlight this was going to happen unless there are requests it not
15:01:12 <bmbouter> plugins who want to use the release automation would need to move their requirements out of setup.py to use it
15:01:28 <bmbouter> I don't see that as a big deal but I wanted to ask and do it transparently
15:01:51 <fao89> so far I have 2 PRs for it
15:01:52 <fao89> https://github.com/pulp/pulp_file/pull/390
15:02:04 <fao89> https://github.com/pulp/pulpcore/pull/714
15:03:07 <ttereshc> bmbouter, we probably should make it visible noticeable to users. I think wibbit recently asked about setup.py because they building rpms and the look at the requirements. So maybe there are some scripts around that and users should be aware
15:04:02 <bmbouter> ttereshc: I agree, what do you suggest we do to do that
15:04:13 <bmbouter> or is there a suggestion rather
15:05:07 <ttereshc> maybe highlighting it in the release announcement (in addition to usual changelog notes) will be enough
15:06:10 <ttereshc> not sure what else users might read :)
15:06:14 <ggainey> that sounds pretty reasonable
15:06:48 <bmbouter> I agree, in each project yes?
15:07:00 <bmbouter> oh you said release announcement +1
15:07:29 <bmbouter> so would we add a .removal note to the Prs fao89 links to above?
15:09:34 <ttereshc> Good question. I'm on the fence since it's not very user specific but at the same time, some might find it useful. I guess a .removal note won't hurt, so +1
15:10:40 <bmbouter> actually it's not really user facing I rescind my suggestion
15:11:07 <bmbouter> ok it sounds like the change itself is acceptable and we should highlight in the release announcement so I think we can next topic, wdyt?
15:11:33 <dkliban> +1
15:11:34 <ttereshc> yes, let's move on
15:11:52 <ggainey> +1
15:12:10 <ttereshc> "Deferring https://github.com/pulp/pulpcore/pull/577 because we can’t review today"
15:12:20 <bmbouter> fao89: it's great you emailed saying we need to review those two 3.4.0 items highlighting the need
15:12:49 <bmbouter> we think we cannot get to PR 577 until tuesday and that's likely too close to the release
15:12:59 <bmbouter> and maybe not even tuesday atually
15:14:05 <bmbouter> so we are thinking of removing it as a 3.4.0 blocker and focusing on the write_only serializer change instead
15:15:16 <dkliban> fao89: let's schedule 30 mins on Tuesday to go over it
15:15:41 <bmbouter> that would be a sweet outcome
15:15:48 <bmbouter> if I need to also join invite me
15:16:33 <fao89> yeah, definitely this PR needs some tour
15:16:37 <dkliban> i don't think you are needed ... i just need 1 person that is familiar with galaxy_ng
15:16:46 <bmbouter> that sounds ideal to me
15:16:50 <bmbouter> +1
15:16:51 <dkliban> fao89: i'll send you an invite
15:17:29 <dkliban> done
15:17:36 <fao89> =)
15:18:07 <ttereshc> last topic: "Closing 2.17.0 milestone that is old and released"
15:18:08 <bmbouter> ok so we leave as blocker now and we'll have a blocker check-in on tuesday at it's open floor
15:18:27 <bmbouter> I'm trying to incorporate a small Redmine data quality change each week
15:18:31 <bmbouter> this is the one for this week
15:18:40 <ggainey> +1
15:18:51 <bmbouter> I can handle this right now, just bringing up for folks to see
15:19:04 <ttereshc> +1 and thank you
15:19:11 <ggainey> bmbouter++
15:19:11 <pulpbot> ggainey: bmbouter's karma is now 270
15:19:32 <fao89> quaterly meeting conflicts with triage, and PR review will be after open floor
15:20:20 <bmbouter> yup I think in the channel next week we can say it's delayed then also
15:20:23 <bmbouter> fao89: ty for pointing this out
15:21:01 <fao89> bmbouter, delaying triage will affect galaxy meeting
15:21:25 <bmbouter> fao89: I was imaginging it would start late and be shortened
15:21:36 <fao89> sounds good
15:21:51 <ttereshc> bmbouter, re redmine. I cleaned some spam today and was looking into their rest api to see if we can automate the process to some extent and there are many things which are not available according to the docs, e.g. removal of a specific comments from the issue.
15:22:14 <bmbouter> oh really...
15:22:18 <ttereshc> do you know how up to date their docs are and is it worth the time filing rfes?
15:22:42 <bmbouter> which site are you looking at? python-redmine?
15:22:50 <ttereshc> let me check
15:22:51 <bmbouter> https://python-redmine.com/
15:23:15 <bmbouter> I think we can end open floor
15:23:27 <ttereshc> bmbouter, https://www.redmine.org/projects/redmine/wiki/Rest_api
15:24:44 <bmbouter> I'll email plan.io and see what they recommend how about that?
15:25:23 <ttereshc> I can e-mail them as well, I actually started writing the e-mail but I thought I'd ask you first
15:25:44 <bmbouter> since you started would you continue and maybe just cc me cuz I'm interested?
15:26:05 <ttereshc> sure
15:26:42 <bmbouter> ty
15:26:56 <ttereshc> I think we can end the open floor
15:27:01 <bmbouter> !end
15:27:06 <fao89> #endmeeting
15:27:06 <fao89> !end