15:00:19 <fao89> #startmeeting Pulp Triage 2020-05-26
15:00:19 <fao89> !start
15:00:19 <fao89> #info fao89 has joined triage
15:00:19 <pulpbot> Meeting started Tue May 26 15:00:19 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:19 <pulpbot> The meeting name has been set to 'pulp_triage_2020-05-26'
15:00:19 <pulpbot> fao89: fao89 has joined triage
15:00:22 <dkliban> #info dkliban has joined triage
15:00:22 <dkliban> !here
15:00:23 <pulpbot> dkliban: dkliban has joined triage
15:00:27 <fao89> !next
15:00:28 <fao89> #topic https://pulp.plan.io/issues/6820
15:00:28 <pulpbot> fao89: 4 issues left to triage: 6820, 6818, 6811, 6714
15:00:28 <ppicka> #info ppicka has joined triage
15:00:28 <ppicka> !here
15:00:29 <pulpbot> RM 6820 - jdjeffers - NEW - pulp_rpm dependency solving with multiple content hrefs doesn't copy all dependent rpms
15:00:30 <pulpbot> https://pulp.plan.io/issues/6820
15:00:31 <pulpbot> ppicka: ppicka has joined triage
15:00:38 <dkliban> we should switch this to RPM
15:00:50 <fao89> #idea Proposed for #6820: move to RPM
15:00:50 <fao89> !propose other move to RPM
15:00:50 <pulpbot> fao89: Proposed for #6820: move to RPM
15:00:56 <fao89> #agreed move to RPM
15:00:56 <fao89> !accept
15:00:56 <pulpbot> fao89: Current proposal accepted: move to RPM
15:00:57 <pulpbot> fao89: 3 issues left to triage: 6818, 6811, 6714
15:00:57 <fao89> #topic https://pulp.plan.io/issues/6818
15:00:58 <pulpbot> RM 6818 - jazhang - NEW - pulp syncing docker content to target repo failed with unknown error
15:00:59 <pulpbot> https://pulp.plan.io/issues/6818
15:01:40 <daviddavis> #info daviddavis has joined triage
15:01:40 <daviddavis> !here
15:01:41 <pulpbot> daviddavis: daviddavis has joined triage
15:01:41 <ipanova> #info ipanova has joined triage
15:01:41 <ipanova> !here
15:01:42 <pulpbot> ipanova: ipanova has joined triage
15:01:48 <fao89> #idea Proposed for #6818: move to container plugin
15:01:48 <fao89> !propose other move to container plugin
15:01:48 <pulpbot> fao89: Proposed for #6818: move to container plugin
15:02:05 <daviddavis> +1
15:02:09 <ipanova> this is pulp2
15:02:13 <ipanova> docker plugin please
15:02:17 <dkliban> +1
15:02:21 <fao89> #agreed move to container plugin
15:02:21 <fao89> !accept
15:02:21 <pulpbot> fao89: Current proposal accepted: move to container plugin
15:02:22 <fao89> #topic https://pulp.plan.io/issues/6811
15:02:22 <pulpbot> fao89: 2 issues left to triage: 6811, 6714
15:02:23 <pulpbot> RM 6811 - cottsay - NEW - Unexpected behavior modifying non-linear repository versions
15:02:24 <ttereshc> #info ttereshc has joined triage
15:02:24 <ttereshc> !here
15:02:24 <pulpbot> https://pulp.plan.io/issues/6811
15:02:25 <pulpbot> ttereshc: ttereshc has joined triage
15:03:21 <fao89> this description is huge
15:03:28 <ttereshc> I haven't tested this one but I agree that it's very unexpected for user
15:03:52 <ttereshc> fao89, yup, that's why people should read upfront ;)
15:04:26 <dkliban> i read this one earlier. i think the main thing the user wants is that if a new version is not created, the latest version be present in the 'created_resources' list
15:04:37 <dkliban> jjeffers has brought this up also
15:05:04 <dkliban> jjeffers is adding some special logic to katello for this case
15:05:18 <ttereshc> I guess wherever, just there should be a way to show the latest version in that branch
15:05:21 <fao89> ggainey, as you were on the chat, do you want to add something about this issue?
15:05:40 <daviddavis> I agree that it would be nice to let the user know somehow that the latest version is unchanged but created_resources seems like a bad match since the version wasn't actually 'created'
15:05:59 <ttereshc> yeah, I feel very similar
15:06:08 <mikedep333> #info mikedep333 has joined triage
15:06:08 <mikedep333> !here
15:06:08 <pulpbot> mikedep333: mikedep333 has joined triage
15:07:11 <ttereshc> daviddavis, dkliban, so if the new version is not created, even though it was based on a different base_version, how does one know which version is the previous one?
15:07:19 <fao89> I'm not sure if we have to change the code or improve the docs
15:07:54 <dkliban> i think this is a story and someone needs to champion it
15:08:09 <bmbouter> #info bmbouter has joined triage
15:08:09 <bmbouter> !here
15:08:09 <pulpbot> bmbouter: bmbouter has joined triage
15:08:30 <ttereshc> I agree to covert it to a story
15:08:40 <ttereshc> *convert
15:09:18 <fao89> #idea Proposed for #6811: convert to a story
15:09:18 <fao89> !propose other convert to a story
15:09:18 <pulpbot> fao89: Proposed for #6811: convert to a story
15:10:05 <fao89> #agreed convert to a story
15:10:05 <fao89> !accept
15:10:05 <pulpbot> fao89: Current proposal accepted: convert to a story
15:10:06 <fao89> #topic https://pulp.plan.io/issues/6714
15:10:06 <pulpbot> fao89: 1 issues left to triage: 6714
15:10:07 <pulpbot> RM 6714 - alikins - NEW - drf builtin manage.py 'generateschema' command fails on pulp base viewsets
15:10:08 <pulpbot> https://pulp.plan.io/issues/6714
15:10:52 <daviddavis> I followed up with alikins (or tried to) but he's on PTo
15:10:56 <dkliban> oh ok
15:11:00 <dkliban> let's skip again
15:11:00 <daviddavis> maybe skip again?
15:11:03 <daviddavis> +1
15:11:03 <bmbouter> +1
15:11:07 <fao89> !skip
15:11:09 <pulpbot> fao89: No issues to triage.
15:11:22 <ttereshc> +1
15:11:25 <fao89> we have no items for open floor: https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
15:11:39 <bmbouter> I added one
15:11:41 <bmbouter> now too
15:12:00 <fao89> Checkin for pulpcore 3.4.0 release tomorrow
15:12:25 <dkliban> fao89 and are meeting to go over his PR for https://pulp.plan.io/issues/6369
15:12:36 <daviddavis> here's the roadmap https://pulp.plan.io/projects/pulp/roadmap
15:13:05 <bmbouter> https://pulp.plan.io/projects/pulp/issues?fixed_version_id=88&set_filter=1&status_id=%2A
15:13:55 <bmbouter> dkliban, fao89 so you two are handling the two at POST effectively?
15:13:58 <fao89> 6692 is really important, because of the SecretCharField
15:14:08 <dkliban> and i am also going to continue testing PR for https://pulp.plan.io/issues/6775 ... which x9c4 has already reviewed yesterday
15:14:12 <fao89> bmbouter, yes!
15:14:15 <dkliban> yes
15:14:19 <bmbouter> thank you!
15:14:37 <ttereshc> I meant to write the docs for 6692 and didn't get to it yesterday, I can probably do it now
15:14:57 <bmbouter> that would be sweet
15:14:58 <fao89> ttereshc++
15:14:58 <pulpbot> fao89: ttereshc's karma is now 185
15:15:45 <bmbouter> I can review if that's helpful
15:15:58 <bmbouter> do we need to do anything for 6421?
15:16:09 <fao89> 6421 still on NEW, but has a lot of notes
15:16:13 <daviddavis> yes https://pulp.plan.io/issues/6421#note-12
15:16:15 <dkliban> yes, i believe we need a PR
15:16:19 <dkliban> or multiple
15:16:35 <daviddavis> I can do it
15:17:06 <bmbouter> sweeeeet
15:17:11 <fao89> !pulp
15:17:11 <pulpbot> 🍊 Yay, Pulp! 🍊 Go team go! 🍊
15:17:27 <fao89> next item?
15:17:43 <bmbouter> who is releasing 3.4.0?
15:17:46 <bmbouter> as part of the checkin for it
15:17:48 <daviddavis> dkliban volunteered
15:17:58 <dkliban> yep
15:18:01 <dkliban> that's teh plan
15:18:56 <bmbouter> ok great ty
15:19:14 <bmbouter> does sending a note to pulp-dev confirming that we're on track to release tomorrow make sense?
15:19:44 <dkliban> bmbouter: yes, but i would like to wait till the end of day here on the east coast
15:19:52 <dkliban> end of business
15:19:55 <bmbouter> +1
15:20:12 <fao89> next topic: redmine notifications are effectively broken
15:20:42 <daviddavis> I added this. I had like 20 spam notifications this morning and it's becoming a problem.
15:20:59 <daviddavis> I'm tempted to unwatch projects but I would rather not
15:21:15 <daviddavis> just curious if it's a problem for anyone else? or if there's some sort of solution?
15:22:15 <ttereshc> it is a problem, I read/clean some spam every other day, or just ignore it :/
15:22:35 <bmbouter> I agree it's a problem
15:22:42 <ttereshc> we had some discussion with redmine and it seems like not everything is possible to do via api https://pulp.plan.io/issues/5878#note-5
15:22:56 <bmbouter> agreed I commented on the upstream issue https://pulp.plan.io/issues/5878#note-6
15:23:07 <ttereshc> and actually the most annoying part (imo) is not possible to do - remove comments
15:23:08 <daviddavis> would this take care of notifications though?
15:23:14 <bmbouter> it would not
15:23:21 <daviddavis> hmm ok
15:23:26 <daviddavis> yea comments are super annoying
15:23:27 <bmbouter> what we need to do is make pulp.plan.io an undesirable place to spam
15:23:35 <bmbouter> and I think that will take care of the comments
15:23:55 <bmbouter> one option is to have an account approval process
15:23:57 <daviddavis> yea, I can't figure out why github issues don't have these problems?
15:24:17 <bmbouter> I suspect because they don't live long and spammers know that (guessing here)
15:24:21 <daviddavis> ah
15:24:36 <bmbouter> that'll be the irony we'll figure out how to resolve the issue, prepare for the worst, and the problem will vanish
15:25:15 <fao89> timebox: 5 minutes
15:25:28 <bmbouter> ttereshc: is emailing back planio and letting them know this is unusable without them resolving that feature something you could do?
15:25:38 <daviddavis> +1
15:25:41 <bmbouter> also we can switch pulp.plan.io into "requires account approval mode"
15:25:55 <bmbouter> we can put more details onto the ticket
15:26:08 <bmbouter> and also details about the other alternative (automated cleaning)
15:26:18 <dkliban> bmbouter: let's do that ... we we have enough admins to handle that
15:26:31 <ttereshc> bmbouter, we could, I was waiting a bit if they write back, becasue the guy said that he's see if they can do something about it
15:26:42 <bmbouter> I agree, so let's revisit this next open floor and do some investigation before then
15:26:45 <ttereshc> *he'll see
15:26:52 <ttereshc> +1
15:26:57 <bmbouter> ttereshc: thaok that works for me
15:27:13 <bmbouter> 3 min, next topic?
15:27:35 <fao89> added check for uncommitted migrations https://github.com/pulp/plugin_template/pull/222
15:27:48 <dkliban> sweet
15:27:52 <daviddavis> just wanted to call this out
15:27:53 <dkliban> let's merge it
15:27:57 <daviddavis> ok
15:27:58 <bmbouter> sweeeeet!
15:28:00 <bmbouter> +1
15:28:03 <fao89> as we have just few minutes, last topic: merging pulp_file and pulpcore release scripts
15:28:06 <bmbouter> daviddavis: will this fail the job if there are a few?
15:28:11 <bmbouter> new
15:28:15 <daviddavis> bmbouter: yes
15:28:22 <bmbouter> great!
15:28:39 <bmbouter> yes I lgtm'd these scripts for release automation
15:28:50 <bmbouter> fao89: can you update the https://pulp.plan.io/projects/pulp/wiki/Pulp3_Release_Guide also?
15:28:53 <bmbouter> and dkliban use them?
15:29:10 <fao89> yep, I can do it
15:29:15 <dkliban> cool
15:29:20 <dkliban> i will use them tomorrow
15:29:26 <daviddavis> great
15:29:34 <bmbouter> how can we roll this out to all the plugins?
15:30:04 <fao89> I'll do it today or tomorrow
15:30:12 <ggainey> fao89: ugh, just returned from making tea - which issue were you asking about?
15:30:43 <fao89> ggainey, it was https://pulp.plan.io/issues/6811
15:30:44 <ggainey> 6811, ah I see
15:33:14 <fao89> #endmeeting
15:33:14 <fao89> !end