14:31:31 <fao89> #startmeeting Pulp Triage 2020-06-09
14:31:31 <fao89> !start
14:31:31 <fao89> #info fao89 has joined triage
14:31:31 <pulpbot> Meeting started Tue Jun  9 14:31:31 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:31 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:31 <pulpbot> The meeting name has been set to 'pulp_triage_2020-06-09'
14:31:31 <pulpbot> fao89: fao89 has joined triage
14:31:52 <daviddavis> #info daviddavis has joined triage
14:31:52 <daviddavis> !here
14:31:52 <pulpbot> daviddavis: daviddavis has joined triage
14:31:56 <fao89> !next
14:31:57 <fao89> #topic https://pulp.plan.io/issues/6915
14:31:57 <pulpbot> fao89: 2 issues left to triage: 6915, 6898
14:31:58 <pulpbot> RM 6915 - daviddavis - NEW - Pulpcore doesn't support django-filter 2.3.0
14:31:59 <pulpbot> https://pulp.plan.io/issues/6915
14:32:13 <fao89> #idea Proposed for #6915: accept and add to sprint
14:32:13 <fao89> !propose other accept and add to sprint
14:32:13 <pulpbot> fao89: Proposed for #6915: accept and add to sprint
14:32:21 <ttereshc> #info ttereshc has joined triage
14:32:21 <ttereshc> !here
14:32:21 <pulpbot> ttereshc: ttereshc has joined triage
14:32:22 <ppicka> #info ppicka has joined triage
14:32:22 <ppicka> !here
14:32:23 <pulpbot> ppicka: ppicka has joined triage
14:32:27 <ipanova> #info ipanova has joined triage
14:32:27 <ipanova> !here
14:32:27 <pulpbot> ipanova: ipanova has joined triage
14:32:38 <bmbouter> #info bmbouter has joined triage
14:32:38 <bmbouter> !here
14:32:38 <pulpbot> bmbouter: bmbouter has joined triage
14:32:45 <daviddavis> I could be convinced either way about adding this to the sprint
14:33:18 <bmbouter> if we can I think we should
14:33:21 <ggainey> #info ggainey has joined triage
14:33:21 <ggainey> !here
14:33:21 <pulpbot> ggainey: ggainey has joined triage
14:33:24 <bmbouter> we want to stay forward compatible
14:33:28 <daviddavis> yea and also I think these errors are an indication that we're using django-filter incorrectly
14:33:33 <ttereshc> fao89, fwiw, I thought there was a rule to wait until N people join the triage, I don't remember the value of N though :)
14:33:35 <fao89> I thought it was the fix for the CI problem we saw yesterday
14:33:48 <daviddavis> no, we fixed that by pinning
14:34:14 <daviddavis> if no one objects, let's add this to the sprint
14:34:31 <ipanova> ttereshc: 3
14:34:32 <ppicka> fao89, ttereshc: I think it was 3 ppl
14:34:34 <ttereshc> low-normal prio for this sprint?
14:34:38 <daviddavis> +1
14:34:52 <ipanova> +1
14:35:09 <fao89> me, pulpbot and daviddavis so I followed the rule =P
14:35:14 <ipanova> haha
14:35:20 <daviddavis> lol
14:35:21 <fao89> #agreed accept and add to sprint
14:35:21 <fao89> !accept
14:35:21 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:35:22 <fao89> #topic https://pulp.plan.io/issues/6898
14:35:22 <pulpbot> fao89: 1 issues left to triage: 6898
14:35:23 <pulpbot> RM 6898 - Dine - NEW - Pulp 2 - REST API for Search ignores critera or raises errors when field or filter is specified
14:35:24 <pulpbot> https://pulp.plan.io/issues/6898
14:35:28 <daviddavis> pulpbot isn't self aware yet
14:35:28 <pulpbot> daviddavis: Error: "isn't" is not a valid command.
14:35:32 <ttereshc> pulpbot is not one of the core devs, you should work on that ;)
14:35:32 <pulpbot> ttereshc: Error: "is" is not a valid command.
14:35:47 <daviddavis> close out?
14:36:10 <ipanova> daviddavis: yes
14:36:11 <ttereshc> yeah, notabug
14:36:28 <fao89> #idea Proposed for #6898: close as notabug
14:36:28 <fao89> !propose other close as notabug
14:36:28 <pulpbot> fao89: Proposed for #6898: close as notabug
14:36:31 <ttereshc> and set pulp 2 flag and remove API category
14:36:45 <ttereshc> and API bindings
14:37:07 <fao89> #agreed close as notabug
14:37:07 <fao89> !accept
14:37:08 <pulpbot> fao89: Current proposal accepted: close as notabug
14:37:09 <pulpbot> fao89: No issues to triage.
14:37:17 <fao89> Open floor
14:37:40 <fao89> topic: Redmine Simplification by bmbouter
14:38:14 <bmbouter> these fields are not used in our current processes
14:38:23 <ttereshc> I keep forgetting what happens when we remove the field. Does it disappear from old issues or not?
14:38:30 <bmbouter> I believe it does
14:38:44 <bmbouter> the redmine UI no longer shows them
14:39:04 <ttereshc> I'm on the fence about smash test.
14:39:32 <ttereshc> not very often but some pulp2 test descriptions are very helpful and it's convenient to find them in redmine
14:39:42 <ttereshc> not critical though
14:39:52 <bmbouter> I could export the data and post it to pulp-dev
14:41:15 <ttereshc> that could work, would it be more convenient than to search in pulp-smash directly?
14:41:35 <ttereshc> if it's a separate search outside of redmine, I think it's not worth the effort
14:42:39 <bmbouter> the search is against a github issue which would like to a PR so it's cludgy already
14:43:19 <ttereshc> alright, then never mind
14:43:24 <ttereshc> just remove the field
14:43:27 <ttereshc> let's move on
14:44:04 <fao89> next topic: Local CI checks https://pulp.plan.io/issues/6938
14:44:31 <daviddavis> I was talking to ggainey this morning about this and how difficult it is for new contributors to satisfy all our CI checks
14:44:32 <ggainey> yes please
14:44:41 <fao89> +1 to this
14:45:01 <ggainey> lowering friction for contributors is pretty critical for a community project
14:45:20 <ttereshc> +1 to improve that
14:45:27 <daviddavis> the pre-commit tool is totally optional and can be used via git hooks or it can run when needed
14:45:49 <bmbouter> +1 to imprvoing this
14:45:59 <bmbouter> +1 to having it be optional
14:46:04 <ggainey> concur
14:46:07 <bmbouter> and also not require root (userspace only)
14:46:12 <daviddavis> +1
14:46:13 <ggainey> god yes
14:46:21 <daviddavis> can we add this to the sprint?
14:46:29 <fao89> +1
14:46:36 <ggainey> needs to be something C Contributor can run while sitting in his pulp3-dev-env
14:46:42 <ttereshc> maybe mark as sprint candidate?
14:46:50 <ttereshc> we have a sprint planning this week
14:46:51 <ggainey> candidate sounds right
14:46:55 <daviddavis> +1
14:47:05 <bmbouter> can it get a little more detail on what the check should improve?
14:47:06 <ggainey> let's be honest, it is *not* going to get worked on in the next three days
14:47:06 <daviddavis> I'll try to add a list to it too
14:47:13 <bmbouter> sweet
14:47:25 <ggainey> bmbouter: I'll throw some sentences in there from my discussion w/ddavis this morning, one sec
14:48:12 <bmbouter> this all sounds great
14:48:24 <fao89> can we move to the next topic?
14:48:40 <daviddavis> yes
14:48:59 <fao89> topic was: Is it possible to have friendly hackmd links?
14:49:14 <fao89> but daviddavis already proved it is possible
14:49:42 <bmbouter> how was it made?
14:49:42 <fao89> I think we should have friendly names for all hackmd links
14:49:50 <fao89> like for the spam one for example
14:49:57 <bmbouter> yup
14:50:13 <ttereshc> +1
14:50:17 <daviddavis> does anyone have access to update the triage invite with the new link?
14:50:18 <fao89> the release pipeline is also a good one to have a better link
14:50:36 <fao89> dkliban, has the access
14:50:38 <bmbouter> dkliban: does
14:51:03 <daviddavis> ok
14:51:06 <bmbouter> also this site needs an update too https://pulpproject.org/get_involved/#meetings
14:51:09 <bmbouter> by anyone
14:51:22 <daviddavis> I'll do it
14:51:28 <fao89> AI: daviddavis to teach everyone how to create friendly links
14:51:35 <ttereshc> daviddavis, so do you have to be an owner of the note or anyone can create a nice name?
14:51:44 <ttereshc> ah that works as well :)
14:53:20 <ttereshc> next topic?
14:53:39 <fao89> topic: Take down fixtures at fedorapeople.org https://pulp.plan.io/issues/6649
14:53:56 <daviddavis> I think anyone can do it https://hackmd.io/c/tutorials/%2Fs%2Fhow-to-publish-note
14:54:15 <fao89> daviddavis++
14:54:15 <pulpbot> fao89: daviddavis's karma is now 329
14:54:17 <daviddavis> do we want to set a date for taking down fedorapeople fixtures and who can do it?
14:55:01 <ttereshc> +1 to set a date
14:55:02 <bmbouter> +1
14:55:21 <ppicka> +1
14:55:22 <ttereshc> I don't know who can. I can't or I'm not aware that I can :)
14:55:37 <bmbouter> dkliban I know can
14:55:42 <daviddavis> cool
14:55:48 <daviddavis> for a date, does july 1 make sense?
14:56:16 <ppicka> if we send notify to pulp-dev asap I +1 for jul 1
14:56:19 <bmbouter> that seems like a reasonable timeline
14:56:30 <daviddavis> ok, I will send out an announcement today
14:56:41 <ttereshc> works for me, or even sooner. Who else uses fixtures except our and maybe katello automation?
14:57:26 <ggainey> +1
14:57:28 <daviddavis> I bet there's something I haven't thought of
14:57:30 <daviddavis> hehe
14:57:34 <ttereshc> :)
14:57:52 <ggainey> daviddavis: "turn it off and see who screams" is a time-honored tradition among our people :)
14:57:52 <dkliban> daviddavis:  i can update triage invite
14:58:01 <daviddavis> dkliban: thanks
14:58:03 <fao89> ttereshc, if we take it down, we will get the answer
14:58:09 <daviddavis> let's do july 1st
14:58:13 <ggainey> +1
14:58:17 <ttereshc> +1
14:58:28 <dkliban> daviddavis: but i don't know what need to be updated
14:58:48 <dkliban> what link is wrong?
14:59:30 <fao89> dkliban, the link is not wrong
14:59:37 <fao89> we will replace with a friendly one
14:59:44 <fao89> https://hackmd.io/@pulp/triage/edit
15:00:06 <dkliban> cool ... i'll updated it
15:00:09 <dkliban> fao89: thank you
15:00:13 <fao89> last topic (so far): Triage on Friday - reschedule or cancel?
15:00:29 <ttereshc> +1 to cancel
15:00:47 <fao89> +1
15:00:53 <ppicka> +1
15:01:00 <bmbouter> +1
15:01:51 <fao89> no more topics
15:02:00 <ttereshc> if we can configure not to require the slash at the end for https://fixtures.pulpproject.org/, it would be more user friendly I think. minor thing but very annoying :)
15:02:10 <ttereshc> wdyt?
15:02:37 <ggainey> well, it would help me, hat's for sure - I *always* forget ending slashes :(
15:02:51 <ppicka> +1, it is always better to enable both options
15:02:54 <ggainey> but, i r dum, so don't change it just for me
15:03:07 <daviddavis> https://fixtures.pulpproject.org seems to work for me?
15:03:23 <ggainey> huh, sure enough - fast work!
15:03:28 <ggainey> daviddavis++
15:03:28 <pulpbot> ggainey: daviddavis's karma is now 330
15:03:45 <ppicka> really fast, before a while I still get nginx welcome
15:03:51 <ggainey> hehehe
15:04:00 <fao89> daviddavis has SLA of 2s for AIs
15:04:07 <ttereshc> :) sweet
15:05:15 <fao89> should I end the open floor or anyone wants to bring some topic?
15:06:12 <ttereshc> let's end
15:07:35 <fao89> #endmeeting
15:07:35 <fao89> !end