14:32:14 <fao89> #startmeeting Pulp Triage 2020-06-16
14:32:14 <fao89> #info fao89 has joined triage
14:32:14 <fao89> !start
14:32:14 <pulpbot> Meeting started Tue Jun 16 14:32:14 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:14 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:32:14 <pulpbot> The meeting name has been set to 'pulp_triage_2020-06-16'
14:32:14 <pulpbot> fao89: fao89 has joined triage
14:32:16 <x9c4> #info x9c4 has joined triage
14:32:16 <x9c4> !here
14:32:16 <pulpbot> x9c4: x9c4 has joined triage
14:32:19 <daviddavis> #info daviddavis has joined triage
14:32:19 <daviddavis> !here
14:32:19 <pulpbot> daviddavis: daviddavis has joined triage
14:32:20 <dkliban> #info dkliban has joined triage
14:32:20 <dkliban> !here
14:32:21 <ggainey> #info ggainey has joined triage
14:32:21 <ggainey> !here
14:32:21 <pulpbot> dkliban: dkliban has joined triage
14:32:22 <pulpbot> ggainey: ggainey has joined triage
14:32:23 <ppicka> #info ppicka has joined triage
14:32:23 <ppicka> !here
14:32:23 <pulpbot> ppicka: ppicka has joined triage
14:32:26 <ttereshc> #info ttereshc has joined triage
14:32:26 <ttereshc> !here
14:32:26 <pulpbot> ttereshc: ttereshc has joined triage
14:32:30 <fao89> !next
14:32:31 <fao89> #topic https://pulp.plan.io/issues/6972
14:32:31 <pulpbot> fao89: 3 issues left to triage: 6972, 6943, 5617
14:32:32 <pulpbot> RM 6972 - fao89 - NEW - Clients should pin pulpcore/plugins versions
14:32:33 <pulpbot> https://pulp.plan.io/issues/6972
14:32:39 <fao89> #idea Proposed for #6972: Leave the issue as-is, accepting its current state.
14:32:39 <fao89> !propose accept
14:32:39 <pulpbot> fao89: Proposed for #6972: Leave the issue as-is, accepting its current state.
14:33:00 <daviddavis> +1
14:33:01 <ipanova> #info ipanova has joined triage
14:33:01 <ipanova> !here
14:33:01 <pulpbot> ipanova: ipanova has joined triage
14:33:05 <x9c4> +1
14:33:14 <ttereshc> +1
14:33:18 <dkliban> i don't think clients should have a depenency on pulpcore
14:33:21 <dkliban> or plugin
14:33:42 <fao89> if a serializer change it would break
14:33:47 <ttereshc> how to make sure that they are aligned?
14:33:56 <bmbouter> #info bmbouter has joined triage
14:33:56 <bmbouter> !here
14:33:57 <pulpbot> bmbouter: bmbouter has joined triage
14:34:04 <dkliban> i am just saying that you should be able to install pulpcore-client without installing pulpcore
14:34:08 <dkliban> and the same thing for plugins
14:34:08 <fao89> the binding model would not have a new field for example
14:34:21 <bmbouter> oh yeah
14:34:30 <bmbouter> clients run on one system, pulpcore on the other
14:34:35 <dkliban> yep
14:34:39 <ttereshc> yeah
14:34:43 <bmbouter> if we do this then the "local" machine would also get pulpcore so we can't do it
14:34:46 <daviddavis> yea, I think there needs to be some other mechanism to check the versions
14:34:47 <ggainey> +1
14:35:02 <x9c4> Like ping status and refuse to work?
14:35:07 <daviddavis> yea
14:35:15 <bmbouter> yup
14:35:20 <bmbouter> that's what I'm hoping the cli also does
14:35:23 <bmbouter> btw
14:35:27 <daviddavis> yup
14:35:38 <fao89> #idea Proposed for #6972: rename and accept
14:35:38 <fao89> !propose other rename and accept
14:35:38 <pulpbot> fao89: Proposed for #6972: rename and accept
14:35:50 <x9c4> It's using the bindings. So that comes for free.
14:35:51 <daviddavis> the cli should automatically do it
14:35:51 <dkliban> +1
14:35:54 <daviddavis> yea
14:35:59 <ppicka> +1
14:36:02 <bmbouter> fao89: can we just rename fo rnow and triage next time?
14:36:11 <fao89> yep
14:36:34 <fao89> #idea Proposed for #6972: rename and skip
14:36:34 <fao89> !propose other rename and skip
14:36:34 <pulpbot> fao89: Proposed for #6972: rename and skip
14:36:46 <fao89> #agreed rename and skip
14:36:46 <fao89> !accept
14:36:46 <pulpbot> fao89: Current proposal accepted: rename and skip
14:36:47 <fao89> #topic https://pulp.plan.io/issues/6943
14:36:47 <pulpbot> fao89: 2 issues left to triage: 6943, 5617
14:36:49 <pulpbot> RM 6943 - gerrod - POST - New Pulp Project fixutres site is incorrectly setup for python plugin
14:36:50 <pulpbot> https://pulp.plan.io/issues/6943
14:37:04 <dkliban> daviddavis: can we merge the PR for this yet?
14:37:13 <dkliban> looks merged actually
14:37:21 <daviddavis> yes but I am working on getting the site updated
14:37:27 <dkliban> cool
14:37:28 <fao89> #idea Proposed for #6943: Leave the issue as-is, accepting its current state.
14:37:29 <fao89> !propose accept
14:37:29 <pulpbot> fao89: Proposed for #6943: Leave the issue as-is, accepting its current state.
14:37:32 <dkliban> +1
14:37:32 <daviddavis> I will handle this if we can accept and add to sprint
14:37:35 <ggainey> +1
14:37:40 <x9c4> +1
14:37:45 <bmbouter> +1
14:37:45 <dkliban> it's already on sprint
14:37:48 <ggainey> daviddavis: it looks like it's on the sprint
14:37:49 <daviddavis> oh sweet
14:37:51 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:37:51 <fao89> !accept
14:37:51 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:51 <fao89> #topic https://pulp.plan.io/issues/5617
14:37:52 <pulpbot> fao89: 1 issues left to triage: 5617
14:37:53 <pulpbot> RM 5617 - ragulb - NEW - Pulp-admin unable to login
14:37:54 <pulpbot> https://pulp.plan.io/issues/5617
14:38:04 <daviddavis> I untriaged this. was hoping we could close this out
14:38:18 <daviddavis> I think it's an environment problem?
14:38:22 <ipanova> looks like
14:38:37 <ggainey> aye concur
14:38:52 <dkliban> i would just close as not a bug
14:38:54 <dkliban> or works for me
14:38:57 <daviddavis> +1
14:39:00 <bmbouter> +1
14:39:08 <bmbouter> works for me
14:39:16 <fao89> #idea Proposed for #5617: close as works for me
14:39:16 <fao89> !propose other close as works for me
14:39:16 <pulpbot> fao89: Proposed for #5617: close as works for me
14:39:22 <fao89> #agreed close as works for me
14:39:22 <fao89> !accept
14:39:22 <pulpbot> fao89: Current proposal accepted: close as works for me
14:39:23 <pulpbot> fao89: No issues to triage.
14:39:30 <fao89> Open floor!
14:39:38 <fao89> https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:39:39 * daviddavis cheers wildly
14:39:51 <fao89> redmine simplification
14:39:59 <dkliban> i am a bit confused about the query for issue during triage
14:40:07 <dkliban> cause i am seeing more issues that we haven't discussed
14:40:27 <dkliban> oh ... nevermind
14:40:31 <daviddavis> dkliban: are you looking at https://pulp.plan.io/issues?query_id=143 ?
14:40:31 <dkliban> they are installer related
14:40:35 <daviddavis> :)
14:40:36 <fao89> dkliban, https://pulp.plan.io/issues?query_id=143 I see just the one we skipped
14:40:48 <dkliban> nevermind. let's go to open floor
14:40:53 <dkliban> and redmine simplification
14:41:03 <fao89> bmbouter, your redmine simplification time
14:41:55 <bmbouter> ok
14:42:00 <ttereshc> I'm +1 for all suggestions
14:42:26 <x9c4> delete over start using in 2.
14:42:44 <ipanova> ttereshc: wants to finish this quickly :D
14:42:58 <ttereshc> +1  to delete cli category, api category and rename sync performance to performance
14:43:04 <dkliban> +!
14:43:05 <dkliban> +1
14:43:09 <ipanova> yes +1
14:43:19 <daviddavis> +1
14:43:22 <ggainey> +1
14:43:36 <bmbouter> I can make all these changes today
14:43:36 <x9c4> +1
14:43:41 <daviddavis> bmbouter++
14:43:41 <pulpbot> daviddavis: bmbouter's karma is now 276
14:44:08 <fao89> ready for next topic?
14:44:15 <bmbouter> is release engineering tag next?
14:44:25 <fao89> I think so
14:44:28 <dkliban> yeah
14:44:31 <x9c4> redmine complification?
14:44:31 <ipanova> +1 to remove it
14:44:45 <bmbouter> so this one I want to confirm with ehelms and pcreech first and then remove it
14:44:49 <bmbouter> and I can do that also
14:44:54 <dkliban> that would be great
14:44:57 <daviddavis> thank you
14:45:02 <bmbouter> and zack also
14:45:10 <bmbouter> zench? (is that his nick?)
14:45:17 <daviddavis> zhunting
14:45:21 <x9c4> Zhenech
14:45:39 <daviddavis> ah
14:45:44 <bmbouter> ty, will do
14:45:44 <dkliban> Zhench is Evgeni
14:45:47 <bmbouter> yup
14:45:48 <x9c4> If you mesnt evgeni
14:45:49 <bmbouter> zhunting
14:46:23 <fao89> next topic?
14:46:27 <daviddavis> the next issue I added. it's a bug in pulp_rpm but I think the fix may lie in pulpcore.
14:46:29 <daviddavis> https://pulp.plan.io/issues/6974
14:46:41 <daviddavis> relevant code: https://git.io/Jf7Mo
14:46:56 <daviddavis> basically Publication.create() creates a publication and it gets returned in the api
14:47:02 <daviddavis> problem is that it's empty and not valid
14:47:10 <x9c4> Is creating objects without serializeres valid?
14:47:56 <fao89> create code - https://git.io/Jf5zP
14:48:24 <daviddavis> we should probably create the object with serializers
14:48:26 <bmbouter> so the first thought is to let the db transaction handle resolving this incosistent state, but this area (as with others) take too long for a transaction to be practical
14:48:54 <daviddavis> yea
14:48:55 <bmbouter> so what we do instead (in other areas) is hide it from the user with the complete=false flag, e.g. with RepositoryVersion's
14:49:09 <dkliban> yeah ... i think we should do the same thing here
14:49:12 <bmbouter> I could be off base here...
14:49:26 <daviddavis> that was my proposal
14:49:28 <bmbouter> but I think that's the only practical solution because the publication needs to exist for other objects to FK to it or no?
14:49:33 <bmbouter> daviddavis: ok cool
14:49:38 <dkliban> bmbouter: yes, exactly
14:49:52 <bmbouter> and to introduce a context manager to help set that state automatically
14:49:57 <bmbouter> is that part of the idea too?
14:49:59 <daviddavis> there's already one
14:50:14 <x9c4> so it will be transparent.
14:50:15 <x9c4> +1
14:50:19 <daviddavis> https://git.io/Jf5gv
14:50:29 <bmbouter> word
14:50:32 <bmbouter> +1
14:50:40 <fao89> +1
14:50:46 <bmbouter> daviddavis: I missed you proposal sorry to re-suggest
14:50:52 <daviddavis> no worries
14:51:13 <bmbouter> how do we handle the bookkeeping? move to pulpcore? copy/revise to pulpcore?
14:51:30 <fao89> add a note and move to pulpcore? https://pulp.plan.io/issues/6974
14:51:37 <daviddavis> yes I can update the issue. basically we'd add an incomplete field to publication and handle it  like we do for repo version.
14:52:37 <daviddavis> or rather teh field is 'complete'
14:52:40 <fao89> last topic so far: Can https://github.com/pulp/plugin_template/pull/217 be closed out?
14:52:43 <ttereshc> I suggest to file a new one for pulpcore, since some changes will be needed in pulp_rpm anywya
14:52:44 <daviddavis> https://git.io/Jf5gL
14:52:49 <daviddavis> ttereshc: +1
14:53:01 <x9c4> +1
14:53:04 <bmbouter> ttereshc: +1
14:53:14 <bmbouter> daviddavis: I can groom if you want to write
14:53:17 <bmbouter> or anyone can
14:53:21 <daviddavis> +1, thanks
14:53:21 <ipanova> and for all the plugins that have publication
14:53:24 <ipanova> like file plugin
14:53:56 <x9c4> Do plugins need to change if it is handled in the context manager?
14:54:08 <bmbouter> I don't think they need a change if they use the context manager
14:54:08 <x9c4> I believe no.
14:54:43 <daviddavis> I'm happy to file issues just in case
14:54:50 <ipanova> sweet
14:54:50 <bmbouter> WFM
14:55:03 <daviddavis> cool
14:55:26 <daviddavis> last topic: can we close out https://github.com/pulp/plugin_template/pull/217
14:55:40 <bmbouter> what does close out mean?
14:55:42 <bmbouter> merge?
14:55:51 <x9c4> no merge
14:55:59 <dkliban> no, no merge just close
14:56:07 <dkliban> it sounds like this is no longer needed
14:56:11 <fao89> +1 to close
14:56:18 <daviddavis> ttereshc: any opinion?
14:56:28 <ttereshc> +1 to close
14:56:28 <bmbouter> do we already have something for this?
14:56:36 <x9c4> And we should enforce the policy to only import from the plugin api.
14:56:45 <bmbouter> I thought this was that enforcement
14:56:57 <x9c4> No it's a way to disable it.
14:56:59 <daviddavis> no this is to optionally disable it
14:57:27 <bmbouter> ohhhh
14:57:29 <bmbouter> ty
14:57:33 <bmbouter> +1 to close we should not disable
14:57:39 <daviddavis> ok cool
14:58:54 <fao89> #endmeeting
14:58:54 <fao89> !end