14:31:22 <fao89> #startmeeting Pulp Triage 2020-06-30
14:31:22 <fao89> #info fao89 has joined triage
14:31:22 <fao89> !start
14:31:22 <pulpbot> Meeting started Tue Jun 30 14:31:22 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:22 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:22 <pulpbot> The meeting name has been set to 'pulp_triage_2020-06-30'
14:31:22 <pulpbot> fao89: fao89 has joined triage
14:31:40 <ppicka> #info ppicka has joined triage
14:31:40 <ppicka> !here
14:31:40 <pulpbot> ppicka: ppicka has joined triage
14:31:45 <x9c4> #info x9c4 has joined triage
14:31:45 <x9c4> !here
14:31:45 <pulpbot> x9c4: x9c4 has joined triage
14:32:07 <dkliban> #info dkliban has joined triage
14:32:07 <dkliban> !here
14:32:07 <pulpbot> dkliban: dkliban has joined triage
14:32:10 <daviddavis> #info daviddavis has joined triage
14:32:10 <daviddavis> !here
14:32:10 <pulpbot> daviddavis: daviddavis has joined triage
14:32:13 <fao89> !next
14:32:14 <pulpbot> fao89: 3 issues left to triage: 7060, 7052, 7003
14:32:14 <fao89> #topic https://pulp.plan.io/issues/7060
14:32:15 <pulpbot> RM 7060 - daviddavis - NEW - Redmine/BZ automation failure: ImportError: cannot import name 'RHBugzilla' from 'bugzilla.rhbugzilla'
14:32:16 <pulpbot> https://pulp.plan.io/issues/7060
14:32:32 <fao89> !propose accept and add to sprint
14:32:32 <pulpbot> fao89: propose accept Propose accepting the current issue in its current state.
14:32:37 <dkliban> +1
14:32:45 <ttereshc> #info ttereshc has joined triage
14:32:45 <ttereshc> !here
14:32:45 <pulpbot> ttereshc: ttereshc has joined triage
14:32:49 <ppicka> +1
14:32:56 <ttereshc> +1
14:33:02 <bmbouter> #info bmbouter has joined triage
14:33:02 <bmbouter> !here
14:33:04 <pulpbot> bmbouter: bmbouter has joined triage
14:33:08 <fao89> !accept
14:33:08 <pulpbot> fao89: No action proposed, nothing to accept.
14:33:08 <daviddavis> +1
14:33:15 <fao89> !propose accept and add to sprint
14:33:15 <pulpbot> fao89: propose accept Propose accepting the current issue in its current state.
14:33:17 <fao89> !accept
14:33:17 <pulpbot> fao89: No action proposed, nothing to accept.
14:33:23 <daviddavis> ha
14:33:26 <dkliban> #idea Proposed for #7060: accept and add to sprint
14:33:26 <dkliban> !propose other accept and add to sprint
14:33:26 <pulpbot> dkliban: Proposed for #7060: accept and add to sprint
14:33:27 <fao89> !propose other accept and add to sprint
14:33:31 <fao89> #agreed accept and add to sprint
14:33:31 <fao89> !accept
14:33:31 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:33:31 <fao89> #topic https://pulp.plan.io/issues/7052
14:33:32 <pulpbot> fao89: 2 issues left to triage: 7052, 7003
14:33:33 <pulpbot> RM 7052 - bmbouter - NEW - As an unauthenticated user I can list pulp_file repoistories
14:33:34 <pulpbot> https://pulp.plan.io/issues/7052
14:33:43 <daviddavis> story
14:33:51 <daviddavis> oh wait
14:34:00 <daviddavis> I should read the issue first and not the title
14:34:09 <dkliban> yep
14:34:17 <daviddavis> accept and add to sprint?
14:34:23 <fao89> #idea Proposed for #7052: accept and add to sprint
14:34:23 <fao89> !propose other accept and add to sprint
14:34:23 <pulpbot> fao89: Proposed for #7052: accept and add to sprint
14:34:45 <bmbouter> +1
14:34:46 <daviddavis> wait
14:34:51 <x9c4> is this happening on master? We should ask for a test...
14:34:52 <fao89> hahaha
14:34:55 <daviddavis> I get a 403
14:35:07 <dkliban> bmbouter: yeah ... i don't think this happens on master
14:35:18 <daviddavis> https://gist.github.com/daviddavis/b2a3c4cba6e7392ec7e3d48975093cd2
14:36:00 <bmbouter> I was on master but it was modified
14:36:12 <bmbouter> so we can close NOTABUT for now
14:36:18 <bmbouter> this evidence is convincing it's not
14:36:20 <dkliban> or works for me?
14:36:21 <x9c4> did you clear permission_classes?
14:38:11 <bmbouter> +1 worksforme
14:38:12 <bmbouter> since it does work
14:38:37 <fao89> #idea Proposed for #7052: close as worksforme
14:38:37 <fao89> !propose other close as worksforme
14:38:37 <pulpbot> fao89: Proposed for #7052: close as worksforme
14:38:41 <fao89> #agreed close as worksforme
14:38:41 <fao89> !accept
14:38:41 <pulpbot> fao89: Current proposal accepted: close as worksforme
14:38:42 <fao89> #topic https://pulp.plan.io/issues/7003
14:38:42 <pulpbot> fao89: 1 issues left to triage: 7003
14:38:43 <pulpbot> RM 7003 - dkliban@redhat.com - NEW - pulpcore-content allows for // in some parts of the URL but not others
14:38:44 <pulpbot> https://pulp.plan.io/issues/7003
14:38:52 <dkliban> i commented on it after open floor
14:39:00 <dkliban> i still need to open up a couple of tasks related to it
14:39:05 <dkliban> but we can go ahead and accept now
14:39:24 <daviddavis> +1
14:39:41 <ppicka> +1
14:39:43 <fao89> #idea Proposed for #7003: Leave the issue as-is, accepting its current state.
14:39:43 <fao89> !propose accept
14:39:43 <pulpbot> fao89: Proposed for #7003: Leave the issue as-is, accepting its current state.
14:39:57 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:39:57 <fao89> !accept
14:39:57 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:39:58 <pulpbot> fao89: No issues to triage.
14:40:06 <fao89> Open floor!
14:40:14 <fao89> https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:40:24 <fao89> topic: Do we want to move mdellweg/ansible_module_pulp to the pulp namespace and publish as pulp.squeezer on galaxy?
14:41:06 <dkliban> +1
14:41:16 <bmbouter> +1
14:41:20 <fao89> https://github.com/mdellweg/ansible_modules_pulp
14:41:31 <fao89> +1
14:41:49 <dkliban> x9c4: i can work with you to make this happen
14:41:56 <x9c4> :D
14:41:58 <dkliban> does anyone object?
14:43:27 <ttereshc> no objections at all
14:43:32 <fao89> I think we can move to next topic
14:43:36 <daviddavis> I dunno. I think we should wait longer.
14:43:38 <daviddavis> jk
14:43:51 * x9c4 cheers wildly
14:43:59 * bmbouter dances
14:43:59 * daviddavis cheers crazily
14:44:04 <fao89> topic: pulpcon https://hackmd.io/4dL6Eg2fSyq2MQsUydGM2A
14:44:30 <bmbouter> can make an edit or two live?
14:44:34 <bmbouter> small things...
14:44:41 <dkliban> sure
14:44:44 <dkliban> let's do it
14:44:57 <dkliban> yep
14:45:51 <bmbouter> does getting ^ into a blog post make any sense?
14:45:55 <ttereshc> Should we change countries to timezones?
14:46:03 <bmbouter> yes we should
14:46:05 <dkliban> yep
14:46:07 <bmbouter> ttereshc: +1
14:46:25 <dkliban> i didn't want to do timezones cause i wasn't sure what the eastern one was going to be called when we have the event
14:46:30 <dkliban> but that is not a big deal
14:46:34 <dkliban> let's do timezones
14:47:12 <bmbouter> dkliban: so that would be a local instead
14:47:14 <bmbouter> locale
14:47:38 <bmbouter> e.g. eastern time is the locale, eastern standard or eastern daylight are the timezones
14:47:46 <dkliban> yeah ...
14:47:59 <dkliban> CET and EST ?
14:48:11 <bmbouter> +1 that's fine
14:48:30 <ttereshc> I was trying to figure out how the czech one is called :D
14:48:38 <ttereshc> I know the US one
14:49:03 <bmbouter> central eastern time probably
14:49:33 <ttereshc> yeah, I know it as gmt+1 or +2
14:49:47 <bmbouter> yup
14:50:18 <ttereshc> should we mention where the dates will be announced? pulp-list?
14:50:24 <x9c4> include GMT so everyone can make hist own calculation?
14:50:25 <ttereshc> or pulp-dev?
14:50:46 <bmbouter> +1 pulp-dev
14:50:59 <bmbouter> so I'm using this these days ... https://everytimezone.com/
14:51:39 <fao89> I just learned I'm in Papa Time Zone
14:51:52 <dkliban> LOL
14:52:19 <fao89> Papa == pope in Portuguese
14:53:10 <fao89> should we move to the next topic?
14:53:41 <dkliban> i think so.
14:53:46 <dkliban> bmbouter:?
14:54:05 <bmbouter> yes but who is taking the next steps?
14:54:14 <dkliban> i'll send it out
14:54:23 <dkliban> or ttereshc ... did you want to do it?
14:54:27 <dkliban> you started this process
14:55:01 <ttereshc> dkliban, up to you
14:55:07 <ttereshc> I can
14:55:21 <daviddavis> I have a meeting at 11 but I'm interested in discussing the next topics
14:55:38 <ttereshc> let's move on, dkliban or I will send it
14:55:48 <dkliban> +1
14:55:55 <fao89> topic: Should we relax the Repository name uniqueness accross all of Pulp to be just for a single plugin?
14:57:02 <x9c4> Should it be ... just for a single RepoType?
14:57:08 <ipanova> this question popped up again during our container meeting
14:57:27 <daviddavis> what was the context?
14:57:39 <ipanova> what prevents us to change the constraint to repo name and repo type?
14:58:04 <dkliban> daviddavis: we have two types of repositories in pulp container
14:58:06 <ipanova> daviddavis: that if you have a repo 'test' created in iso plugin, you won't be able to create a test repo in any other plugin
14:58:30 <daviddavis> I see
14:59:07 <bmbouter> fwiw, I think soon this won't be an issue at all with RBAC ueryset restriction
14:59:23 <bmbouter> in terms of having it "fully loosened", in fact we'll have to
15:00:59 <ttereshc> dkliban, do you remember a user asking for a feature to use repo names instead of uuids, or am I mixing it up with something else?
15:01:42 <dkliban> ttereshc: the user was asking to be able to use repository names to reference resource in the bindings
15:01:49 <dkliban> which means that the name would be part of the URL
15:02:21 <dkliban> this item for open floor is not related to that though
15:02:40 <ttereshc> ok, thanks for recalling what it was
15:03:15 <dkliban> let's all think about this repo name uniqueness and come back to it next tuesday
15:03:42 <dkliban> i can even send a note to pulp-dev if that would help?
15:03:53 <dkliban> i'll explain the problem statement
15:03:58 <bmbouter> that sounds good
15:04:04 <fao89> yep
15:04:18 <dkliban> let's talk aobut https://pulp.plan.io/issues/6899
15:04:27 <dkliban> i would like us to work on this asap
15:05:49 <bmbouter> yes I agree it's important
15:06:05 <ttereshc> I'm +1, I think it's the most useful part to automate in the whole release process
15:07:54 <fao89> I can take it
15:09:14 <dkliban> awesome
15:09:27 <bmbouter> +1
15:09:27 <fao89> #endmeeting
15:09:27 <fao89> !end