14:30:17 <fao89> #startmeeting Pulp Triage 2020-07-07
14:30:17 <fao89> #info fao89 has joined triage
14:30:18 <pulpbot> Meeting started Tue Jul  7 14:30:17 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:18 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:18 <pulpbot> The meeting name has been set to 'pulp_triage_2020-07-07'
14:30:18 <pulpbot> fao89: fao89 has joined triage
14:30:29 <dkliban> #info dkliban has joined triage
14:30:29 <dkliban> !here
14:30:30 <pulpbot> dkliban: dkliban has joined triage
14:30:50 <x9c4> #info x9c4 has joined triage
14:30:50 <x9c4> !here
14:30:50 <pulpbot> x9c4: x9c4 has joined triage
14:31:40 <bmbouter> #info bmbouter has joined triage
14:31:40 <bmbouter> !here
14:31:46 <fao89> !next
14:31:47 <fao89> #topic https://pulp.plan.io/issues/7090
14:31:47 <pulpbot> fao89: 5 issues left to triage: 7090, 7088, 7087, 7075, 7066
14:31:48 <pulpbot> RM 7090 - daviddavis - NEW - Pulpcore docs have issues
14:31:49 <pulpbot> https://pulp.plan.io/issues/7090
14:31:52 <ggainey> #info ggainey has joined triage
14:31:52 <ggainey> !here
14:32:10 <daviddavis> #info daviddavis has joined triage
14:32:10 <daviddavis> !here
14:32:21 <daviddavis> just accept?
14:32:22 <fao89> #idea Proposed for #7090: accept and add to sprint
14:32:22 <fao89> !propose other accept and add to sprint
14:32:27 <dkliban> +1
14:32:30 <bmbouter> accept add to sprint
14:32:36 <bmbouter> #NoLimits
14:32:40 <daviddavis> lol
14:32:40 <dkliban> lol
14:32:42 <fao89> I propose add to sprint since we are close to release
14:33:17 <bmbouter> I think we're releasing today and this likely won't be fixed before that
14:33:21 <bmbouter> but regardles I'm +1
14:34:28 <fao89> so I change to just accept, hahaha
14:35:12 <fao89> #agreed accept and add to sprint
14:35:12 <fao89> !accept
14:35:12 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:35:13 <fao89> #topic https://pulp.plan.io/issues/7088
14:35:13 <pulpbot> fao89: 4 issues left to triage: 7088, 7087, 7075, 7066
14:35:14 <pulpbot> RM 7088 - mdellweg - NEW - pulp_gem needs SingleContentArtifactField and PulpTemporaryUploadedFile in plugin api
14:35:15 <pulpbot> https://pulp.plan.io/issues/7088
14:36:00 <dkliban> we should add these to the plugin api
14:36:07 <daviddavis> +1
14:36:12 <dkliban> though this is more of a task than an issue
14:36:21 <dkliban> or a story from the plugin writer perspective
14:36:34 <dkliban> we should accept and add to sprint
14:36:38 <daviddavis> +1
14:36:42 <fao89> #idea Proposed for #7088: accept and add to sprint
14:36:42 <fao89> !propose other accept and add to sprint
14:36:42 <pulpbot> fao89: An error has occurred and has been logged. Please contact this bot's administrator for more information.
14:36:50 <fao89> #idea Proposed for #7088: accept and add to sprint
14:36:50 <fao89> !propose other accept and add to sprint
14:36:58 <mikedep333> #info mikedep333 has joined triage
14:36:58 <mikedep333> !here
14:37:05 <fao89> #agreed accept and add to sprint
14:37:05 <fao89> !accept
14:37:05 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:37:13 <bmbouter> +1
14:37:23 <fao89> !next
14:37:23 <fao89> #topic https://pulp.plan.io/issues/7087
14:37:24 <pulpbot> fao89: 3 issues left to triage: 7087, 7075, 7066
14:37:25 <pulpbot> RM 7087 - mdellweg - NEW - "module 'pulpcore.client.pulp_file' has no attribute 'FileFileContent'"
14:37:26 <pulpbot> https://pulp.plan.io/issues/7087
14:38:01 <fao89> #idea Proposed for #7087: accept and add to sprint
14:38:01 <fao89> !propose other accept and add to sprint
14:38:01 <pulpbot> fao89: Proposed for #7087: accept and add to sprint
14:38:21 <dkliban> x9c4: what change do you want to see?
14:38:36 <fao89> seems to be related with the write_only bindings change
14:38:41 <dkliban> yes it is
14:38:59 <x9c4> Yes, and we need the  'FileFileContent' serializer for write
14:39:00 <dkliban> but i want to better understand what x9c4 is expecting to happen to resolve this issue
14:39:08 <dkliban> oh ok
14:39:20 <x9c4> 'FileFileContentRead' is there.
14:39:44 <daviddavis> accept and add to sprint
14:39:44 <dkliban> i understand now ... we need the write version which is FileFileContent
14:39:46 <dkliban> +1
14:39:57 <x9c4> +1
14:40:00 <fao89> it it a release blocker?
14:40:27 <daviddavis> that's a good question
14:40:33 <x9c4> For every one using the bindings to create FileContent it is a Problem.
14:40:35 <fao89> if katello uses it, it would break them
14:40:56 <ggainey> (I added the "needs to be there for Write" discussion to the issue)
14:41:15 <x9c4> ggainey++
14:41:15 <pulpbot> x9c4: ggainey's karma is now 30
14:41:27 <fao89> if it is happening on pulp_file, it may happen in other plugins
14:41:35 <fao89> I believe it is a blocker
14:41:36 <bmbouter> agreed
14:41:41 <dkliban> yep
14:41:55 <fao89> I'll accept, and we can discuss more at open floor
14:42:02 <fao89> #agreed accept and add to sprint
14:42:02 <fao89> !accept
14:42:02 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:42:21 <x9c4> I have not immediately seen the same issue with ansible_role, but who knows...
14:42:55 <fao89> pulpbot is doing half job today
14:42:55 <pulpbot> fao89: Error: "is" is not a valid command.
14:42:59 <fao89> !next
14:43:00 <pulpbot> fao89: 2 issues left to triage: 7075, 7066
14:43:00 <fao89> #topic https://pulp.plan.io/issues/7075
14:43:01 <pulpbot> RM 7075 - spredzy - NEW - As a user I want Pulp to run on EL8 with SELinux enforced
14:43:02 <pulpbot> https://pulp.plan.io/issues/7075
14:43:22 <ggainey> that's a story/task yeah?
14:43:27 <daviddavis> yesh
14:43:39 <bmbouter> yup
14:43:42 <fao89> #idea Proposed for #7075: convert to a story
14:43:42 <fao89> !propose other convert to a story
14:43:42 <pulpbot> fao89: Proposed for #7075: convert to a story
14:43:45 <dkliban> +1
14:43:50 <fao89> #agreed convert to a story
14:43:50 <fao89> !accept
14:43:50 <pulpbot> fao89: Current proposal accepted: convert to a story
14:43:51 <fao89> #topic https://pulp.plan.io/issues/7066
14:43:51 <pulpbot> fao89: 1 issues left to triage: 7066
14:43:52 <pulpbot> RM 7066 - SimonPe - NEW - Denial of Service in pulp-content when CONTENT_PATH_PREFIX is followed by a `/`
14:43:53 <pulpbot> https://pulp.plan.io/issues/7066
14:44:04 <daviddavis> there's a pr for this so accept and add to sprint
14:44:08 <bmbouter> agreed
14:44:23 <fao89> #idea Proposed for #7066: accept and add to sprint
14:44:23 <fao89> !propose other accept and add to sprint
14:44:23 <pulpbot> fao89: Proposed for #7066: accept and add to sprint
14:44:35 <fao89> #agreed accept and add to sprint
14:44:35 <fao89> !accept
14:44:35 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:44:36 <pulpbot> fao89: No issues to triage.
14:44:51 <fao89> Open floor!
14:45:11 <fao89> topic: allow_list and deny_list vs. includes and excludes .. Should we strive for uniform language between plugins or is that not practical?
14:45:15 <dkliban> I added this one
14:45:55 <ggainey> dkliban: "strive for", yes - but with plugins being owned by Whoever, I don't know there's any way to enforce
14:45:59 <bmbouter> I agree
14:46:04 <daviddavis> I conquer
14:46:08 <fao89> +1
14:46:14 <ggainey> dkliban: maybe add to plugin-writers-guide as a recommendation
14:46:17 <bmbouter> also in some cases the language e.g. on a remote mirrors a name we didn't choose, e.g. an upstream name for that community
14:46:26 <dkliban> yep
14:46:49 <dkliban> should we add any docs?
14:47:24 <dkliban> i am a bit conflicted myself. but i wanted to discuss the topic because i noticed a variety of language used between plugins
14:47:36 <bmbouter> we can but I'm wondering what is the current state of language across the plugins?
14:48:25 <bmbouter> as in a quick audit would help me understand where we're at
14:48:25 <dkliban> one sec
14:49:01 <dkliban> python plugin uses 'inxludes' and 'excludes'
14:49:52 <ggainey> there is discussion going on *right now* about consitent terminology around this, we shouldn't invent our own
14:49:57 <dkliban> and container plugin is deciding what to chagne 'whitelist_tags' to
14:50:12 <ggainey> consistent, even
14:50:38 <dkliban> and i think pulp_container should use 'include_tags'
14:50:49 <dkliban> instead of allow_tags
14:50:58 <lmjachky_> +10000
14:51:10 <dkliban> and i know that this is plugin specific discussion, but i wanted to discuss witha wider audience
14:51:37 <fao89> naming is always hard
14:51:46 <bmbouter> one of the hardest things in this biz
14:52:00 <daviddavis> it might be a good idea to see what other projects are doing too. I know foreman is going through this as well.
14:52:06 <daviddavis> maybe mcorr could weigh in
14:52:20 <ggainey> yes
14:52:27 <fao89> mcorr shared some PRs at ansible
14:52:44 <ggainey> there are A LOT of projects working on this - s'why I'd rather not be solving it on our own
14:53:06 <fao89> I like the way they are doing at ansible
14:53:39 <dalley> allowlist and blocklist are seemingly the ones with the most traction
14:53:59 <dalley> and fyi, that is most likely what the python plugin will switch to, because I believe bandersnatch is switching to it
14:54:14 <daviddavis> ugh I hate blocklist
14:54:27 <fao89> the example mcorr shared: https://github.com/ansible/ansible/pull/70028/files
14:54:55 <daviddavis> they're using reject list instead of black list
14:55:02 <x9c4> it could have been denylist... as in allow/deny
14:55:19 <fao89> another one: https://github.com/ansible/ansible/pull/70082
14:56:44 <dkliban> so what i am seeing is that each application has a slightly different context for these terms
14:57:08 <dkliban> and we should use the adjective that best fits the use case
14:57:25 <x9c4> My take is: do not follow pulp_python if they are about to change...
14:58:40 <daviddavis> I think it might make sense to have a broader discussion about this than the handful of developers that are here at open floor right now
14:59:13 <bmbouter> yeah it's confusing for me because this is a cat-herding kind of thing
14:59:21 <bmbouter> so many different plugins, different needs, interests
14:59:33 <fao89> the first thing, and very important is: we all are aware, stopping to introduce this terms is already a good thing
14:59:49 <ggainey> +1
14:59:52 <dkliban> +1
15:00:02 <dkliban> i am going to send out a short email to pulp-dev
15:00:16 <daviddavis> +1
15:01:15 <ggainey> +1
15:01:44 <fao89> are we ready to move to the next topic?
15:01:48 <dkliban> yes
15:02:02 <fao89> topic: should we create a mail list for each mini-team? AKA async meeting
15:02:32 <ggainey> what problem are we trying to solve?
15:02:45 <daviddavis> not having enough mailing lists
15:02:49 <ggainey> heh
15:02:49 <dkliban> lol
15:03:19 <ggainey> so yeah - at this point, I'd be against making more lists unless we tink we're having a *major* issue with volume/confusion
15:03:36 <ggainey> "make a new list" is a *great* way to start down the silo path
15:03:41 <fao89> I think the idea was to try to reduce the meetings
15:04:02 <x9c4> I don't think, we need a list for async meetings.
15:04:24 <ggainey> I think one could accomplish that with a new *thread* :)
15:04:47 <daviddavis> we have miniteam irc channels already. does that not suffice?
15:05:24 <fao89> not for all mini teams
15:05:38 <daviddavis> that's true
15:05:48 <ggainey> yeah, IRC has some qualitative differences from email
15:05:51 <fao89> but I agree we don't need more mailing lists
15:06:09 * ggainey heaves a sigh of relief - So. Many. Filters. already
15:06:12 <bmbouter> agreed on not more mailing lists
15:06:19 <bmbouter> one thing we don't use is github conversations
15:06:22 <dalley> agree no more mailing lists
15:06:32 <fao89> next topic: IRC channel for sharing tech stuff
15:06:39 <bmbouter> one sec
15:07:06 <fao89> I'm wondering where would be a good place to share articles, tutorials, ...?
15:07:22 <bmbouter> so I wanted to point out the github stuff a bit to highlight it
15:07:32 <bmbouter> we have these teams (which not everyone can probably see) https://github.com/orgs/pulp/teams
15:07:43 <ggainey> interesting
15:07:57 <bmbouter> and in them, each has a "discussion" section https://github.com/orgs/pulp/teams/ansible-installer
15:08:05 <ggainey> have done absolutely zero w/github-teams, looks worth reading up on for sure
15:08:32 <bmbouter> and these disucsisons are bydefault visible to everyone in the pulp organization (not jus tthat team)
15:08:56 <bmbouter> https://github.com/orgs/pulp/teams/ansible-installer/discussions/1
15:09:05 <bmbouter> so that's a test discussion for the installer team for example
15:09:21 <bmbouter> and they can also be "private" just to the team members, e.g. maybe some sensitive security stuff
15:09:37 <bmbouter> and they can be pinned so meaningful things can stay "at the top"
15:09:42 <bmbouter> and and and!
15:09:44 <fao89> I liked it
15:09:51 <ggainey> looks cool
15:10:06 <ggainey> (altho also looks like the 'team membership' needs some updates/curating :) )
15:10:13 <bmbouter> nice fao I see you made this one! https://github.com/orgs/pulp/teams/ansible-installer/discussions/2
15:10:15 <bmbouter> yes we should!
15:10:22 <bmbouter> yeah they are mostly up to date but not fully
15:11:07 <bmbouter> also you can ping a whole team with something like:   @pulp/<teamname>
15:11:11 <bmbouter> e.g.    @pulp/ansible-installer
15:11:22 <bmbouter> which btw, installer peeps we should rename the team to just be @pulp/installer
15:11:55 <fao89> +1
15:12:04 <dkliban> that all sounds good to me
15:12:05 <bmbouter> I put it on the intsallers agenda
15:12:18 <x9c4> +1
15:12:21 <ggainey> +1
15:12:38 <bmbouter> ^ pinging works on PRs also, it's a great way to ask for review from a team
15:13:12 <ggainey> I am all for taking more advantage of the tools our tools offer us :)
15:13:25 <fao89> when a new member join the team, it will be easier to catch up
15:13:39 <bmbouter> agreed
15:13:46 <bmbouter> I'm good to move on
15:14:02 <fao89> so the next topic is about sharing knowledge
15:14:09 <x9c4> pulp-dev?
15:14:24 <fao89> after dkliban thank me for sharing the content of operator workshop, I start to wonder where would be a good place for us to share links, articles, ...
15:14:44 <ggainey> fao89: honestly, I'd second 'pulp-dev'
15:14:54 <dkliban> ggainey: in this case the recordings were internal
15:14:57 <dkliban> on bluejeans i think
15:15:08 <bmbouter> +1 pulp-dev
15:15:13 <bmbouter> also that mailing list is searchable
15:15:19 <ggainey> ahhh - then there's no point in sharing them anywhere on freenode, alas
15:16:48 <fao89> so pulp-dev if public and pulp-internal if not?
15:17:12 <ggainey> aye, belike
15:17:30 <fao89> next topic: Going to merge https://github.com/pulp/pulp-fixtures/pull/177
15:17:31 <bmbouter> yup
15:18:04 <dkliban> that's fine
15:18:07 <fao89> "The modular package could be helpful in Pulp 3 testing."
15:18:08 <ggainey> yeah
15:18:08 <dkliban> let's merge that PR
15:18:20 <daviddavis> ok cool
15:18:22 <daviddavis> thanks
15:18:33 <fao89> last topic: release!
15:18:46 <dkliban> i heard we have a blocker
15:18:58 <dkliban> related to the OpenAPI schema
15:19:15 <fao89> yep, I think the bindings issue is a blocker
15:19:22 <fao89> do we have more blockers?
15:19:49 <ggainey> fao89: you mean https://pulp.plan.io/issues/7087 , yeah?
15:19:49 <dkliban> i am not aware of any
15:20:01 <dkliban> yes, that one ggainey
15:20:04 <ggainey> kk
15:20:07 <fao89> yep!
15:20:46 <dkliban> who is able to investigate this one?
15:20:56 <fao89> I can
15:21:16 <daviddavis> fao89++
15:21:16 <pulpbot> daviddavis: fao89's karma is now 78
15:21:44 <fao89> who is going to do the release? So I can poke when I finish it
15:22:06 <dkliban> daviddavis: did we decide if it was me or you?
15:22:14 <dkliban> or did we have ggainey wanting to do it?
15:23:05 <ggainey> hrm, I thought that was 3.6? (could def be worng tho)
15:23:51 <dkliban> ggainey: i have no idea
15:23:55 <ggainey> heh, same
15:24:01 <ggainey> it's been a long year this month :)
15:24:12 <fao89> one more thing about the release, should we try it? https://github.com/pulp/pulp_file/pull/409
15:24:13 <dkliban> daviddavis: and i are both working on the pulp 2 release
15:24:25 <dkliban> trying to get the tests passing
15:24:29 <bmbouter> fao89: yes I'm about to lgtm that PR
15:24:45 <dkliban> yes we should
15:24:52 <dkliban> do we have a similar PR for pulpcore?
15:25:04 <fao89> we have it on plugin_template
15:25:17 <fao89> https://github.com/pulp/plugin_template/pull/240
15:25:39 <fao89> (actually I need to do one change at plugin_template)
15:25:52 <bmbouter> fao89: https://github.com/pulp/pulp_file/pull/409#pullrequestreview-444002971
15:26:43 <bmbouter> we should get the same ofr pulpcore and try both
15:27:02 <bmbouter> so given that it would be most efficient if fao89 can release both because then he can fix the script
15:27:12 <bmbouter> I'm sure there will be issues, there always are the first time
15:27:27 <ggainey> heh, very true
15:27:56 <daviddavis> I don't know if fao89 can release if he doesn't have the commit bit
15:28:12 <fao89> I can do the PR
15:28:25 <bmbouter> yup someone else can merge and tag+push
15:28:28 <dkliban> yep
15:30:01 <fao89> #endmeeting
15:30:01 <fao89> !end