14:32:24 <fao89> #startmeeting Pulp Triage 2020-07-17
14:32:24 <fao89> !start
14:32:24 <pulpbot> Meeting started Fri Jul 17 14:32:24 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:24 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:32:24 <pulpbot> The meeting name has been set to 'pulp_triage_2020-07-17'
14:32:24 <fao89> #info fao89 has joined triage
14:32:24 <pulpbot> fao89: fao89 has joined triage
14:32:27 <bmbouter> #info bmbouter has joined triage
14:32:27 <bmbouter> !here
14:32:27 <pulpbot> bmbouter: bmbouter has joined triage
14:32:29 <ppicka> #info ppicka has joined triage
14:32:29 <ppicka> !here
14:32:29 <pulpbot> ppicka: ppicka has joined triage
14:32:32 <ttereshc> #info ttereshc has joined triage
14:32:32 <ttereshc> !here
14:32:32 <pulpbot> ttereshc: ttereshc has joined triage
14:32:36 <daviddavis> #info daviddavis has joined triage
14:32:37 <daviddavis> !here
14:32:37 <pulpbot> daviddavis: daviddavis has joined triage
14:32:42 <fao89> !next
14:32:43 <fao89> #topic https://pulp.plan.io/issues/7156
14:32:43 <pulpbot> fao89: 4 issues left to triage: 7156, 7154, 7143, 7110
14:32:44 <pulpbot> RM 7156 - ttereshc - NEW - Release script doesn't set upper limit on pulpcore dep for all commits when making a patch release
14:32:45 <pulpbot> https://pulp.plan.io/issues/7156
14:32:55 <fao89> #idea Proposed for #7156: Leave the issue as-is, accepting its current state.
14:32:55 <fao89> !propose accept
14:32:55 <pulpbot> fao89: Proposed for #7156: Leave the issue as-is, accepting its current state.
14:33:05 <ttereshc> +1
14:33:26 <ppicka> +1
14:33:27 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:33:27 <fao89> !accept
14:33:27 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:28 <fao89> #topic https://pulp.plan.io/issues/7154
14:33:28 <pulpbot> fao89: 3 issues left to triage: 7154, 7143, 7110
14:33:29 <pulpbot> RM 7154 - ekohl - NEW - Please provide either 'view_name' or 'view_name_pattern' for DetailRelatedField on _call_with_frames_removed
14:33:30 <pulpbot> https://pulp.plan.io/issues/7154
14:34:28 <fao89> I think this related with OpenAPI
14:34:44 <ttereshc> basically any of the pulp packages can give this warning, so some places are not fixed
14:35:03 <ttereshc> I *think* I saw one for the migration plugin, might be it
14:35:25 <x9c4> #info x9c4 has joined triage
14:35:25 <x9c4> !here
14:35:25 <pulpbot> x9c4: x9c4 has joined triage
14:35:39 <fao89> ttereshc, https://pulp.plan.io/issues/6801
14:35:42 <dkliban> #info dkliban has joined triage
14:35:42 <dkliban> !here
14:35:43 <pulpbot> dkliban: dkliban has joined triage
14:35:58 <ttereshc> yeah, it's the same
14:36:07 <ttereshc> just it was not fixed everywhere I guess
14:36:16 <daviddavis> the warning seems strange. where is _call_with_frames_removed ?
14:36:24 <fao89> probably it is another model
14:36:49 <dkliban> x9c4: this is related to change you made
14:37:03 <dkliban> in pulpcore ... and not every plugin has made the needed changes
14:37:27 <fao89> #idea Proposed for #7154: Leave the issue as-is, accepting its current state.
14:37:27 <fao89> !propose accept
14:37:27 <pulpbot> fao89: Proposed for #7154: Leave the issue as-is, accepting its current state.
14:37:41 <dkliban> https://github.com/pulp/pulpcore/blob/master/pulpcore/app/serializers/base.py#L152
14:37:42 <x9c4> Yes. it means, there is a detail-related field without view-name
14:37:48 <daviddavis> I think this is it https://git.io/JJZ6X
14:38:09 <x9c4> And the warning is strange, becuse we try to extract the context from the backtrace.
14:38:36 <x9c4> and sometimes we target the wron frame i guess.
14:39:31 <bmbouter> yikes https://github.com/pulp/pulpcore/blob/master/pulpcore/app/serializers/base.py#L153
14:40:23 <fao89> as it is in importlib, it seems to be on migration plugin
14:41:16 <x9c4> Turn the warning into a failure and you should see where the problem was.
14:42:12 <daviddavis> ok so accept and add to sprint?
14:42:14 <dkliban> yes
14:42:25 <dkliban> #idea Proposed for #7154: accept and add to sprint
14:42:25 <dkliban> !propose other accept and add to sprint
14:42:25 <pulpbot> dkliban: Proposed for #7154: accept and add to sprint
14:42:44 <ttereshc> +1
14:42:47 <x9c4> +1
14:43:01 <fao89> #agreed accept and add to sprint
14:43:01 <fao89> !accept
14:43:01 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:43:03 <fao89> #topic https://pulp.plan.io/issues/7143
14:43:03 <pulpbot> fao89: 2 issues left to triage: 7143, 7110
14:43:04 <pulpbot> RM 7143 - dalley - POST - Improve performance of content stage
14:43:05 <pulpbot> https://pulp.plan.io/issues/7143
14:43:07 <ttereshc> whoever fixes it will need to move it to the correct project in redmine
14:43:24 <ttereshc> (it's about #7154)
14:43:47 <dkliban> sounds good ttereshc
14:43:56 <fao89> it is in post but does not have a PR attached
14:43:59 <dkliban> we should accept and add to sprint this one also
14:44:07 <dkliban> there are 2 PRs actually that need to be associated
14:44:21 <dkliban> dalley: could you update the commit message on the PRs so the bot notices them
14:44:21 <fao89> #idea Proposed for #7143: accept and add to sprint
14:44:21 <fao89> !propose other accept and add to sprint
14:44:21 <pulpbot> fao89: Proposed for #7143: accept and add to sprint
14:44:22 <dkliban> ?
14:44:41 <fao89> dalley, is in a training
14:44:47 <dkliban> cool
14:44:50 <dkliban> i'll ping him later
14:45:00 <fao89> #agreed accept and add to sprint
14:45:00 <fao89> !accept
14:45:00 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:45:01 <fao89> #topic https://pulp.plan.io/issues/7110
14:45:01 <pulpbot> fao89: 1 issues left to triage: 7110
14:45:02 <pulpbot> RM 7110 - wibbit - NEW - pulpcore-client - Artifact upload fails when using python27
14:45:03 <pulpbot> https://pulp.plan.io/issues/7110
14:45:14 <dkliban> oh shit
14:45:20 <mikedep333> #info mikedep333 has joined triage
14:45:20 <mikedep333> !here
14:45:20 <pulpbot> mikedep333: mikedep333 has joined triage
14:45:22 <dkliban> i was supposed to take care of closing this
14:45:24 <daviddavis> hehe
14:45:24 <dkliban> i'll do it now
14:45:42 <ttereshc> thanks
14:45:58 <fao89> #idea Proposed for #7110: dkliban to close it
14:45:58 <fao89> !propose other dkliban to close it
14:45:58 <pulpbot> fao89: Proposed for #7110: dkliban to close it
14:46:02 <dkliban> though actually, we pulled in a new version of openapi-generator and it has a bug fix related to this
14:46:03 <fao89> #agreed dkliban to close it
14:46:03 <fao89> !accept
14:46:03 <pulpbot> fao89: Current proposal accepted: dkliban to close it
14:46:04 <pulpbot> fao89: No issues to triage.
14:46:09 <fao89> Open floor!
14:46:16 <fao89> https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:46:27 <fao89> topic: Proposal: pulpcore 3.6 tentative release date Aug 11th
14:46:58 <dkliban> that date works for me
14:47:03 <daviddavis> me too
14:47:38 <ttereshc> +1
14:48:08 <fao89> next topic?
14:48:10 <ppicka> +1
14:48:45 <bmbouter> ja
14:49:12 <fao89> topic: CI/CD team is no longer meeting regularly
14:49:43 <daviddavis> we'd like to propose checking CI status (takes about ~5 min) once a week during scrum
14:49:55 <fao89> pulp_container is failing with cherrypick | pulp-operator is failing when building pulpcore image
14:50:17 <dalley> dkliban, the commit message should be updated already, not sure why it did not get picked up https://github.com/pulp/pulpcore/pull/749/commits
14:51:11 <fao89> dalley, it is because pulpbot does not revisit PRs
14:51:13 <daviddavis> dalley: pulpbot doesn't revisit PRs https://pulp.plan.io/issues/6720
14:51:32 <daviddavis> dkliban or x9c4 can you take a look into the pulp_container failure?
14:51:36 <dkliban> yah ... would this group mind if either on Friday or Tuesday we did a CI check at the begining of the meeting or as part of open floor?
14:52:07 <dkliban> we jsut want to assign a person to investigate a failure if there is one going on
14:52:13 <dkliban> daviddavis: yes, i'll take a look at pulp_container
14:52:13 <daviddavis> +1
14:52:20 <daviddavis> thanks
14:52:43 <x9c4> I think it failed to cherrypick a commit due to conflicts.
14:52:52 <daviddavis> so I am thinking fridays we can just add the ci check to the open floor agenda?
14:52:58 <dkliban> yeah
14:53:01 <dkliban> i think that would be good
14:53:06 <x9c4> +1
14:53:25 <daviddavis> is the pulp-operator failure being looked into btw?
14:53:38 <x9c4> Can we have the pulpbot to generate a ci summary?
14:53:40 <fao89> non-CI people, any comment?
14:53:53 <dkliban> fao89: good question
14:54:07 <daviddavis> x9c4: that would be amazing
14:54:09 <dkliban> x9c4: i agree with your assesment
14:54:27 <dkliban> and +1 to pulpbot providing a summary
14:54:38 <fao89> daviddavis, I believe the problem with pulp-operator is related with: https://github.com/pulp/pulpcore/pull/657
14:54:53 <daviddavis> ttereshc bmbouter ppicka any objection to allowing us to spend 5 min reviewing ci statuses for projects during our friday scrums?
14:55:02 <ttereshc> I'm not against looking at failures here, if those are brief and not in detail for everyplugin or failure
14:55:19 <fao89> we are using fedora 30 which is too old, and maybe is the reason we are experiencing failures when pulling it
14:55:22 <bmbouter> agreed
14:55:33 <daviddavis> in our experience, it's usually just 1-3 failures and we don't want to discuss the cause of the failure. just assign someone to take a look.
14:55:39 <ppicka> +1 for short overview
14:55:43 <bmbouter> chat is an efficient forum really, and an open one +1
14:56:04 <daviddavis> the alternative is to just let teams handle their own ci failures
14:56:14 <daviddavis> and watching their own CIs
14:56:23 <bmbouter> I think we'll do better with a centralized approach
14:56:51 <bmbouter> until the a point when there are lots of docs, all built, little changing
14:56:53 <ppicka> I'd stay with centralised.
14:57:15 <daviddavis> ok so let's try a ci status check on fridays then between triage and open floor
14:57:43 <daviddavis> and if it goes well we can also update pulpbot
14:58:19 <fao89> next topic?
14:59:13 <fao89> topic: RBAC for pulpcore update
14:59:53 <bmbouter> yeah so the update part is that this PR is going to bring all of the features (lots of changelog entries) in one go https://github.com/pulp/pulpcore/compare/master...bmbouter:rbac-PoC
15:00:00 <bmbouter> and I'm doing lots of docs today
15:00:07 <bmbouter> so it's nearing the ready for final review stage
15:00:17 <daviddavis> I gotta go to a meeting
15:00:42 <bmbouter> I can recap this on email also
15:00:48 <bmbouter> oh ggainey is also out
15:00:56 <bmbouter> I can ask about import/export objects later
15:01:54 <bmbouter> I think status and workers can be fully public ... no RBAC
15:02:17 <bmbouter> so I think I need to add RBAC for orphan cleanup, task groups, and uploads...
15:02:44 <bmbouter> so that is what I'll do and then post it for public review towards a merge
15:02:51 <ttereshc> bmbouter, when you say rbac for workers, what do you mean?
15:03:05 <bmbouter> I mean this endpoint https://docs.pulpproject.org/restapi.html#tag/workers
15:03:11 <bmbouter> /pulp/api/v3/workers/
15:03:36 <ttereshc> ah ok
15:03:37 <ttereshc> thanks
15:03:47 <ttereshc> +1 to your suggestions
15:04:11 <dkliban> bmbouter: that all sounds good
15:04:18 <bmbouter> also there are some questions about the upgrade experience ... I think we need to have the 'admin' user receive all object level permissions they would have received if they had made all the objects had RBAC been in place from the start
15:04:22 <bmbouter> so I need to write a migration that does that
15:04:35 <bmbouter> probably with helper methods because all plugins will need similar
15:04:37 <bmbouter> so I can do that also
15:04:52 <bmbouter> I'll summarize all this as it happens to the list
15:07:14 <ttereshc> thanks
15:07:28 <x9c4> sounds great!
15:07:36 <dkliban> thank you bmbouter
15:08:36 <fao89> #endmeeting
15:08:36 <fao89> !end