14:30:08 <fao89> #startmeeting Pulp Triage 2020-07-31
14:30:08 <fao89> !start
14:30:08 <fao89> #info fao89 has joined triage
14:30:08 <pulpbot> Meeting started Fri Jul 31 14:30:08 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:08 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:08 <pulpbot> The meeting name has been set to 'pulp_triage_2020-07-31'
14:30:08 <pulpbot> fao89: fao89 has joined triage
14:30:17 <ppicka> #info ppicka has joined triage
14:30:17 <ppicka> !here
14:30:17 <pulpbot> ppicka: ppicka has joined triage
14:30:24 <ggainey> #info ggainey has joined triage
14:30:24 <ggainey> !here
14:30:24 <pulpbot> ggainey: ggainey has joined triage
14:30:32 <ttereshc> #info ttereshc has joined triage
14:30:32 <ttereshc> !here
14:30:33 <pulpbot> ttereshc: ttereshc has joined triage
14:30:42 <fao89> !next
14:30:42 <daviddavis> !here
14:30:43 <fao89> #topic https://pulp.plan.io/issues/7246
14:30:43 <daviddavis> #info daviddavis has joined triage
14:30:43 <pulpbot> fao89: 6 issues left to triage: 7246, 7245, 7239, 7232, 7227, 7205
14:30:45 <pulpbot> RM 7246 - daviddavis - NEW - Failed pulp exports leave behind an export file
14:30:46 <pulpbot> https://pulp.plan.io/issues/7246
14:30:47 <pulpbot> daviddavis: daviddavis has joined triage
14:31:06 <fao89> #idea Proposed for #7246: Leave the issue as-is, accepting its current state.
14:31:06 <fao89> !propose accept
14:31:06 <pulpbot> fao89: Proposed for #7246: Leave the issue as-is, accepting its current state.
14:31:12 <daviddavis> +1 from me
14:31:22 <ggainey> +1
14:31:28 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:31:28 <fao89> !accept
14:31:28 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:31:29 <fao89> #topic https://pulp.plan.io/issues/7245
14:31:29 <pulpbot> fao89: 5 issues left to triage: 7245, 7239, 7232, 7227, 7205
14:31:29 <ppicka> +1
14:31:30 <pulpbot> RM 7245 - daviddavis - NEW - Unexpected param error not being returned
14:31:31 <pulpbot> https://pulp.plan.io/issues/7245
14:31:47 <dkliban> #info dkliban has joined triage
14:31:47 <dkliban> !here
14:31:47 <pulpbot> dkliban: dkliban has joined triage
14:31:59 <ggainey> huh, interesting
14:32:18 <daviddavis> yea this bit me when I tried to set policy when syncing
14:32:36 <fao89> #idea Proposed for #7245: accept and add to sprint
14:32:36 <fao89> !propose other accept and add to sprint
14:32:36 <pulpbot> fao89: Proposed for #7245: accept and add to sprint
14:32:37 <ggainey> oh - because you think it worked, but in reality it is silently ignored
14:32:40 <dkliban> +1
14:32:44 <ggainey> +1
14:32:45 <ppicka> +1 as user friendly
14:32:46 <dkliban> ggainey: exactly
14:32:54 <ggainey> yah
14:32:57 <fao89> #agreed accept and add to sprint
14:32:57 <fao89> !accept
14:32:57 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:32:58 <fao89> #topic https://pulp.plan.io/issues/7239
14:32:58 <pulpbot> fao89: 4 issues left to triage: 7239, 7232, 7227, 7205
14:32:59 <pulpbot> RM 7239 - iballou - NEW - ValueError: time data '' does not match format '%Y-%m-%dT%H:%M:%SZ' for any Pulp 3 task
14:33:00 <pulpbot> https://pulp.plan.io/issues/7239
14:33:12 <mikedep333> #info mikedep333 has joined triage
14:33:12 <mikedep333> !here
14:33:12 <pulpbot> mikedep333: mikedep333 has joined triage
14:33:48 <ggainey> this looks like an env-issue - is there anything left to do here?
14:33:54 <dkliban> i don't thnk so
14:34:03 <dkliban> he fixed it by upgrading an RPM
14:34:06 <ggainey> close as WORKSFORME?
14:34:09 <fao89> should we do something on the installer?
14:34:38 <bmbouter> #info bmbouter has joined triage
14:34:38 <bmbouter> !here
14:34:38 <pulpbot> bmbouter: bmbouter has joined triage
14:34:50 <bmbouter> CLOSED - NOTABUG I think
14:35:00 <ttereshc> he mentioned that it might be that re-install helped
14:35:01 <ggainey> fao89: not sure - was the installer itself involved, or just pip-install <plugin>?
14:35:03 <bmbouter> oh actually WORKSFORME is good too
14:35:14 <bmbouter> because it's valid but inreproducable
14:35:14 <dkliban> yeah ... worksforme is better
14:35:22 <bmbouter> unreproducable
14:35:23 <fao89> #idea Proposed for #7239: close as worksforme
14:35:23 <fao89> !propose other close as worksforme
14:35:23 <pulpbot> fao89: Proposed for #7239: close as worksforme
14:35:27 <fao89> #agreed close as worksforme
14:35:27 <fao89> !accept
14:35:27 <pulpbot> fao89: Current proposal accepted: close as worksforme
14:35:28 <fao89> #topic https://pulp.plan.io/issues/7232
14:35:28 <pulpbot> fao89: 3 issues left to triage: 7232, 7227, 7205
14:35:29 <pulpbot> RM 7232 - bmbouter - NEW - As a user, I can CRUD Groups via an API
14:35:30 <pulpbot> https://pulp.plan.io/issues/7232
14:35:31 <ggainey> bmbouter: yeah, I'd prefer WORKSFOR, because the behavior doesn't exist-and-is-expected, it's an environmental one-off
14:35:38 <ggainey> cool
14:35:49 <ttereshc> story?
14:35:56 <ggainey> +1
14:35:58 <dkliban> yes, it's a story
14:36:07 <bmbouter> yes and it needs some revision, I meant it to be marked story
14:36:08 <fao89> #idea Proposed for #7232: convert to story
14:36:08 <fao89> !propose other convert to story
14:36:08 <pulpbot> fao89: Proposed for #7232: convert to story
14:36:13 <fao89> #agreed convert to story
14:36:13 <fao89> !accept
14:36:13 <pulpbot> fao89: Current proposal accepted: convert to story
14:36:13 <fao89> #topic https://pulp.plan.io/issues/7227
14:36:14 <bmbouter> I plan to revise here soon, please convert
14:36:14 <pulpbot> fao89: 2 issues left to triage: 7227, 7205
14:36:15 <pulpbot> RM 7227 - newswangerd - NEW - Permission checking
14:36:16 <bmbouter> ty
14:36:17 <pulpbot> https://pulp.plan.io/issues/7227
14:36:19 <ipanova> #info ipanova has joined triage
14:36:19 <ipanova> !here
14:36:19 <pulpbot> ipanova: ipanova has joined triage
14:36:28 <bmbouter> similar here, story, I plan to revise and send out for comment soon
14:36:41 <fao89> #idea Proposed for #7227: convert to story
14:36:41 <fao89> !propose other convert to story
14:36:41 <pulpbot> fao89: Proposed for #7227: convert to story
14:36:50 <ggainey> +1
14:36:54 <fao89> #agreed convert to story
14:36:54 <fao89> !accept
14:36:54 <pulpbot> fao89: Current proposal accepted: convert to story
14:36:55 <fao89> #topic https://pulp.plan.io/issues/7205
14:36:55 <pulpbot> fao89: 1 issues left to triage: 7205
14:36:56 <ipanova> +1
14:36:57 <pulpbot> RM 7205 - pc - NEW - ClientConnectorSSLError during remote sync with cdn.redhat.com
14:36:58 <pulpbot> https://pulp.plan.io/issues/7205
14:37:23 <ipanova> skip?
14:37:34 <bmbouter> yes skip b/c once we make a change on the concurrency we can recommend they upgrade
14:37:57 <fao89> !skip
14:37:58 <pulpbot> fao89: No issues to triage.
14:38:04 <fao89> Open floor!  https://hackmd.io/@pulp/triage/edit
14:38:21 <fao89> topic: Noticed that several projects are failing https://travis-ci.com/github/pulp
14:38:37 <dkliban> pulp_container is failing for cherry-picks
14:38:43 <dkliban> we are planning to disable that
14:38:54 <fao89> same for pulp_file and pulpcore
14:39:08 <dkliban> and we agreed to disable cherry-picks there also
14:39:29 <ggainey> yeah
14:39:35 <fao89> next topic: Django update in pulp 2 https://github.com/pulp/pulp-packaging/pull/111
14:39:40 <ipanova> that;s an old agenda
14:39:47 <ggainey> aye
14:39:51 <ggainey> it's the 31st
14:40:18 <ipanova> ah no, it's just old date
14:40:27 <ggainey> ahhhhh
14:40:28 <ggainey> ok
14:40:29 <ttereshc> +1 to Django update
14:40:37 <ggainey> concur
14:40:42 <fao89> last triage was the +1 vote, hard to forget
14:40:47 <ipanova> +1
14:40:48 <daviddavis> it's all CVEs
14:40:51 <daviddavis> I'll merge it
14:40:55 <ggainey> cool
14:41:18 <bmbouter> +1
14:41:40 <fao89> next topic: Changing download_concurrency to 10
14:42:08 <dkliban> so this is jsut for the RPM packaging
14:42:15 <dkliban> i have Django 2 installed on my dev box
14:43:01 <daviddavis> for pulp 2?
14:43:08 <dkliban> oooooh
14:43:11 <dkliban> nevermind
14:43:15 <daviddavis> :)
14:43:18 <bmbouter> yeah for the pulp2 django we ship it ourselves https://repos.fedorapeople.org/pulp/pulp/stable/2.21/7Server/x86_64/
14:43:27 <dkliban> ok ... let's update it
14:43:29 <fao89> last triage the migration to 10 was: in favor: 4 against: 3 votes
14:43:30 <dkliban> for sure
14:43:48 <daviddavis> yea so for download_concurrency, I heard some concerns (from me included) but no strong objections to a migration
14:44:10 <ggainey> RE 7112 - there was a lot more discussion, I know jsherrill/katello weighed in on "please migrate existing 20s to 10"
14:44:13 <daviddavis> I think it makes sense to do a migration and change the default to 10
14:44:19 <ggainey> aye, concur
14:44:29 <dkliban> let's do it
14:44:32 <ggainey> I can add a comment to the issue
14:44:40 <bmbouter> +1
14:44:52 <ipanova> +1
14:44:53 <ttereshc> what about storing or not storing a default in the db?
14:44:56 <ggainey> also, it's assigned to me because I was doing the timing study, but I'll put it back to NEW (I may pick it up if nobody else does, tho)
14:45:01 <ttereshc> especially if we need to update it again
14:45:06 <fao89> I like it ttereshc
14:45:20 <ggainey> ttereshc: I'd think that would be a separate story?
14:45:21 <fao89> I would go with env var
14:45:24 <bmbouter> I was concerned about doing it that way for this attribute when no other defaults are done that way
14:45:32 <ggainey> yeah, that's my concern
14:45:40 <ggainey> it's not a bad idea - but it should be consistent
14:45:45 <bmbouter> if we're rethinking defaults that's fine w/ me but we should do it everywhere
14:46:03 <ttereshc> ok, sounds reasonable
14:46:14 <ggainey> in any event - I don't think we want to mix that with "set the default lower so we stop breaking ppl"
14:46:57 <dkliban> yep
14:47:03 <fao89> ready for the next topic?
14:47:06 <ttereshc> yes
14:47:06 <ggainey> yup
14:47:13 <fao89> topic: Give users the ability to reopen closed issues?
14:47:29 <daviddavis> so this would be for people without a role
14:47:38 <daviddavis> we could do it for everyone or for authors
14:47:43 <fao89> +1 to limit to authors
14:47:51 <daviddavis> and we can select which states (eg CLOSED WONTFIX) can be reopened
14:48:10 <bmbouter> +1 limit to authors, +1 closed states other than CURRENTRELEASE
14:48:17 <ppicka> +1 to author
14:48:27 <ipanova> +1 to bmbouter's +1
14:48:42 <ttereshc> I really want to allow it for everyone but I'm worried that spammers will use it
14:48:48 <daviddavis> yea
14:48:51 <ggainey> yeah, CURRENTRELEASE needs to be permanent, if the problem reoccurs it needs a new report
14:48:52 <ipanova> yep
14:48:56 <ggainey> ttereshc: yeah same
14:49:02 <ttereshc> what about closed-duplicate?
14:49:10 <ggainey> ttereshc: good point
14:49:17 <ttereshc> I don't think it's worth reopening
14:49:26 <ggainey> yeah
14:49:50 <ggainey> plus, if someone really can make a case for it, there's always "find us in #pulp and have an admin reopen"
14:50:23 <ggainey> same with "the author no longer is involved but *I* need this bug fixed", the user can find an admin online and make the request
14:50:50 <ggainey> so, yeah = +1 to authors-only, +1 to CURRENTRELEASE and DUPLICATE being 'permanent'
14:51:08 <bmbouter> this all sounds fine to me
14:51:09 <daviddavis> also, COMPLETE
14:51:19 <ttereshc> yup
14:51:21 * ggainey didn't even know COMPLETE was an option
14:51:26 <daviddavis> yea for tasks
14:51:52 <fao89> next topic: RBAC for pulpcore: attempting to merge next week
14:52:10 * ggainey cheers wildly
14:52:26 <bmbouter> we're in the end-game at this point, feature wise it's all there for pulpcore to enable plugin writers
14:52:35 <fao89> big change close to release date, should we delay the release?
14:53:29 <bmbouter> I don't think so as the upstream we should be favoring change users can upgrade when they feel ready
14:53:39 <dkliban> bmbouter: does your change require users to take any acgtion when they upgrade to 3.6?
14:53:47 <ggainey> I wouldn't, honestly - yes it's abig change, but esp if this is putting the machinery in place w/out closing the gates, should be fine
14:54:05 <dkliban> or will everything continue to work as is if the user takes no action
14:54:07 <ggainey> and we're aiming at 4-5 wk release cycles right now, *any* date is 'close to a release' :)
14:54:07 <dkliban> ?
14:54:10 <daviddavis> bmbouter: how do I review the code? is there a PR?
14:54:11 <bmbouter> no action required is my goal and I think it'll pan out
14:54:33 <bmbouter> this still has WIP b/c I'm finishing docs and it needs a rebase, but https://github.com/pulp/pulpcore/pull/815/files
14:54:35 <dkliban> in that case i am not worried about this being merged close to release time
14:54:41 <bmbouter> code-wise it's not WIP realy
14:54:42 <bmbouter> really
14:54:47 <daviddavis> cool
14:54:50 <bmbouter> early review would be really great
14:54:51 <ttereshc> I wanted to ask if it's an ask for review
14:54:59 <ttereshc> ok great
14:55:02 <bmbouter> yes please
14:55:21 <ggainey> coolio
14:55:37 * fao89 cheers wildly
14:55:39 <bmbouter> my goal is to merge get it fully wrapped up with it's current scope and then add the user/groups api's in a separate PR, and then add other protection of other core endpoints in other PRs
14:56:20 <ggainey> sounds good2me
14:56:21 <bmbouter> the primary point of this is to make sure plugin writers have everything they need, e.g. galaxy_ng
14:56:23 <dkliban> +1 to that plan
14:56:40 <ttereshc> all those are for 3.6, right?
14:56:57 <bmbouter> users and groups are for 3.6 for sure
14:57:05 <bmbouter> other endpoints being protected could be deferred
14:57:12 <bmbouter> this PR definitly for 3.6
14:57:22 <ggainey> yupyup
14:57:29 <ttereshc> thanks for clarification
14:57:33 <bmbouter> galaxy_ng needs this and users and groups and they are releasing just after 3.6
14:57:41 <bmbouter> and they are built on top of this branch already for a few weeks now
14:58:00 <bmbouter> it's testing well for them
14:58:16 <bmbouter> I saw a UI demo where rbac was showing just the objects users could edit and enforcing their actions, it was slick as hell
14:58:29 <bmbouter> they'll be sharing that w/ us in recorded form here in a week or so also btw
14:58:35 <ipanova> nice!
14:59:00 <ttereshc> great
14:59:14 <bmbouter> so please review is the ask, I think we can next-topic
14:59:18 * daviddavis cheers wildly
14:59:32 <fao89> next topic: Proposal: Start allowing old z-streams
15:00:36 <bmbouter> regardless of if we start allowing old z-streams, we need a process to request backport bugfixes
15:01:11 <daviddavis> I agree
15:01:13 <ggainey> esp as more projects start using pulp3 on a given version
15:01:17 <ggainey> yeah
15:01:26 <daviddavis> is there still a limit on which releases we'll backport to?
15:01:36 <bmbouter> I don't think there is a liit on what can be requested
15:01:44 <bmbouter> limit*
15:01:59 <daviddavis> I'm just worried that this might encourage users to not upgrade
15:02:02 <bmbouter> in fact if a user wanted to backport to their own really old version I'm ok w/ that
15:02:32 <bmbouter> that risk is accurate I think daviddavis
15:02:47 <ggainey> we def want to have guardrails on the kinds-of things that can be backported
15:02:49 <daviddavis> I guess we can burn that bridge when we come to it
15:02:51 <bmbouter> but the benefits to me still are overwhelming
15:02:54 <fao89> upgrades are somewhat painful at the installer side
15:02:55 <ggainey> (ie, "not features" to start :) )
15:03:32 <bmbouter> I think it may be common that backports are requested and then closed WONTFIX based on the complexity and time availability
15:03:42 <ggainey> aye
15:03:50 <fao89> when talking about pulpcore, because plugins have different release dates
15:04:07 <bmbouter> fao89: I don't follow
15:04:48 <fao89> I rather want pulpcore 3.5.8 than 3.6.0
15:04:59 <fao89> because of the preflight thing
15:05:22 <ipanova> bmbouter: what is the main driver enabling also users asking this and not only downstream?
15:05:52 <bmbouter> the primary driver is that some "downstreams" like katello for example don't have separate source trees
15:06:09 <bmbouter> so if we don't accept the backport and release it upstream it wouldn't be released
15:06:36 <bmbouter> jsherrill expressed that it's desirable for a bugfix to be released upstream whenever possible which I also agree w/
15:07:17 <bmbouter> but we can't backport features, that's just an option so if that's what downstreams want backported, they'll have to have separate source trees
15:07:30 <bmbouter> correction: just *not* an option
15:07:42 <dkliban> so we are talking about backporting bug fixes only
15:07:54 <bmbouter> yes semver only allows us to do that, our hands are tied
15:07:56 <ggainey> that was my understanding
15:08:02 <ggainey> yeah zacly
15:08:02 <ttereshc> yes,  I think we always talked only about them
15:08:13 <ipanova> i understand this intention, my concern if we put this into our regular practice where *any* users could ask this we might open a pandora box which would lead to 1) users will be less motivated to upgrade 2) more work on our shoulders 3) too many requests
15:08:49 <bmbouter> fwiw I don't see us having much choice, galaxy_ng requested a backport yesterday, katello also will be having a variety of them soon
15:09:04 <bmbouter> w.r.t 2) and 3) I think we CLOSE WONTFIX probably often
15:09:23 <ggainey> yeah, we'll def need to work at holding the line
15:09:26 <bmbouter> ipanova: I agree with you on the capacity problem completely
15:09:33 <daviddavis> ipanova: I have the same concern and I think we'll eventually develop a policy over time
15:09:43 <ipanova> yeah
15:09:48 <ttereshc> yeah, +1 to policy over time
15:09:53 <fao89> if we don't have a choice, it is already chosen
15:09:55 <ttereshc> hard to come up with it now
15:10:26 <fao89> next topic: Supporting content mapping in export https://pulp.plan.io/issues/7252
15:10:31 <bmbouter> fao89: more like forced on us, projects that use us say "we can't upgrade now yet we need this bugfix"
15:10:34 <ipanova> i am thinking not only of katello and galaxy_ng but also such users like Ben Li, for example bmbouter
15:10:46 <ipanova> but yeah i agree we don't have much of the choice bmbouter
15:11:11 <bmbouter> yup, and it would be kind of cool to me if users authored a patch and then released it
15:11:23 <bmbouter> that was already present in master, everything goes to master
15:11:47 <bmbouter> what next step should come out of ths convo?
15:12:11 <daviddavis> create a backport tracker type and document it
15:12:15 <bmbouter> one thing is to create the Backport Tracker type which I can do
15:12:19 <ipanova> bmbouter: create new tracker, announce on pulp-dev
15:12:27 <ipanova> + docs, yes
15:12:32 <daviddavis> I think we have some redmine docs which describes the trackers
15:12:39 <bmbouter> I agree
15:12:53 <bmbouter> is someone able to help make these changes? I'm trying to focus only on rbac
15:13:18 <ttereshc> I can
15:13:29 <bmbouter> ttereshc++
15:13:29 <pulpbot> bmbouter: ttereshc's karma is now 207
15:13:31 <bmbouter> yaaaaay!
15:13:38 <ggainey> ttereshc++
15:13:38 <pulpbot> ggainey: ttereshc's karma is now 208
15:14:09 <fao89> next topic: Supporting content mapping in export https://pulp.plan.io/issues/7252
15:14:22 <ggainey> yeah, I was lookin at this this morning
15:14:25 <daviddavis> ok great
15:14:26 <ggainey> it's complicated
15:14:29 <daviddavis> ha yea
15:14:32 <daviddavis> welcome to kickstarts
15:14:36 <ggainey> yup
15:14:37 <dkliban> lol
15:14:51 <daviddavis> I was hoping maybe one more person could look at it
15:14:59 <daviddavis> but one might be fine
15:15:19 <ggainey> daviddavis: can you maybe draw out an example? i found I was confusing myself trying to picture what was/needed to go on
15:15:33 <daviddavis> ggainey: of the kickstart models?
15:15:42 <daviddavis> or the exported files?
15:15:57 <ggainey> um
15:16:05 <daviddavis> or both
15:16:31 <ttereshc> daviddavis, I'm not sure which repo you want to map content of subrepos to
15:16:35 <ggainey> you know, I'm not sure I know, which is prob an artifact of how my brain locked up thinking about this
15:16:53 <daviddavis> ha ok, maybe I can explain it later on our scrum
15:16:55 <ggainey> I think an example of the output-json for option-1 is what I meant
15:16:59 <ggainey> sure
15:17:04 <daviddavis> ah ok
15:17:34 <daviddavis> I will add that
15:17:40 <ggainey> (also, we need to keep in mind that moving from name-unique in repos to name/pulp_type-unique will have an impact on PIE
15:17:41 <ggainey> )
15:17:45 <ggainey> coolio, thanks
15:17:52 <daviddavis> agreed
15:18:27 <ggainey> not specific to this story, just a general note for us
15:18:35 <daviddavis> yup
15:18:40 <ggainey> kk
15:20:49 <daviddavis> that's all I had for that topic
15:20:50 <fao89> #endmeeting
15:20:50 <fao89> !end