14:30:12 <fao89> #startmeeting Pulp Triage 2020-08-04
14:30:12 <fao89> #info fao89 has joined triage
14:30:12 <fao89> !start
14:30:12 <pulpbot> Meeting started Tue Aug  4 14:30:12 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:12 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:12 <pulpbot> The meeting name has been set to 'pulp_triage_2020-08-04'
14:30:12 <pulpbot> fao89: fao89 has joined triage
14:30:16 <daviddavis> #info daviddavis has joined triage
14:30:16 <daviddavis> !here
14:30:16 <pulpbot> daviddavis: daviddavis has joined triage
14:30:27 <dkliban> #info dkliban has joined triage
14:30:27 <dkliban> !here
14:30:27 <pulpbot> dkliban: dkliban has joined triage
14:31:04 <fao89> !next
14:31:05 <fao89> #topic https://pulp.plan.io/issues/7271
14:31:05 <pulpbot> fao89: 5 issues left to triage: 7271, 7270, 7268, 7238, 7205
14:31:07 <pulpbot> RM 7271 - alikins - NEW - Enable swagger-ui drf-spectactular view
14:31:08 <pulpbot> https://pulp.plan.io/issues/7271
14:31:28 <daviddavis> task?
14:31:40 <dkliban> it's a story
14:31:46 <daviddavis> +1
14:31:48 <fao89> #idea Proposed for #7271: convert to story
14:31:48 <fao89> !propose other convert to story
14:31:48 <pulpbot> fao89: Proposed for #7271: convert to story
14:31:54 <fao89> #agreed convert to story
14:31:54 <fao89> !accept
14:31:54 <pulpbot> fao89: Current proposal accepted: convert to story
14:31:55 <fao89> #topic https://pulp.plan.io/issues/7270
14:31:55 <pulpbot> fao89: 4 issues left to triage: 7270, 7268, 7238, 7205
14:31:56 <pulpbot> RM 7270 - lmjachky - NEW - NoArtifactContentUploadViewSet should use PulpTemporaryFile instead of Artifact to store temporary data
14:31:57 <pulpbot> https://pulp.plan.io/issues/7270
14:32:09 <daviddavis> refactor, also it would be nice to get this into 3.6
14:32:26 <lmjachky> what is deadline for 3.6?
14:32:30 <daviddavis> august 11
14:32:42 <fao89> #idea Proposed for #7270: convert to refactor
14:32:42 <fao89> !propose other convert to refactor
14:32:42 <pulpbot> fao89: Proposed for #7270: convert to refactor
14:32:44 <dkliban> should be merged on the 10th though
14:32:48 <dkliban> +1
14:33:14 <fao89> add to sprint?
14:33:23 <dkliban> yes
14:33:34 <fao89> #agreed convert to refactor
14:33:34 <fao89> !accept
14:33:34 <pulpbot> fao89: Current proposal accepted: convert to refactor
14:33:35 <fao89> #topic https://pulp.plan.io/issues/7268
14:33:35 <pulpbot> fao89: 3 issues left to triage: 7268, 7238, 7205
14:33:36 <pulpbot> RM 7268 - cmeissner - NEW - Pulp can't connect to server with self signed certificates
14:33:37 <pulpbot> https://pulp.plan.io/issues/7268
14:33:38 <ggainey> #info ggainey has joined triage
14:33:38 <ggainey> !here
14:33:38 <pulpbot> ggainey: ggainey has joined triage
14:34:14 <daviddavis> skip for now and let user try out suggestion? or just close?
14:34:31 <fao89> move to rpm?
14:34:32 <dkliban> i already commented on this
14:34:35 <bmbouter> #info bmbouter has joined triage
14:34:35 <bmbouter> !here
14:34:35 <pulpbot> bmbouter: bmbouter has joined triage
14:34:46 <dkliban> it's a works for me
14:34:51 <daviddavis> works for me
14:34:55 <ggainey> +1
14:34:56 <dkliban> and also ... that site does not use self signed cetrts
14:35:18 <fao89> !propose close as worksforme
14:35:18 <pulpbot> fao89: Error: "propose" is not a valid command.
14:35:21 <fao89> !accept
14:35:21 <pulpbot> fao89: No action proposed, nothing to accept.
14:35:29 <fao89> !propose otherclose as worksforme
14:35:29 <pulpbot> fao89: Error: "propose" is not a valid command.
14:35:32 <fao89> #idea Proposed for #7268: close as worksforme
14:35:32 <fao89> !propose other close as worksforme
14:35:33 <pulpbot> fao89: Proposed for #7268: close as worksforme
14:35:35 <fao89> #agreed close as worksforme
14:35:35 <fao89> !accept
14:35:35 <pulpbot> fao89: Current proposal accepted: close as worksforme
14:35:36 <fao89> #topic https://pulp.plan.io/issues/7238
14:35:36 <pulpbot> fao89: 2 issues left to triage: 7238, 7205
14:35:37 <pulpbot> RM 7238 - iballou - NEW - "integer out of range" error when syncing OracleLinux 8 AppStream repo
14:35:38 <pulpbot> https://pulp.plan.io/issues/7238
14:35:42 <ipanova> #info ipanova has joined triage
14:35:42 <ipanova> !here
14:35:42 <pulpbot> ipanova: ipanova has joined triage
14:36:11 <daviddavis> accept and add to sprint
14:36:14 <ipanova> +1
14:36:21 <dkliban> i think we may have fixed soemthing similar already
14:36:31 <fao89> #idea Proposed for #7238: accept and add to sprint
14:36:31 <fao89> !propose other accept and add to sprint
14:36:31 <pulpbot> fao89: Proposed for #7238: accept and add to sprint
14:36:37 <dkliban> +1
14:36:40 <fao89> #agreed accept and add to sprint
14:36:40 <fao89> !accept
14:36:40 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:36:41 <fao89> #topic https://pulp.plan.io/issues/7205
14:36:41 <pulpbot> fao89: 1 issues left to triage: 7205
14:36:42 <pulpbot> RM 7205 - pc - NEW - ClientConnectorSSLError during remote sync with cdn.redhat.com
14:36:43 <pulpbot> https://pulp.plan.io/issues/7205
14:37:11 <ipanova> it has been 2 weeks almost with no response, what about closing?
14:37:21 <fao89> +1
14:37:23 <ipanova> and suggest to re-open if issues persists
14:37:27 <daviddavis> +1
14:37:27 <ggainey> +1
14:37:52 <fao89> close as worksforme?
14:38:02 <dkliban> but aren't we actually making a change related to this
14:38:04 <dkliban> ?
14:38:14 <dkliban> the reduction in the default download concurrency
14:38:23 <ipanova> we are, but this has a separate issue to track that effort
14:38:29 <ggainey> dkliban: we're changing concurrency - but we have no idea if that's this user's actual issue
14:38:35 <ggainey> and...yeah, that
14:38:44 <ggainey> :)
14:38:54 <dkliban> ok ... so what status should we close it with?
14:40:04 <ipanova> mmm
14:40:23 <ipanova> notabug?
14:40:44 <ggainey> anybody in a place where they can sync rhel7.6-optional? if we are, and can, worksforme/notabug?
14:41:06 <ggainey> I don't have a rhel cert handy, alas
14:41:14 <ipanova> or wont fix, because there is no followup from the user?
14:41:16 <fao89> I would go with duplicate and point to the download concurrency issue, or close as worksforme
14:41:46 <ggainey> I wouldn't close as dup, because we don't *know* that's the problem, we were suggesting that it mighth be
14:42:41 <ipanova> i don't have any strong preference
14:42:58 <dkliban> i can try syncing it
14:43:10 <bmbouter> if you can sync it then +1 worksforme
14:43:16 <fao89> last skip?
14:43:18 <ggainey> yeah, sounds good to me too
14:43:21 <dkliban> let's skip for now
14:43:21 <ipanova> yes, worksforme
14:43:24 <ggainey> kk
14:43:27 <dkliban> i'll sync that repo today
14:43:32 <fao89> !skip
14:43:33 <pulpbot> fao89: No issues to triage.
14:43:34 <ipanova> dkliban:  thank you
14:43:40 <fao89> Open floor!
14:43:50 <fao89> https://hackmd.io/@pulp/triage/edit
14:44:00 <fao89> topic: Create changelog for plugin_template?
14:44:06 <fao89> +1
14:44:20 <ipanova> +1
14:44:21 <bmbouter> +1
14:44:27 <daviddavis> yea, do we also want to tag plugin_template when there's a pulpcore release?
14:44:34 <bmbouter> the only question I have is: how often will it be cut?
14:44:36 <daviddavis> we need some point at which we generate the changelog
14:45:12 <fao89> yeah, I think it is tied with pulpcore
14:45:26 <bmbouter> that is a good place to start
14:45:34 <ipanova> agreed
14:45:36 <bmbouter> I was thinking more frequently but this sonds fine (and organized)
14:45:58 <ipanova> we can do more often releases adhoc ones when needed
14:46:11 <daviddavis> +1
14:46:41 <fao89> next topic?
14:46:58 <ipanova> yes
14:47:00 <fao89> topic: 3.6 - do we need to send out email to announce?
14:47:16 <bmbouter> what is the plan to implement the changelog from ^?
14:47:22 <bmbouter> in terms of tracking it, doing it, etc
14:48:10 <ipanova> can you elaborate?
14:48:23 <ipanova> how 3.6 release process is different form previous ones?
14:48:30 <fao89> it will be a CHANGES.rst as all towncrier's
14:48:56 <dkliban> plugin_template should use towncrier
14:48:59 <daviddavis> I can file a task to get us started on the implementation?
14:49:09 <dkliban> and we should make releases on a weekly bases
14:49:10 <bmbouter> I was wondering about tracking it so +1 to the task
14:49:19 <dkliban> or as needed
14:49:39 <ggainey> ah - I was confused, I thought we were talking about 3.6, okay
14:49:41 <fao89> we just need a go to place, and it will be CHANGES.rst
14:49:47 <ipanova> ggainey: heh me too
14:49:51 <bmbouter> but also is the idea to add a new section to the pulpcore log, or have a dedicated on in CHANGES.rst in the plugin_template? (as in the where... )
14:50:06 <bmbouter> CHANGES.rst in which repo, plugin_template?
14:50:07 <fao89> ggainey, the previous topic did not end
14:50:12 <fao89> yes!
14:50:14 <daviddavis> I was imagining a CHANGES.rst in plugin_template
14:50:16 <dkliban> we needed a CHANGES.rst in plugin_template
14:50:21 <ggainey> fao89: yup, thanks I caught up eventually :)
14:50:29 <bmbouter> ok great, I wasn't sure if we all thought the same
14:50:32 <bmbouter> +!
14:50:32 <ipanova> +1 to changes.rst in plugin_template
14:50:34 <bmbouter> +1
14:50:39 <bmbouter> +1 to a task to track that addition
14:50:45 <daviddavis> I'll add an item to the release guide too to create a changelog to plugin_template in case we forget to do it as needed
14:50:46 <bmbouter> and also the release notes need updating then too I guess
14:50:52 <bmbouter> you read my mind
14:50:54 <bmbouter> thank you!
14:51:02 <bmbouter> and the travis CI check machinery ...
14:51:03 <fao89> now, the other topic: 3.6 - do we need to send out email to announce?
14:51:13 <ggainey> don't we always?
14:51:33 <dkliban> yes
14:51:33 <bmbouter> we will when post release as usual, is this asking for a pre-release announcement?
14:51:45 <dkliban> yes, pre-release announcement on pulp-dev
14:51:51 <dkliban> to plugin developers
14:51:53 <ggainey> ah
14:52:13 <ggainey> prob a good idea, yeah?
14:52:21 <fao89> this release will have many significant changes
14:52:46 <dkliban> i agree
14:52:48 <fao89> openapi, rbac, removing containers, probably performance improvements, ...
14:53:02 <bmbouter> what of these will require them to take action?
14:53:10 <dkliban> openapi v3
14:53:23 <bmbouter> rbac will not
14:53:42 <fao89> and I believe the bindings documentation should go with this release
14:53:45 <bmbouter> I think highlighting things plugin writers will need to take action on for compatability (especially if large) is very useful
14:54:01 <fao89> hey! we broke your bindings, but at least here is the docs
14:54:26 <bmbouter> fao89: yup I agree but we are still trying to avoid checking built assets into version control (or maybe I am)
14:55:02 <dkliban> i just followed up with the team that manages pulpproject.org
14:55:11 <dkliban> i would like to continue pursuing that route
14:55:17 <fao89> neither do I, but I believe undocumented big change is worse
14:56:43 <ipanova> do i understand correctly that we a drafting an email with the planned release date and all the breaking changes that will have impact?
14:56:46 <dkliban> let's provide a link to our docs on how to generate the bindings documentation
14:56:57 <dkliban> ipanova: yes, that's teh plan
14:58:13 <fao89> the docs is off topic, I believe we all agree with the email, should we move to the next topic?
14:58:56 <ipanova> yes..
14:59:00 <daviddavis> wait
14:59:04 <daviddavis> who is sending the email?
14:59:15 <daviddavis> maybe I missed that
14:59:17 <fao89> pulpbot
14:59:20 <dkliban> lol
14:59:21 <daviddavis> lol
14:59:24 <ggainey> heheh
14:59:28 <bmbouter> ha
14:59:31 <ipanova> who is going to make 3.6 release?
14:59:41 <dkliban> same person that will send this email
15:01:22 <dkliban> bueler ....
15:01:31 <ipanova> let's try to find that person in the following day or 2?
15:01:38 <dkliban> yeah
15:01:41 <daviddavis> ok
15:01:54 <ggainey> kk
15:02:09 <fao89> topic: add backport to triage query
15:02:29 <daviddavis> this is tricky. the new backport tickets use Groomed instead of Triaged
15:02:41 <daviddavis> and we can't have a query that does Groomed OR Triaged
15:02:49 <daviddavis> or rather un-groomed OR un-triaged
15:03:00 <bmbouter> mmmm
15:03:18 <ipanova> can we add Triaged field?
15:03:46 <bmbouter> we could
15:03:50 <daviddavis> that would be the simplest way to go
15:03:58 <bmbouter> would we remove the 'groomed' field from it?
15:03:59 <bmbouter> also
15:04:00 <ipanova> this way we will always stop them during triage process
15:04:12 <ipanova> bmbouter: probably
15:04:13 <bmbouter> whack-a-mole
15:04:18 <bmbouter> I can make both of these changes now
15:04:25 <ipanova> do you see any benefit of keeping groomed?
15:04:25 <bmbouter> and we can see if my test shows up on Friday's triage
15:04:43 <ipanova> bmbouter: that will be great
15:04:52 <bmbouter> ipanova: it could be a signal that the work is being accepted
15:04:54 <fao89> !friday
15:04:54 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
15:05:02 <bmbouter> what does triaging a backport mean... ?
15:05:25 <bmbouter> but we could also put them onto a release as an indicator it's scheduled
15:05:35 <daviddavis> +1
15:05:44 <bmbouter> so let me remove add triage, and remove groomed from Backport and we'll see how it goes
15:05:46 * bmbouter does it now
15:05:47 <bmbouter> ack?
15:05:52 <daviddavis> ack
15:05:54 <ipanova> ack
15:05:58 <ggainey> ack!
15:06:43 <bmbouter> done!
15:06:58 <ggainey> https://www.pinterest.com/pin/474637248201523122/
15:07:39 <bmbouter> next topic?
15:07:53 <ipanova> ys
15:08:22 <fao89> topic: FYI: external contribution to django-lifecycle needed for Pulp's use (which RBAC PR uses)
15:09:10 <bmbouter> it is failing CI due to language compat issues and flake8 I think https://travis-ci.com/github/bmbouter/django-lifecycle/builds/178313157
15:09:14 <bmbouter> I will fix those today
15:10:07 <bmbouter> so this is an FYI, is anyone concerned if we do this for the 3.6 release?
15:10:28 <bmbouter> and then switch to the released django-lifecycle when it's released
15:10:48 <bmbouter> worst case, this is 100% rejected and we port our use to signals, that would still not be a breaking user change just a lot of work and not nearly as great
15:10:54 <dkliban> i would like to hear from the maintainer of django-lifecycle before we decide to go this route. i want to know that he is at least interested in resolving this isssue
15:11:28 <bmbouter> so the choice in front of me is spend a day ripping out django-lifecycle today, or "go this route"
15:11:40 <bmbouter> which worst case involves ripping it out (same work) just later
15:11:58 <dkliban> i think we should continue going this route (using your fork) until we know otherwise
15:11:58 <ggainey> ah, I get it
15:12:13 <bmbouter> hopefully I'll hear back by Friday's open floor
15:12:26 <ipanova> sounds good
15:12:35 <ggainey> yeah, concur
15:13:07 <bmbouter> ok I'll fix this up and correspond w/ them more
15:13:18 <ggainey> +1 - and thanks, nice work
15:14:04 <bmbouter> cool that's all I had for that item
15:14:17 <fao89> #endmeeting
15:14:17 <fao89> !end