14:31:10 <fao89> #startmeeting Pulp Triage 2020-08-07
14:31:10 <fao89> #info fao89 has joined triage
14:31:10 <fao89> !start
14:31:10 <pulpbot> Meeting started Fri Aug  7 14:31:10 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:10 <pulpbot> The meeting name has been set to 'pulp_triage_2020-08-07'
14:31:10 <pulpbot> fao89: fao89 has joined triage
14:31:31 <daviddavis> #info daviddavis has joined triage
14:31:31 <daviddavis> !here
14:31:32 <pulpbot> daviddavis: daviddavis has joined triage
14:31:59 <fao89> !friday
14:31:59 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:32:32 <ipanova> #info ipanova has joined triage
14:32:32 <ipanova> !here
14:32:33 <pulpbot> ipanova: ipanova has joined triage
14:32:34 <ttereshc> #info ttereshc has joined triage
14:32:34 <ttereshc> !here
14:32:34 <pulpbot> ttereshc: ttereshc has joined triage
14:32:42 <fao89> !next
14:32:42 <fao89> #topic https://pulp.plan.io/issues/7205
14:32:43 <pulpbot> fao89: 1 issues left to triage: 7205
14:32:44 <pulpbot> RM 7205 - pc - NEW - ClientConnectorSSLError during remote sync with cdn.redhat.com
14:32:45 <pulpbot> https://pulp.plan.io/issues/7205
14:33:15 <ggainey> #info ggainey has joined triage
14:33:15 <ggainey> !here
14:33:15 <pulpbot> ggainey: ggainey has joined triage
14:33:17 <fao89> dkliban, I believe you tested it
14:33:59 <x9c4> #info x9c4 has joined triage
14:33:59 <x9c4> !here
14:33:59 <pulpbot> x9c4: x9c4 has joined triage
14:34:24 <ipanova> let's skip it, if dkliban tested it, he will update the issue with his observations
14:34:26 <fao89> #idea Proposed for #7205: close as ????
14:34:26 <fao89> !propose other close as ????
14:34:26 <ttereshc> it's been 2 weeks and user hasn't responded yet
14:34:26 <pulpbot> fao89: Proposed for #7205: close as ????
14:34:47 <ipanova> ttereshc: yeah, i was in favor in closing it last time
14:34:48 <ttereshc> I'd close as notabug
14:35:16 <ggainey> sure - esp in the absence of any responses
14:35:34 <fao89> #idea Proposed for #7205: close as notabug
14:35:34 <fao89> !propose other close as notabug
14:35:34 <pulpbot> fao89: Proposed for #7205: close as notabug
14:36:05 <bmbouter> #info bmbouter has joined triage
14:36:05 <bmbouter> !here
14:36:05 <pulpbot> bmbouter: bmbouter has joined triage
14:37:02 <fao89> #agreed close as notabug
14:37:02 <fao89> !accept
14:37:02 <pulpbot> fao89: Current proposal accepted: close as notabug
14:37:03 <pulpbot> fao89: No issues to triage.
14:37:08 <fao89> Open floor!
14:37:15 <fao89> https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw?both
14:37:26 <fao89> topic: Redmine improvement
14:37:58 <ttereshc> oh actually I put it there
14:38:10 <fao89> problem: Version field is often out of date, users can't specify an appropriate version
14:38:30 <fao89> Proposal: Stop using Version field
14:38:31 <ttereshc> I noticed a user trying to properly fill all the fields and the version one is outdated
14:39:19 <ttereshc> the question is whether we should get rid of it at all
14:39:40 <ttereshc> or if we want to have pulpcore version + version filed for every plugin
14:39:47 <ttereshc> (the majority have it already)
14:39:50 <fao89> I'm +1 to get rid of it
14:39:57 <bmbouter> I am also +1 to getting rid of it
14:40:07 <dkliban> #info dkliban has joined triage
14:40:07 <dkliban> !here
14:40:07 <pulpbot> dkliban: dkliban has joined triage
14:40:42 <ttereshc> the question I ask each time and each time I forget the answer: what will happen to all the issue where it is set?
14:41:08 <ttereshc> I guess it's mostly pulp2
14:41:11 <bmbouter> since it is a custom field (not a tag) I believe it will be removed
14:41:17 <bmbouter> I'm also ok w/ that
14:41:21 <ggainey> same
14:41:43 <ipanova> +1 to remove it
14:41:54 <dkliban> +1 to remove that field
14:41:57 <ggainey> +1
14:42:02 <ttereshc> ok, I'll remove it then
14:42:05 <fao89> next topic: Any objections to giving ALL users ability to reopen issues?
14:42:09 <ipanova> ttereshc: most likely it will be unset/removed form those issues
14:42:14 <fao89> * Except CLOSED - COMPLETE, CLOSED - DUPLICATE, and CLOSED - CURRENT RELEASE
14:42:23 <ipanova> no objections
14:42:30 <ttereshc> no objections
14:42:30 <fao89> no objections from me
14:42:41 <ggainey> the only thing about letting anyone reopen, is it lets spammers create logins and open old issues. I don't know that that's really a problem, tho
14:42:53 <ggainey> can anyone see a way that that increases our spam-exposure?
14:43:12 <x9c4> Are we closing or deleting spam issues?
14:43:41 <ggainey> x9c4: I was thinking they'd be able to reopen not-spam-issues and use them to post more spam into
14:44:02 <ggainey> like I said, not sure if that's actually a problem
14:44:21 <bmbouter> delete is the plan
14:44:22 <fao89> in the past we deleted, but for getting data for the script, we start to close some of them
14:44:23 <x9c4> I see. But they can just as well pollute open issues. We have enough of them. ;)
14:44:28 <bmbouter> closing doesn't help us because the links are still there ...
14:44:30 <daviddavis> spammers can comment on closed issues anyway
14:44:38 <daviddavis> I think
14:44:41 <bmbouter> agreed
14:44:42 <daviddavis> yea no they can
14:44:53 <ggainey> ahh, good point - ok, then I don't have any problems w/the proposal
14:45:07 <daviddavis> ok, we can always turn this off again later if they abuse it
14:45:13 <ggainey> sure
14:45:19 <fao89> next topic: Need more feedback on pulp-dev list about closing issues
14:45:26 <daviddavis> this is just an FYI
14:45:28 <fao89> https://www.redhat.com/archives/pulp-dev/2020-August/msg00017.html
14:46:06 <daviddavis> please look by the end of next week or else I am just closing all open issues :)
14:46:14 <ggainey> ha!
14:46:25 <ggainey> is that a threat or a promise, though? :)
14:46:27 <ipanova> daviddavis: haha
14:46:42 <daviddavis> I guess a promise. would alleviate all our work
14:47:14 <ggainey> heh
14:47:24 <bmbouter> I will reply, ty
14:47:42 <fao89> next topic: RBAC: call for review - https://github.com/pulp/pulpcore/pull/815
14:47:45 <bmbouter> generally I think we should close broadly and invite to reopen and not spend too much time on it
14:47:51 <daviddavis> bmbouter: agreed
14:48:15 <ggainey> +1
14:48:22 <bmbouter> yeah so I just removed the WIP, I see comments on here for review which is great, I'm about to start fixing those and replying to some
14:48:46 <bmbouter> the tests were passing, and they are failing w/ flake8 or black, so I'm fixing that now
14:49:27 <bmbouter> what I've learned is that the 'admin' user is a superuser ... so while RBAC is going into 3.6 it's not going to make any difference practically for users because we're keeping the labels saying users should only use pulp as a single-user system with 3.6 still
14:49:39 <ipanova> daviddavis: what about all those that we have filed and not users?
14:49:39 <bmbouter> which is good because it lowers the risk significantly of this merge
14:50:45 <bmbouter> ipanova: I think close broadly (including not looking at who filed it), I believe the current proposal is for pulpcore only
14:50:46 <ttereshc> bmbouter, apart from reading the code, should I test it in any way? I guess it would mean to use some mixins and add policies to a plugin?
14:51:28 <ttereshc> the question is basically, what are the expectations from a reviewer?
14:51:36 <bmbouter> ttereshc: I'd say test the funcationlity coming with the tasks endpoint, but really it's optional (to me)
14:51:53 <ipanova> bmbouter: i started to look into it as well, but so far just reading
14:52:00 <bmbouter> all mixins etc are used by the /pulp/api/v3/tasks/ endpoint so everything will be tested if that is behaving correctly
14:52:02 <daviddavis> ipanova: not sure I understand
14:52:21 <bmbouter> I hand test it every day, I can post some simple instructions on how to do that as well on the PR in a few min
14:52:23 <ttereshc> bmbouter, ok, thanks
14:52:35 <ttereshc> bmbouter, that would be nice
14:52:38 <bmbouter> also the galaxy_ng plugin uses this stuff too so it's getting independant testing there as well
14:52:50 <bmbouter> I'll post some instructions here in a just a min or two
14:52:52 <ttereshc> great
14:53:02 <bmbouter> and push my new docs along w/ it
14:53:02 <ipanova> daviddavis: tldr,  i am afraid to mass close all of them, especially the ones we have filed
14:53:50 <daviddavis> ipanova: we can talk about it more on the list but I feel like it's easy for people to reopen their own issues if they're still valid
14:54:13 <bmbouter> I want to label rbac in the user docs I write on monday as tech preview
14:54:19 <ipanova> daviddavis: whenever you open an issues, how often do you go through the backlog to see if there is one so you can re-open it?
14:54:23 <bmbouter> as in users can try it, but Pulp is still not safe as a multi-user system
14:54:32 * bmbouter pauses rbac discussion
14:55:17 <ipanova> daviddavis: let's talk more on the list
14:55:27 <daviddavis> ipanova: I usually search first but I am less concerned ATM about dupe issues than our large backlog
14:55:38 <daviddavis> ipanova: ok
14:55:40 <ipanova> daviddavis: gotcha, ok
14:55:48 <bmbouter> ipanova: for me if I took time writing one I remember it, and if I can't remember it's not worth the search (just my opinion)
14:56:05 * bmbouter resumes rbac convo
14:56:06 <ipanova> bmbouter: yeah i see your point as well
14:56:19 <bmbouter> ipanova: i hear your conern too
14:56:49 <ipanova> bmbouter: thanks for adding instructions for the rbac
14:56:56 <bmbouter> so basically the last major deliverable is user docs for rbac for pulpcore for 3.6 and I'm going to write those monday and put a tech-preview label indicating pulp still is not safe for multi-user
14:57:09 <bmbouter> and users should continue using 'admin' as their only user on production systems
14:57:29 <ipanova> sounds good
14:57:53 <fao89> last topic: 3.6 release announcement
14:58:12 <fao89> * Please write draft content here: https://hackmd.io/xd5-j7xFSxSTJFn2cvO6Lg
15:02:04 <fao89> #endmeeting
15:02:04 <fao89> !end