14:30:06 <fao89> #startmeeting Pulp Triage 2020-08-11
14:30:06 <fao89> !start
14:30:06 <fao89> #info fao89 has joined triage
14:30:06 <pulpbot> Meeting started Tue Aug 11 14:30:06 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:06 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:06 <pulpbot> The meeting name has been set to 'pulp_triage_2020-08-11'
14:30:06 <pulpbot> fao89: fao89 has joined triage
14:30:31 <ppicka> #info ppicka has joined triage
14:30:31 <ppicka> !here
14:30:31 <pulpbot> ppicka: ppicka has joined triage
14:30:52 <daviddavis> #info daviddavis has joined triage
14:30:52 <daviddavis> !here
14:30:52 <pulpbot> daviddavis: daviddavis has joined triage
14:31:15 <ggainey> #info ggainey has joined triage
14:31:15 <ggainey> !here
14:31:15 <pulpbot> ggainey: ggainey has joined triage
14:31:25 <fao89> !next
14:31:26 <fao89> #topic https://pulp.plan.io/issues/7299
14:31:26 <pulpbot> fao89: 1 issues left to triage: 7299
14:31:27 <pulpbot> RM 7299 - daviddavis - ASSIGNED - HTML in our json schema
14:31:28 <pulpbot> https://pulp.plan.io/issues/7299
14:31:37 <ttereshc> #info ttereshc has joined triage
14:31:37 <ttereshc> !here
14:31:37 <pulpbot> ttereshc: ttereshc has joined triage
14:31:46 <fao89> #idea Proposed for #7299: accept and add to sprint
14:31:46 <fao89> !propose other accept and add to sprint
14:31:46 <pulpbot> fao89: Proposed for #7299: accept and add to sprint
14:31:55 <ggainey> +1
14:31:59 <daviddavis> +1
14:32:00 <fao89> #agreed accept and add to sprint
14:32:00 <fao89> !accept
14:32:00 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:32:01 <ppicka> +1
14:32:02 <pulpbot> fao89: No issues to triage.
14:32:08 <dkliban> #info dkliban has joined triage
14:32:08 <dkliban> !here
14:32:08 <pulpbot> dkliban: dkliban has joined triage
14:32:08 <ttereshc> +1
14:32:15 <ipanova> #info ipanova has joined triage
14:32:15 <ipanova> !here
14:32:15 <pulpbot> ipanova: ipanova has joined triage
14:32:31 <fao89> open floor: https://hackmd.io/@pulp/triage/edit
14:32:48 <fao89> topic: How to version plugin_template? https://pulp.plan.io/issues/7273
14:33:05 <dkliban> yes, the date is a good way to go
14:33:20 <ggainey> date wfm
14:33:36 <daviddavis> fao89: do you want to document this or should I?
14:34:00 <ttereshc> date works, however is it compatible with our automation?
14:34:09 <fao89> daviddavis, I added step 0
14:34:10 <dkliban> do we use the US date formate or the rest of the world?
14:34:10 <ttereshc> or will it be done without it
14:34:14 <fao89> you can review it
14:34:18 <bmbouter> #info bmbouter has joined triage
14:34:18 <bmbouter> !here
14:34:18 <pulpbot> bmbouter: bmbouter has joined triage
14:34:28 <x9c4> #info x9c4 has joined triage
14:34:28 <x9c4> !here
14:34:28 <pulpbot> x9c4: x9c4 has joined triage
14:34:31 <daviddavis> I think yyyy.mm.dd is unambiguous
14:34:43 <dkliban> yes
14:34:45 <dkliban> let's do that
14:34:47 <daviddavis> it's the same for the us and the rest of the world
14:34:48 <bmbouter> +1
14:34:55 <ggainey> ISO stds ftw
14:35:18 <daviddavis> ttereshc: I don't think we're actually releasing plugin_template so there's no automation
14:35:43 <ttereshc> ah, so we won't release it, just assign a version?
14:35:51 <dkliban> we shouhld tag it though
14:35:58 <daviddavis> agreed
14:36:05 <x9c4> Unix timestamp would also be unique And you can do it several times a day
14:36:09 <ttereshc> ok
14:36:40 <daviddavis> eh, unix timestamp is hard to parse
14:36:44 <dkliban> lol
14:36:45 <daviddavis> we could add hour
14:36:48 <ggainey> x9c4: unix timestamp trips over DST (as in, there are timestamps that happen twice in one day)
14:37:19 <daviddavis> I don't see us tagging multiple times per day but we could add another number or something
14:37:26 <ttereshc> I think the tag should be more human friendly than the timestamp
14:37:27 <dkliban> i agree
14:37:31 <ggainey> concur
14:37:52 <fao89> next topic: Spam: do we clean up comments and issues or just leave them for the spam script?
14:38:05 <daviddavis> so like 2020.08.11 by default and then 2020.08.11-1 and so forth if needed
14:38:08 <fao89> I personally clean the triage ones before the triage
14:38:30 <bmbouter> daviddavis: +1
14:38:31 <dkliban> daviddavis: +1
14:38:32 <bmbouter> that sounds good
14:38:41 <x9c4> daviddavis: +1
14:38:45 <ipanova> +1
14:38:52 <ggainey> fao89: if you notice them, I guess go for it, but I'm happy letting the script do its thing
14:38:57 <daviddavis> ok so we can still clean up spam in redmine as we encounter it?
14:38:58 <ggainey> daviddavis: +1 indeed
14:39:42 <daviddavis> if no one knows the answer, I can check with lubos
14:39:59 <ttereshc> lmjachky, ^
14:40:02 <bmbouter> I heard from lubos that he needs this smtp thing resolved
14:40:32 <lmjachky> you are allowed to remove them all
14:40:43 <lmjachky> the script itself is working
14:41:02 <lmjachky> I planned to send an email to pulp-dev that you are allowed to remove all spam content
14:41:04 <bmbouter> lmjachky: yeah what do we need to do to get that script in production
14:41:15 <lmjachky> but was not sure whether I am allowed or not
14:41:40 <lmjachky> I am creating a ticket for IT whether it is possible to create for us a new email address that I can manage
14:42:11 <lmjachky> or whether it is possible to create a temporary TXT record for me during the verification process when signing up for an SMTP relay service
14:42:17 <bmbouter> oh man this is sounding complicated
14:42:39 <lmjachky> do I have another option?
14:42:53 <lmjachky> I think not; and I do not want to use my email address for sending notifications
14:43:01 <lmjachky> may I use your email address? :)
14:43:06 <bmbouter> probalby the official correct path, but waiting on a third part for a special case sounds like we'll be held up for a while
14:43:31 <bmbouter> I agree to not use your email I wouldn't either
14:43:51 <bmbouter> this is a no-reply email, I don't think it's important if it has @redhat.com at the end or gmail.com or protonmail.com
14:44:24 <bmbouter> ok silly idea time: let's create pulpnoreply@gmail.com and configure pulp-infra@redhat.com as its backup
14:44:30 <bmbouter> and then use gmail's smtp servers for now
14:44:49 <ttereshc> I think it should be fine for IT to provide a no-reply e-mail, I'd just make it more specific, like pulp-no-reply@XXX
14:45:19 <lmjachky> hmm hmm
14:45:29 <lmjachky> yeah
14:45:30 <bmbouter> ttereshc: I'm ok w/ that route but I don't think we should invest in cleaning up spam manually in the meantime
14:45:32 <ipanova> agree with ttereshc
14:45:52 <lmjachky> I am almost done with the ticket
14:46:00 <ggainey> concur w/all of the above - spam has been hanging out while we trained the script, a few more days isn't going to hurt
14:46:07 <lmjachky> meanwhile I will create pulpnoreply@gmail.com
14:46:14 <ggainey> and let's give IT a chance to give us a 'real' adr to use
14:46:19 <lmjachky> and do the rest, so we can start using it now
14:46:25 <bmbouter> lmjachky: I'm hearing we should wait for IT, if I'm ok w/ that
14:46:26 <ttereshc> +1 not to invest time into manual cleanup
14:46:38 <bmbouter> s/if I'm/and I'm/
14:46:43 <lmjachky> when we will obtain a replay from the It, then I will open a new PR against pulp-ci to chahnge the from email address
14:46:50 <bmbouter> I'm also ok w/ that
14:47:09 <bmbouter> ipanova: ggainey ttereshc ya'll make the decision, what do you want to advise
14:47:39 <lmjachky> so, the consensus is -> open ticket -> register a new email address at gmail.com -> wait for the response from the IT -> update the email address if any response given
14:48:02 <ggainey> bmbouter: I'd say open the ticket, revisit if we don't have an answer by THurs - but I don't have a prob w/the above sequence either
14:48:14 <lmjachky> otherwise, we are tight up for the pulpnoblablareply@gmail.com
14:48:24 <ttereshc> the current suggestion works for me. I'm ok with any temp solution if we are still trying to get the official email, and +1 to not invest any time into manual cleanup
14:48:31 <ggainey> +1
14:49:00 <fao89> last topic: Release
14:49:09 <bmbouter> lmjachky: do you have everything you need to proceed?
14:49:50 <bmbouter> lmjachky: please ensure the script runs carefully the first time somehow when it does the mass deleting
14:49:51 <lmjachky> bmbouter, I need to add one secret to the github repository
14:49:53 <lmjachky> and that is all
14:49:59 <lmjachky> sure
14:50:07 <lmjachky> I will reach out to you
14:50:18 <bmbouter> lmjachky: sounds good let's start in #pulp-dev
14:50:36 <bmbouter> put some nicks on the request we'll have to gpg exchange is my belief
14:51:53 <fao89> last topic: Release
14:52:23 <fao89> subtopic: release blockers
14:52:40 <bmbouter> I moved the list of PRs up to that section
14:52:57 <bmbouter> I thinkwe need a [yes] or [no] on each of these
14:53:09 <bmbouter> https://github.com/pulp/pulpcore/pull/820 needs to be a yes due to immediate usage by galaxy_ng plugin
14:54:26 <ggainey> bmbouter: do you mean "yes it's a blocker", or "yes it's ready to be merged"?
14:54:46 <bmbouter> yes it is a blocker
14:54:52 <ggainey> kk cool
14:55:53 <dkliban> 820 is a blocker, 834 is a blocker because we need clear docs on SSL configs
14:56:23 <bmbouter> I agree, and with 3.6 specifically the installer is switching to SSL only
14:56:38 <ggainey> so 835, 770, and 829 all have some variant of 'approved' or 'lgtm' on them
14:57:05 <bmbouter> I think we can merge these
14:57:11 <ggainey> concur
14:57:24 <ttereshc> they are not blcokers I think but +1 to merge since it's ready
14:57:24 <bmbouter> I hear one +1 if there is a second I can click merge right now
14:57:32 <bmbouter> ok that's two
14:57:36 * bmbouter clicks merge
14:58:01 <ggainey> 834 - explanation looks reasonable to me
14:59:03 <ttereshc> 834 needs to be rebased
14:59:09 <ttereshc> there are conflicts
14:59:19 <ttereshc> dkliban, ^
14:59:29 <bmbouter> I'm asking for a change on https://github.com/pulp/pulpcore/pull/835/files#r468648012 so I marged it as [no]
14:59:35 <bmbouter> I don't think it's a release blocker
14:59:38 <ggainey> oh bah, that must have just happened as a result of the other merges :)
14:59:45 <dkliban> ttereshc: i will rebase 834, but i am also waiting for the installer change to be finished so i can add more docs
14:59:57 <bmbouter> yeah we'll need more docs I was thinking too
15:00:06 <ggainey> kk
15:00:10 <ttereshc> ok, so we can mark it as blocked at the moment
15:00:15 <fao89> dkliban, did you read mikedep333 status?
15:00:26 <fao89> installer change won't be ready today
15:00:42 <fao89> "Will not finish pulp_installer's support for letsencrypt in time for 3.6.0 release today"
15:00:44 <dkliban> fao89: i did ... we also met today
15:00:47 <mikedep333> fao89: I am implementing the backup plan.
15:00:56 <fao89> cool
15:01:46 <mikedep333> I am testing / developing manually with letsencrypt's actual service on an AWS instance. Which is something we'd want instructions for, but have to test manually, anyway.
15:01:59 <bmbouter> that sounds good
15:02:19 <mikedep333> Rather writing CI code to sett up a test ACME protocol server.
15:02:33 <dkliban> mikedep333: thank you
15:02:44 <dkliban> let's make 7299 a blocker
15:02:52 <dkliban> it's an easy fix
15:03:03 <fao89> +1
15:03:22 <bmbouter> +1
15:03:43 <bmbouter> who is fixing? fao and I are working on the uers/groups so I don't think we can
15:03:47 <ggainey> sure - it's sounding to me like "release on the 12th", just to get the last-minute changes merged?
15:03:55 <ggainey> (which is fine)
15:05:32 <bmbouter> ggainey: I agree but if we move the goal to the 12th then what happens is it ends up being the 13th
15:05:40 <bmbouter> I think the goal should still be EOB today
15:05:58 <fao89> the last subtopic is the real question here
15:06:07 <fao89> what is the plan
15:06:25 <bmbouter> lol yeah
15:06:41 <fao89> so this is a release with many significant changes, and we don't have an owner yet
15:08:25 <fao89> I can do pulp_ansible and pulp_installer releases
15:08:45 <dkliban> you can't do those until pulpcore is done
15:08:52 <ttereshc> bmbouter, do you plan to add rbac to the announcement email?
15:08:52 <dkliban> and i think the main questin is about pulpcore right now
15:09:08 <dkliban> i can do the pulpcore release
15:09:14 <bmbouter> ttereshc: actually I don't, I removed it I'd like to chat up about why after we fid release owners
15:09:27 <dkliban> i will do the pulpcore release
15:09:46 <fao89> I don't agree, IIRC you did it last time
15:10:10 <dkliban> i don't remember, but i really don't mind
15:10:31 <fao89> ok
15:11:07 <fao89> now we need a plan
15:11:22 <bmbouter> I would volunteer but I have been on the critical path for a long time now I don't want to own the release
15:11:30 <bmbouter> rbac has worn me out
15:11:41 <ggainey> def understandable
15:12:00 <bmbouter> fao89: and I are still on it even with https://github.com/pulp/pulpcore/pull/820
15:12:10 <bmbouter> ggainey: ty
15:12:47 <bmbouter> any other release owners need to be identified I think maybe that's all of them? pulpcore, pulp_installer, and pulp_ansible ?
15:13:05 <bmbouter> really the first two, but we'll need pulp_ansible asap also
15:13:06 <dkliban> i will do pulpcore adn pulp_file
15:13:11 <fao89> I will end the open floor because it is holding me from working on the blocker
15:13:16 <bmbouter> oh yeah pulp_file how could I forget you
15:13:36 <ttereshc> I can help with pulp_file if needed
15:13:38 <bmbouter> fao89: agreed I should explain the rbac positioning anyway
15:13:40 <ttereshc> or pulpcore
15:13:48 <ttereshc> dkliban, ping me if you prefer to share the load
15:13:53 <dkliban> ok
15:13:59 <fao89> #endmeeting
15:13:59 <fao89> !end