14:55:34 <fao89> #startmeeting Pulp Triage 2020-08-28
14:55:34 <fao89> !start
14:55:34 <fao89> #info fao89 has joined triage
14:55:34 <pulpbot> Meeting started Fri Aug 28 14:55:34 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:55:34 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:55:34 <pulpbot> The meeting name has been set to 'pulp_triage_2020-08-28'
14:55:34 <pulpbot> fao89: fao89 has joined triage
14:55:50 <ppicka> #info ppicka has joined triage
14:55:50 <ppicka> !here
14:55:50 <pulpbot> ppicka: ppicka has joined triage
14:56:06 <ipanova> #info ipanova has joined triage
14:56:06 <ipanova> !here
14:56:06 <pulpbot> ipanova: ipanova has joined triage
14:56:12 <ttereshc> #info ttereshc has joined triage
14:56:12 <ttereshc> !here
14:56:12 <pulpbot> ttereshc: ttereshc has joined triage
14:56:35 <fao89> !next
14:56:35 <fao89> #topic https://pulp.plan.io/issues/7404
14:56:36 <pulpbot> fao89: 3 issues left to triage: 7404, 7395, 7391
14:56:37 <pulpbot> RM 7404 - daviddavis - POST - Have the commit issue checker be case insensitive
14:56:38 <pulpbot> https://pulp.plan.io/issues/7404
14:56:41 <daviddavis> #info daviddavis has joined triage
14:56:41 <daviddavis> !here
14:56:41 <pulpbot> daviddavis: daviddavis has joined triage
14:56:52 <fao89> #idea Proposed for #7404: accept and add to sprint
14:56:52 <fao89> !propose other accept and add to sprint
14:56:52 <pulpbot> fao89: Proposed for #7404: accept and add to sprint
14:56:59 <daviddavis> +1
14:57:00 <fao89> #agreed accept and add to sprint
14:57:00 <fao89> !accept
14:57:00 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:57:00 <fao89> #topic https://pulp.plan.io/issues/7395
14:57:01 <pulpbot> fao89: 2 issues left to triage: 7395, 7391
14:57:02 <pulpbot> RM 7395 - ttereshc - NEW - Release script can identify a wrong commit to get redmine info from
14:57:03 <pulpbot> https://pulp.plan.io/issues/7395
14:57:12 <dkliban> #info dkliban has joined triage
14:57:12 <dkliban> !here
14:57:12 <pulpbot> dkliban: dkliban has joined triage
14:57:19 <ttereshc> #idea Proposed for #7395: Leave the issue as-is, accepting its current state.
14:57:19 <ttereshc> !propose accept
14:57:19 <pulpbot> ttereshc: Proposed for #7395: Leave the issue as-is, accepting its current state.
14:57:24 <ipanova> +1
14:57:32 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:57:32 <fao89> !accept
14:57:32 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:57:33 <fao89> #topic https://pulp.plan.io/issues/7391
14:57:33 <pulpbot> fao89: 1 issues left to triage: 7391
14:57:34 <pulpbot> RM 7391 - fao89 - NEW - As plugin writer, I want to customize the CI container image
14:57:35 <pulpbot> https://pulp.plan.io/issues/7391
14:57:59 <fao89> #idea Proposed for #7391: convert to story
14:57:59 <fao89> !propose other convert to story
14:57:59 <pulpbot> fao89: Proposed for #7391: convert to story
14:58:05 <ttereshc> +1
14:58:11 <ipanova> +1
14:58:23 <fao89> #agreed convert to story
14:58:23 <fao89> !accept
14:58:23 <pulpbot> fao89: Current proposal accepted: convert to story
14:58:24 <pulpbot> fao89: No issues to triage.
14:58:37 <fao89> we already have a quarter field on redmine!
14:58:52 <fao89> Open floor!
14:59:04 <fao89> https://hackmd.io/@pulp/triage/edit
14:59:18 <fao89> topic: remove lgtm badges or enable code review?
15:00:03 <fao89> https://github.com/pulp/pulpcore displays lgtm badge with B quality
15:00:31 <fao89> I'm wondering if we should remove the badge or enable lgtm to analyze or PRs
15:00:40 <daviddavis> I'm guessing it pass/fails the PR if code quality dips?
15:01:06 <fao89> I'm not sure how this works
15:01:18 <ipanova> what is the purpose of this badge?
15:02:15 <fao89> I don't know, I leaning towards removing the badge
15:02:59 <bmbouter> #info bmbouter has joined triage
15:02:59 <bmbouter> !here
15:02:59 <pulpbot> bmbouter: bmbouter has joined triage
15:03:01 <daviddavis> I'm fine with that. I don't think we use it?
15:03:04 <ipanova> aha, now i see it
15:03:18 <ipanova> i did not even know about its existence
15:03:18 <fao89> by git blame, bmbouter was the one who added this badge
15:03:28 <bmbouter> indeed
15:03:39 <ttereshc> pulp/pulp_puppet has A+ quality ;)
15:03:39 <bmbouter> I'm ok to remove it, it doesn't cause a change in our behavior
15:03:43 <bmbouter> lol
15:03:45 <bmbouter> of course it does
15:03:51 <ttereshc> yup
15:03:59 <ipanova> i am fine to remove it
15:04:19 <bmbouter> +1
15:04:31 <fao89> next topic: should we release pulpcore 3.6.1
15:06:00 <ipanova> yes, we need to get those prs merged first
15:06:01 <ttereshc> I thought we agreed on that
15:06:40 <daviddavis> yea, I'm +1
15:06:44 <fao89> we are echoing pulpcore meeting
15:06:59 <fao89> next topic: black update
15:07:26 <fao89> daviddavis, sent an email with a deadline to merge it
15:07:28 <daviddavis> there's a discussion on pulp-dev but just wanted to raise this again and call for any objections
15:07:30 <daviddavis> yea
15:07:36 <daviddavis> please get your pulpcore PRs in!
15:07:41 <daviddavis> by tuesday
15:08:02 <fao89> next topic: Katello proposal to change layout
15:09:01 <fao89> https://github.com/pulp/pulpcore/pull/799#issuecomment-682014733
15:09:13 <bmbouter> we need to look at it again
15:09:23 <daviddavis> +1
15:10:48 <fao89> next topic: Spam cleaner seems to be removing users but not removing spam
15:11:26 <ipanova> lmjachky: did you have a chance to take a look?
15:11:51 <lmjachky> no way
15:11:56 <lmjachky> how it seems?
15:12:48 <ipanova> we found an issue(a valid one) that had anonymous user
15:13:13 <lmjachky> are you sure anyone of you have not removed the user?
15:13:30 <daviddavis> yea, I've seen several of these
15:13:57 <lmjachky> you are still removing some issues even though you are not supposed to, are you still sure that you did not remove the user?
15:14:30 <ttereshc> a more general question, why are we removing users instead of locking them? is locking available through redmine API?
15:15:34 <ttereshc> fwiw, I remove issues or comments, but I always lock users, so they don't reuse credentials
15:15:51 <daviddavis> yea me too
15:16:00 <ipanova> yea same here
15:16:04 <daviddavis> I do see the spam cleaner is removing issues and comments though
15:16:18 <lmjachky> ttereshc, I have not idea whether it is implemented in the redmine API
15:16:37 <lmjachky> it should not remove the issues because of timestamp
15:16:47 <lmjachky> this night
15:17:02 <lmjachky> all 500 fields will be purged from the sheet if everything works correctly
15:17:24 <lmjachky> 500 issues/journals/annonymous comments with external links
15:17:46 <ttereshc> are there logs to see resources which are removed?
15:18:16 <lmjachky> ttereshc, when a resource is removed, it should be deleted from the sheet automatically
15:18:17 <fao89> I believe we need a spam script presentation
15:19:03 <ttereshc> lmjachky, is there any history to audit?
15:19:32 <lmjachky> I can share with you the spreadsheet; the spreadsheet itself contains "history"
15:20:02 <ttereshc> ok, so no logs for the script.
15:20:06 <lmjachky> no logs
15:20:18 <ttereshc> I'm +1 to look into locking users instead of removing
15:21:02 <fao89> ready for the next topic?
15:21:07 <lmjachky> so
15:21:17 <lmjachky> no next topic
15:21:22 <lmjachky> are you sure you are not removing users?
15:21:41 <lmjachky> no way the script ever run the cleanup so far
15:21:51 <daviddavis> it's possible
15:21:52 <dalley> ttereshc, which issue is it that has anonymous user?
15:22:13 <ipanova> another option was that the user removed his account(if that's possible)
15:22:24 <daviddavis> https://pulp.plan.io/issues/7321
15:22:44 <ttereshc> dalley, ^
15:22:47 <daviddavis> we have his email. we could email him to ask.
15:23:01 <fao89> I think only lmjachky has the knowledge for all the spam workflow (spreadsheet, pulp-infra email, the script), I vote for a presentation so we all can learn more about it
15:23:13 <ttereshc> +1
15:23:32 <lmjachky> fao89, I do not know why you need a presentation for that
15:23:39 <ttereshc> however my +1 to lock users is absolutely independent from the current convo, I just think it's a right thing todo
15:23:41 <lmjachky> everything you should know was already sent via emails
15:23:56 <lmjachky> ttereshc, I can take a look at that
15:24:07 <fao89> I receive pulp-infra email and I don't know what to do with them
15:24:30 <ttereshc> lmjachky, to share some knowledge and see the script, so not only you maintain it and for those who want to understand better how it works
15:25:37 <lmjachky> hmm
15:25:39 <fao89> I want to learn the relation between the spreadsheet, script and the emails I receive at pulp-infra
15:26:06 <lmjachky> okay, I will do that
15:26:46 <ipanova> thanks lmjachky
15:26:46 <lmjachky> next topic, if you are not removing users and users are not removing themselves
15:27:25 <lmjachky> +1 to locking them instead of removing...
15:27:38 <lmjachky> the actual removal is going to happen today
15:27:49 <daviddavis> let's lock users
15:27:57 <daviddavis> it also prevents them from signing up again I believe
15:28:28 <fao89> next topic: 2-release pulpcore deprecation policy next steps?
15:29:07 <bmbouter> so this proposal got various +1's and I didn't see any adjustments suggested
15:29:39 <ttereshc> agreed
15:29:47 <bmbouter> to accomplish this I think we would: declare the policy for pulpcore (and document it) and add the new test to plugin_template https://pulp.plan.io/issues/7411
15:30:24 <bmbouter> I can file an issue to add the document declaration and highlight these two issues as next steps on-thread
15:30:58 <bmbouter> is this a change we can put into affect so that 3.7 is not a breaking change release for existing GA's plugins compatible with 3.6?
15:31:53 <ttereshc> plugins already pinned 3.6
15:32:02 <bmbouter> yup good point
15:32:23 <bmbouter> can we put this in place so that future versions will be compatible and "start it" with the 3.7 plugin releases?
15:32:49 <ttereshc> yeah +1
15:33:15 <ipanova> sounds good
15:33:24 <daviddavis> hey
15:33:25 <ttereshc> with 3.7, we should suggest plugins to do >=3.7,<3.9
15:33:37 <daviddavis> how do we deprecate things? perhaps we need a new changelog type?
15:33:59 <ttereshc> we have deprecations and removals, maybe we should separate those?
15:34:18 <x9c4> Plugins can relax the pinning with a z-release.
15:34:40 <bmbouter> daviddavis: yes!
15:34:46 <bmbouter> I can file that as an issue also for pulpcore
15:35:14 <bmbouter> pulpcore is the only one that needs it really for the CHANGES/plugin_api/*.depcrecated
15:35:31 <bmbouter> ttereshc: yes I think exactly that version restriction
15:35:48 <bmbouter> x9c4: we could but not all plugins would put that out, I think we can let the y release handle it
15:38:52 <bmbouter> I can take these next steps: file the depcreation changelog type, file the documentation declaration, put them into an epic, and send the 4 stories to the list w/ a timeline of enabling before the 3.7 release
15:38:56 <bmbouter> how does ^ sound?
15:39:15 <daviddavis> sounds good
15:39:16 <ttereshc> sounds very organized :D
15:39:32 * bmbouter will do
15:39:41 <bmbouter> concerns and adjustments can still be sent there as well
15:40:32 <ttereshc> thank you
15:41:33 <fao89> last topic: radical proposal: switch issue tracking to github
15:41:40 <daviddavis> lol
15:41:58 <ttereshc> nice
15:42:00 <bmbouter> yup I put this on here
15:42:31 <daviddavis> I have reservations
15:42:33 <daviddavis> at the beach
15:42:38 <bmbouter> lolol
15:42:39 <lmjachky> (I sent an email to Aant who is the author of the issue https://pulp.plan.io/issues/7321)
15:42:43 <ttereshc> :)
15:42:50 <daviddavis> lmjachky: thank you
15:43:04 <bmbouter> I have much love for both redmine and plan.io
15:43:08 <daviddavis> we'll need to think of how to do some things if we move to github issues like linking BZs to issues
15:43:20 <bmbouter> I agree
15:43:30 <bmbouter> this will require a lot of comprehensive planning
15:43:51 <bmbouter> and what I learned from brexit is that we need a plan and decide on that plan not on a goal without a plan
15:44:02 <ttereshc> pulpcon topic?
15:44:07 <daviddavis> +1
15:44:13 <fao89> +1
15:44:16 <daviddavis> I want to help suss this out
15:44:22 <bmbouter> great
15:44:32 <ttereshc> yeah, I can as well if you need more folks
15:44:56 <daviddavis> I'll start the hackmd pad
15:45:05 <bmbouter> daviddavis: that would be really really great
15:45:19 <bmbouter> link me and ttereshc (and maybe others via pulp-dev if you want) and we can put some content
15:45:24 <daviddavis> will do
15:45:25 <bmbouter> I have some content to add, specifically in the motivation section
15:45:51 <bmbouter> that's roughly what I wanted us to accomplish on this topic here, today
15:46:31 <fao89> #endmeeting
15:46:31 <fao89> !end