14:31:18 <fao89> #startmeeting Pulp Triage 2020-09-01
14:31:18 <fao89> #info fao89 has joined triage
14:31:18 <fao89> !start
14:31:18 <pulpbot> Meeting started Tue Sep  1 14:31:18 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:18 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:18 <pulpbot> The meeting name has been set to 'pulp_triage_2020-09-01'
14:31:18 <pulpbot> fao89: fao89 has joined triage
14:31:23 <daviddavis> #info daviddavis has joined triage
14:31:23 <daviddavis> !here
14:31:23 <pulpbot> daviddavis: daviddavis has joined triage
14:31:25 <ppicka> #info ppicka has joined triage
14:31:25 <ppicka> !here
14:31:25 <pulpbot> ppicka: ppicka has joined triage
14:31:27 <ggainey> #info ggainey has joined triage
14:31:27 <ggainey> !here
14:31:27 <pulpbot> ggainey: ggainey has joined triage
14:31:42 <dkliban> #info dkliban has joined triage
14:31:42 <dkliban> !here
14:31:42 <pulpbot> dkliban: dkliban has joined triage
14:31:57 <fao89> !next
14:31:58 <fao89> #topic https://pulp.plan.io/issues/7428
14:31:58 <pulpbot> fao89: 2 issues left to triage: 7428, 7427
14:31:59 <pulpbot> RM 7428 - awcrosby - NEW - pulp_ansible collection list only shows collection if highest version in repo
14:32:00 <pulpbot> https://pulp.plan.io/issues/7428
14:32:07 <daviddavis> move to pulp_ansible
14:32:13 <dkliban> +1
14:32:17 <fao89> #idea Proposed for #7428: move to pulp_ansible
14:32:17 <fao89> !propose other move to pulp_ansible
14:32:17 <pulpbot> fao89: Proposed for #7428: move to pulp_ansible
14:32:19 <ggainey> +1
14:32:20 <fao89> #agreed move to pulp_ansible
14:32:20 <fao89> !accept
14:32:20 <pulpbot> fao89: Current proposal accepted: move to pulp_ansible
14:32:21 <fao89> #topic https://pulp.plan.io/issues/7427
14:32:21 <pulpbot> fao89: 1 issues left to triage: 7427
14:32:23 <pulpbot> RM 7427 - dalley - NEW - [Epic] As a user, I can audit actions taken by Pulp users
14:32:24 <pulpbot> https://pulp.plan.io/issues/7427
14:32:31 <daviddavis> story
14:32:34 <bmbouter> #info bmbouter has joined triage
14:32:34 <bmbouter> !here
14:32:34 <pulpbot> bmbouter: bmbouter has joined triage
14:32:37 <dkliban> +1
14:32:39 <ppicka> +1
14:32:40 <ggainey> story
14:32:41 <ttereshc> #info ttereshc has joined triage
14:32:41 <ttereshc> !here
14:32:41 <pulpbot> ttereshc: ttereshc has joined triage
14:32:48 <fao89> #idea Proposed for #7427: convert to story
14:32:48 <fao89> !propose other convert to story
14:32:48 <pulpbot> fao89: Proposed for #7427: convert to story
14:32:51 <ttereshc> +1
14:32:59 <fao89> #agreed convert to story
14:32:59 <fao89> !accept
14:32:59 <pulpbot> fao89: Current proposal accepted: convert to story
14:33:00 <pulpbot> fao89: No issues to triage.
14:33:00 <bmbouter> +1
14:33:09 <ipanova> #info ipanova has joined triage
14:33:09 <ipanova> !here
14:33:09 <pulpbot> ipanova: ipanova has joined triage
14:33:21 <fao89> open floor
14:33:35 <fao89> https://hackmd.io/@pulp/triage/edit
14:33:44 <dalley> that was fast
14:33:50 <daviddavis> :D
14:33:52 <fao89> CI status check
14:34:12 <daviddavis> I see some failures
14:34:18 <daviddavis> pulp_maven, pulp_container, pulp_rpm
14:34:21 <dkliban> yep
14:34:36 <dkliban> maven and container are due to black
14:34:39 <fao89> pulp_rpm is failing due sync issue
14:34:47 <fao89> all the others are due black
14:35:07 <daviddavis> can we assign someone to look into each failure?
14:35:12 <daviddavis> would that make sense?
14:35:24 <dalley> the black PRs are getting merged today, correct?
14:36:13 <daviddavis> the pulpcore one is getting merged tomorrow
14:36:15 <fao89> lmjachky, has a PR for pulp_container
14:36:34 <fao89> I have one for maven
14:36:51 <daviddavis> ok so that leaves pulp_rpm?
14:37:01 <dkliban> pulp_container PR got closed by fao89
14:37:15 <ttereshc> rpm has issue with the recent repo added by the external contributor
14:37:22 <fao89> I think pulp_gem is not on cron
14:37:26 <ttereshc> I'll ask ppicka if he has time
14:37:48 <fao89> dkliban, I closed because lubos already had it in one branch
14:38:13 <dkliban> ok
14:38:15 <ppicka> ttereshc: ok
14:38:22 <dkliban> let's move on to the rest of the agenda
14:38:26 <daviddavis> +2
14:38:27 <daviddavis> +1
14:38:29 <fao89> I do not have permission to enable cron for pulp_gem
14:38:30 <ipanova> dkliban: we need to review this pr because it has 2 commits, black included https://github.com/pulp/pulp_container/pull/143
14:38:41 <ttereshc> ah you are here,  ppicka,  :) I didn't notice
14:38:41 <dkliban> ipanova: sounds good
14:40:42 <dkliban> so next topic ...
14:41:18 <daviddavis> Putting 1-release deprecation cycle epic into effect for 3.7
14:41:26 <daviddavis> move https://pulp.plan.io/issues/7416 onto sprint?
14:41:39 <daviddavis> add 3.7 milestone
14:41:52 <bmbouter> yup this went out to pulp-dev as advertisement also
14:41:59 <daviddavis> +1 from me
14:42:22 <bmbouter> I am proposer I cannot +1, but I am in favor (obviously)
14:42:32 <ggainey> yeah, +1 here as well
14:42:34 <dkliban> +1
14:42:36 <ppicka> +1
14:42:49 <dkliban> this will be a great improvement for our users
14:42:51 <bmbouter> I can click the buttons if there are no concerns
14:42:53 <bmbouter> I agree
14:43:01 <bmbouter> I can make the 3.7.0 milestone also for pulpcore
14:43:08 <bmbouter> our users are going to love this I think
14:43:13 <dkliban> i agree
14:43:18 <daviddavis> bmbouter: I beat you to it
14:43:22 <bmbouter> daviddavis: wonderful :)
14:43:42 <ggainey> :)
14:45:17 <bmbouter> next topic?
14:45:39 <daviddavis> proposal for pulpcore and pulp_file: require a test for each fix or feature
14:47:07 <dkliban> this is a good idea ... would we want to have some kind of check in our CI to make sure that .feature or .bugfix comes with a test?
14:47:08 <ggainey> I like the proposal. I will note that some bugs we see are really difficult to set up in the test framework (eg, problems involving proxies)
14:47:25 <ggainey> current proposal suggests starting w/manual, yeah?
14:47:50 <bmbouter> yeah the idea is to do manual enforcement at review time
14:48:20 <bmbouter> my strategy is that I didn't want complexity of how to automatically enforce to hold us back from making the policy change
14:48:26 <ggainey> yeah
14:48:35 <fao89> next topic: Putting 1-release deprecation cycle epic into effect for 3.7
14:48:35 <ttereshc> +1
14:48:35 <ttereshc> I feel like we agreed on it last time :)
14:48:35 <ipanova> yeah
14:48:35 <ipanova> i think we will bring some stories for the sprint planning
14:48:36 <fao89> can we move on to the next topic?
14:48:36 <ipanova> i think so
14:48:36 <fao89> topic: proposal for pulpcore and pulp_file - require a test for each fix or feature
14:48:36 <fao89> +1
14:48:36 <ttereshc> +1
14:48:36 <ipanova> +1
14:48:36 <fao89> next topic: 3.6.1 release task https://pulp.plan.io/issues/7429
14:48:36 <ipanova> nice
14:48:36 <ipanova> do we assign to the release shepherd?
14:48:36 <fao89> I think so
14:48:36 <ttereshc> can we remove "if a y-release" items, it's clear that we have a z stream
14:48:36 <ttereshc> I can do it if there are no objections
14:48:36 <fao89> wow, what happened?
14:48:51 <ggainey> whoa
14:48:54 <bmbouter> whoaaaaaa
14:48:55 <ggainey> that was...odd
14:48:55 <ttereshc> exactly
14:48:56 <daviddavis> lol
14:48:57 <fao89> now I understand why only ipanova and ttereshc were replying
14:48:59 <bmbouter> I think there was a partial netsplit
14:49:04 <fao89> some US outage
14:49:06 <ggainey> yeah zacly
14:49:35 <ipanova> heh
14:49:38 <dkliban> i will do the release this afternoon
14:49:38 <fao89> we were having 2 open floor in parallel
14:49:38 <ggainey> ok, so the US crew is still discussing test-proposal :)
14:49:47 <bmbouter> so back to pulpcore pulp_file tests
14:49:52 <daviddavis> in different dimensions that sometime converge
14:50:10 <bmbouter> one thing about this proposal is there is no story to document this in our contributor guide
14:50:22 <ggainey> (now I know what Schroedinger's Cat felt like...)
14:50:44 <bmbouter> there seems to be broad support for it, but I need to probably write that story, get it reviewed, and added to sprint
14:50:54 <bmbouter> otherwise contributors won't know it's required
14:51:05 <fao89> let me try to recap, everyone were present for the CI checking
14:51:05 <ggainey> we def need to doc this - also, I'd like there to be a defined exception-path - like [noissue], you *can* do that, but you'll get extra scutiny if you do
14:51:13 <ggainey> yes
14:51:34 <bmbouter> so I can take the action item (just after this) to write that docs story, and ask for grooming in #pulp-dev and to add to sprint post grooming
14:51:44 <fao89> I believe everyone agreed with: Putting 1-release deprecation cycle epic into effect for 3.7
14:51:45 <bmbouter> how does ^ sound as my action? (I'll also email to list w/ the issue link)
14:51:50 <ggainey> bmbouter: +1 - and thanks
14:51:55 <ggainey> fao89: concur
14:52:11 <fao89> so we all are in : proposal for pulpcore and pulp_file - require a test for each fix or feature
14:52:17 <ggainey> concur
14:52:33 <fao89> me, ipanova and ttereshc +1 to that
14:52:44 <fao89> so I think we all are in the same page
14:52:51 <ggainey> concur, again :)
14:52:55 <ttereshc> +1
14:52:57 <ppicka> +1
14:53:18 <x9c4> #info x9c4 has joined triage
14:53:18 <x9c4> !here
14:53:18 <pulpbot> x9c4: x9c4 has joined triage
14:53:22 <x9c4> +1
14:53:36 <fao89> async triage was crazy
14:53:53 <ggainey> fao89: it was the UDP version instead of the TCP version? :)
14:53:54 <bmbouter> I summarized my actions on L#20-22
14:53:58 <ggainey> +1
14:54:09 <fao89> ggainey++
14:54:09 <pulpbot> fao89: ggainey's karma is now 42
14:54:13 <fao89> exactly!
14:54:38 <fao89> last topic: 3.6.1 release task https://pulp.plan.io/issues/7429
14:54:54 <ggainey> +1 to the checklist template
14:55:08 <daviddavis> dkliban said this was going out this afternoon
14:55:13 <ttereshc> can we remove "if a y-release" items, it's clear that we have a z stream? I can do that if there are no objections
14:55:13 <daviddavis> any feedback on the release checklist is welcome
14:55:24 <daviddavis> I can do it
14:55:26 <bmbouter> should we have two checklists?
14:55:35 <ttereshc> we need two templates
14:55:36 <bmbouter> y-release checklist, z-release checklist?
14:55:40 <bmbouter> templates rather...
14:55:43 <ttereshc> yes
14:55:44 <ggainey> +1
14:55:46 <daviddavis> the only problem is that much of the items are duplicated
14:55:56 <daviddavis> so it's kind of a pain to fix something in both places
14:56:06 <fao89> +1 to templates, and one checklist for picking the right template =P
14:56:07 <daviddavis> I'd suggest we have one for now until it stabilizes
14:56:08 <bmbouter> it's true, but a pain we can pay once
14:56:12 <bmbouter> daviddavis: I'm ok w/ that
14:56:18 <ggainey> sure
14:56:28 <bmbouter> it is new after all
14:56:34 <daviddavis> I can work on two for 3.7 though depending on how 3.6.1 goes
14:56:49 <bmbouter> +1
14:57:34 <daviddavis> that's all I got
14:57:37 <bmbouter> me too
14:57:48 <dkliban> sounds godo to me
14:59:05 <ttereshc> daviddavis, you mentioned that it's easy to convert this template to md, didn't you?
14:59:12 <ttereshc> how would you do that?
14:59:15 <daviddavis> ttereshc: yea, it's markdown
14:59:38 <daviddavis> it's just text: https://pulp.plan.io/projects/pulp/checklist_templates/3/edit
14:59:46 <daviddavis> for github, you'd prefix each line with "- [ ]"
15:00:00 <ttereshc> ok
15:00:02 <ttereshc> thanks
15:00:06 <daviddavis> np :)
15:00:26 <ttereshc> I forgot that it's in one blob
15:00:29 <ttereshc> :)
15:01:04 <fao89> #endmeeting
15:01:04 <fao89> !end