14:30:11 <fao89> #startmeeting Pulp Triage 2020-09-11
14:30:11 <fao89> #info fao89 has joined triage
14:30:11 <fao89> !start
14:30:11 <pulpbot> Meeting started Fri Sep 11 14:30:11 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:11 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:11 <pulpbot> The meeting name has been set to 'pulp_triage_2020-09-11'
14:30:11 <pulpbot> fao89: fao89 has joined triage
14:30:57 <daviddavis> #info daviddavis has joined triage
14:30:57 <daviddavis> !here
14:30:57 <pulpbot> daviddavis: daviddavis has joined triage
14:31:15 <dkliban> #info dkliban has joined triage
14:31:15 <dkliban> !here
14:31:15 <pulpbot> dkliban: dkliban has joined triage
14:31:57 <bmbouter> #info bmbouter has joined triage
14:31:57 <bmbouter> !here
14:31:57 <pulpbot> bmbouter: bmbouter has joined triage
14:32:01 * bmbouter does the dance of friday
14:32:02 <fao89> !next
14:32:03 <fao89> #topic https://pulp.plan.io/issues/7495
14:32:03 <pulpbot> fao89: 4 issues left to triage: 7495, 7486, 7485, 7476
14:32:04 <pulpbot> RM 7495 - awcrosby - NEW - duplicate key violation, Repository.next_version already exists
14:32:05 <pulpbot> https://pulp.plan.io/issues/7495
14:32:47 <dkliban> we had a similar bug filed before
14:33:01 <dkliban> but it was for the pulp_rpm plugin
14:33:20 <fao89> #idea Proposed for #7495: Leave the issue as-is, accepting its current state.
14:33:20 <fao89> !propose accept
14:33:20 <pulpbot> fao89: Proposed for #7495: Leave the issue as-is, accepting its current state.
14:33:27 <dkliban> +1
14:33:53 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:33:53 <fao89> !accept
14:33:53 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:54 <fao89> #topic https://pulp.plan.io/issues/7486
14:33:54 <pulpbot> fao89: 3 issues left to triage: 7486, 7485, 7476
14:33:55 <pulpbot> RM 7486 - daviddavis - NEW - 1.3.0 release
14:33:56 <pulpbot> https://pulp.plan.io/issues/7486
14:34:01 <daviddavis> convert to task
14:34:03 <bmbouter> +1
14:34:04 <dkliban> +1
14:34:12 <daviddavis> I'll do that
14:34:25 <fao89> #idea Proposed for #7486: convert to task
14:34:25 <fao89> !propose other convert to task
14:34:25 <pulpbot> fao89: Proposed for #7486: convert to task
14:34:29 <fao89> #agreed convert to task
14:34:29 <fao89> !accept
14:34:29 <pulpbot> fao89: Current proposal accepted: convert to task
14:34:30 <fao89> #topic https://pulp.plan.io/issues/7485
14:34:30 <pulpbot> fao89: 2 issues left to triage: 7485, 7476
14:34:32 <pulpbot> RM 7485 - thm - NEW - Documentation: Pulp all-in-one container with CentOS7's docker
14:34:33 <pulpbot> https://pulp.plan.io/issues/7485
14:34:52 <dkliban> #idea Proposed for #7485: Leave the issue as-is, accepting its current state.
14:34:52 <dkliban> !propose accept
14:34:52 <pulpbot> dkliban: Proposed for #7485: Leave the issue as-is, accepting its current state.
14:35:06 <dkliban> we need to update our pulpproject.org page to include a note about this
14:35:12 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:35:12 <fao89> !accept
14:35:12 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:35:12 <fao89> #topic https://pulp.plan.io/issues/7476
14:35:13 <pulpbot> fao89: 1 issues left to triage: 7476
14:35:14 <pulpbot> RM 7476 - dalley - NEW - [Docs] Improve plugin API reference section of the guide
14:35:15 <pulpbot> https://pulp.plan.io/issues/7476
14:36:15 <ggainey> #info ggainey has joined triage
14:36:15 <ggainey> !here
14:36:15 <pulpbot> ggainey: ggainey has joined triage
14:36:22 <dalley> the next 3 I would suggest accept + low prio
14:36:26 <fao89> #idea Proposed for #7476: accept and add to current quarter
14:36:26 <fao89> !propose other accept and add to current quarter
14:36:26 <pulpbot> fao89: Proposed for #7476: accept and add to current quarter
14:37:57 <fao89> #agreed accept and add to current quarter
14:37:57 <fao89> !accept
14:37:57 <pulpbot> fao89: Current proposal accepted: accept and add to current quarter
14:37:58 <pulpbot> fao89: No issues to triage.
14:37:58 <dalley> + convert to task
14:38:34 <fao89> Open floor!
14:38:47 <fao89> https://hackmd.io/@pulp/triage/edit
14:38:59 <daviddavis> !friday
14:38:59 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:39:03 <fao89> topic: why redmine queries are so easy to delete?
14:39:42 <fao89> is there a way to improve it?
14:40:23 <dkliban> i don't think so
14:40:30 <dkliban> but i have not looked into it
14:40:46 <bmbouter> I also believe there is not, we are not able to configure permissions more finely than we have already and we can't customize our redmine (it's hosted not by us)
14:40:57 <bmbouter> the good news is though, if we switch to github it won't be an issue
14:41:00 <fao89> =/
14:41:21 <fao89> next topic: Add a tag or new tracker to track release tasks
14:41:26 <x9c4> #info x9c4 has joined triage
14:41:26 <x9c4> !here
14:41:26 <pulpbot> x9c4: x9c4 has joined triage
14:42:09 <bmbouter> my concern with this is that the more we add the more choice users have when filing tasks
14:42:32 <daviddavis> these fields do already exist though
14:42:33 <bmbouter> this was the motivation for my big push to super-simplify our redmine actually
14:42:43 <bmbouter> choice when selecting them
14:42:47 <bmbouter> is still increased
14:42:52 <daviddavis> that's true
14:43:06 <daviddavis> my problem is there's no way to search on release issues reliably
14:43:51 <bmbouter> for any of these issues there would be a corresponding version field already created
14:43:52 <x9c4> Can we prevent users from creating issues in the release tracker?
14:44:11 <x9c4> So only admins can?
14:44:24 <daviddavis> that might be an option
14:44:30 <daviddavis> bmbouter: not sure I follow
14:44:44 <fao89> I feel this discussion would be good after pulpcon, since we will be discussing moving to github issues
14:45:02 <bmbouter> daviddavis: what I'm getting at is that the release tracker isn't the real thing, it's just a bookkeeping helper
14:45:27 <bmbouter> I think the roadmap page is the real thing, e.g. https://pulp.plan.io/versions/126 versus https://pulp.plan.io/issues/7463
14:45:34 <daviddavis> yea, that's kind of why I am leaning towards a tag
14:45:58 <bmbouter> we cannot restrict some users to set some tags in redmine at least
14:46:13 <daviddavis> this is true
14:46:22 <bmbouter> if you want to still do this I can disagree and say ok
14:46:42 <bmbouter> I think I'm worn out mostly on redmine customization having done it for soooo longgggg
14:47:09 <fao89> release task could be the first task to be added to the milestone, so we can look at the milestone
14:47:14 <daviddavis> yea, I agree. but as someone who primarily manages these release issues, it would help me to be organized.
14:47:38 <daviddavis> fao89: the only problem is I can't see release issues across milestones
14:47:40 <dkliban> can we add a boolean just for tasks?
14:47:56 <dkliban> most users dont' file tasks
14:48:00 <bmbouter> we can but is this really that special
14:48:45 <dkliban> eh
14:49:20 <dkliban> i don't think so
14:49:42 <bmbouter> daviddavis: if this is helpful to you and you want to configure it somehow having stated my concerns I would say feel free to do it
14:49:42 <daviddavis> I don't have a strong preference as long as I can search for release issues. I'm happy to raise this again after pulpcon if we want more time to think about it.
14:50:16 <daviddavis> it doesn't sound like there's overwhelming support for any solution here so let's revisit later
14:50:29 <dkliban> let's revisit later
14:50:59 <fao89> next topic: hacktoberfest
14:51:28 <fao89> do we have issues that we can add the hacktoberfest label?
14:52:05 <fao89> hacktoberfest awards people who make 4 contributions to open source during October
14:52:33 <daviddavis> maybe something cli related?
14:52:59 <dkliban> that would be good
14:53:05 <daviddavis> or auto-distribution ?
14:53:41 <daviddavis> assuming we design that out in advance
14:54:47 <daviddavis> this might make a better mailing list discussion so peopel can think of ideas
14:55:07 <ggainey> +1
14:55:08 <fao89> I just wanted to point out, we can benefit from contributors during October
14:55:25 <fao89> next topic: pulpcon video links
14:55:28 <ggainey> yes indeed - I signed up for updates, had not seen this before, thanks fao89
14:56:16 <fao89> ggainey, for us it is free t-shirt and stickers every year, since we are always contributing to open source
14:56:30 <ggainey> zacly :)
14:56:53 <bmbouter> so this is what I learned about our video links
14:57:08 <bmbouter> and I was I think the main proponent of per-session links because I wasn't sure this would work
14:57:13 <bmbouter> but it does work, so let's keep it simple
14:57:18 <ggainey> +1
14:57:20 <daviddavis> +1
14:57:26 <daviddavis> KISS
14:57:42 <daviddavis> keep it simple smarty
14:57:46 <ggainey> heh
14:58:39 <bmbouter> I'm adding the links to the schedule now
14:59:45 <fao89> #endmeeting
14:59:45 <fao89> !end