14:30:36 <fao89> #startmeeting Pulp Triage 2020-09-22
14:30:36 <fao89> #info fao89 has joined triage
14:30:36 <fao89> !start
14:30:36 <pulpbot> Meeting started Tue Sep 22 14:30:36 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:36 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:36 <pulpbot> The meeting name has been set to 'pulp_triage_2020-09-22'
14:30:36 <pulpbot> fao89: fao89 has joined triage
14:30:53 <daviddavis> #info daviddavis has joined triage
14:30:53 <daviddavis> !here
14:30:54 <pulpbot> daviddavis: daviddavis has joined triage
14:30:54 <dkliban> #info dkliban has joined triage
14:30:54 <dkliban> !here
14:30:55 <pulpbot> dkliban: dkliban has joined triage
14:31:16 <ppicka> #info ppicka has joined triage
14:31:16 <ppicka> !here
14:31:16 <pulpbot> ppicka: ppicka has joined triage
14:31:18 <fao89> !next
14:31:19 <fao89> #topic https://pulp.plan.io/issues/7543
14:31:19 <pulpbot> fao89: 4 issues left to triage: 7543, 7542, 7532, 7513
14:31:20 <pulpbot> RM 7543 - wibbit - NEW - "reserved_resources_record" missing from tasks (python client)
14:31:21 <pulpbot> https://pulp.plan.io/issues/7543
14:31:59 <fao89> I think it was already addressed
14:32:26 <dkliban> fao89: do you mean there is already a fix for this on master branch?
14:32:37 <fao89> yes, I'm checking it
14:32:41 <ipanova> #info ipanova has joined triage
14:32:41 <ipanova> !here
14:32:41 <pulpbot> ipanova: ipanova has joined triage
14:33:12 <fao89> dkliban, https://pulp.plan.io/issues/7347
14:33:36 <dkliban> so we should close as a duplicate then
14:33:42 <dkliban> i'll add the relationship
14:33:55 <ipanova> issues is reported against 3.6.0
14:33:59 <fao89> I'll check the openapi schema
14:34:03 <ipanova> the fix was released in 3.6.1
14:34:10 <dkliban> he is using 3.6.0
14:34:30 <fao89> it is there: https://docs.pulpproject.org/pulpcore/api.json
14:34:35 <ipanova> yes, this is what i said
14:34:43 <ipanova> we should close and say it is fixed in 3.6.1
14:35:01 <bmbouter> #info bmbouter has joined triage
14:35:01 <bmbouter> !here
14:35:01 <pulpbot> bmbouter: bmbouter has joined triage
14:35:13 <x9c4> #info x9c4 has joined triage
14:35:13 <x9c4> !here
14:35:13 <pulpbot> x9c4: x9c4 has joined triage
14:35:16 <dkliban> fao89: i closed it
14:35:22 <bmbouter> +1
14:35:24 <fao89> #idea Proposed for #7543: close as duplicated
14:35:24 <fao89> !propose other close as duplicated
14:35:24 <pulpbot> fao89: Proposed for #7543: close as duplicated
14:35:29 <fao89> #agreed close as duplicated
14:35:29 <fao89> !accept
14:35:29 <pulpbot> fao89: Current proposal accepted: close as duplicated
14:35:30 <fao89> #topic https://pulp.plan.io/issues/7542
14:35:30 <pulpbot> fao89: 3 issues left to triage: 7542, 7532, 7513
14:35:31 <pulpbot> RM 7542 - wilful - NEW - Can't upload artifacts and filter artifacts does't work
14:35:32 <pulpbot> https://pulp.plan.io/issues/7542
14:36:03 <dkliban> he needs to use == in the filter
14:36:08 <daviddavis> I just commented
14:36:13 <dkliban> daviddavis++
14:36:13 <pulpbot> dkliban: daviddavis's karma is now 365
14:36:39 <fao89> close as not a bug?
14:36:42 <dkliban> +1
14:36:43 <daviddavis> sure
14:36:55 <ipanova> +1
14:36:55 <fao89> #idea Proposed for #7542: close as notabug
14:36:55 <fao89> !propose other close as notabug
14:36:55 <pulpbot> fao89: Proposed for #7542: close as notabug
14:36:59 <fao89> #agreed close as notabug
14:36:59 <fao89> !accept
14:36:59 <pulpbot> fao89: Current proposal accepted: close as notabug
14:37:00 <fao89> #topic https://pulp.plan.io/issues/7532
14:37:00 <pulpbot> fao89: 2 issues left to triage: 7532, 7513
14:37:01 <pulpbot> RM 7532 - mdepaulo@redhat.com - NEW - pulpcore-selinux fails to build due to unknown type pulpcore_etc_t
14:37:02 <pulpbot> https://pulp.plan.io/issues/7532
14:37:27 <daviddavis> selinux tag
14:37:33 <dkliban> accept and add to sprint
14:37:42 <daviddavis> and add selinux tag
14:37:47 <dkliban> yes yes
14:37:58 <ipanova> +1
14:38:04 <fao89> #idea Proposed for #7532: accept and add to sprint
14:38:04 <fao89> !propose other accept and add to sprint
14:38:04 <pulpbot> fao89: Proposed for #7532: accept and add to sprint
14:38:07 <fao89> #agreed accept and add to sprint
14:38:07 <fao89> !accept
14:38:08 <fao89> #topic https://pulp.plan.io/issues/7513
14:38:08 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:38:09 <pulpbot> fao89: 1 issues left to triage: 7513
14:38:10 <pulpbot> RM 7513 - thm - NEW - bulk-delete tasks
14:38:11 <pulpbot> https://pulp.plan.io/issues/7513
14:38:16 <dkliban> convert to story
14:38:18 <daviddavis> +1
14:38:30 <ppicka> +1
14:38:39 <fao89> #idea Proposed for #7513: convert to story
14:38:39 <fao89> !propose other convert to story
14:38:39 <pulpbot> fao89: Proposed for #7513: convert to story
14:38:44 <fao89> #agreed convert to story
14:38:44 <fao89> !accept
14:38:44 <pulpbot> fao89: Current proposal accepted: convert to story
14:38:45 <pulpbot> fao89: No issues to triage.
14:39:00 <fao89> open floor!
14:39:09 <fao89> https://hackmd.io/@pulp/triage/edit
14:39:13 <fao89> CI status
14:39:16 <dkliban> pulp CI is failing due to the docs publishing changes
14:39:22 <fao89> pulp and pulplift are failing
14:39:24 <dkliban> i will update the 2-master branch
14:39:36 <dkliban> with the new username that should be used
14:39:44 <daviddavis> great
14:40:06 <dkliban> pulplift is failing due to fedora vagrant boxes being old ... or that's my theory
14:40:37 <dkliban> actually, it's gettinga  500 error from vagrant cloud trying to download F 31 and F32 boxes
14:40:46 <daviddavis> ah so intermittent error
14:41:02 <dkliban> i think so
14:41:09 <daviddavis> let's monitor then to see if it keeps happening
14:41:09 <dkliban> let's see what happens next time it runs
14:41:19 <fao89> !topic Flip triage will open floor. It is easier to advertise and get attention for open floor then triage
14:41:19 <pulpbot> fao89: (topic [<channel>]) -- Returns the topic for <channel>. <channel> is only necessary if the message isn't sent in the channel itself.
14:41:29 <fao89> topic: Flip triage will open floor. It is easier to advertise and get attention for open floor then triage
14:42:16 <ipanova> this came as suggestion during pulpcon
14:43:32 <ipanova> open floor is one of the ways to get interaction with our community, however because it does not have an exact time when it starts it is not possible to advertise it
14:43:33 <ipanova> thoughts?
14:43:45 <dkliban> open floor can take a long time
14:43:51 <dkliban> and we would need to timebox it
14:43:51 <ipanova> that's true
14:44:08 <ipanova> what about time boxing it for 30 mins?
14:44:23 <dkliban> what about doing a video call with users once a month
14:44:28 <dkliban> ?
14:44:45 <ipanova> people who would have the intention to join i would expect to do so in the first 30 mins
14:44:51 <ipanova> dkliban: yeah we could
14:45:02 <ppicka> dkliban: good idea, but with chat as backup, I think not everyone wan't to video
14:45:03 <ipanova> the benefit of open floor is that it is twice a week
14:45:29 <bmbouter> I like chat for this meeting but I'm in favor of a once a month video call
14:45:43 <dkliban> so let's go back to the original suggestion
14:46:22 <dkliban> my concern with making open floor 30 mins at the begining is that it sometimes doesnt' take 30 mins
14:46:23 <ipanova> bmbouter: what would be the program of that meeting, how do you see it advertised?
14:46:45 <fao89> we could timebox the triage
14:46:54 <ppicka> we can plan it for 30 minutes, and if no topics wait 10mins for user and then skip to triage
14:46:54 <ipanova> dkliban: i share that concern
14:47:00 <fao89> we generally do it in 10-20 minutes
14:47:23 <bmbouter> ipanova: it's not related to this meeting really, let me put it as it's own idea at the end of open floor for today on the agenda
14:47:49 <fao89> and we can: skip to discuss at open floor
14:49:19 <dkliban> so who is in favor of having open floor be 30 minutes at the begining of this meeting/
14:49:21 <dkliban> ?
14:50:04 <ipanova> bmbouter: the benefit i see to keep this in the open floor is that people can come twice a week and have "clinic hours", having this once a month might be too seldom
14:50:05 <ppicka> +1 if option to skip if no topics/users available
14:50:38 <x9c4> I'm in favor of tying the switch. We can always go back if doesnot work out
14:50:46 <ipanova> bmbouter: also having this as a separate meeting might lead to no topics at all, while having this combined with open floor we will always gather together and have things to get discussed
14:51:22 <bmbouter> it doesn't have to be video
14:51:29 <bmbouter> my idea and dennis' are not really related actually at all
14:51:35 <dkliban> lol
14:51:47 <dkliban> so let's finish this topic though
14:52:26 <ipanova> i am in favor of trying to switch
14:52:29 <dkliban> i don't see much value in switching open floor to the begining of the meeting ... however, if there are others that see the value, i am not going to oppose it
14:52:29 <bmbouter> I want this to stay as written because chat meetings promote inclusivity both in terms of record and for english as second language folks who are more comfortable in a written format (what I've learned from osas)
14:52:39 <bmbouter> switching the order is fine w/ me
14:52:56 <daviddavis> I don't have a strong opinion but am happy to try out the switch
14:53:01 <dkliban> cool
14:53:06 <dkliban> it sounds like we are going to try it out
14:53:10 <fao89> when we start the switch?
14:53:14 <dkliban> friday!
14:53:20 <fao89> !friday
14:53:20 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:53:21 <ipanova> dkliban: i think i care more of the open floor having an exact time to start, whether this is before or after triage i do not really care
14:53:50 <fao89> topic: Proposal: disable merging by commit for pulpcore and pulp_file
14:54:06 <ipanova> bmbouter: agreed on the written format
14:54:32 <dkliban> i think this change will require us to change how we checkout Required PRs
14:54:42 <daviddavis> will it?
14:54:48 <dkliban> daviddavis: i was about to ask you
14:54:50 <daviddavis> I've not used merge by commit in 3 years
14:54:50 <dkliban> lol
14:55:08 <daviddavis> I think everything should work
14:55:23 <daviddavis> here's a great illustration of merge by commit vs not using merge by commit https://imgur.com/a/uiIa0Mr
14:55:27 <dkliban> are we going to disable creating of a merge commit?
14:55:39 <daviddavis> yes exactly
14:55:46 <daviddavis> just use rebase and merge
14:56:03 <daviddavis> that's what I've been using now for years
14:56:17 <dkliban> i am for this
14:56:28 <ipanova> me too
14:56:47 <bmbouter> I am also +1
14:56:53 <daviddavis> cool, I make this change to pulpcore and pulp_file
14:56:58 <bmbouter> yes please!
14:57:28 <ipanova> daviddavis: can you share where this change will happen?
14:57:34 <ipanova> in the repo settings?
14:58:07 <daviddavis> ipanova: yea go to https://github.com/pulp/pulpcore/settings and scroll down to merge button
14:58:47 <daviddavis> done.
14:58:47 <ipanova> daviddavis: i see,thanks
14:58:51 <daviddavis> np :)
14:59:08 <daviddavis> I'll send out a quick email too
14:59:27 <ipanova> sounds good
14:59:51 <fao89> topic: What about a "Pulp, what the heck?" invite, maybe with video (or not)?
15:00:42 <dkliban> i like this
15:00:57 <x9c4> +1
15:01:03 <ipanova> the thing is - most of the users will come from pulp2 experience
15:01:05 <daviddavis> maybe we could also demo stuff too
15:01:16 <dkliban> we can do it on IRC, but i also see value of doing it on a different platfrom that people that avoid IRC might be more willing to participate in
15:01:23 <ipanova> are we going to highlight that this is pulp3 only?
15:01:41 <dkliban> ipanova: it doesn't matter ... we will just tell them to use pulp 3
15:01:47 <daviddavis> lol
15:01:58 <ipanova> dkliban: well i am not sure this kind of answer will be helpful for them
15:02:09 <ipanova> expecially if migration wise are not production ready
15:02:33 <daviddavis> "I can't sync from puppet forge"
15:02:36 <daviddavis> "use pulp 3!!"
15:02:43 <dkliban> nope ... switch to ansible
15:02:46 <dkliban> lol
15:02:49 <daviddavis> lol
15:03:11 <bmbouter> yeah so this what the heck idea
15:03:16 <fao89> we used to have the demo session on youtube, why it stopped?
15:03:38 <bmbouter> we stopped because we weren't getting demo's recorded by developers
15:03:47 <ipanova> if i come to share my pain points my hope/expectations that i will be provided some sort of workaround/fix. if the answer will be - switch to pulp3 this will not help my today's pain
15:04:35 <ipanova> i am in favor of having this sessions however i would at least try to highlight that this is pulp3 targeted.
15:04:38 <ipanova> thoughts?
15:04:55 <bmbouter> pulp2 is in maintenance mode so we can't fix there, but I still want them to express their pain
15:05:01 <fao89> I agree with you ipanova
15:05:04 <bmbouter> here is the hass.io invite on their WTH https://www.home-assistant.io/blog/2020/08/18/the-month-of-what-the-heck/
15:06:05 <daviddavis> I like this idea
15:06:26 <ipanova> bmbouter: i am +1 on hearing the pain points independent of the version they use
15:06:54 <ipanova> what will be the next steps? shall we draft a blogpost?
15:07:02 <dkliban> i agree ... we want to hear about user experience
15:08:21 <bmbouter> we should mention to mcorr somewhere/somehow I think
15:08:33 <ipanova> speaking of the format - video or written form I think we should start with a written form
15:09:05 <ipanova> people could share their experience in an email and we would then work towards a blogpost in a format: problem ---> solution
15:09:47 <fao89> how does it differ from using pulp-list?
15:09:58 <ipanova> bmbouter: what about putting this among headlines at our pulpteam meeting
15:10:32 <ipanova> fao89: it will be i guess better articulated and targeted to cover bigger audience
15:10:51 <ipanova> plus not everyone as it turns out are subscribed to our lists
15:12:04 <fao89> does the user need be subscribed to send an email to pulp-list?
15:12:10 <bmbouter> fao89: yes
15:12:16 <bmbouter> otherwise spammers send
15:12:24 <bmbouter> also users wouldn't receive a reply
15:13:17 <fao89> =/
15:13:18 <bmbouter> ipanova: I'll add to a headline
15:13:37 <ipanova> sounds good, thank you
15:13:51 <dkliban> so we'll discuss the format on Monday/?
15:14:17 <ipanova> dkliban: i think so, plus get some input from mcorr
15:16:02 <dkliban> sounds good
15:16:44 <fao89> #endmeeting
15:16:44 <fao89> !end