14:30:28 <fao89> #startmeeting Pulp Triage 2020-10-06
14:30:28 <fao89> #info fao89 has joined triage
14:30:28 <fao89> !start
14:30:28 <pulpbot> Meeting started Tue Oct  6 14:30:28 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:28 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:28 <pulpbot> The meeting name has been set to 'pulp_triage_2020-10-06'
14:30:28 <pulpbot> fao89: fao89 has joined triage
14:31:20 <dkliban> #info dkliban has joined triage
14:31:20 <dkliban> !here
14:31:20 <pulpbot> dkliban: dkliban has joined triage
14:31:25 <daviddavis> #info daviddavis has joined triage
14:31:25 <daviddavis> !here
14:31:25 <pulpbot> daviddavis: daviddavis has joined triage
14:31:29 <bmbouter> #info bmbouter has joined triage
14:31:29 <bmbouter> !here
14:31:29 <pulpbot> bmbouter: bmbouter has joined triage
14:31:32 * bmbouter does the tuesday dance
14:31:39 <fao89> topic: backporting migrations (revisited)
14:31:40 <daviddavis> !tuesday
14:31:40 <pulpbot> daviddavis: Error: "tuesday" is not a valid command.
14:32:17 <daviddavis> so I spent some time trying to figure out how to reorder migrations programmatically and gave up after about 2 hours
14:32:29 <ggainey> #info ggainey has joined triage
14:32:29 <ggainey> !here
14:32:29 <pulpbot> ggainey: ggainey has joined triage
14:32:44 <daviddavis> there might be some way outside of django to do so but it's almost impossible using django
14:33:14 <dkliban> daviddavis: we would need to write an algorithm for analyzing the relationships between migrations based on the fields/models being modified
14:33:32 <dkliban> the scope is way outside of Pulp
14:33:37 <ggainey> yup
14:33:43 <daviddavis> yea
14:33:50 <bmbouter> agreed
14:33:55 <daviddavis> so I think the next step is document that we don't support backporting migrations?
14:34:06 <dkliban> yes please
14:34:08 <ggainey> +1
14:34:15 <daviddavis> I can do this
14:34:18 <bmbouter> I agree, question though is it that we don't backport migrations or is it that AND we don't ship migrations in z-stream
14:34:27 <bmbouter> actually these are the same
14:34:31 <daviddavis> :)
14:34:35 <bmbouter> by definition a backport would be z-stream
14:34:40 <bmbouter> maybe we can just call it out explicitly
14:34:47 <ggainey> sounds like a good idea
14:34:49 <daviddavis> yea
14:35:20 <daviddavis> I will open a PR and we can hammer out the specific language
14:35:25 <ggainey> +1
14:35:26 <bmbouter> ty
14:35:50 <fao89> daviddavis++
14:35:50 <pulpbot> fao89: daviddavis's karma is now 369
14:36:07 <fao89> next topic: hacktober: project-participation now requires a label to be added to the project(s)
14:36:13 <ggainey> right, I put this on there
14:36:26 <ggainey> just wanted to bring it to the attention of everyone
14:36:36 <ipanova> #info ipanova has joined triage
14:36:36 <ipanova> !here
14:36:36 <pulpbot> ipanova: ipanova has joined triage
14:36:36 <ggainey> the downside, as someone has noted, is there's a spam problem this year
14:36:41 <fao89> I got my 4 PRs before this rule! \o/
14:36:45 <ggainey> heh
14:36:52 <bmbouter> ha nice!
14:37:00 <ggainey> so, the question is, do we want to participate (given the spam issues)?
14:37:13 <fao89> just to bring awareness of the downside of hacktoberfest: downside: may attract spam - https://github.com/theforeman/theforeman.org/pull/1688
14:37:19 <ggainey> yup
14:37:31 <dkliban> i don't think we should participate
14:38:10 <ggainey> yeah, I was concerned myself - it's become A Problem :(
14:38:17 <bmbouter> I'm ok not to participate
14:38:17 <dkliban> i don't think we need hacktoberfest to attract contributions
14:38:29 <bmbouter> I'll get my 4 PRs against hass
14:38:33 <ipanova> i am hesitant because of spam issue
14:38:34 <dkliban> lol
14:39:07 <fao89> 4 PRs at RebeccaBlack repo!
14:39:12 <dkliban> LOL
14:39:22 <daviddavis> lol
14:39:30 <ggainey> so I think I'm hearing we're all wary , and prob should *not* apply the tag to the projects
14:39:31 <ggainey> heheh
14:39:38 <fao89> bmbouter, I think you should add hacktoberfest label at this repo
14:39:43 <fao89> the world needs it
14:40:47 <dkliban> that's correct ggainey
14:40:57 <fao89> I think each plugin can decide, I don't mind to put hacktoberfest label at pulp_npm for example
14:41:19 <bmbouter> lol!
14:41:29 <ggainey> coolio - sounds good to me
14:42:19 <fao89> but I don't have powers for adding label, I think we can use pulp_npm as "honey pot" this year and see how it goes
14:42:47 <bmbouter> I agree, in fact I keep coming back to the value of each plugin deciding almost all things for themselves
14:43:42 <ipanova> i think it is not enough just to add a label but also to have some bugs/features ready to be worked on
14:43:46 <dkliban> cool ... we decided that pulpcore doesn't want this label
14:44:02 <dkliban> yeah ... i agree ipanova
14:44:07 <bmbouter> ipanova: I agree
14:44:12 <ggainey> +1
14:44:51 <fao89> next topic?
14:45:03 <ipanova> yup
14:45:28 <ggainey> +1
14:45:30 <fao89> topic: what does everyone want out of open floor, e.g. decisions or discussion?
14:45:54 <ipanova> depends on the topic i think?
14:46:10 <dkliban> i want both
14:46:30 <bmbouter> I put this on there, just for discussion purposes
14:46:36 <daviddavis> not for a decision?
14:46:37 <fao89> we just had an example, migrations stared as discussion, and today it was decision
14:46:37 <ggainey> often discussion leads to "I'll summarize and send an email to pulp-dev@ to gather more discussion"
14:46:54 <dkliban> yeah ... the migration discussion is a great example
14:46:56 <bmbouter> what I'm realizing is that we approach decisions here and on the mailing list as decisions for all plugins
14:46:57 <fao89> s/stared/started
14:46:57 <ggainey> and sometimes we can reach a consensus quickly :)
14:47:24 <bmbouter> true but only with folks who are here participating at that moment
14:47:31 <ggainey> yus
14:47:50 <bmbouter> I almost titled this section: how can we stop approaching decisions as applying to all mini-teams
14:48:17 <dkliban> we need to be more clear in our discussions
14:48:27 <dkliban> when a topic is specific to pulpcore we should state that
14:48:37 <dkliban> or if the topic is about a particular plugin we should state that
14:49:18 <ipanova> +1
14:49:25 <bmbouter> +1
14:49:27 <ggainey> +1
14:50:01 <fao89> should I start triage?
14:50:12 <bmbouter> so this brings it back around to the topic
14:50:16 <dkliban> ok ...
14:50:38 <bmbouter> plugin teams have their own venues for decision making, and I think that leaves this venue as the place for global decisions or discussion
14:51:12 <ggainey> sounds reasonable
14:51:13 <bmbouter> and the number of actual global decisions may be so few that it's primarily discussion (granted z-stream migrations now being possibleis a great example of something globally applicable)
14:51:18 <bmbouter> s/now/not/
14:52:12 <bmbouter> having said that I want to listen to what others are feeling about this perspective
14:52:33 <ipanova> we can always start the discussion here and move it to the list when more input is needed, for example plugins input
14:53:26 <ipanova> so for example, as follow up for the hacktoberfest topic we can reply that pulpcore decided not to go for it but plugins can still decide whatever they think is the best for them
14:53:34 <ipanova> reply to the list ^
14:54:22 <bmbouter> I like this because it's more inclusive for folks who can't attend during this specific time
14:54:23 <dkliban> bmbouter: what i am hearing is that you want open floor to only focus on issues that affect all plugins
14:54:38 <fao89> and we can start topic at plugin and bring it here to understand how other plugins handled a similar issue
14:55:08 <bmbouter> dkliban: not exactly, I think almost any discussion plugin-to-plugin would be good even if not applicable to all
14:55:33 <dkliban> bmbouter: yeah ... i did not phrase that correctly.
14:55:35 <bmbouter> what I'm cautious of is to use this as either a) a pulpcore decision venue or b) a decision venue for global decisions when in reality those are pretty rare
14:56:01 <bmbouter> fao89: +1
14:56:03 <bmbouter> dkliban: np
14:56:52 <bmbouter> I've heard some good feedback, we can share more at retro or any other time too
14:57:13 <fao89> I think we can try to label the open floor topics e.g. [global] migrations ...
14:57:22 <bmbouter> some labels would be legittttt
14:57:25 <ggainey> +1
14:59:05 <ipanova> it's tricky with labels, sometimes conversation can start as a problem in the plugin then you realize this is a core problem
14:59:47 <ipanova> imo, i would not complicate out process, i would continue bringing up topics and based on how the discussion goes we'd figure out into what category it falls into
14:59:53 <ipanova> s/out/our
15:00:05 <bmbouter> process aside, that's exactly the kind of valuable convo I hope for at open floor
15:00:17 <fao89> ipanova, +1
15:01:02 <fao89> should I start triage?
15:01:07 <bmbouter> +1
15:01:17 <fao89> !next
15:01:18 <pulpbot> fao89: 1 issues left to triage: 7655
15:01:18 <fao89> #topic https://pulp.plan.io/issues/7655
15:01:19 <pulpbot> RM 7655 - wibbit - NEW - Erronious Documentation
15:01:20 <pulpbot> https://pulp.plan.io/issues/7655
15:01:43 <dkliban> we should fix this during our docs push
15:01:50 <dkliban> before 3.8
15:01:59 <fao89> #idea Proposed for #7655: Leave the issue as-is, accepting its current state.
15:01:59 <fao89> !propose accept
15:01:59 <pulpbot> fao89: Proposed for #7655: Leave the issue as-is, accepting its current state.
15:02:05 <daviddavis> add docs tag
15:02:14 <daviddavis> so we can find it later during docs day or whatever
15:02:23 <ggainey> +1
15:02:25 <fao89> #idea Proposed for #7655: accept and add docs tag
15:02:25 <fao89> !propose other accept and add docs tag
15:02:25 <pulpbot> fao89: Proposed for #7655: accept and add docs tag
15:02:31 <bmbouter> +1
15:02:33 <fao89> #agreed accept and add docs tag
15:02:33 <fao89> !accept
15:02:33 <pulpbot> fao89: Current proposal accepted: accept and add docs tag
15:02:34 <pulpbot> fao89: No issues to triage.
15:02:43 <daviddavis> speaking of docs day, when is the next one?
15:02:43 <ipanova> +1
15:02:55 <ipanova> daviddavis: good question
15:03:02 <bmbouter> yes docs day!
15:03:06 <ipanova> i was waiting on the tentative date for the next pulpcore release
15:03:12 <ggainey> how about next Thurs the 13th?
15:03:15 <ipanova> it is oct 20 right?
15:03:20 <ggainey> that works too :)
15:03:21 <daviddavis> yea oct 20
15:03:22 <fao89> yes
15:03:28 <daviddavis> oct 13 works
15:03:38 <fao89> 13th is the go/no-go
15:03:41 <ipanova> oct 13 sounds like a good day
15:03:45 <daviddavis> oh what about oct 15 or 16
15:03:48 <ggainey> I meant Thurs the 15th, sorry
15:03:52 <daviddavis> ha
15:03:55 <ggainey> calendars are hard
15:04:00 <ipanova> 16 is recharge day
15:04:07 <daviddavis> oh yea
15:04:08 <ggainey> zacly
15:04:10 <daviddavis> oct 15 then!
15:04:27 <ggainey> would be a day to 'clean the decks' and then have a day off, was my thinking
15:04:44 <ipanova> daviddavis: because you are out?:D
15:04:48 <daviddavis> haha yea
15:04:51 <ggainey> :P
15:04:54 <bmbouter> haha
15:05:16 <bmbouter> can we cancel all meeting on docs day?
15:05:34 <fao89> I think it can go from 13 to 20
15:05:56 <daviddavis> we have extra meetings on the 15 due to recharge day
15:06:02 <ipanova> yep..
15:06:12 <ggainey> bmbouter: not a bad idea. would make 15th a nonstarter, we need retro/planning
15:06:27 <bmbouter> ggainey: agreed
15:06:31 <bmbouter> I'd like docs day to get more love
15:06:40 <bmbouter> so maybe we find a day that we can cancel all?
15:06:41 <ipanova> i suggest oct 13, who will want to catch up will still have time to submit some PRs in the following days
15:07:01 <fao89> +1
15:07:02 <ggainey> 13th wfm
15:07:13 <bmbouter> wfm
15:07:17 <ggainey> my calendar at least is mostly-empty :)
15:07:28 <ipanova> bmbouter: i'd love to have a meeting free day however :D
15:07:44 <daviddavis> ugh me too
15:08:07 <bmbouter> we should consider it somehow
15:08:07 <fao89> ipanova, it is called recharge day
15:08:10 <bmbouter> lol
15:08:14 <bmbouter> I mean more weekly or bi-weekly
15:08:17 <ipanova> ok so oct 13 it is! i will send an email and mark in the outage
15:08:25 <bmbouter> oct 13th! ty
15:08:37 <ipanova> fao89: heh that's the reality
15:11:25 <fao89> #endmeeting
15:11:25 <fao89> !end