14:31:51 <dkliban> #startmeeting Pulp Triage 2020-10-09
14:31:51 <dkliban> !start
14:31:51 <dkliban> #info dkliban has joined triage
14:31:51 <pulpbot> Meeting started Fri Oct  9 14:31:51 2020 UTC.  The chair is dkliban. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:51 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:51 <pulpbot> The meeting name has been set to 'pulp_triage_2020-10-09'
14:31:51 <pulpbot> dkliban: dkliban has joined triage
14:32:12 <ppicka> #info ppicka has joined triage
14:32:12 <ppicka> !here
14:32:12 <pulpbot> ppicka: ppicka has joined triage
14:32:15 <dkliban> Open Floor - https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:32:15 <ipanova> #info ipanova has joined triage
14:32:15 <ipanova> !here
14:32:16 <pulpbot> ipanova: ipanova has joined triage
14:32:25 <bmbouter> #info bmbouter has joined triage
14:32:25 <bmbouter> !here
14:32:25 <pulpbot> bmbouter: bmbouter has joined triage
14:32:29 <x9c4> #info x9c4 has joined triage
14:32:29 <x9c4> !here
14:32:29 <pulpbot> x9c4: x9c4 has joined triage
14:33:22 <dkliban> Topic: * docs day cross-plugin
14:33:32 <dkliban> * Plugin A would pick a workflow
14:33:34 <dkliban> * Person from Plugin B would try that workflow and document what is missing
14:34:28 <ipanova> can someone give more background on 'picking a workflow'?
14:35:43 <dkliban> i am not sure who put this on the agenda but i can take a stab at it
14:36:30 <dkliban> someone from plugin A would ask another person on the team to follow the docs for a particular workflow in the docs
14:36:52 <dkliban> the idea is to have someone who is not as familiar with that plugin following the docs
14:37:25 <x9c4> this sounds like producing more docs tickets instead of solving existing ones...
14:37:34 <dkliban> i agree
14:37:45 <ipanova> yeah
14:37:51 <bmbouter> yup
14:38:07 <bmbouter> also fwiw, the workflows docs need to be ported to a CLI
14:38:12 <ipanova> how about we can get to this once we first cover opened docs issues
14:38:36 <bmbouter> for example the workflow docs are all out of date now that they require --verify no due to SSL by default w/ self-signed certificates
14:38:47 <bmbouter> I don't think fixing those is worth it (yes they are broken I know)
14:38:59 <bmbouter> we need the CLI to replace them as a strategic goal
14:39:03 <ttereshc> #info ttereshc has joined triage
14:39:03 <ttereshc> !here
14:39:03 <pulpbot> ttereshc: ttereshc has joined triage
14:39:18 <bmbouter> what do others think about this goal/approach?
14:39:58 <dkliban> +1 to updating to the CLI ... but i don't think the CLI is quite ready
14:40:04 <dkliban> though we are going to try to get it ready
14:40:22 <daviddavis> I agree. I wonder about timeframe though too.
14:40:37 <ipanova> i think we should wait with adding extensive docs to CLI, since this is still in high development
14:40:52 <ipanova> daviddavis: we hopefully will get some feedback from community
14:40:56 <ipanova> mayber after that
14:41:05 <daviddavis> yea, I just sent a bunch of emails out to rhui, support people, etc
14:41:12 <daviddavis> for feedback
14:41:14 <ipanova> sounds great
14:41:34 <ttereshc> ty
14:41:35 <daviddavis> I hope by the end of the year, we'll have a 0.1.0 release or whatever
14:42:06 <daviddavis> and then I think we should rewrite workflow docs
14:42:24 <ipanova> +1
14:42:51 <dkliban> that sounds good to me
14:43:14 <x9c4> +1
14:43:28 <dkliban> i would love for us to have a CLI to show off at virtual FOSDEM
14:43:37 <daviddavis> that would be awesome
14:43:46 <ttereshc> yeah, that would be great
14:43:58 * daviddavis eyes x9c4
14:44:05 <ttereshc> (:
14:44:07 <dkliban> cool ... so right now we are going to spend a lot of time on the workflow docs
14:44:19 <daviddavis> we are?
14:44:23 <dkliban> not
14:44:25 <dkliban> lol
14:44:26 <daviddavis> lol
14:44:30 * x9c4 nodds repeatedly
14:44:30 <dkliban> i had a typo there
14:44:44 <ipanova> :)
14:45:09 <dkliban> We don't have any other topics on the agenda
14:45:22 <dkliban> are we ready to go through the Triage query?
14:45:37 <daviddavis> +1
14:45:37 <dkliban> https://pulp.plan.io/issues?query_id=143
14:45:53 <dkliban> !next
14:45:54 <pulpbot> dkliban: 2 issues left to triage: 7682, 7675
14:45:54 <dkliban> #topic https://pulp.plan.io/issues/7682
14:45:55 <pulpbot> RM 7682 - daviddavis - POST - Update dynaconf requirement to 3.1.2
14:45:56 <pulpbot> https://pulp.plan.io/issues/7682
14:46:06 <dkliban> looks like this one is at POST
14:46:06 <daviddavis> I got a pr open for this so add to sprint
14:46:08 <daviddavis> yea
14:46:12 <daviddavis> reviews welcome: https://github.com/pulp/pulpcore/pull/956
14:46:17 <dkliban> #idea Proposed for #7682: accept and add to sprint
14:46:17 <dkliban> !propose other accept and add to sprint
14:46:17 <pulpbot> dkliban: Proposed for #7682: accept and add to sprint
14:46:19 <ttereshc> !agreed
14:46:20 <pulpbot> ttereshc: Error: "agreed" is not a valid command.
14:46:23 <ttereshc> +1
14:46:32 <ipanova> +1
14:46:32 <dkliban> #agreed accept and add to sprint
14:46:32 <dkliban> !accept
14:46:32 <pulpbot> dkliban: Current proposal accepted: accept and add to sprint
14:46:33 <dkliban> #topic https://pulp.plan.io/issues/7675
14:46:33 <pulpbot> dkliban: 1 issues left to triage: 7675
14:46:35 <pulpbot> RM 7675 - daviddavis - NEW - Seeing signing errors in CI builds of pulp-fixtures
14:46:36 <pulpbot> https://pulp.plan.io/issues/7675
14:46:47 <daviddavis> accept
14:47:07 <ppicka> +1
14:47:19 <dkliban> #idea Proposed for #7675: Leave the issue as-is, accepting its current state.
14:47:19 <dkliban> !propose accept
14:47:19 <pulpbot> dkliban: Proposed for #7675: Leave the issue as-is, accepting its current state.
14:47:32 <ttereshc> daviddavis, does it block anything?
14:48:28 <ttereshc> I take silence as no :)
14:48:33 <ppicka> not really, fixtures
14:48:41 <ppicka> *are built ok
14:48:47 <dkliban> #agreed Leave the issue as-is, accepting its current state.
14:48:47 <dkliban> !accept
14:48:47 <pulpbot> dkliban: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:48:48 <pulpbot> dkliban: No issues to triage.
14:49:08 <dkliban> i am ending this meeting
14:49:18 <daviddavis> ttereshc: no I think it's harmless
14:49:20 <daviddavis> I guess
14:49:23 <dkliban> #endmeeting
14:49:23 <dkliban> !end