14:33:28 <ttereshc> #startmeeting Pulp Triage 2020-10-23
14:33:28 <ttereshc> !start
14:33:28 <ttereshc> #info ttereshc has joined triage
14:33:28 <pulpbot> Meeting started Fri Oct 23 14:33:28 2020 UTC.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:28 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:33:28 <pulpbot> The meeting name has been set to 'pulp_triage_2020-10-23'
14:33:28 <pulpbot> ttereshc: ttereshc has joined triage
14:33:32 <daviddavis> #info daviddavis has joined triage
14:33:32 <daviddavis> !here
14:33:32 <pulpbot> daviddavis: daviddavis has joined triage
14:33:35 <bmbouter> fc!here
14:33:36 <ipanova> #info ipanova has joined triage
14:33:36 <ipanova> !here
14:33:36 <pulpbot> ipanova: ipanova has joined triage
14:33:37 <bmbouter> #info bmbouter has joined triage
14:33:37 <bmbouter> !here
14:33:38 <pulpbot> bmbouter: bmbouter has joined triage
14:33:41 <x9c4> #info x9c4 has joined triage
14:33:41 <x9c4> !here
14:33:41 <pulpbot> x9c4: x9c4 has joined triage
14:33:59 <ttereshc> Open floor
14:34:02 <ttereshc> Process for backporting cherry picks and issue #s
14:34:09 <ttereshc> https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:34:19 <daviddavis> man, I've had 2 hard discussions and it's not even 11am
14:34:23 <daviddavis> now here's #3
14:34:29 <ttereshc> :D
14:34:35 <daviddavis> this is not a friday :)
14:34:36 <ttereshc> it's Friday
14:34:46 <ipanova> daviddavis: better to swallow all the frogs first
14:34:51 <ipanova> :d
14:34:59 <daviddavis> heh
14:35:18 <daviddavis> so cherry picking changes for issues that have been released breaks everything
14:35:24 <daviddavis> ttereshc and i were discussing this
14:35:28 <bmbouter> yup
14:35:37 <daviddavis> I see two solutions
14:35:40 <daviddavis> maybe there are more
14:35:56 <daviddavis> first, we edit the cherrypicked commits to point to the backport issues
14:36:00 <daviddavis> this is complex and painful
14:36:08 <daviddavis> and involves editing commits
14:36:17 <ttereshc> yes, painful
14:36:19 <daviddavis> the other is we update the commit validation and automation
14:36:56 <ttereshc> well, we can't assign same issues to different milestones
14:36:56 <daviddavis> one easy fix here maybe is not to not check commits against release (ie \d.\d) branches
14:37:13 <x9c4> Who closes the backport issue then?
14:37:34 <x9c4> do we add a "backport #1234" to the commit message?
14:37:36 <daviddavis> it would be a manual process for now if we go with option #2
14:37:48 <daviddavis> yea, that would be option #1 I think
14:38:03 <daviddavis> we update the CHANGES entry and the commit message to point to the backport issue
14:38:23 <x9c4> i think option #1 was to update changes and use "closes #1111"
14:38:30 <daviddavis> correct
14:38:39 <daviddavis> oh I see what you're saying
14:38:55 <ggainey> #info ggainey has joined triage
14:38:55 <ggainey> !here
14:38:55 <pulpbot> ggainey: ggainey has joined triage
14:38:56 <bmbouter> changing the commit log I think is fine if needed, can we avoid changing the commit itself (time concerns w/ that)
14:39:38 <daviddavis> I think that might work since the release automation uses CHANGES entries
14:39:42 <x9c4> If we added another hint that it is a backport with a reference to the backport that could trigger skipping the other validation and affect the backport ticket without touching anything in the commit.
14:40:56 <daviddavis> what would we do about the release automation?
14:42:00 <daviddavis> I think the simplest solution is to update the CHANGES entry and have commit validation not run against release branches
14:42:08 <daviddavis> then maybe add in other features later?
14:42:27 <bmbouter> what would the changelog say in that case w/ CHANGES entry changed?
14:43:19 <daviddavis> that's a good question and I don't have a strong opinion
14:43:32 <x9c4> if the commit meassage contains "closes #1111 \n backport #1234" it would not affect #1111 but only #1234. And the change was still "1111.bugfix"
14:43:57 <bmbouter> from a user perspective having the 1111.bugfix I thin is important
14:44:26 <bmbouter> this is maybe why I think keeping the commit in-tact is a good strategy
14:44:54 <ttereshc> that sounds like a good idea, having the backport keyword and keeping the 1111.bugfix
14:45:29 <daviddavis> I like the idea. the only challenge is updating the release automation since it tries to assign issues to a release based on what's in CHANGES.
14:45:54 <bmbouter> yeah that would be the next step needed :/
14:46:08 <ttereshc> yeah, it needs to look into commits it seems :/
14:46:14 <x9c4> It's like "that is your ticket, but when talking to plan.io use the other number."
14:46:29 <bmbouter> or disabling those checks on release branches is the other option I heard
14:46:37 <x9c4> So it would "git blame" the changes file?
14:47:34 <daviddavis> cool, maybe we can see if that's easy and if not, just disable this for release branches?
14:47:42 <daviddavis> I think I have a good enough understanding to file a task
14:47:43 <bmbouter> yeah +1
14:48:14 <ttereshc> great, thanks
14:48:15 <ipanova> seems like we have 2 ideas to try
14:48:33 <x9c4> Or should we add the backport issue to the "real" CHANGELOG anyway?
14:49:13 <ipanova> i think we should keep just the original issue in the the changelog
14:49:20 <x9c4> ok
14:49:24 <bmbouter> yeah I think users will appreciate us keeping it the same
14:50:00 <ttereshc> How about daviddavis files a task and we can figure out details discussing them on the ticket?
14:50:08 <x9c4> +1
14:50:23 <daviddavis> +1
14:50:25 <ttereshc> any other open floor topic?
14:50:46 * bmbouter sings friday
14:50:57 <ttereshc> ok, let's go to triage quickly then :)
14:50:57 * bmbouter runs rebeccablack
14:51:03 <ttereshc> !next
14:51:04 <pulpbot> ttereshc: 2 issues left to triage: 7737, 7624
14:51:04 <ttereshc> #topic https://pulp.plan.io/issues/7737
14:51:05 <pulpbot> RM 7737 - jsherril@redhat.com - NEW - Backport request: 6463: duplicate key error when sync to pulpcore 3.6/pulp-rpm
14:51:06 <pulpbot> https://pulp.plan.io/issues/7737
14:51:40 <ttereshc> yay, backport
14:52:12 <ttereshc> I believe this one came from the foreman forum
14:52:35 <ipanova> yes
14:52:40 <ttereshc> it looks like a clean backport to 3.6, any objections?
14:52:48 <ipanova> no objections, +1
14:52:54 <ggainey> +1
14:52:54 <bmbouter> +1
14:52:56 <x9c4> are there migrations?
14:52:58 <ttereshc> no
14:53:01 <x9c4> +1
14:53:05 <bmbouter> good question
14:53:14 <ttereshc> ok, who is going to do a backport and a release?
14:53:42 <ttereshc> it includes pulpcore and installer release
14:54:15 <ttereshc> I'm not sure we can accept a backport if there is no one to do it. wdyt?
14:54:52 <ipanova> that's a fair observation
14:54:54 <bmbouter> I agree w/ that
14:55:19 <ttereshc> ok, I'm skipping it then till the next triage
14:55:26 <bmbouter> +1
14:55:29 <ttereshc> !skip
14:55:30 <ttereshc> #topic https://pulp.plan.io/issues/7624
14:55:30 <pulpbot> ttereshc: 1 issues left to triage: 7624
14:55:31 <pulpbot> RM 7624 - dalley - NEW - Add pulpcore version to the plugin API
14:55:32 <pulpbot> https://pulp.plan.io/issues/7624
14:55:45 <ipanova> let's also put this on our pulpcore team meeting agenda ttereshc?
14:56:05 <bmbouter> yes let's
14:56:06 <daviddavis> sure
14:56:10 <ttereshc> ipanova, I thought to write an e-mail to pulp-internal but that will do as well
14:56:13 <bmbouter> I actually filed another issue that requests this for all plugins
14:56:25 <daviddavis> we ran into some technical issues
14:56:34 <bmbouter> we need a way for plugins to get the version without distutils
14:56:47 <daviddavis> +1
14:56:52 <ttereshc> looks like a story not a bug
14:56:54 <ttereshc> ?
14:56:59 <bmbouter> agreed
14:57:04 <ggainey> +1
14:57:10 <ttereshc> #idea Proposed for #7624: convert to story
14:57:10 <ttereshc> !propose other convert to story
14:57:10 <pulpbot> ttereshc: Proposed for #7624: convert to story
14:57:16 <daviddavis> I can add it to pulpcore agenda
14:57:59 <ttereshc> thanks
14:58:12 <ttereshc> #agreed convert to story
14:58:12 <ttereshc> !accept
14:58:12 <pulpbot> ttereshc: Current proposal accepted: convert to story
14:58:13 <pulpbot> ttereshc: No issues to triage.
14:58:27 <ttereshc> any last thoughts apart from rebeccablack?
14:58:45 <daviddavis> !friday
14:58:45 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:58:51 <ttereshc> #endmeeting
14:58:51 <ttereshc> !end