15:39:50 <fao89_> #startmeeting Pulp Triage 2020-11-03
15:39:50 <fao89_> !start
15:39:50 <fao89_> #info fao89_ has joined triage
15:39:50 <pulpbot> Meeting started Tue Nov  3 15:39:50 2020 UTC.  The chair is fao89_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:39:50 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:39:50 <pulpbot> The meeting name has been set to 'pulp_triage_2020-11-03'
15:39:50 <pulpbot> fao89_: fao89_ has joined triage
15:39:53 <ggainey> #info ggainey has joined triage
15:39:53 <ggainey> !here
15:39:53 <pulpbot> ggainey: ggainey has joined triage
15:39:56 <ppicka> #info ppicka has joined triage
15:39:56 <ppicka> !here
15:39:56 <pulpbot> ppicka: ppicka has joined triage
15:40:01 <ttereshc> #info ttereshc has joined triage
15:40:01 <ttereshc> !here
15:40:01 <pulpbot> ttereshc: ttereshc has joined triage
15:40:05 <fao89_> https://hackmd.io/@pulp/triage/edit
15:40:13 <daviddavis> #info daviddavis has joined triage
15:40:13 <daviddavis> !here
15:40:14 <pulpbot> daviddavis: daviddavis has joined triage
15:40:23 <fao89_> topic: Travis pricing - https://blog.travis-ci.com/2020-11-02-travis-ci-new-billing
15:40:27 <dkliban> #info dkliban has joined triage
15:40:27 <dkliban> !here
15:40:27 <pulpbot> dkliban: dkliban has joined triage
15:40:33 <daviddavis> yea so this could potentially impact us badly
15:40:36 <fao89_> we just had a meeting for that
15:40:38 <daviddavis> yea
15:40:54 <daviddavis> we agreed to do more research and wait and see
15:41:20 <fao89_> the backup plan is moving to github actions, the downside would be: we can't re-run single jobs
15:41:22 <ggainey> do we have any idea how many minutes the pulpproj org is using on travis today?
15:41:32 <daviddavis> the whole org?
15:41:35 <ggainey> yeah
15:41:36 <daviddavis> over 1000 probably
15:41:57 <ggainey> well yeah - but "what do we do" is different, if it's 1010, than if it's 100,000 :)
15:42:08 <daviddavis> 45,101 mins
15:42:10 <daviddavis> per month
15:42:14 <ggainey> oof, ok
15:42:38 <dalley> https://i.pinimg.com/originals/ae/38/6c/ae386c11446f208a85e304f0724cba48.jpg
15:42:47 <ggainey> and is the 1K/month per-org or per-repo, do we know?
15:42:55 <fao89_> dalley++
15:42:55 <pulpbot> fao89_: dalley's karma is now 293
15:42:56 <mcorr> in what way fao89  ?
15:42:58 <daviddavis> it's unclear
15:43:03 <ggainey> fun
15:43:35 <ttereshc> should we email their support and ask for their advice or at least clarification
15:43:55 <fao89> mcorr: I'm not seeing pulpbot messages again
15:44:00 <dalley> I think so. I think we should pre-emptively ask to raise our limit to at least 5000
15:44:02 <x9c4> #info x9c4 has joined triage
15:44:02 <x9c4> !here
15:44:02 <pulpbot> x9c4: x9c4 has joined triage
15:44:02 <mcorr> Damn. And it was working the last time :(
15:44:19 <dalley> otherwise we will run out very quickly
15:44:33 <daviddavis> 5000 is well short of the 45000 we use each month
15:44:37 <ggainey> I mean, at a minimum we need to be able to answer the question "How much is this going to cost us at current consumption?" when asked
15:44:39 <ggainey> yah
15:44:46 <dalley> daviddavis, is that really how many we use
15:44:49 <dalley> wow
15:45:04 <daviddavis> this is based on https://travis-ci.com/github/pulp?tab=insights not sure how accurate it is tho
15:45:05 <ggainey> if we're using 45K/mo, 5K means we run out in a week or so
15:45:30 <daviddavis> I'll email travis and ask some questions
15:45:35 <ggainey> kk
15:45:40 <fao89_> let's create 10 pulp orgs, hahaha
15:45:43 <daviddavis> lol
15:45:48 <daviddavis> each plugin has their own pulp org
15:45:53 <fao89_> yep!
15:45:56 <ggainey> yeah, I expect that would work for about a month :)
15:46:56 <fao89_> can we move to the next topic?
15:47:11 <ggainey> did y'all come to any conclusion about how much time/resource it would take to switch us to github actions?
15:47:55 <dalley> ggainey, not really, although since part of the work has already been done, it would be an easier migration than gitlab CI most likely
15:47:56 <fao89_> I think about one day
15:48:17 <daviddavis> one day seems really optimistic
15:48:31 <fao89_> we already have pulp_npm running on github actions, it is a matter of moving it to plugin-template and apply to other plugins
15:48:34 <dkliban> yeah ... i think a week. we have meetings and such
15:48:37 <ggainey> ok - I mean, if it's less than a person-week, feels like maybe next sprint we just bite the bullet, push off someting esle, and make the switch
15:48:43 <daviddavis> what about the release stuff?
15:48:47 <daviddavis> setting vars, etc
15:48:51 <daviddavis> non-plugin repos
15:49:18 <ggainey> daviddavis: if we can get the bulk of the travis-use off of travis as a first cut, it's prob worth the exercise
15:49:30 <daviddavis> I agree
15:50:28 <ggainey> anyway - sounds like The CI Gang is on top of this
15:50:34 * ggainey cheers wildly from the sidelines
15:50:37 <dalley> I think it would be a good idea to ask internally what are people's experiences with Gitlab and Github Actions
15:50:42 <ggainey> +1
15:50:55 <fao89_> +1
15:51:02 <daviddavis> +1
15:51:54 <dalley> which comment are we +1-ing
15:52:06 <daviddavis> your comment
15:52:06 <ggainey> "ask internally" I think
15:52:09 <ggainey> yus
15:52:12 <fao89_> yours
15:52:20 <dalley> ok lol
15:52:24 <dalley> just checking
15:53:13 <ggainey> I'm good to move on to next topic, fwiw
15:53:17 <daviddavis> +1
15:53:28 <dalley> fwiw, even if we see Gitlab as a better long-term option, if it really won't take long to move to GHA then we can do so temporarily
15:53:45 <ttereshc> +1 to move to the next topic
15:53:48 <ggainey> I'm good w/stepwise-refinement
15:53:50 <fao89_> topic: Makefile https://github.com/pulp/plugin_template/pull/278
15:54:29 <daviddavis> so I wanted to get some more buy in here before I committed more time to this
15:54:43 <dalley> I think it's a really good idea
15:54:48 <ggainey> +100
15:54:51 <ggainey> daviddavis++
15:54:51 <pulpbot> ggainey: daviddavis's karma is now 379
15:55:03 <daviddavis> cool, alright, any objections? dkliban bmbouter ttereshc
15:55:07 <ggainey> daviddavis: can I send you beer as a reward? :)
15:55:10 <daviddavis> lol
15:55:12 <fao89_> daviddavis++
15:55:12 <pulpbot> fao89_: daviddavis's karma is now 380
15:55:17 <daviddavis> I will always accept beer
15:55:17 <dkliban> daviddavis: no objections from me
15:55:26 <ttereshc> no objections, big +1
15:55:36 <daviddavis> cool
15:55:41 <x9c4> +1
15:55:48 <daviddavis> just need to find the time for this then
15:55:49 <bmbouter> +1
15:55:56 <bmbouter> this would be a great thing
15:56:03 <ggainey> strongly concur
15:56:21 <fao89> matrix is back!
15:56:27 <ggainey> would also cut down on our travbis-minutes, by letting us reliably run tests locally before pushing a PR :)
15:56:35 <daviddavis> tru
15:57:03 <daviddavis> that's all I had for this then
15:57:23 <fao89_> topic: Are there any builds we can disable in Travis?
15:57:41 <daviddavis> I saw this run last night https://travis-ci.com/github/pulp/pulplift/builds/197596891
15:57:50 <daviddavis> can it be disabled?
15:57:54 <x9c4> yes
15:58:02 * daviddavis disables it
15:58:05 <daviddavis> anything else?
15:58:13 <fao89_> that's it
15:58:27 <fao89_> !next
15:58:28 <pulpbot> fao89_: 2 issues left to triage: 7766, 7760
15:58:28 <fao89_> #topic https://pulp.plan.io/issues/7766
15:58:29 <pulpbot> RM 7766 - dkliban@redhat.com - NEW - docs for older versions of pulpcore overwrite latest docs
15:58:30 <pulpbot> https://pulp.plan.io/issues/7766
15:58:45 <fao89_> #idea Proposed for #7766: Leave the issue as-is, accepting its current state.
15:58:45 <fao89_> !propose accept
15:58:45 <pulpbot> fao89_: Proposed for #7766: Leave the issue as-is, accepting its current state.
15:58:57 <daviddavis> +1
15:59:00 <ppicka> +1
15:59:01 <x9c4> +1
15:59:12 <ttereshc> +1
15:59:13 <fao89_> #agreed Leave the issue as-is, accepting its current state.
15:59:13 <fao89_> !accept
15:59:13 <pulpbot> fao89_: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:59:14 <fao89_> #topic https://pulp.plan.io/issues/7760
15:59:14 <pulpbot> fao89_: 1 issues left to triage: 7760
15:59:15 <pulpbot> RM 7760 - lboclboc - POST - Multiple errors in documentation
15:59:16 <pulpbot> https://pulp.plan.io/issues/7760
15:59:23 <dalley> fao89_, daviddavis if the installer / nested virt tests run on every PR, we could decrease them to nightly and/or every release
16:00:11 <daviddavis> dalley: yea, I know nothing about the installer CI but that makes sense to me
16:00:16 <daviddavis> for 7760, accept
16:00:16 <ggainey> 7760 - already in post, accept and add?
16:00:20 <daviddavis> +1
16:00:24 <dalley> +1
16:00:28 <ppicka> +1
16:00:35 <fao89_> #idea Proposed for #7760: accept and add
16:00:35 <fao89_> !propose other accept and add
16:00:35 <pulpbot> fao89_: Proposed for #7760: accept and add
16:00:37 <fao89_> #agreed accept and add
16:00:37 <fao89_> !accept
16:00:37 <pulpbot> fao89_: Current proposal accepted: accept and add
16:00:38 <pulpbot> fao89_: No issues to triage.
16:00:42 <ggainey> woot
16:00:49 <x9c4> dalley, they excercise codepaths we do not check by our molecule tests.
16:00:49 <ttereshc> dalley, ggainey, ipanova, dkliban, let's start the meeting at :10 mins ?
16:01:00 <ggainey> ttereshc: works4me
16:01:08 <dkliban> ttereshc: yeah
16:01:09 <ggainey> I have to get some tea anyway
16:01:27 <fao89_> #endmeeting
16:01:27 <fao89_> !end