15:30:43 <fao89> #startmeeting Pulp Triage 2020-11-10
15:30:43 <fao89> !start
15:30:43 <fao89> #info fao89 has joined triage
15:30:43 <pulpbot> Meeting started Tue Nov 10 15:30:43 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:43 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:43 <pulpbot> The meeting name has been set to 'pulp_triage_2020-11-10'
15:30:43 <pulpbot> fao89: fao89 has joined triage
15:30:56 <ppicka> #info ppicka has joined triage
15:30:56 <ppicka> !here
15:30:56 <pulpbot> ppicka: ppicka has joined triage
15:30:58 <dkliban> #info dkliban has joined triage
15:30:58 <dkliban> !here
15:30:58 <pulpbot> dkliban: dkliban has joined triage
15:31:35 <fao89> https://hackmd.io/@pulp/triage/edit  - No items
15:31:38 <daviddavis> !here!here
15:31:38 <pulpbot> daviddavis: Error: "here!here" is not a valid command.
15:31:44 <daviddavis> lol
15:31:45 <daviddavis> #info daviddavis has joined triage
15:31:45 <daviddavis> !here
15:31:45 <pulpbot> daviddavis: daviddavis has joined triage
15:32:13 <fao89> should I start the triage since we don't have items for open floor?
15:32:27 <daviddavis> yes
15:32:38 <fao89> !next
15:32:39 <fao89> #topic https://pulp.plan.io/issues/7808
15:32:39 <pulpbot> fao89: 2 issues left to triage: 7808, 7796
15:32:40 <pulpbot> RM 7808 - newswangerd - NEW - Store mirror configurations on the remote data model
15:32:41 <pulpbot> https://pulp.plan.io/issues/7808
15:32:57 <ttereshc> #info ttereshc has joined triage
15:32:57 <ttereshc> !here
15:32:57 <pulpbot> ttereshc: ttereshc has joined triage
15:33:01 <fao89> !propose convert to task
15:33:01 <pulpbot> fao89: Error: "propose" is not a valid command.
15:33:14 <fao89> #idea Proposed for #7808: convert to task
15:33:14 <fao89> !propose other convert to task
15:33:14 <pulpbot> fao89: Proposed for #7808: convert to task
15:33:19 <ggainey> fao89: story, yeah?
15:33:22 <ggainey> not task
15:33:23 <daviddavis> yea story
15:33:29 <daviddavis> this could use some discussion btw
15:33:29 <ttereshc> it feels like we had it in the past
15:33:33 <fao89> #idea Proposed for #7808: convert to story
15:33:33 <fao89> !propose other convert to story
15:33:33 <pulpbot> fao89: Proposed for #7808: convert to story
15:33:33 <daviddavis> we did
15:33:36 <ttereshc> then decided to move to one-time
15:33:41 <daviddavis> yup
15:33:42 <ttereshc> and now we are flipping it back
15:33:57 <daviddavis> the reason we made it one time was that remotes might be shared
15:34:08 <daviddavis> but one of the solutions I proposed I think could address that
15:34:25 <daviddavis> in that if the mirror is null, it must be supplied at sync time
15:34:40 <daviddavis> fwiw, we've heard from users that they want this so they don't have to supply mirror every time
15:35:08 <ttereshc> ok
15:35:16 <fao89> #agreed convert to story
15:35:16 <fao89> !accept
15:35:16 <pulpbot> fao89: Current proposal accepted: convert to story
15:35:16 <ttereshc> that's interesting
15:35:17 <fao89> #topic https://pulp.plan.io/issues/7812
15:35:17 <pulpbot> fao89: 2 issues left to triage: 7812, 7796
15:35:18 <pulpbot> RM 7812 - iballou - NEW - Pulp 3 should have an environment variable (or another convenient way) to enable debug logging
15:35:19 <pulpbot> https://pulp.plan.io/issues/7812
15:35:25 <ttereshc> I thought they don't do i manually
15:35:42 <daviddavis> supply mirror at sync time?
15:35:45 <ttereshc> yeah
15:35:54 <ttereshc> it's some automation that does it
15:35:57 <ttereshc> scripts or ansible
15:36:16 <daviddavis> yea, for galaxy, they probably don't do it manually
15:36:23 <daviddavis> my point was about pulp users though
15:36:33 <dkliban> yeah
15:36:35 <daviddavis> those not using scripts/etc
15:36:35 <ttereshc> yeah, I'm thinking about pulp users as well
15:36:41 <ttereshc> ah
15:36:55 <daviddavis> if I am using the cli to sync for example, I have to set mirror each time
15:37:03 <dkliban> yep
15:37:08 <ttereshc> ok ok :)
15:37:16 <dkliban> and in the UI we would have the same issue
15:37:17 <ttereshc> we can move on, sorry for derailing
15:37:20 <daviddavis> anyway, feel free to respond on the issue. there's some different ways to implement
15:37:22 <daviddavis> no prob
15:37:45 <dkliban> still a story and not an issue thoug
15:37:58 <dkliban> and the same thing for this next one, 7812
15:38:04 <ggainey> concur
15:38:09 <ttereshc> +1
15:38:21 <daviddavis> we need to address 7812
15:38:25 <fao89> what about https://github.com/pulp/pulpcore/blob/master/pulpcore/app/settings.py#L29 ?
15:38:34 <daviddavis> we're going to have to debug katello instances soon and it's gonig to be a pain
15:39:18 <dkliban> fao89: that's a different setting. i don't think it changes the value here: https://github.com/pulp/pulpcore/blob/master/pulpcore/app/settings.py#L195
15:39:22 <fao89> oh! I misread the issue
15:39:43 <fao89> #idea Proposed for #7812: convert to story
15:39:43 <fao89> !propose other convert to story
15:39:43 <pulpbot> fao89: Proposed for #7812: convert to story
15:39:50 <daviddavis> +1
15:40:06 <fao89> #agreed convert to story
15:40:06 <fao89> !accept
15:40:06 <pulpbot> fao89: Current proposal accepted: convert to story
15:40:07 <fao89> #topic https://pulp.plan.io/issues/7796
15:40:07 <pulpbot> fao89: 1 issues left to triage: 7796
15:40:08 <pulpbot> RM 7796 - tosif.meman@kindredgroup.com - NEW - Pulp Version 2.20 - Mongod and pulp_celerybeat failing randomly
15:40:09 <pulpbot> https://pulp.plan.io/issues/7796
15:40:30 <daviddavis> sounds like mongodb is failing and thus causing celery to fail?
15:40:48 <fao89> #idea Proposed for #7796: Leave the issue as-is, accepting its current state.
15:40:48 <fao89> !propose accept
15:40:48 <pulpbot> fao89: Proposed for #7796: Leave the issue as-is, accepting its current state.
15:41:09 <ggainey> daviddavis: yeah
15:41:24 <dkliban> +1
15:41:33 <daviddavis> I don't think we should accept this
15:41:46 <dkliban> oops
15:41:47 <ggainey> there isn't nearly enough info to do anything with here
15:42:10 <daviddavis> yea agreed and I'm guessing it's either a) an env problem or b) something that celery could do better
15:42:11 <dalley> lovely
15:42:18 <ggainey> celerybeat is just doin it's job "omg I can't talk to mongo!"
15:42:19 <daviddavis> neither of which are within our control
15:42:24 <ggainey> yus
15:42:25 <dkliban> i agree
15:42:36 <daviddavis> I can comment on this
15:42:42 <ggainey> daviddavis++
15:42:42 <pulpbot> ggainey: daviddavis's karma is now 381
15:42:50 <fao89> daviddavis++
15:42:50 <pulpbot> fao89: daviddavis's karma is now 382
15:42:54 <daviddavis> !skip
15:43:01 <fao89> !skip
15:43:04 <pulpbot> fao89: No issues to triage.
15:43:21 * ggainey cheers
15:43:31 <fao89> #endmeeting
15:43:31 <fao89> !end