15:30:54 <fao89> #startmeeting Pulp Triage 2020-11-17
15:30:54 <fao89> !start
15:30:54 <fao89> #info fao89 has joined triage
15:30:54 <pulpbot> Meeting started Tue Nov 17 15:30:54 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:54 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:54 <pulpbot> The meeting name has been set to 'pulp_triage_2020-11-17'
15:30:54 <pulpbot> fao89: fao89 has joined triage
15:30:58 <daviddavis> #info daviddavis has joined triage
15:30:58 <daviddavis> !here
15:30:58 <pulpbot> daviddavis: daviddavis has joined triage
15:30:59 <ggainey> #info ggainey has joined triage
15:30:59 <ggainey> !here
15:31:00 <pulpbot> ggainey: ggainey has joined triage
15:31:28 <fao89> https://hackmd.io/@pulp/triage/edit
15:32:15 <ggainey> not likely to have too many ppl today
15:32:21 <x9c4> #info x9c4 has joined triage
15:32:21 <x9c4> !here
15:32:21 <pulpbot> x9c4: x9c4 has joined triage
15:32:24 <fao89> I think we don't have quorum even for open floor
15:33:05 <dalley> #info dalley has joined triage
15:33:05 <dalley> !here
15:33:05 <pulpbot> dalley: dalley has joined triage
15:33:15 <fao89> now we have it
15:33:18 <ggainey> heh
15:33:21 <fao89> topic: 3.10 release timeframe?
15:33:32 <fao89> mid-December (eg Dec 21) or early January?
15:33:59 <dalley> early January
15:34:06 <ggainey> so I think early-Jan is better - releasing at the end of Dec is just asking for not having the right ppl available to push all the buttons, and/or ppl working over holidays to fix problems
15:34:11 <dalley> releasing right before the holidays is a recipe for badness
15:34:13 <fao89> +1
15:34:19 <dalley> bad things
15:34:22 <daviddavis> that works for me
15:34:39 <daviddavis> maybe jan 7th is good
15:34:46 <x9c4> agreed
15:34:52 <ggainey> sure
15:34:54 <daviddavis> I imagine we'll also have the go/no-go meeting in january
15:35:20 <ggainey> yeah - maybe the 4th?
15:35:23 <daviddavis> +1
15:35:55 <x9c4> didn't we have two checkins last time?
15:36:14 <fao89> how about the release owner? should we wait for the next open floor?
15:36:15 <ggainey> could see having something in mid-Dec?
15:36:23 <ggainey> I'd wait
15:36:37 <daviddavis> yea let's wait
15:36:40 <mikedep333> #info mikedep333 has joined triage
15:36:40 <mikedep333> !here
15:36:40 <pulpbot> mikedep333: mikedep333 has joined triage
15:36:57 <daviddavis> I do remember there being 2 go/no-go meetings but I don't remember why
15:37:05 <daviddavis> I was only planning on having one for 3.9
15:37:18 <x9c4> +1
15:37:22 <bmbouter> #info bmbouter has joined triage
15:37:22 <bmbouter> !here
15:37:22 <pulpbot> bmbouter: bmbouter has joined triage
15:37:25 <ggainey> well, if you have one and the answer is no-go, you'll eventually have a second :)
15:37:30 <daviddavis> haha yea
15:37:38 <fao89> we are getting more mature about go/no-go, I think we can try just 1
15:37:44 <ggainey> coolio
15:37:48 <daviddavis> sounds good
15:37:58 <x9c4> I thought it was like still-go/no-go and then go/no-go
15:38:46 <daviddavis> hmm ok
15:39:04 <x9c4> Not saying that i _want_ two.
15:39:27 <ggainey> ther's time - maybe wait til we have a release-manager, and let them make the call?
15:39:38 <daviddavis> +1
15:39:40 <fao89> +1
15:39:43 <x9c4> +1
15:39:50 <daviddavis> I'll ask for a release manager at our next pulpcore meeting
15:39:53 <ggainey> coolio
15:40:05 <fao89> next topic: Completely drop support of Travis from plugin_template?
15:40:23 <fao89> yes, the question is when
15:40:26 <ggainey> once everything is running on actions?
15:40:34 <x9c4> no... Let's not make it "no way back" until we are there.
15:40:51 <x9c4> We can disinclude it from all.
15:41:06 <fao89> +1
15:41:13 <mikedep333> I think we can drop it now. No plugins that use Travis will be able to use it for very long.
15:41:29 <fao89> good point!
15:41:37 <daviddavis> I would prefer to wait
15:41:48 <x9c4> Travis is not going to change the way it's going to be used.
15:42:06 <daviddavis> yea, wait until everything's running on GHA and then drop it
15:42:07 <x9c4> And we should not force community plugins to move right now.
15:42:08 <fao89> maybe we don't have the wait option, we don't know when travis will change our plan
15:42:11 <ggainey> if we hit a showstopper w/github, we *could* continue with Travis - we'd just have to hold bake-sales to pay for it for a while :)
15:42:26 <daviddavis> ha yea
15:42:27 <x9c4> xactly
15:42:43 <daviddavis> to be clear
15:42:52 <ggainey> so my $0.02US is wait till we're up and running on actions
15:42:55 <mikedep333> I guess some community plugins will use so few minutes, they'll be OK.
15:42:55 <daviddavis> if you look at dalley's pr his changes live alongside Travis files
15:43:09 <mikedep333> But we can also count our community plugins with one hand.
15:43:18 <daviddavis> agreed
15:43:21 <ggainey> aye
15:43:30 <daviddavis> I just want to make sure github actions is up and running before we drop travis support
15:43:31 <fao89> what happens if travis change our plan tomorrow?
15:43:38 <x9c4> I mean potential ones we don't know about.
15:43:47 <x9c4> that don't live in the pulp org
15:43:48 <ggainey> fao89: then we have an emergency
15:43:58 <fao89> we use 8000 minutes week
15:44:16 <daviddavis> fao89: to be clear we're not delaying moving to github actions
15:44:23 <daviddavis> we're just not dropping the travis code until we've moved
15:44:38 <fao89> gotcha!
15:44:41 <x9c4> until then and a bit
15:44:44 <daviddavis> +1
15:44:57 <fao89> +1
15:45:16 <ggainey> +1
15:45:31 <dalley> +1
15:45:45 <mikedep333> +1
15:45:52 <x9c4> +1
15:45:55 <fao89> I'll start triage, unless someone wants to bring another topic
15:46:29 <fao89> !next
15:46:30 <fao89> #topic https://pulp.plan.io/issues/7838
15:46:31 <pulpbot> fao89: 3 issues left to triage: 7838, 7836, 7796
15:46:32 <pulpbot> RM 7838 - mdellweg - NEW - file publication reports wrong manifest if custom manifest is used
15:46:33 <pulpbot> https://pulp.plan.io/issues/7838
15:46:55 <fao89> #idea Proposed for #7838: Leave the issue as-is, accepting its current state.
15:46:55 <fao89> !propose accept
15:46:55 <pulpbot> fao89: Proposed for #7838: Leave the issue as-is, accepting its current state.
15:47:01 <ggainey> oo, interesting
15:47:12 <ggainey> +1
15:47:20 <daviddavis> +1
15:47:38 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:47:38 <fao89> !accept
15:47:39 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:47:39 <fao89> #topic https://pulp.plan.io/issues/7836
15:47:40 <pulpbot> fao89: 2 issues left to triage: 7836, 7796
15:47:41 <pulpbot> RM 7836 - ggainey - NEW - Import fails when ArtifactResource.json has blank checksums
15:47:42 <pulpbot> https://pulp.plan.io/issues/7836
15:47:50 <ggainey> oh right
15:48:00 <ggainey> found this while testing fips/checksum workflows
15:48:16 <x9c4> +1
15:48:27 <fao89> #idea Proposed for #7836: accept and add to sprint
15:48:27 <fao89> !propose other accept and add to sprint
15:48:27 <pulpbot> fao89: Proposed for #7836: accept and add to sprint
15:48:34 <ggainey> we're mtg this afternon if anyone is interested
15:48:38 <ggainey> yes please
15:48:44 <x9c4> +1
15:49:09 <fao89> #agreed accept and add to sprint
15:49:09 <fao89> !accept
15:49:09 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:49:10 <fao89> #topic https://pulp.plan.io/issues/7796
15:49:10 <pulpbot> fao89: 1 issues left to triage: 7796
15:49:11 <pulpbot> RM 7796 - tosif.meman@kindredgroup.com - NEW - Pulp Version 2.20 - Mongod and pulp_celerybeat failing randomly
15:49:12 <pulpbot> https://pulp.plan.io/issues/7796
15:49:28 <daviddavis> close out?
15:49:36 <daviddavis> or wait longer?
15:50:04 <daviddavis> I'll close it out
15:50:05 <ggainey> we have nothing from the user, it's an old version of pulp2, and it's "when mongo breaks things get odd" - I'd close
15:50:08 <ggainey> yeah
15:50:11 <daviddavis> ok
15:50:25 <fao89> #idea Proposed for #7796: close out
15:50:25 <fao89> !propose other close out
15:50:25 <pulpbot> fao89: Proposed for #7796: close out
15:50:26 <bmbouter> yup
15:50:29 <fao89> #agreed close out
15:50:29 <fao89> !accept
15:50:30 <pulpbot> fao89: Current proposal accepted: close out
15:50:31 <pulpbot> fao89: No issues to triage.
15:50:45 <fao89> #endmeeting
15:50:45 <fao89> !end