15:31:38 <fao89> #startmeeting Pulp Triage 2020-11-24
15:31:38 <fao89> #info fao89 has joined triage
15:31:38 <fao89> !start
15:31:38 <pulpbot> Meeting started Tue Nov 24 15:31:38 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:38 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:31:38 <pulpbot> The meeting name has been set to 'pulp_triage_2020-11-24'
15:31:38 <pulpbot> fao89: fao89 has joined triage
15:32:17 <daviddavis> #info daviddavis has joined triage
15:32:17 <daviddavis> !here
15:32:17 <pulpbot> daviddavis: daviddavis has joined triage
15:32:25 <fao89> Open floor!
15:32:35 <ttereshc> #info ttereshc has joined triage
15:32:35 <ttereshc> !here
15:32:35 <pulpbot> ttereshc: ttereshc has joined triage
15:32:40 <fao89> https://hackmd.io/@pulp/triage/edit the agenda is empty
15:32:48 <daviddavis> D:
15:32:54 <fao89> but we have lots of issues at triage query
15:32:58 <daviddavis> great
15:33:23 <fao89> I just need one more person to join, so we can move to triage
15:34:03 <dalley> #info dalley has joined triage
15:34:03 <dalley> !here
15:34:03 <pulpbot> dalley: dalley has joined triage
15:34:14 <fao89> https://pulp.plan.io/issues?query_id=143
15:34:37 <fao89> !next
15:34:38 <pulpbot> fao89: 12 issues left to triage: 7890, 7888, 7878, 7875, 7867, 7857, 7856, 7854, 7853, 7848, 7845, 7835
15:34:38 <fao89> #topic https://pulp.plan.io/issues/7890
15:34:39 <pulpbot> RM 7890 - daviddavis - ASSIGNED - Unskip broken filesystem exporter test
15:34:40 <pulpbot> https://pulp.plan.io/issues/7890
15:34:41 <ipanova> #info ipanova has joined triage
15:34:41 <ipanova> !here
15:34:42 <pulpbot> ipanova: ipanova has joined triage
15:34:58 <daviddavis> task
15:35:01 <fao89> #idea Proposed for #7890: Leave the issue as-is, accepting its current state.
15:35:01 <fao89> !propose accept
15:35:01 <pulpbot> fao89: Proposed for #7890: Leave the issue as-is, accepting its current state.
15:35:12 <ttereshc> +1 to task and accept
15:35:24 <fao89> #idea Proposed for #7890: convert to task
15:35:24 <fao89> !propose other convert to task
15:35:24 <pulpbot> fao89: Proposed for #7890: convert to task
15:35:30 <fao89> #agreed convert to task
15:35:30 <fao89> !accept
15:35:30 <pulpbot> fao89: Current proposal accepted: convert to task
15:35:31 <fao89> #topic https://pulp.plan.io/issues/7888
15:35:31 <pulpbot> fao89: 10 issues left to triage: 7888, 7878, 7867, 7857, 7856, 7854, 7853, 7848, 7845, 7835
15:35:32 <pulpbot> RM 7888 - equipe_serveurs@exane.com - POST - Can't update Fields through Rest API We pages (PUT requests)
15:35:33 <pulpbot> https://pulp.plan.io/issues/7888
15:35:37 <bmbouter> #info bmbouter has joined triage
15:35:37 <bmbouter> !here
15:35:37 <pulpbot> bmbouter: bmbouter has joined triage
15:35:43 <daviddavis> accept?
15:35:53 <fao89> #idea Proposed for #7888: Leave the issue as-is, accepting its current state.
15:35:53 <fao89> !propose accept
15:35:53 <pulpbot> fao89: Proposed for #7888: Leave the issue as-is, accepting its current state.
15:35:54 <ipanova> daviddavis: there is a pr up if you can take a look also
15:36:15 <bmbouter> daviddavis: I was unsure about all this
15:36:23 <daviddavis> I'm probably not a good person to review this. I don't use the html stuff.
15:36:50 <daviddavis> but I can try to take a look if no one else can
15:36:56 <ipanova> we initially thought this pr is  from the students
15:37:12 <daviddavis> I don't think so. this person is based in Paris.
15:37:19 <bmbouter> oh I said that it's my mistake
15:37:24 <bmbouter> I thought student team
15:37:25 <dalley> yeah, it's from a bank
15:37:31 <bmbouter> so this is significant enough that we need to be sure
15:37:41 <mikedep333> #info mikedep333 has joined triage
15:37:41 <mikedep333> !here
15:37:41 <pulpbot> mikedep333: mikedep333 has joined triage
15:37:54 <bmbouter> I'm happy to get on a call for 15-30 min to at least talk it over with anyone else
15:38:35 <fao89> I can be the rubber duck
15:39:21 <bmbouter> sold to me and fabricio!
15:39:40 <fao89> should I accept?
15:39:42 <fao89> or skip?
15:40:33 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:40:33 <fao89> !accept
15:40:33 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:40:34 <fao89> #topic https://pulp.plan.io/issues/7878
15:40:34 <pulpbot> fao89: 9 issues left to triage: 7878, 7867, 7857, 7856, 7854, 7853, 7848, 7845, 7835
15:40:36 <pulpbot> RM 7878 - daviddavis - POST - Developer setup still refers to pulplift
15:40:37 <pulpbot> https://pulp.plan.io/issues/7878
15:40:47 <daviddavis> accept and add to sprint
15:40:54 <bmbouter> +1
15:40:57 <ttereshc> +1
15:40:59 <ipanova> +1
15:41:11 <fao89> #idea Proposed for #7878: accept and add to sprint
15:41:11 <fao89> !propose other accept and add to sprint
15:41:11 <pulpbot> fao89: Proposed for #7878: accept and add to sprint
15:41:11 <fao89> #agreed accept and add to sprint
15:41:11 <fao89> !accept
15:41:12 <fao89> #topic https://pulp.plan.io/issues/7867
15:41:12 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:41:13 <pulpbot> fao89: 8 issues left to triage: 7867, 7857, 7856, 7854, 7853, 7848, 7845, 7835
15:41:14 <pulpbot> RM 7867 - tosif.meman@kindredgroup.com - NEW - Issue #7796 : Pulp Version 2.20 - Mongod and pulp_celerybeat failing randomly
15:41:15 <pulpbot> https://pulp.plan.io/issues/7867
15:42:27 <fao89> skip?
15:42:48 <ttereshc> we need to add pulp 2 tag at least
15:43:26 <ttereshc> skipping it doesn't help I think...
15:43:39 <ttereshc> dalley, bmbouter, any thoughts on the issue?
15:43:59 <ipanova> they have lock on the mongo
15:44:06 <dalley> bmbouter, is this the one you were already looking into?
15:44:33 <ipanova> they need to remove lock and  repair their db
15:45:23 <bmbouter> yeah they should cancel all their tasks
15:45:31 <bmbouter> and I gotta make this patch today for pulp2
15:45:48 <bmbouter> but it won't help them until it's released and that prevents it occuring again
15:45:59 <bmbouter> I can post on this issue explaining for them to cancell all tasks
15:46:15 <fao89> so what should I do? accept the issue?
15:46:28 <ipanova> bmbouter: ty, should we also put it on the sprint? or just accept
15:46:31 <bmbouter> although ... is this the same issue?
15:46:41 <bmbouter> well maybe neither I'm already fixing it as another issue
15:47:23 <fao89> I will skip it then
15:47:36 <ipanova> #idea Proposed for #7867: bmbouter will comment on the issue and close as dup if necessary
15:47:36 <ipanova> !propose other bmbouter will comment on the issue and close as dup if necessary
15:47:36 <pulpbot> ipanova: Proposed for #7867: bmbouter will comment on the issue and close as dup if necessary
15:47:43 <bmbouter> https://pulp.plan.io/issues/5502
15:47:51 <bmbouter> so I don't think this is realted
15:47:53 <fao89> #agreed bmbouter will comment on the issue and close as dup if necessary
15:47:53 <fao89> !accept
15:47:53 <pulpbot> fao89: Current proposal accepted: bmbouter will comment on the issue and close as dup if necessary
15:47:55 <fao89> #topic https://pulp.plan.io/issues/7857
15:47:55 <pulpbot> fao89: 7 issues left to triage: 7857, 7856, 7854, 7853, 7848, 7845, 7835
15:47:56 <pulpbot> RM 7857 - jsherril@redhat.com - NEW - 502 proxy error when trying to yum install a package
15:47:57 <pulpbot> https://pulp.plan.io/issues/7857
15:48:10 <bmbouter> I don't have any info to give that user
15:48:19 <bmbouter> can we go back
15:48:31 <ipanova> bmbouter: i agree they are not related
15:49:05 <daviddavis> could this be related to django-cleanup?
15:49:27 <bmbouter> for 7796?
15:49:28 <fao89> I don't know if it is possible to go back
15:49:39 <dalley> I think so daviddavis
15:49:41 <daviddavis> no 7857
15:49:45 <dalley> it's at least a good guess
15:49:58 <daviddavis> yea
15:50:28 <bmbouter> re 7867, I think I will just link the user to https://docs.mongodb.com/manual/tutorial/transparent-huge-pages/
15:50:45 <bmbouter> when using mongo they should not have that system option enabled
15:50:55 <bmbouter> also I'll encourage them to switch to pulp3
15:51:08 <ttereshc> we might have this recommendation in our docs
15:51:08 <fao89> +1
15:51:13 <bmbouter> we do
15:51:17 <bmbouter> I'll link there too
15:51:29 <bmbouter> I'll leave it open tho for 1 more week or close it?
15:51:49 <bmbouter> actually I recommend close it, they can repost if necessary, pulp2 is maint mode
15:51:55 <ipanova> bmbouter: close
15:51:56 <ttereshc> bmbouter, https://docs.pulpproject.org/en/2.21/user-guide/installation/index.html?highlight=huge
15:52:05 <fao89> +1
15:53:14 <fao89> for 7857, should I accpet and add to sprint?
15:54:34 <ttereshc> I think we can only encourage to upgrade and see if the issue stays
15:54:35 <fao89> #idea Proposed for #7857: Leave the issue as-is, accepting its current state.
15:54:35 <fao89> !propose accept
15:54:35 <pulpbot> fao89: Proposed for #7857: Leave the issue as-is, accepting its current state.
15:54:53 <bmbouter> what is the resolution do we think for 7857
15:54:53 <ttereshc> how far did we backport django-cleanup?
15:55:03 <bmbouter> great question!
15:55:08 <bmbouter> you always have those great questions
15:55:09 <ttereshc> I think all the way
15:55:34 <ttereshc> so I'd suggest to upgrade katello to the latest 3.6
15:55:38 <fao89> ttereshc++
15:55:38 <pulpbot> fao89: ttereshc's karma is now 255
15:55:42 <ttereshc> :)
15:55:58 <ipanova> i think have backported to 3.7.3
15:56:38 <fao89> #idea Proposed for #7857: accept and add to sprint
15:56:38 <fao89> !propose other accept and add to sprint
15:56:39 <pulpbot> fao89: Proposed for #7857: accept and add to sprint
15:57:04 <daviddavis> yes django-cleanup was never in 3.6
15:57:11 <daviddavis> so this predates django-cleanup
15:57:18 <daviddavis> django-cleanup was added in 3.7
15:57:44 <ttereshc> ok, so then the reason is different :/
15:58:06 <daviddavis> yup
15:58:27 <daviddavis> from comment 1 it sounds like they upgraded
15:58:30 <daviddavis> from pulp 2
15:58:39 <daviddavis> err no wait
15:58:50 <daviddavis> they have pulp-server-2.21.4
15:58:56 <daviddavis> but it's maybe not an upgrade
15:59:26 <fao89> we have 6 more issues to triage
15:59:28 <ttereshc> daviddavis, so rpm stuff is pulp 2 here, docker and file are pulp3
15:59:28 <daviddavis> we can accept but I'm stumped as to how to approach this
15:59:51 <ipanova> i don't know how  we'd reproduce this
16:00:04 <ipanova> i feel like there is not enough info
16:00:09 <bmbouter> so is this a mixed environment?
16:00:12 <bmbouter> pulp2/pulp3
16:00:21 <ttereshc> so they can have only fresh install for rpm and not migration
16:00:26 <bmbouter> I guess that's how katello runs maybe?
16:00:49 <daviddavis> I believe so
16:01:15 <ttereshc> yeah
16:01:30 <bmbouter> ack
16:01:38 <ttereshc> ipanova, I agree there is not enough info to reproduce but I'mnot sure what to ask for
16:02:18 <ipanova> yeah
16:02:53 <ipanova> is there a change they have upgraded from 3.6 to a version in between that had django-cleanup
16:03:02 <ipanova> s/change/chance
16:03:08 <ttereshc> #idea Proposed for #7857: skip, ttereshc will ask jsherrill about the setup
16:03:08 <ttereshc> !propose other skip, ttereshc will ask jsherrill about the setup
16:03:08 <pulpbot> ttereshc: Proposed for #7857: skip, ttereshc will ask jsherrill about the setup
16:03:20 <fao89> #agreed skip, ttereshc will ask jsherrill about the setup
16:03:20 <fao89> !accept
16:03:20 <pulpbot> fao89: Current proposal accepted: skip, ttereshc will ask jsherrill about the setup
16:03:21 <pulpbot> fao89: 6 issues left to triage: 7856, 7854, 7853, 7848, 7845, 7835
16:03:22 <fao89> #topic https://pulp.plan.io/issues/7856
16:03:22 <pulpbot> RM 7856 - ggainey - NEW - FIPS: Plugin-author doc needs to talk about ALLOWED_CHECKSUMS and Artifact.DIGEST_FIELDS
16:03:24 <pulpbot> https://pulp.plan.io/issues/7856
16:03:44 <daviddavis> convert to task?
16:03:50 <ttereshc> +1
16:03:54 <fao89> #idea Proposed for #7856: convert to task
16:03:54 <fao89> !propose other convert to task
16:03:54 <pulpbot> fao89: Proposed for #7856: convert to task
16:04:03 <fao89> #agreed convert to task
16:04:03 <fao89> !accept
16:04:03 <pulpbot> fao89: Current proposal accepted: convert to task
16:04:03 <fao89> #topic https://pulp.plan.io/issues/7854
16:04:04 <pulpbot> fao89: 5 issues left to triage: 7854, 7853, 7848, 7845, 7835
16:04:05 <pulpbot> RM 7854 - ggainey - NEW - FIPS: QueryExistingArtifacts stage needs to enforce ALLOWED_ALGORITHMS
16:04:06 <pulpbot> https://pulp.plan.io/issues/7854
16:04:22 <daviddavis> task?
16:04:39 <fao89> #idea Proposed for #7854: convert to task
16:04:39 <fao89> !propose other convert to task
16:04:39 <pulpbot> fao89: Proposed for #7854: convert to task
16:04:57 <fao89> #agreed convert to task
16:04:57 <fao89> !accept
16:04:57 <pulpbot> fao89: Current proposal accepted: convert to task
16:04:58 <fao89> #topic https://pulp.plan.io/issues/7853
16:04:58 <pulpbot> fao89: 4 issues left to triage: 7853, 7848, 7845, 7835
16:04:59 <pulpbot> RM 7853 - ggainey - NEW - FIPS: downloader needs to notice if expected-digest-algorithm is FORBIDDEN
16:05:00 <pulpbot> https://pulp.plan.io/issues/7853
16:05:42 <fao89> #idea Proposed for #7853: convert to task
16:05:42 <fao89> !propose other convert to task
16:05:42 <pulpbot> fao89: Proposed for #7853: convert to task
16:06:03 <ttereshc> no preference, can be both task or issue, imo
16:06:10 <ttereshc> depends how to look at it :)
16:06:32 <daviddavis> me too
16:06:47 <ipanova> yep
16:07:01 <fao89> he put a hackmd, I think he wanted to discuss
16:07:29 <daviddavis> the hackmd was from the discussion we already had
16:07:44 <fao89> #agreed convert to task
16:07:44 <fao89> !accept
16:07:44 <pulpbot> fao89: Current proposal accepted: convert to task
16:07:44 <fao89> #topic https://pulp.plan.io/issues/7848
16:07:45 <pulpbot> fao89: 3 issues left to triage: 7848, 7845, 7835
16:07:46 <pulpbot> RM 7848 - daviddavis - NEW - credentials.enc file not being used
16:07:47 <pulpbot> https://pulp.plan.io/issues/7848
16:08:16 <daviddavis> let's skip. I think we'll end up deleting .travis directories eventually and this will go away.
16:08:16 <ipanova> hmmm
16:08:25 <ipanova> daviddavis: +1
16:08:25 <bmbouter> that sounds good
16:08:29 <fao89> !skip
16:08:30 <fao89> #topic https://pulp.plan.io/issues/7845
16:08:30 <pulpbot> fao89: 2 issues left to triage: 7845, 7835
16:08:31 <ttereshc> +1
16:08:32 <pulpbot> RM 7845 - mdellweg - ASSIGNED - The view_set parameter on AccessPolicy is not namespacing plugins
16:08:33 <pulpbot> https://pulp.plan.io/issues/7845
16:08:58 <fao89> #idea Proposed for #7845: accept and add to sprint
16:08:58 <fao89> !propose other accept and add to sprint
16:08:58 <pulpbot> fao89: Proposed for #7845: accept and add to sprint
16:09:17 <daviddavis> +1
16:09:18 <ttereshc> is it a plugin api change/feature?
16:09:26 <ttereshc> or is it a bugfix?
16:09:45 <daviddavis> a bit of both?
16:10:01 <daviddavis> it could certainly lead to bugs
16:10:16 <ttereshc> we don't have this flavour yet :)
16:10:22 <ttereshc> ok, +1 to accept
16:10:26 <bmbouter> x9c4: didn't this get addressed i nyour PR?
16:10:53 <bmbouter> https://github.com/pulp/pulpcore/pull/1029
16:11:14 <daviddavis> that pr is for this issue
16:11:28 <daviddavis> or at least it has CHANGES/7845.bugfix
16:11:30 <x9c4> Yes. but pulpbot didn't revisit the pr.
16:11:43 <daviddavis> pro tip: if you delete the commit, it will revisit the pr
16:11:59 <daviddavis> s/commit/comment/
16:12:01 <fao89> #agreed accept and add to sprint
16:12:01 <fao89> !accept
16:12:01 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
16:12:02 <fao89> #topic https://pulp.plan.io/issues/7835
16:12:02 <pulpbot> fao89: 1 issues left to triage: 7835
16:12:03 <pulpbot> RM 7835 - ipanova@redhat.com - NEW - Repair feature should remove unrepairable corrupted file
16:12:04 <pulpbot> https://pulp.plan.io/issues/7835
16:12:22 <bmbouter> I think this is right
16:12:31 <ttereshc> it's a story
16:12:37 <bmbouter> agreed
16:12:40 <x9c4> daviddavis++
16:12:40 <pulpbot> x9c4: daviddavis's karma is now 399
16:12:45 <fao89> #idea Proposed for #7835: convert to story
16:12:45 <fao89> !propose other convert to story
16:12:45 <pulpbot> fao89: Proposed for #7835: convert to story
16:12:59 <ipanova> +1
16:13:02 <fao89> #agreed convert to story
16:13:02 <fao89> !accept
16:13:02 <pulpbot> fao89: Current proposal accepted: convert to story
16:13:03 <pulpbot> fao89: No issues to triage.
16:13:19 <daviddavis> +1
16:13:28 <fao89> #endmeeting
16:13:28 <fao89> !end