15:30:27 <fao89> #startmeeting Pulp Triage 2020-12-11
15:30:27 <fao89> #info fao89 has joined triage
15:30:27 <fao89> !start
15:30:27 <pulpbot> Meeting started Fri Dec 11 15:30:27 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:27 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:27 <pulpbot> The meeting name has been set to 'pulp_triage_2020-12-11'
15:30:27 <pulpbot> fao89: fao89 has joined triage
15:31:57 <ggainey> #info ggainey has joined triage
15:31:57 <ggainey> !here
15:31:57 <pulpbot> ggainey: ggainey has joined triage
15:31:58 <daviddavis> #info daviddavis has joined triage
15:31:58 <daviddavis> !here
15:31:58 <pulpbot> daviddavis: daviddavis has joined triage
15:31:58 <x9c4> #info x9c4 has joined triage
15:31:58 <x9c4> !here
15:31:59 <pulpbot> x9c4: x9c4 has joined triage
15:32:02 <dalley> #info dalley has joined triage
15:32:02 <dalley> !here
15:32:02 <pulpbot> dalley: dalley has joined triage
15:32:37 <ttereshc> #info ttereshc has joined triage
15:32:37 <ttereshc> !here
15:32:37 <pulpbot> ttereshc: ttereshc has joined triage
15:33:03 <fao89> no items for open floor
15:33:08 <ipanova> #info ipanova has joined triage
15:33:08 <ipanova> !here
15:33:08 <pulpbot> ipanova: ipanova has joined triage
15:33:17 <ttereshc> Happy Christmas Jumper Day
15:33:20 <fao89> moving to triage
15:33:44 <daviddavis> hehe
15:34:14 * fao89 is googling
15:34:15 <ppicka> #info ppicka has joined triage
15:34:15 <ppicka> !here
15:34:15 <pulpbot> ppicka: ppicka has joined triage
15:34:34 <fao89> !next
15:34:35 <fao89> #topic https://pulp.plan.io/issues/7982
15:34:35 <pulpbot> fao89: 9 issues left to triage: 7982, 7980, 7963, 7960, 7958, 7953, 7951, 7950, 7947
15:34:36 <pulpbot> RM 7982 - dalley - NEW - "`Correlation-ID` was not found in the incoming request. Generated new GUID"  log messages are spammy
15:34:37 <pulpbot> https://pulp.plan.io/issues/7982
15:34:51 <ipanova> heh
15:34:55 <fao89> #idea Proposed for #7982: Leave the issue as-is, accepting its current state.
15:34:55 <fao89> !propose accept
15:34:55 <pulpbot> fao89: Proposed for #7982: Leave the issue as-is, accepting its current state.
15:35:04 <daviddavis> I'm not sure what the solution is?
15:35:09 <ttereshc> is it a suggestion to provide different default configuraiton?
15:35:14 <dalley> daviddavis, log as debug
15:35:16 <ggainey> mark them as DEBUG
15:35:22 <ipanova> daviddavis: i think you can link to the line of code from django
15:35:40 <daviddavis> dalley: they come from django-guid not our code
15:35:46 <ggainey> oh
15:35:49 <daviddavis> I can try to open an upstream message?
15:35:49 <ggainey> sigh
15:36:10 <ipanova> daviddavis: we can try at least?
15:36:20 <ttereshc> daviddavis, what about disabling the validation? or what was the conf for guid
15:36:38 <daviddavis> that won't stop this message
15:36:47 <ttereshc> oh ok
15:37:31 <fao89> how about: logging.getLogger('django-guid').setLevel(logging.DEBUG)
15:37:34 <daviddavis> even if they do fix this, I doubt they will backport it to django-guid 2 (which is the compatible version for django 2)
15:38:00 <x9c4> https://django-guid.readthedocs.io/en/latest/README_PYPI.html?highlight=warning#django-guid-logger-optional
15:38:18 <fao89> x9c4++
15:38:18 <pulpbot> fao89: x9c4's karma is now 85
15:38:18 <daviddavis> that works
15:38:36 <ipanova> nice
15:38:36 <x9c4> Is that the right logger to configure?
15:39:15 <daviddavis> maybe?
15:39:24 <daviddavis> I'm not an expert at logging in python/django
15:39:29 <dalley> we can try it
15:39:30 <ipanova> i left this link in the comment on the issue, lets accept and put on the sprint?
15:39:32 <ggainey> x9c4: let's add that to the issue
15:39:38 <ggainey> ipanova++
15:39:38 <pulpbot> ggainey: ipanova's karma is now 159
15:39:40 <dalley> +1
15:39:43 <x9c4> ipanova++
15:39:43 <pulpbot> x9c4: ipanova's karma is now 160
15:39:47 <x9c4> +1
15:39:49 <daviddavis> +1
15:40:01 <ttereshc> +1
15:40:32 <fao89> #idea Proposed for #7982: accept and add to sprint
15:40:32 <fao89> !propose other accept and add to sprint
15:40:32 <pulpbot> fao89: Proposed for #7982: accept and add to sprint
15:40:38 <ggainey> +1
15:40:53 <x9c4> do we want to backport it to 3.9?
15:40:56 <fao89> #agreed accept and add to sprint
15:40:56 <fao89> !accept
15:40:56 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:40:57 <pulpbot> fao89: 8 issues left to triage: 7980, 7963, 7960, 7958, 7953, 7951, 7950, 7947
15:40:57 <fao89> #topic https://pulp.plan.io/issues/7980
15:40:58 <pulpbot> RM 7980 - daviddavis - ASSIGNED - The state for canceled tasks is set to failed
15:40:59 <pulpbot> https://pulp.plan.io/issues/7980
15:41:10 <ggainey> accept and add
15:41:17 <x9c4> +1
15:41:24 <daviddavis> +1
15:41:25 <ttereshc> +1
15:41:29 <ppicka> +1
15:41:30 <fao89> #idea Proposed for #7980: accept and add to sprint
15:41:30 <fao89> !propose other accept and add to sprint
15:41:30 <pulpbot> fao89: Proposed for #7980: accept and add to sprint
15:41:32 <fao89> #agreed accept and add to sprint
15:41:32 <fao89> !accept
15:41:32 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:41:33 <fao89> #topic https://pulp.plan.io/issues/7963
15:41:33 <pulpbot> fao89: 7 issues left to triage: 7963, 7960, 7958, 7953, 7951, 7950, 7947
15:41:35 <pulpbot> RM 7963 - daviddavis - NEW - Distribution filter help text is not helpful
15:41:36 <pulpbot> https://pulp.plan.io/issues/7963
15:41:44 <ttereshc> :)
15:41:45 <daviddavis> this was feedback from wibbit
15:41:47 <ttereshc> nice title
15:42:03 <daviddavis> hehe
15:42:14 <daviddavis> accept?
15:42:15 <ttereshc> add to our next docs day?
15:42:16 <ipanova> accept?
15:42:24 <fao89> #idea Proposed for #7963: Leave the issue as-is, accepting its current state.
15:42:24 <fao89> !propose accept
15:42:24 <pulpbot> fao89: Proposed for #7963: Leave the issue as-is, accepting its current state.
15:42:28 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:42:28 <fao89> !accept
15:42:28 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:42:29 <fao89> #topic https://pulp.plan.io/issues/7960
15:42:29 <ipanova> ttereshc: some time in middle of january i think
15:42:30 <pulpbot> fao89: 6 issues left to triage: 7960, 7958, 7953, 7951, 7950, 7947
15:42:31 <ggainey> +1
15:42:31 <pulpbot> RM 7960 - daviddavis - NEW - FIPS and support for ALLOWED_CONTENT_CHECKSUMS
15:42:32 <pulpbot> https://pulp.plan.io/issues/7960
15:42:37 <daviddavis> ttereshc: +1
15:42:43 <ipanova> i don't think we have discussed this topic yet ttereshc
15:42:54 <daviddavis> oh this is a story
15:43:08 <ggainey> yeah - or a task
15:43:12 <ttereshc> an epic story!
15:43:16 <fao89> #idea Proposed for #7960: convert to story
15:43:16 <fao89> !propose other convert to story
15:43:16 <pulpbot> fao89: Proposed for #7960: convert to story
15:43:18 <ggainey> indeed!
15:43:21 <ggainey> +1
15:43:23 <ttereshc> +1
15:43:38 <fao89> #agreed convert to story
15:43:38 <fao89> !accept
15:43:38 <pulpbot> fao89: Current proposal accepted: convert to story
15:43:39 <fao89> #topic https://pulp.plan.io/issues/7958
15:43:39 <pulpbot> fao89: 5 issues left to triage: 7958, 7953, 7951, 7950, 7947
15:43:40 <pulpbot> RM 7958 - deepthireddy21 - NEW - Last Modified header not updated on repodata updates
15:43:41 <pulpbot> https://pulp.plan.io/issues/7958
15:43:54 <ggainey> oh god
15:44:17 <ggainey> this is pulp2, and turns out our ETag header has been wrong/not-useful since forever
15:44:23 <ggainey> which can break caching proxies
15:44:32 <dkliban> i don't think we are going to fix this one
15:44:34 <dkliban> #info dkliban has joined triage
15:44:34 <dkliban> !here
15:44:34 <pulpbot> dkliban: dkliban has joined triage
15:44:51 <ttereshc> +1 for not fixing it
15:44:54 <ggainey> dkliban: esp since there *is* a workaround
15:44:58 <dkliban> yep
15:44:59 <ttereshc> yup
15:45:15 <ttereshc> can we have a similar problem in pulp3?
15:45:22 <ggainey> want me to add the "There is a workaround and Pulp2 is in critical-maintenance-only mode - WONTFIX"?
15:45:30 <ggainey> we should def check to see what Pulp3 does
15:45:44 <ipanova> ggainey: +1 on ticket resolution
15:45:50 <dkliban> +1
15:46:01 <ggainey> ok, I'll take that as an AI
15:46:46 <x9c4> We don't have etags on pulp3
15:47:07 <x9c4> not sure about if_modified_since.
15:47:18 <ttereshc> I thought it's about enabling them in apache, no?
15:47:56 <x9c4> i believe it would at least need a django middleware
15:48:08 <dkliban> yeah ... i think it's a middleware
15:48:13 <ttereshc> ok
15:48:17 <x9c4> you can get the last modified only from the db
15:48:30 <ttereshc> that's riight
15:48:38 <ttereshc> pulp3! :)
15:48:55 <fao89> what should I do? skip? close?
15:49:11 <ttereshc> ggainey will close it seems
15:49:18 <dkliban> skip for now ... ggainey is going to close it
15:49:18 <ggainey> fao89: yeah, I'm on it
15:49:22 <ggainey> +1
15:49:28 <x9c4> ggainey++
15:49:28 <pulpbot> x9c4: ggainey's karma is now 74
15:49:55 <ggainey> and done, next?
15:50:17 <fao89> !skip
15:50:17 <fao89> #topic https://pulp.plan.io/issues/7953
15:50:18 <pulpbot> fao89: 4 issues left to triage: 7953, 7951, 7950, 7947
15:50:19 <pulpbot> RM 7953 - bmbouter - NEW - Release 1.5.0
15:50:20 <pulpbot> https://pulp.plan.io/issues/7953
15:50:31 <ggainey> task?
15:50:32 <daviddavis> convert to task
15:50:33 <dkliban> yes
15:50:35 <daviddavis> yesh
15:50:38 <fao89> #idea Proposed for #7953: convert to task
15:50:38 <fao89> !propose other convert to task
15:50:38 <pulpbot> fao89: Proposed for #7953: convert to task
15:50:42 <ggainey> +1
15:50:47 <ttereshc> who plans to do the release?
15:50:52 <dkliban> i am going to do it
15:50:54 <ttereshc> do we need a volunteer?
15:50:57 <ttereshc> ah ok
15:50:59 <ttereshc> ty
15:51:07 <ggainey> dkliban++
15:51:07 <pulpbot> ggainey: dkliban's karma is now 564
15:51:07 <fao89> #agreed convert to task
15:51:07 <fao89> !accept
15:51:08 <pulpbot> fao89: Current proposal accepted: convert to task
15:51:08 <fao89> #topic https://pulp.plan.io/issues/7951
15:51:09 <pulpbot> fao89: 3 issues left to triage: 7951, 7950, 7947
15:51:10 <pulpbot> RM 7951 - newswangerd - NEW - Backport 7907
15:51:11 <pulpbot> https://pulp.plan.io/issues/7951
15:51:16 <ggainey> accept and add
15:51:28 <ipanova> +1
15:51:53 <x9c4> Is there a migration?
15:51:56 <ttereshc> no
15:52:08 <x9c4> +1
15:52:11 <ttereshc> but I believe any accepted backport requires a volunteer to do a release
15:52:37 <ipanova> should we put this topic for the pulpcore team meeting?
15:52:41 <dkliban> +1
15:52:46 <daviddavis> I'll do it
15:52:49 <ipanova> i will do it
15:52:55 <ipanova> ok, daviddavis will do it
15:52:56 <ttereshc> no, I will do it then
15:53:00 <daviddavis> add it as topic that is
15:53:00 <ipanova> :D
15:53:02 <dkliban> lol
15:53:05 <daviddavis> hehe
15:53:16 <ggainey> *so* many volunteers :)
15:53:17 <x9c4> I can do it. Do we need to backport it to more than one branch?
15:53:19 <ttereshc> do we kno wwhen they need it?
15:53:33 <ttereshc> x9c4, they mentioned 3.7
15:53:33 <fao89> #idea Proposed for #7951: accept and add to sprint
15:53:33 <fao89> !propose other accept and add to sprint
15:53:34 <pulpbot> fao89: Proposed for #7951: accept and add to sprint
15:53:40 <fao89> #agreed accept and add to sprint
15:53:40 <fao89> !accept
15:53:40 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:53:40 <fao89> #topic https://pulp.plan.io/issues/7950
15:53:41 <pulpbot> fao89: 2 issues left to triage: 7950, 7947
15:53:42 <pulpbot> RM 7950 - newswangerd - NEW - Backport 7912
15:53:43 <pulpbot> https://pulp.plan.io/issues/7950
15:53:47 <x9c4> so do we need it on 3.8 too?
15:54:06 <ipanova> only 3.7 i think
15:54:22 <ttereshc> I guess we'll discuss it on the pulpocre meeting
15:54:30 <ipanova> they will upgrade then to the pulpcore that has the fix eventually?
15:54:33 <ttereshc> it's confusing when 3.7 has it and later do not
15:54:41 <ipanova> fao89: do you have more info?
15:54:45 <x9c4> yep
15:55:20 <ttereshc> I'd skip the 7912 because the original fix is not ready yet
15:55:28 <ggainey> yeah, was about to ask about that
15:55:35 <ggainey> +1 to skip
15:56:06 <daviddavis> maybe be worth while to wait though
15:56:11 <daviddavis> so we don't have to backport twice?
15:56:17 <fao89> no I don't, but it is an issue in prod, so if we ask they will say to release soon
15:56:24 <daviddavis> oh
15:56:24 <ttereshc> +1 to wait
15:56:40 <fao89> !skip
15:56:41 <fao89> #topic https://pulp.plan.io/issues/7947
15:56:41 <pulpbot> fao89: 1 issues left to triage: 7947
15:56:42 <pulpbot> RM 7947 - lboclboc - NEW - CI build fails for documentation-only PR
15:56:43 <pulpbot> https://pulp.plan.io/issues/7947
15:57:00 <ttereshc> we can probably close this one
15:57:04 <fao89> I agree
15:57:15 <fao89> both backports need to go together
15:58:01 <ggainey> +1
15:58:44 <fao89> I agree
15:58:50 <ggainey> RE 7947 - we're waiting on OP input - skip?
15:58:50 <fao89> #idea Proposed for #7947: close as worksforme
15:58:50 <fao89> !propose other close as worksforme
15:58:50 <pulpbot> fao89: Proposed for #7947: close as worksforme
15:58:55 <ggainey> ah k
15:59:26 <ttereshc> we couldn't find a PR they were talking about
15:59:26 <x9c4> +1
15:59:30 <ttereshc> and they are quiet
15:59:43 <ttereshc> so if it's still an issue, they can open a new one I htink
16:00:01 <ttereshc> +1 to close
16:00:10 <fao89> and by now, most plugins already released, so the docs issue probably is fixed
16:00:22 <fao89> #agreed close as worksforme
16:00:22 <fao89> !accept
16:00:22 <pulpbot> fao89: Current proposal accepted: close as worksforme
16:00:23 <pulpbot> fao89: No issues to triage.
16:00:29 * ggainey cheers
16:00:33 <fao89> #endmeeting
16:00:33 <fao89> !end