15:30:40 <fao89> #startmeeting Pulp Triage 2021-01-08
15:30:40 <fao89> #info fao89 has joined triage
15:30:40 <fao89> !start
15:30:40 <pulpbot> Meeting started Fri Jan  8 15:30:40 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:40 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:40 <pulpbot> The meeting name has been set to 'pulp_triage_2021-01-08'
15:30:40 <pulpbot> fao89: fao89 has joined triage
15:30:43 <dkliban> #info dkliban has joined triage
15:30:43 <dkliban> !here
15:30:43 <pulpbot> dkliban: dkliban has joined triage
15:30:47 <ppicka> #info ppicka has joined triage
15:30:47 <ppicka> !here
15:30:47 <pulpbot> ppicka: ppicka has joined triage
15:31:18 <ggainey> #info ggainey has joined triage
15:31:18 <ggainey> !here
15:31:18 <pulpbot> ggainey: ggainey has joined triage
15:31:29 <dalley> #info dalley has joined triage
15:31:29 <dalley> !here
15:31:29 <pulpbot> dalley: dalley has joined triage
15:31:56 <daviddavis> #info daviddavis has joined triage
15:31:56 <daviddavis> !here
15:31:56 <pulpbot> daviddavis: daviddavis has joined triage
15:32:03 <fao89> no items so far
15:32:10 <fao89> should we start the triage?
15:32:31 <dkliban> let's do it
15:32:39 <ggainey> fao89: sure - let's not borrow trouble :)
15:32:52 <fao89> !next
15:32:53 <fao89> #topic https://pulp.plan.io/issues/8052
15:32:53 <pulpbot> fao89: 5 issues left to triage: 8052, 8048, 8047, 8044, 7950
15:32:54 <pulpbot> RM 8052 - pieta - NEW - Some repositories cannot be synchronized with error: Artifact() got an unexpected keyword argument 'sha'
15:32:55 <pulpbot> https://pulp.plan.io/issues/8052
15:33:40 <fao89> #idea Proposed for #8052: move to rpm project
15:33:40 <fao89> !propose other move to rpm project
15:33:40 <pulpbot> fao89: Proposed for #8052: move to rpm project
15:33:49 <dkliban> +1
15:34:02 <daviddavis> +1
15:34:13 <fao89> #agreed move to rpm project
15:34:13 <fao89> !accept
15:34:13 <pulpbot> fao89: Current proposal accepted: move to rpm project
15:34:13 <fao89> #topic https://pulp.plan.io/issues/8048
15:34:14 <pulpbot> fao89: 4 issues left to triage: 8048, 8047, 8044, 7950
15:34:15 <pulpbot> RM 8048 - newswangerd - NEW - Object permissions endpoint breaks for objects with unknown viewsets
15:34:16 <pulpbot> https://pulp.plan.io/issues/8048
15:36:17 <dkliban> hmm
15:36:18 <daviddavis> skip for now until someone with rbac knowledge can weigh in?
15:36:35 <dkliban> i think we should accept and have someone dig into this
15:36:41 <ttereshc> #info ttereshc has joined triage
15:36:41 <ttereshc> !here
15:36:41 <pulpbot> ttereshc: ttereshc has joined triage
15:36:43 <fao89> it is not exactly rbac issue
15:36:46 <x9c4> #info x9c4 has joined triage
15:36:46 <x9c4> !here
15:36:46 <pulpbot> x9c4: x9c4 has joined triage
15:36:59 <x9c4> I will take a look
15:37:07 <ipanova> #info ipanova has joined triage
15:37:07 <ipanova> !here
15:37:07 <pulpbot> ipanova: ipanova has joined triage
15:37:25 <dkliban> x9c4: that would be great ... so let's add it to the sprint?
15:37:35 <fao89> they don't use NamedModelViewset so their Namespace model doesn't have a viewset "attached" to it
15:38:18 <daviddavis> I see
15:38:22 <ggainey> is this a pulpcore issue, or an ansible-plugin issue?
15:38:41 <ggainey> (I think we should add/investigate either way, just wondering if we want to move to the ansible project)
15:38:46 <daviddavis> they could hit this without pulp_ansible so it's a pulpcore issue
15:38:48 <fao89> kinda blur thing
15:38:51 <ggainey> ah kk
15:38:55 <ggainey> let's lv in core then
15:38:58 <dkliban> it's poossibly an issue with pulpcore ... or we close it as won't fix
15:39:08 <dkliban> or not a bug
15:39:09 <ggainey> gotcha
15:39:22 <fao89> #idea Proposed for #8048: accept and add to sprint
15:39:22 <fao89> !propose other accept and add to sprint
15:39:22 <pulpbot> fao89: Proposed for #8048: accept and add to sprint
15:39:33 <ggainey> +1
15:39:42 <fao89> or skip for investigation?
15:40:06 <dkliban> let's accept
15:40:16 <fao89> #agreed accept and add to sprint
15:40:16 <fao89> !accept
15:40:16 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:40:17 <fao89> #topic https://pulp.plan.io/issues/8047
15:40:17 <pulpbot> fao89: 3 issues left to triage: 8047, 8044, 7950
15:40:18 <pulpbot> RM 8047 - fao89 - NEW - New artifact is downloaded even when we already have a content unit with the same identity
15:40:19 <pulpbot> https://pulp.plan.io/issues/8047
15:41:10 <fao89> this is another situation where it is in the middle of ansible and core
15:41:29 <ggainey> fun
15:41:50 <fao89> so when pulpcore doesn't know how to differentiate signed x unsigned content, it end up download both artifacts
15:42:07 <fao89> but only one is linked to ContentArtifact
15:42:18 <dkliban> so this seems like a pulp_ansible bug becuase there needs to be another uniqueness constraint on the content
15:42:32 <dkliban> if the checksum is different, i would think that the content is different
15:42:39 <dkliban> even if it is called the same thing
15:42:45 <ipanova> fao89: so what happens with the old aritfact, is it being replaced with the new one?
15:42:51 <x9c4> I agree.
15:42:59 <fao89> it is not
15:43:10 <daviddavis> no you get two artifacts on the same contnet unit I belive
15:43:12 <ipanova> dkliban: i agree
15:43:17 <fao89> it keeps the old, and just downloads the new one for nothing
15:43:25 <ttereshc> +1 to ansible bug
15:43:38 <x9c4> It is then still serving the unofficial one as official?
15:44:09 <fao89> it serves the first synced
15:44:22 <fao89> #idea Proposed for #8047: move to ansible project
15:44:22 <fao89> !propose other move to ansible project
15:44:22 <pulpbot> fao89: Proposed for #8047: move to ansible project
15:44:28 <daviddavis> +1
15:44:30 <x9c4> +1
15:44:34 <ggainey> +1
15:44:35 <fao89> #agreed move to ansible project
15:44:35 <fao89> !accept
15:44:35 <pulpbot> fao89: Current proposal accepted: move to ansible project
15:44:36 <pulpbot> fao89: 2 issues left to triage: 8044, 7950
15:44:36 <fao89> #topic https://pulp.plan.io/issues/8044
15:44:37 <pulpbot> RM 8044 - ttereshc - ASSIGNED - no index for _last_updated on content models causes a fatal error when ordered result is queried
15:44:38 <pulpbot> https://pulp.plan.io/issues/8044
15:44:50 <ggainey> accept and add - I'm prepping a PR for this today :)
15:44:56 <ggainey> pretty please :)
15:45:09 <fao89> #idea Proposed for #8044: accept and add to sprint
15:45:09 <fao89> !propose other accept and add to sprint
15:45:09 <pulpbot> fao89: Proposed for #8044: accept and add to sprint
15:45:13 <ttereshc> +1
15:45:15 <dkliban> +1
15:45:23 <daviddavis> +1
15:45:24 <fao89> #agreed accept and add to sprint
15:45:24 <fao89> !accept
15:45:24 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:45:25 <fao89> #topic https://pulp.plan.io/issues/7950
15:45:25 <pulpbot> fao89: 1 issues left to triage: 7950
15:45:26 <pulpbot> RM 7950 - newswangerd - NEW - Backport 7912
15:45:27 <pulpbot> https://pulp.plan.io/issues/7950
15:45:28 <ggainey> (this is the 2.21.5 side of the order-by-_last_updated for the migration plugin)
15:45:52 <fao89> I think it still in review, so I'll skip
15:45:56 <fao89> !skip
15:45:57 <pulpbot> fao89: No issues to triage.
15:45:57 <dkliban> +1
15:46:07 <fao89> #endmeeting
15:46:07 <fao89> !end