15:39:36 <dkliban> #startmeeting Pulp Triage 2021-01-12
15:39:36 <dkliban> #info dkliban has joined triage
15:39:36 <dkliban> !start
15:39:36 <pulpbot> Meeting started Tue Jan 12 15:39:36 2021 UTC.  The chair is dkliban. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:39:36 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:39:36 <pulpbot> The meeting name has been set to 'pulp_triage_2021-01-12'
15:39:36 <pulpbot> dkliban: dkliban has joined triage
15:40:33 <dkliban> so who is going to do the release?
15:40:47 <dkliban> i will not be able to do it because i plan to take that day off
15:41:15 <daviddavis> lol
15:41:17 <daviddavis> me too
15:41:44 <daviddavis> I would prefer not to since I did 3.9 and have a bunch of work to wrap up for 3.10 but could if no one else can
15:42:10 <daviddavis> it sounds like many people aren't here right now
15:42:41 <daviddavis> let's maybe ask again at friday's open floor?
15:42:53 <dkliban> ok
15:43:02 <dkliban> sounds good ... i'll add it to firday's agenda
15:43:19 <daviddavis> also, it sounds like it's just me and you which I don't think constitutes a quorum
15:43:43 <dkliban> true dat
15:46:32 <dkliban> so are we continuing?
15:47:14 <daviddavis> I don't think so
15:47:25 <dalley> #info dalley has joined triage
15:47:25 <dalley> !here
15:47:25 <pulpbot> dalley: dalley has joined triage
15:49:58 <dkliban> daviddavis: dalley: looks like there are 3 of us now
15:49:59 <fao89> I'm back
15:50:14 <dkliban> ok
15:50:22 <fao89> sorry guys, I had to be a real firefighter
15:50:28 <dkliban> oh damn
15:50:55 <dkliban> Next topic: Move off Travis - https://pulp.plan.io/issues/7859
15:51:15 <fao89> #info fao89 has joined triage
15:51:16 <fao89> !here
15:51:16 <pulpbot> fao89: fao89 has joined triage
15:51:45 <dkliban> it looks like we need to finish 3 subtasks
15:52:10 <fao89> I think we can take these tasks out and close the epic
15:52:26 <dkliban> it's actually just 2 issues ... 7910 and 7884
15:52:40 <dkliban> i am fine with that
15:53:27 <fao89> both tasks were being discussed even before starting the migration
15:54:13 <dkliban> daviddavis: what do you think?
15:56:33 <daviddavis> hey sorry
15:56:33 <dkliban> it doesn't seem like we have enough participants to continue this meeting
15:56:34 <daviddavis> +1 from me
15:56:43 <dkliban> cool
15:56:50 <bmbouter> ok w/ me
15:56:53 <dkliban> cool
15:57:30 <dkliban> daviddavis: i will do the bookkeeping to close out this epic
15:58:00 <bmbouter> cool
15:58:38 <dkliban> bmbouter: we decided on Jan 26 for the release date, but will be picking a release person on Friday
15:58:43 <daviddavis> dkliban++
15:58:43 <pulpbot> daviddavis: dkliban's karma is now 573
15:58:49 <bmbouter> +1
15:58:51 <bmbouter> ty
15:58:57 <dkliban> let's go on to Bug Triage https://pulp.plan.io/issues?query_id=143
15:59:23 <dkliban> !nexy
15:59:24 <pulpbot> dkliban: Error: "nexy" is not a valid command.
15:59:27 <dkliban> !next
15:59:28 <pulpbot> dkliban: 3 issues left to triage: 8073, 8058, 7950
15:59:28 <dkliban> #topic https://pulp.plan.io/issues/8073
15:59:29 <pulpbot> RM 8073 - tosif.meman@kindredgroup.com - NEW - Need help to migrate pulp 2.20 to latest version of pulp 3
15:59:30 <pulpbot> https://pulp.plan.io/issues/8073
15:59:38 <dalley> +1 to previous
15:59:55 <dkliban> This is not a bug and the user just needs to be pointed to the migration plugin
15:59:58 <fao89> close and point to docs?
15:59:59 <bmbouter> yup
16:00:03 <dalley> yeah
16:00:09 <bmbouter> and also invite future requests through user support mailing list
16:00:14 <daviddavis> +1
16:00:16 <fao89> +1
16:00:22 <bmbouter> I can close/comment
16:00:22 <dkliban> #idea Proposed for #8073: close and comment with link to docs and mailing list
16:00:22 <dkliban> !propose other close and comment with link to docs and mailing list
16:00:22 <pulpbot> dkliban: Proposed for #8073: close and comment with link to docs and mailing list
16:00:24 <dalley> dkliban, worth noting, they need to upgrade to 2.21 first
16:00:31 <bmbouter> ack
16:00:35 <dkliban> #agreed close and comment with link to docs and mailing list
16:00:35 <dkliban> !accept
16:00:36 <dkliban> #topic https://pulp.plan.io/issues/8058
16:00:37 <pulpbot> dkliban: Current proposal accepted: close and comment with link to docs and mailing list
16:00:37 <bmbouter> shall I close/comment?
16:00:38 <pulpbot> dkliban: 2 issues left to triage: 8058, 7950
16:00:39 <pulpbot> RM 8058 - andyfry - NEW - Proxy credentials displayed in clear text
16:00:40 <pulpbot> https://pulp.plan.io/issues/8058
16:00:41 <dalley> ttereshc, ^
16:01:06 <fao89> #idea Proposed for #8058: accept and add to sprint
16:01:06 <fao89> !propose other accept and add to sprint
16:01:06 <pulpbot> fao89: Proposed for #8058: accept and add to sprint
16:01:16 <bmbouter> we should close this also
16:01:19 <bmbouter> but before we move on
16:01:27 <bmbouter> shall I close comment the previous or who is doing that?
16:01:43 <dkliban> bmbouter: uyou are
16:01:49 <bmbouter> ty doig it now
16:02:11 <bmbouter> so credentials are displayed in plaintext by design, pulp currently expects a single user and to use https
16:02:25 <bmbouter> and later in multi-user environments rbac will make it safe
16:02:36 <dkliban> bmbouter: this is about logs
16:02:56 <dkliban> are you sure we want the logs to display the credentials?
16:03:04 <bmbouter> I only read the title
16:03:11 <bmbouter> if it's in the logs, it shouldn't be in the logs
16:03:27 <dkliban> i don't think pulpcore is in position to fix it but we can file a bug against aiohttp
16:04:01 <daviddavis> this is pulp 2 no?
16:04:02 <dalley> bmbouter, yeah, the exception message contains them
16:04:05 <bmbouter> I agree pulpcore can't
16:04:09 <dalley> daviddavis, pulp 3
16:04:10 <bmbouter> it's got to be pulp3 because it's aiohttp
16:04:17 <daviddavis> oh I saw the pulp-worker-2. ty
16:04:23 <daviddavis> +1
16:04:58 <daviddavis> I'm happy to file an aiohttp bug
16:05:04 <dkliban> i think we should accept it
16:05:13 <daviddavis> +1
16:05:34 <dalley> +1
16:05:42 <dkliban> however, i am nto sure about adding it to the sprint
16:05:56 <dkliban> #idea Proposed for #8058: Leave the issue as-is, accepting its current state.
16:05:56 <dkliban> !propose accept
16:05:56 <pulpbot> dkliban: Proposed for #8058: Leave the issue as-is, accepting its current state.
16:06:00 <bmbouter> I agree it's not a pulp issue
16:06:25 <dkliban> #agreed Leave the issue as-is, accepting its current state.
16:06:25 <dkliban> !accept
16:06:25 <pulpbot> dkliban: Current proposal accepted: Leave the issue as-is, accepting its current state.
16:06:26 <dkliban> #topic https://pulp.plan.io/issues/8078
16:06:26 <pulpbot> dkliban: 2 issues left to triage: 8078, 7950
16:06:27 <pulpbot> RM 8078 - awcrosby - NEW - Make consistent pulp_ansible namespace max_length in Collection and CollectionVersion
16:06:28 <pulpbot> https://pulp.plan.io/issues/8078
16:06:39 <bmbouter> move to pulp_ansible
16:06:43 <dkliban> +1
16:06:50 <dkliban> #idea Proposed for #8078: move to pulp_ansible
16:06:50 <dkliban> !propose other move to pulp_ansible
16:06:50 <pulpbot> dkliban: Proposed for #8078: move to pulp_ansible
16:06:58 <dkliban> #agreed move to pulp_ansible
16:06:58 <dkliban> !accept
16:06:58 <pulpbot> dkliban: Current proposal accepted: move to pulp_ansible
16:06:59 <dkliban> #topic https://pulp.plan.io/issues/7950
16:06:59 <pulpbot> dkliban: 1 issues left to triage: 7950
16:07:00 <pulpbot> RM 7950 - newswangerd - NEW - Backport 7912
16:07:01 <pulpbot> https://pulp.plan.io/issues/7950
16:07:07 <dkliban> we
16:07:15 <dkliban> ve been skipping this one because the change is not ready
16:07:24 <bmbouter> makes sense to skip then still I think
16:07:28 <fao89> we can cacth 503 before it raises ClientHttpProxyError, I believe this way we get rid of the log
16:08:18 <dkliban> !skip
16:08:20 <pulpbot> dkliban: No issues to triage.
16:09:22 <dkliban> fao89: it could be a lot of different errors
16:09:39 <dkliban> i am hesitant to try doing something ourselves
16:10:13 <fao89> yep, I saw it now when I googled what 503 is
16:11:29 <dkliban> daviddavis: are you going to file an aiohttp bug?
16:13:08 <daviddavis> dkliban: yea
16:13:26 <dkliban> thank you
16:13:35 <dkliban> that's all folks!
16:13:42 <dkliban> #endmeeting