15:30:37 <fao89> #startmeeting Pulp Triage 2021-01-15
15:30:37 <fao89> #info fao89 has joined triage
15:30:37 <fao89> !start
15:30:37 <pulpbot> Meeting started Fri Jan 15 15:30:37 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:37 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:37 <pulpbot> The meeting name has been set to 'pulp_triage_2021-01-15'
15:30:37 <pulpbot> fao89: fao89 has joined triage
15:30:51 <fao89> Open floor!
15:30:53 <fao89> https://hackmd.io/@pulp/triage/edit
15:31:07 <ppicka> #info ppicka has joined triage
15:31:07 <ppicka> !here
15:31:07 <pulpbot> ppicka: ppicka has joined triage
15:31:16 <daviddavis> #info daviddavis has joined triage
15:31:16 <daviddavis> !here
15:31:16 <pulpbot> daviddavis: daviddavis has joined triage
15:31:31 <dkliban> #info dkliban has joined triage
15:31:31 <dkliban> !here
15:31:31 <pulpbot> dkliban: dkliban has joined triage
15:31:49 <ggainey> #info ggainey has joined triage
15:31:49 <ggainey> !here
15:31:49 <pulpbot> ggainey: ggainey has joined triage
15:31:55 <ttereshc> #info ttereshc has joined triage
15:31:55 <ttereshc> !here
15:31:55 <pulpbot> ttereshc: ttereshc has joined triage
15:32:11 <fao89> topic: Reminder: 3.10 release https://pulp.plan.io/versions/166
15:32:45 <daviddavis> this is just an FYI
15:32:50 <ggainey> yupyup
15:32:51 <fao89> cool
15:32:51 <dkliban> i do want to say one thing about it
15:32:53 <daviddavis> date is jan 26 and ttereshc will shepherd
15:33:09 <fao89> next topic: Label selector problem https://pulp.plan.io/issues/8067#note-1
15:33:18 <ipanova> #info ipanova has joined triage
15:33:18 <ipanova> !here
15:33:18 <pulpbot> ipanova: ipanova has joined triage
15:33:33 <dkliban> plugins are encouraged to released before Jan  26 with compatibility for 7930
15:33:42 <dkliban> https://pulp.plan.io/issues/7930
15:33:52 <daviddavis> yup that's a good piont
15:34:04 <daviddavis> maybe we should email out a reminder?
15:34:12 <ttereshc> yeah we definitely should
15:34:22 <gerrod> #info gerrod has joined triage
15:34:22 <gerrod> !here
15:34:22 <pulpbot> gerrod: gerrod has joined triage
15:34:23 <fao89> but the OpenAPI schema test may fail
15:34:41 <dkliban> we should ... cause i am pretty sure when i ran the latest single container i saw pulp_rpm not being compliant
15:34:51 <ttereshc> I can email pulp-dev if no one wants to do that
15:35:33 <ttereshc> fao89,  what will fail because of this change?
15:35:40 <dkliban> ttereshc: if you do that, could you also point on that plugin_template currently has code that needs to be commented out like here ...
15:35:52 <ttereshc> ack
15:36:02 <dkliban> https://github.com/pulp/pulp_file/pull/458/commits/e873580a0a9ac921c652f8394ea14ed1cce02b6dc
15:36:12 <dkliban> ttereshc: that's what fao89 was referring to
15:36:20 <fao89> the CI tries to validate the OpenAPI schema, and only 3.10 has the fix
15:37:03 <fao89> I think it is better to remove it from plugin-template and add it again after 3.10 is released
15:37:16 <dkliban> fao89: you want to do that?
15:37:31 <fao89> I can, it will be less confusing
15:37:53 <dkliban> ok
15:38:25 <ttereshc> thanks fao89
15:38:32 <bmbouter> #info bmbouter has joined triage
15:38:32 <bmbouter> !here
15:38:32 <pulpbot> bmbouter: bmbouter has joined triage
15:38:34 <dkliban> fao89++
15:38:34 <pulpbot> dkliban: fao89's karma is now 134
15:38:37 <dkliban> ttereshc++
15:38:37 <pulpbot> dkliban: ttereshc's karma is now 277
15:38:42 <daviddavis> +1
15:38:46 <ttereshc> dkliban, so nothing to point out to in the email then
15:38:50 <dkliban> correct
15:39:48 <ttereshc> I guess we can move on to the next topic
15:39:52 <dkliban> yes
15:40:03 <fao89> next topic: Label selector problem https://pulp.plan.io/issues/8067#note-1
15:40:04 <ggainey> +1
15:40:15 <daviddavis> this is an issue I am not sure how to solve
15:40:32 <bmbouter> so I've thought some about this
15:40:35 <daviddavis> we use kubernetes style selector syntax but they limit their chars to alphanumeric
15:40:58 <bmbouter> first question is: is this "We're already using urlencoding to unescape the search selector string" in our code or in some middleware prior to our code?
15:41:36 <daviddavis> I don't think so
15:42:19 <daviddavis> the label selector filter gets the string and it should be urlencoded
15:42:36 <bmbouter> ok so it's happening before ok
15:42:49 <bmbouter> so my second question is: can we just disallow commas in the data?
15:42:54 <bmbouter> s/data/label/
15:43:20 <bmbouter> the requirements says "all alphanumeric characters" but do they really need ',' ?
15:43:37 <ipanova> bmbouter: they at least need a /
15:43:49 <dkliban> we can encode that ... right?
15:43:49 <bmbouter> that's ok '/' doesn't cause the issue
15:44:00 <daviddavis> edx said they need to use gpg keys
15:44:07 <bmbouter> yeah the issue is that filter separation specifically uses ','
15:44:07 <daviddavis> exd
15:44:12 <ggainey> yeah, sounds like ',' is the one problem, is that correct daviddavis ?
15:44:19 <daviddavis> I think so
15:44:20 <ggainey> dammit - you ppl type too fast for me :)
15:44:28 <ttereshc> daviddavis, I was hoping we are working with edx now
15:44:34 <ggainey> heh
15:44:52 <daviddavis> :)
15:45:00 <daviddavis> so just disallow ","?
15:45:04 <ggainey> +1
15:45:19 <daviddavis> actually I think "(" may be a problem too
15:46:17 <daviddavis> a possible search string is "foo in (bar, foobar)"
15:46:30 <daviddavis> so I'll do "," and parantheses
15:46:38 <ggainey> kk
15:47:03 <bmbouter> I don't understand that search string
15:47:06 <ipanova> we can also cross this bridge when we come to it. this issue might not be an issue for a really long time, until they (if)move to pulp3
15:47:41 <daviddavis> bmbouter: so that would be where "foo" is either "bar" or "foobar"
15:48:02 <daviddavis> ipanova: sounds good
15:48:02 <bmbouter> they can submit that to the REST aPI?
15:48:44 <daviddavis> bmbouter: yea see here https://kubernetes.io/docs/concepts/overview/working-with-objects/labels/#list-and-watch-filtering
15:49:07 <bmbouter> oh it's the k8s filterspec
15:49:13 <daviddavis> yep
15:49:54 <daviddavis> if there are no other questions/comments, I'll update the issue
15:50:09 <bmbouter> +1 to that resolution I think is fine
15:50:14 <daviddavis> cool
15:50:22 <ggainey> +1
15:50:25 <fao89> can we start the triage now?
15:50:26 <bmbouter> I am slightly soncerned (although probably much too late apologies) that we're bringing in a new filter syntax
15:50:27 <ttereshc> ty daviddavis
15:50:34 <bmbouter> concerned
15:50:48 <bmbouter> but not enough to go into it here or even to change it
15:51:59 <bmbouter> will this be tech preview for 3.10?
15:52:04 <daviddavis> that's the plan
15:52:15 <bmbouter> that'll work, ty
15:52:23 <daviddavis> also, i haven't started on the work
15:52:29 <daviddavis> so it'd be better to speak up now
15:52:32 <bmbouter> oh really...
15:52:42 <bmbouter> do you want to talk here or maybe a few min elsewhere?
15:52:43 <daviddavis> I mean I have obj labels but not the filtering
15:53:02 <bmbouter> either chat or a 10 min on video
15:53:09 <daviddavis> either works for me
15:53:22 <bmbouter> let's do a quick video after this
15:53:27 <daviddavis> +1
15:53:34 <bmbouter> we'll talk really fast
15:53:41 <bmbouter> like a high word / min rate
15:53:46 <daviddavis> :)
15:53:48 <fao89> I'll start the triage
15:54:14 <daviddavis> +1
15:54:25 <fao89> gerrod: FYI ^
15:54:29 <fao89> !next
15:54:30 <pulpbot> fao89: 4 issues left to triage: 8099, 8088, 7950, 7922
15:54:30 <fao89> #topic https://pulp.plan.io/issues/8099
15:54:32 <pulpbot> RM 8099 - iballou - NEW - File upload causes django.security.SuspiciousFileOperation:ERROR
15:54:33 <pulpbot> https://pulp.plan.io/issues/8099
15:55:32 <dkliban> i don't think we have this issue for installs performed using pulp_installer
15:55:44 <ttereshc> oh, I guess there are some assumptions in the code and katello has a custom media root?
15:55:58 <ttereshc> ok, maybe it's installation issue
15:55:58 <dkliban> however, this will be fixed when PR 799 is merged
15:56:11 <dkliban> https://github.com/pulp/pulpcore/pull/799
15:56:48 <fao89> not sure what to propose, accept?
15:57:01 <ttereshc> it will help new installation only, right? dkliban
15:57:13 <ttereshc> *installations
15:57:42 <dkliban> ttereshc: no ... there is an installer PR also that will move files
15:57:48 <dkliban> https://github.com/pulp/pulp_installer/pull/510
15:58:01 <ttereshc> nice
15:58:12 <ipanova> +1 to accept
15:58:16 <ttereshc> maybe worth linking the issue in this PR
15:58:32 <fao89> #idea Proposed for #8099: Leave the issue as-is, accepting its current state.
15:58:32 <fao89> !propose accept
15:58:33 <pulpbot> fao89: Proposed for #8099: Leave the issue as-is, accepting its current state.
15:58:44 <dkliban> +1
15:58:52 <ttereshc> +1
15:58:56 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:58:56 <fao89> !accept
15:58:56 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:58:57 <fao89> #topic https://pulp.plan.io/issues/8088
15:58:57 <pulpbot> fao89: 3 issues left to triage: 8088, 7950, 7922
15:58:58 <pulpbot> RM 8088 - ByteSore - NEW - implementing virus scan on on_demand repository
15:58:59 <pulpbot> https://pulp.plan.io/issues/8088
15:59:06 <dkliban> this is a feature
15:59:08 <ggainey> story?
15:59:09 <ggainey> yeah
15:59:09 <daviddavis> +1
15:59:11 <dkliban> so let's convert to a story
15:59:18 <ipanova> move to python project?
15:59:29 <fao89> #idea Proposed for #8088: convert to story
15:59:29 <fao89> !propose other convert to story
15:59:29 <pulpbot> fao89: Proposed for #8088: convert to story
15:59:37 <ttereshc> I beleive they add it to the base downloader
15:59:38 <daviddavis> I imagine we'll want something in pulpcore for other plugins to do the same?
15:59:45 <dkliban> yeah
15:59:51 <dkliban> let's keep it in pulpcore for now
15:59:54 <ggainey> yeah - if we want this it'd be useful as a global tool
15:59:55 <ttereshc> +1
15:59:58 <ggainey> +1
15:59:58 <fao89> +1
16:00:02 <fao89> #agreed convert to story
16:00:02 <fao89> !accept
16:00:02 <pulpbot> fao89: Current proposal accepted: convert to story
16:00:03 <fao89> #topic https://pulp.plan.io/issues/7950
16:00:03 <pulpbot> fao89: 2 issues left to triage: 7950, 7922
16:00:05 <pulpbot> RM 7950 - newswangerd - NEW - Backport 7912
16:00:06 <pulpbot> https://pulp.plan.io/issues/7950
16:00:29 <ttereshc> skip as usual I guess
16:00:32 <dkliban> lol
16:00:35 <fao89> was the fix merged?
16:00:38 <ttereshc> nope
16:00:39 <ipanova> not yet
16:00:44 <fao89> !skip
16:00:44 <fao89> #topic https://pulp.plan.io/issues/7922
16:00:45 <pulpbot> fao89: 1 issues left to triage: 7922
16:00:46 <pulpbot> RM 7922 - bmclaugh - NEW - additional AVC denials
16:00:47 <pulpbot> https://pulp.plan.io/issues/7922
16:01:07 <dkliban> bmbouter: should we accept this issue?
16:01:21 <dkliban> or move it to pulp_ansible?
16:01:30 <dkliban> it's really not for the pulp team to fix
16:03:15 * bmbouter reads
16:03:47 <bmbouter> oh this one, I think skip probably, ultmately a change will occur in pulpcore-selinux but we're not going to be driving it
16:04:39 <fao89> !skip
16:04:40 <pulpbot> fao89: No issues to triage.
16:04:45 <fao89> #endmeeting
16:04:45 <fao89> !end