15:30:19 <fao89> #startmeeting Pulp Triage 2021-01-29
15:30:19 <fao89> #info fao89 has joined triage
15:30:19 <fao89> !start
15:30:19 <pulpbot> Meeting started Fri Jan 29 15:30:19 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:19 <pulpbot> The meeting name has been set to 'pulp_triage_2021-01-29'
15:30:19 <pulpbot> fao89: fao89 has joined triage
15:30:42 <x9c4> #info x9c4 has joined triage
15:30:42 <x9c4> !here
15:30:42 <pulpbot> x9c4: x9c4 has joined triage
15:31:09 <gerrod> #info gerrod has joined triage
15:31:09 <gerrod> !here
15:31:09 <pulpbot> gerrod: gerrod has joined triage
15:31:10 <ppicka> #info ppicka has joined triage
15:31:10 <ppicka> !here
15:31:10 <pulpbot> ppicka: ppicka has joined triage
15:31:29 <daviddavis> #info daviddavis has joined triage
15:31:29 <daviddavis> !here
15:31:29 <pulpbot> daviddavis: daviddavis has joined triage
15:31:37 <fao89> topic: start with triage today?
15:32:01 <ttereshc> #info ttereshc has joined triage
15:32:01 <ttereshc> !here
15:32:01 <pulpbot> ttereshc: ttereshc has joined triage
15:32:08 <fao89> I think so, open floor is taking too much time lately
15:32:10 <ttereshc> sure why not
15:32:16 <daviddavis> +1
15:32:23 <fao89> !next
15:32:24 <fao89> #topic https://pulp.plan.io/issues/8167
15:32:24 <pulpbot> fao89: 3 issues left to triage: 8167, 8058, 7950
15:32:24 <x9c4> is this a one off?
15:32:25 <pulpbot> RM 8167 - bmbouter - NEW - As a user, I have proxy_password and proxy_username available on all remotes.
15:32:26 <pulpbot> https://pulp.plan.io/issues/8167
15:32:43 <fao89> #idea Proposed for #8167: Leave the issue as-is, accepting its current state.
15:32:43 <fao89> !propose accept
15:32:43 <pulpbot> fao89: Proposed for #8167: Leave the issue as-is, accepting its current state.
15:32:44 <ttereshc> story?
15:32:49 <daviddavis> +1 to story
15:32:59 <fao89> oh yeah
15:33:08 <x9c4> +1 to story
15:33:10 <ggainey> +1
15:33:11 <fao89> #idea Proposed for #8167: convert to story
15:33:11 <fao89> !propose other convert to story
15:33:11 <pulpbot> fao89: Proposed for #8167: convert to story
15:33:13 <ggainey> #info ggainey has joined triage
15:33:13 <ggainey> !here
15:33:13 <pulpbot> ggainey: ggainey has joined triage
15:33:20 <fao89> #agreed convert to story
15:33:20 <fao89> !accept
15:33:20 <pulpbot> fao89: Current proposal accepted: convert to story
15:33:21 <fao89> #topic https://pulp.plan.io/issues/8058
15:33:21 <pulpbot> fao89: 2 issues left to triage: 8058, 7950
15:33:22 <pulpbot> RM 8058 - andyfry - NEW - Proxy credentials displayed in clear text
15:33:23 <pulpbot> https://pulp.plan.io/issues/8058
15:33:34 <daviddavis> accept. I have a PR open against aiohttp
15:33:41 <ipanova> #info ipanova has joined triage
15:33:41 <ipanova> !here
15:33:41 <pulpbot> ipanova: ipanova has joined triage
15:33:42 <fao89> #idea Proposed for #8058: Leave the issue as-is, accepting its current state.
15:33:42 <fao89> !propose accept
15:33:42 <pulpbot> fao89: Proposed for #8058: Leave the issue as-is, accepting its current state.
15:33:57 <ggainey> +1
15:34:06 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:34:06 <fao89> !accept
15:34:07 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:34:07 <fao89> #topic https://pulp.plan.io/issues/7950
15:34:08 <pulpbot> fao89: 1 issues left to triage: 7950
15:34:09 <pulpbot> RM 7950 - newswangerd - NEW - Backport 7912
15:34:10 <pulpbot> https://pulp.plan.io/issues/7950
15:34:27 <bmbouter> #info bmbouter has joined triage
15:34:27 <bmbouter> !here
15:34:27 <pulpbot> bmbouter: bmbouter has joined triage
15:34:29 <fao89> was the PR merged?
15:34:32 <ipanova> this pr got merged, should accept the backport?
15:34:34 <ggainey> PR is merged! we can finally accept thos one!
15:34:45 <bmbouter> soooo
15:34:51 <bmbouter> they actually said they'll receive the fix as part of 3.10
15:35:03 <ipanova> cool
15:35:04 <bmbouter> they declined the backport as of tuesday
15:35:08 <bmbouter> so close wontfix
15:35:09 <fao89> #idea Proposed for #7950: close
15:35:10 <fao89> !propose other close
15:35:10 <pulpbot> fao89: Proposed for #7950: close
15:35:14 <ttereshc> even better :)
15:35:22 <ggainey> well ok then :)
15:35:27 <ttereshc> wait long enough and things will close out themselves
15:35:28 <fao89> #agreed close
15:35:28 <fao89> !accept
15:35:28 <pulpbot> fao89: Current proposal accepted: close
15:35:29 <pulpbot> fao89: No issues to triage.
15:35:32 <daviddavis> hehe
15:35:46 <fao89> Open floor!
15:35:56 <fao89> topic: extend open floor time?
15:36:08 <x9c4> -1
15:36:10 <daviddavis> if there's one thing we need less of besides more meetings, it's longer meetings
15:36:29 <x9c4> I think there is a natural fluctuation in the time it needs.
15:36:37 <ggainey> I don't know that we need to extend OF - yes, sometimes we run long, but I don't think that's an always-problem
15:36:41 <ttereshc> +1 no need to extend
15:36:41 <ggainey> +1
15:36:41 <fao89> the past 2 open floor/triages didn't have time for triage
15:36:57 <dalley> +1, agree with x9c4
15:37:35 <daviddavis> can I suggest something though?
15:37:35 <x9c4> maybe we need to break longer discussions and move them elsewhere.
15:37:39 <daviddavis> yes, that
15:37:40 <ipanova> fao89: we can time box the open floor depending on the situation with bugs to triage
15:37:41 <ggainey> aye
15:37:42 <ttereshc> if it's consistently bad we can start having triage at the beginning on a regular basis
15:37:43 <fao89> rephrasing it, is it ok to have open floor full time?
15:37:45 <daviddavis> or circle back to these longer topics
15:37:51 <daviddavis> after triage
15:37:54 <bmbouter> I agree
15:37:59 <bmbouter> we can't make the meeting longer
15:38:11 <fao89> so, what would be the timecheck for starting triage?
15:38:12 <bmbouter> triage should come first
15:38:27 <ggainey> yeah, I think if we're better about "this needs more discussion, let's open an email-thread/document/have a specific mtg/whatever", and move on
15:38:44 <ipanova> we used to have triage and then we moved open floor to come first for the sake of community
15:38:54 <ggainey> bmbouter: we moved open-floor first in response to ppl wanting to hear the discussion, w/out having to sit thru the triage
15:39:21 <daviddavis> no community members have attended open floor so it may be a pipe dream
15:39:28 <ggainey> heh
15:39:36 <daviddavis> we could always see if there are community member topics and then move open floor first if there are
15:39:37 <ipanova> daviddavis: well, it takes time and patience ;)
15:40:00 <daviddavis> some day :)
15:40:05 <fao89> I think we need different slots for open floor and triage
15:40:16 * ttereshc is curious how long the conversation about the timeboxing and meeting process will take
15:40:23 <x9c4> ELMO
15:40:28 <ipanova> i think we need to keep time for openfloor consistent.
15:40:36 <fao89> 10:30 - 11 - open floor / 11 - 11:30 triage
15:40:44 <ipanova> fao89: +1
15:40:48 <daviddavis> we could lead with open floor on fridays and encourage community members to attend that day
15:40:55 <daviddavis> on tuesdays we do triage first
15:41:30 <ggainey> that works for me
15:41:49 <x9c4> It sounds like a self regulating schema to me. +1
15:41:56 <ttereshc> so what if we have few things to discuss ot to triage, we wait in between?, I'm not sure I'm in favor of fixed time for each
15:42:03 <ttereshc> +1 to alternate order
15:42:34 <ipanova> ttereshc: we would just start the triage without waitiing in between
15:42:43 <bmbouter> +1
15:42:50 <bmbouter> let's do triage first, because it's shorter
15:43:00 <daviddavis> and then start open floor early?
15:43:03 <fao89> I'm lost with the +1 and proposals
15:43:06 <bmbouter> ha me too
15:43:08 <ipanova> heh
15:43:22 <x9c4> +1 to the checker-board pattern
15:43:28 <ttereshc> ipanova, then we can't announced the fixed time anywhere
15:43:39 <ttereshc> +1 to  the checker-board pattern as well
15:43:46 <ggainey> +1 to triage-first-Tuesday, Floor-First-Friday
15:44:02 <daviddavis> floor-first-fridays, I like it
15:44:18 <ttereshc> \o/
15:44:24 <ttereshc> FFF
15:44:28 <daviddavis> TTT
15:44:33 <ttereshc> :D
15:44:38 <ipanova> i am not fun of alternating things because it brings in confusion, but i will not block this if most of the people are on board.
15:44:42 <bmbouter> I agree
15:44:43 <fao89> the first proposal to be written on hackmd is the winner
15:44:46 <bmbouter> simplicity is the way
15:46:07 <daviddavis> the alternative I heard was 10:30-11 triage and 11-11:30 open floor which introduces either waiting or not honoring the actual start times
15:46:13 <ipanova> fao89: done :-P
15:46:29 <fao89> best one
15:46:32 <ggainey> well, simplest is "leave well enough alone" - we've been running floor-first for months, and it's only been the last week that it ran into problems with taking too much time
15:46:34 <fao89> ipanova++
15:46:34 <pulpbot> fao89: ipanova's karma is now 175
15:47:00 <daviddavis> yea, if we call out that topics are taking too long, that might be the best solutoin right now
15:47:29 <daviddavis> call out = ask that they be mailing list discussions, meetings, or we circle back to them after triage
15:47:30 <x9c4> this discussion is taking toooo long.
15:47:33 <daviddavis> haha
15:47:45 <bmbouter> agreed
15:47:54 <bmbouter> I don't feel a need for a change (personally) maybe others do
15:48:02 <fao89> the winner: if we call out that topics are taking too long, that might be the best solutoin right now
15:48:11 <ttereshc> sweet
15:48:16 <ttereshc> let's move on
15:48:19 <fao89> next topic: https://hub.docker.com/r/pulp/pulp-fedora31
15:48:24 <ggainey> +1
15:48:52 <daviddavis> I was going to work on a date to remove this
15:48:58 <daviddavis> and email it to pulp-dev
15:49:01 <ggainey> fao89: punt f31, it's not getting updates any more
15:49:07 <ggainey> daviddavis++
15:49:07 <pulpbot> ggainey: daviddavis's karma is now 427
15:49:11 <ggainey> yes please
15:49:17 <x9c4> daviddavis++
15:49:17 <pulpbot> x9c4: daviddavis's karma is now 428
15:49:19 <daviddavis> ok, any objections?
15:49:22 <fao89> daviddavis++
15:49:22 <pulpbot> fao89: daviddavis's karma is now 429
15:49:25 <ppicka> daviddavis++
15:49:25 <pulpbot> ppicka: daviddavis's karma is now 430
15:49:41 <ttereshc> no objections
15:49:50 <fao89> next topic: Documenting workflows with CLI
15:49:50 <daviddavis> great thanks, I'll send an email today
15:50:12 <x9c4> +1
15:50:15 <x9c4> next?
15:50:15 <bmbouter> one sec
15:50:29 <bmbouter> so my recorded demos use https://hub.docker.com/r/pulp/pulp-fedora31
15:50:57 <bmbouter> ultimately we want them to use pulp/pulp instead is that right?
15:51:03 <daviddavis> correct
15:51:37 <bmbouter> ok yeah let's take down pulp-fedora31 because even though that will be confusing we don't want users to get into that environment that really needs to go away
15:51:41 <bmbouter> ok ty +1 next topic
15:51:44 <fao89> bmbouter: you did use pulp-galaxy-ng, and it is now centos8
15:51:54 <bmbouter> yeah pulp-galaxy-ng is fine cuz the name is the same
15:52:04 <bmbouter> and the OS shouldn't matter for the user for hte purposes of my demo
15:52:14 <fao89> so the next topic is about documenting workflows with pulp-cli
15:52:21 <x9c4> +1
15:52:23 <daviddavis> +1
15:52:35 <daviddavis> I started on pulp_file the other night
15:52:38 <fao89> bmbouter: proposed this: https://github.com/pulp/pulp_ansible/pull/506#issuecomment-768544798 (move to sphinx doctest to avoid bash scripts)
15:52:47 <fao89> https://www.sphinx-doc.org/en/master/usage/extensions/doctest.html
15:53:13 <gerrod> i've been looking into doctest and i think it can only do python cod
15:53:17 <gerrod> code*
15:53:22 <ipanova> is this a good idea to keep this for docs day?
15:53:25 <bmbouter> yup I worry about the same thing
15:53:44 <bmbouter> I think of docs day as an extra push for docs but if folks want to doc on other days that's ok
15:53:58 <daviddavis> pulp_file is probably the only other plugin that's ready to have its docs updated
15:54:05 <bmbouter> I don't think we can have a proposal about using doctest until we have a PoC showing it working
15:54:06 <daviddavis> the cli for container and rpm is incomplete I think
15:54:14 <gerrod> there are other sphinx extensions that can run bash commands like programoutput https://sphinxcontrib-programoutput.readthedocs.io/en/latest/
15:54:21 <bmbouter> nice
15:54:24 <fao89> I see
15:54:39 <bmbouter> but if we're talking "hey can we switch a plugin to use the CLI" then +1 to pulp_file switching
15:54:42 <fao89> so I think we can move to the next topic?
15:54:45 <bmbouter> and container and rpm switching when their CLIs are complete
15:54:52 <bmbouter> pulp_ansible alredy switches (ty gerrooddddddd)
15:54:56 <ipanova> sounds good
15:55:21 <ggainey> +1
15:55:27 <fao89> last topic: how to ship changes to a default access policy?
15:56:08 <bmbouter> so we're about to ship a lot of default accesspolicyies
15:56:30 <bmbouter> and I was thinking about what x9c4 said: "we will have a problem shiping changes to the default policy" and he is right
15:56:43 <ttereshc> yes
15:56:55 <ipanova> yes
15:57:06 <x9c4> propose: Write a release note what changed. Tall admin to have a look. And provide a reset to default primitive.
15:57:19 <bmbouter> propose: https://pulp.plan.io/issues/8182?next_issue_id=8181
15:58:10 <bmbouter> I think this would be an easy resolution
15:58:48 <ttereshc> this or just compare
15:59:07 <ttereshc> apart from how to do it technically, we briefly touched on this yesterday and it sounds to some like a change in behaviour and probably requires a major version bump
15:59:12 <x9c4> But if a site has a customized policy, and we add a new action, it will be unaccessible until the admin takes action.
16:00:02 <bmbouter> yes but the change will be in the release notes for them
16:00:29 <bmbouter> if they've customized things they have a responsibility to determine if their customizations still make sense at upgrade time
16:00:31 <ttereshc> if they have a custom policy we won't touch it, right? they can start using a new action but we can't them force to start checking it
16:00:38 <bmbouter> really this is about all the folks who didn't customize
16:00:56 <ttereshc> yeah , +1
16:01:13 <ipanova> we should add this in 3.10
16:01:17 <bmbouter> yes we should
16:01:28 <x9c4> OK, modified field sounds fine, because comparing might give false positives.
16:01:53 <bmbouter> also it's useful the user could filter on modified=True
16:02:05 <x9c4> Should we add a reset_to_default anyway? It would also reset modified.
16:02:07 <ipanova> bmbouter: + maybe adding some docs around this would be nice
16:02:11 <bmbouter> which otherwise determining how this system's rbac is customized would be like yikes
16:02:34 <bmbouter> ipanova: I agree, we need user facing docs on rbac as a whole really
16:02:44 <bmbouter> there are no user facing rbac docs :/
16:02:54 <ttereshc> should the flag be named is_default maybe?
16:03:06 <x9c4> or customized
16:03:14 <bmbouter> either of those sound fine to me
16:03:27 <bmbouter> ya'll pick :)
16:03:29 <ttereshc> modified is a bit ambiguous to me, I modified my custom policy
16:03:36 <bmbouter> let's not use modified
16:03:50 <x9c4> tainted
16:03:50 <ttereshc> we can agree on the name on the PR
16:04:01 <ipanova> x9c4: heh
16:04:03 <bmbouter> I think I would go with customized
16:04:13 <ttereshc> works for me
16:04:21 <ipanova> customized is fine
16:04:32 <x9c4> +1
16:05:13 <ipanova> was this the last topic for open floor?
16:05:43 <x9c4> To be clear, we would reset all the non-customized policies on migrate. right?
16:06:00 <fao89> yep
16:06:01 <fao89> #endmeeting
16:06:01 <fao89> !end