15:30:48 <daviddavis> #startmeeting Pulp Triage 2021-03-02
15:30:48 <daviddavis> #info daviddavis has joined triage
15:30:48 <daviddavis> !start
15:30:48 <pulpbot> Meeting started Tue Mar  2 15:30:48 2021 UTC.  The chair is daviddavis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:48 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:48 <pulpbot> The meeting name has been set to 'pulp_triage_2021-03-02'
15:30:48 <pulpbot> daviddavis: daviddavis has joined triage
15:30:57 <ttereshc> #info ttereshc has joined triage
15:30:57 <ttereshc> !here
15:30:57 <pulpbot> ttereshc: ttereshc has joined triage
15:31:03 <ppicka> #info ppicka has joined triage
15:31:03 <ppicka> !here
15:31:03 <pulpbot> ppicka: ppicka has joined triage
15:31:11 <daviddavis> no open floor topics
15:31:27 <daviddavis> !next
15:31:28 <daviddavis> #topic https://pulp.plan.io/issues/8317
15:31:28 <pulpbot> daviddavis: 7 issues left to triage: 8317, 8315, 8312, 8306, 8305, 8295, 8282
15:31:29 <pulpbot> RM 8317 - mprahl - NEW - Allow the auth private key size to be configurable
15:31:30 <pulpbot> https://pulp.plan.io/issues/8317
15:31:40 <ipanova> #info ipanova has joined triage
15:31:40 <ipanova> !here
15:31:40 <pulpbot> ipanova: ipanova has joined triage
15:31:44 <ggainey> !
15:31:49 <ggainey> #info ggainey has joined triage
15:31:49 <ggainey> !here
15:31:49 <pulpbot> ggainey: ggainey has joined triage
15:32:03 <ipanova> this is a pulp2 issue, we should accept it- there is a PR
15:32:08 <bmbouter> #info bmbouter has joined triage
15:32:08 <bmbouter> !here
15:32:08 <pulpbot> bmbouter: bmbouter has joined triage
15:32:15 <daviddavis> #idea Proposed for #8317: add pulp 2 tag and accept
15:32:15 <daviddavis> !propose other add pulp 2 tag and accept
15:32:15 <pulpbot> daviddavis: Proposed for #8317: add pulp 2 tag and accept
15:32:36 <ttereshc> ipanova, do you mean that we'll merge it?
15:33:01 <ipanova> ttereshc: that's a good change and i think this is related to the EXD repodata signing effort
15:33:27 <ttereshc> change is good, I'm just trying to figure out when we stop adding features to pulp2
15:33:43 <ggainey> ttereshc: ask me again in December :)
15:33:43 <bmbouter> yeah the change is good the issue is that I don't think we'll have another Y release
15:33:54 <ipanova> ttereshc: this also look a bugfix
15:33:58 <ttereshc> bmbouter, see my reviewin pulp_rpm
15:34:10 <ipanova> because fedora 33 willbreak with hardcoded key 1024
15:34:13 <ttereshc> I no longer know what we'll have and what we won't
15:34:36 <bmbouter> this adds a new setting, is it really bugfix?
15:34:54 <ipanova> bmbouter: it adds a new setting in order to fix a bug
15:34:55 <bmbouter> granted the pulp2 feature/bugfix was not very strict so it's maaaaaybe ok
15:35:08 <bmbouter> yes but pulp itself is getting a new feature...
15:35:10 <ttereshc> I have the same thought, it looks like  feature to me
15:35:31 <ttereshc> we can move on I guess, it's exd, we need to review at least
15:35:43 <daviddavis> I'll skip then?
15:35:45 <bmbouter> yeah I saw the pulp_rpm I plan to look very soon
15:36:16 <daviddavis> !skip
15:36:17 <daviddavis> #topic https://pulp.plan.io/issues/8315
15:36:17 <pulpbot> daviddavis: 6 issues left to triage: 8315, 8312, 8306, 8305, 8295, 8282
15:36:18 <pulpbot> RM 8315 - daviddavis - NEW - Found some instances of bad i18n
15:36:19 <pulpbot> https://pulp.plan.io/issues/8315
15:36:31 <daviddavis> #idea Proposed for #8315: Leave the issue as-is, accepting its current state.
15:36:31 <daviddavis> !propose accept
15:36:31 <pulpbot> daviddavis: Proposed for #8315: Leave the issue as-is, accepting its current state.
15:36:47 <ipanova> +1
15:36:49 <daviddavis> this is a good one to raise awareness of :)
15:37:02 <daviddavis> f-strings and gettext don't mix
15:37:02 <bmbouter> yuuuup
15:37:10 <bmbouter> +1
15:37:11 <ttereshc> :)
15:37:13 * daviddavis eyes ggainey
15:37:13 <ttereshc> +1
15:37:18 <daviddavis> #agreed Leave the issue as-is, accepting its current state.
15:37:18 <daviddavis> !accept
15:37:18 <pulpbot> daviddavis: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:37:19 <daviddavis> #topic https://pulp.plan.io/issues/8312
15:37:19 <pulpbot> daviddavis: 5 issues left to triage: 8312, 8306, 8305, 8295, 8282
15:37:20 <pulpbot> RM 8312 - vatavu - NEW - Pulp2 fails to validate file size for tgz from the manifest generated by Pulp3
15:37:21 <pulpbot> https://pulp.plan.io/issues/8312
15:37:22 <ggainey> can we add "this is why" to the issue?
15:37:36 <daviddavis> ggainey: will do
15:37:41 <ggainey> thanks
15:38:18 <ttereshc> heh, we haven't tried syncing from pulp3 using pulp2
15:38:31 <daviddavis> hehe
15:38:36 <ttereshc> it's very ... creative :)
15:38:54 <ipanova> ttereshc: i believe this is what will happen with capsules
15:39:17 <ipanova> so there will be a lot of sync from pulp3 with pulp2
15:39:35 <ttereshc> yeah
15:39:38 <bmbouter> agreed
15:40:04 <ipanova> i think we should accept and fix soon
15:40:23 <ttereshc> let's look into it soon then
15:40:24 <ggainey> ipanova: is the prob happening on the pulp2 side?
15:40:35 <daviddavis> soon = add to the sprint?
15:40:37 <ggainey> (not disagreeing on fixing, just trying to wrap my head around the issue)
15:40:46 <ttereshc> my worry is that we might work with different file size types in different pulps
15:41:18 <ipanova> ggainey: i think pulp3, because pulp-2to-pulp2 sis not have such reports for a long time
15:41:29 <ipanova> s/sis/did
15:41:32 <ggainey> ok
15:41:44 <ttereshc> daviddavis, soon = by May-ish
15:41:49 <daviddavis> ah ok
15:41:53 <bmbouter> yeahhhhh
15:41:55 <bmbouter> that kind of soon
15:42:06 <ipanova> def after 3.11 relase :D
15:42:09 <daviddavis> should I put it on a milestone?
15:42:16 <daviddavis> or just accept?
15:42:23 <bmbouter> I think just accept
15:42:29 <daviddavis> #idea Proposed for #8312: Leave the issue as-is, accepting its current state.
15:42:29 <daviddavis> !propose accept
15:42:29 <bmbouter> what do others think?
15:42:29 <pulpbot> daviddavis: Proposed for #8312: Leave the issue as-is, accepting its current state.
15:42:37 <ttereshc> yeah, we might mark it as katello
15:42:44 <ttereshc> I'll run it by jsherrill
15:42:46 <ipanova> +1 to katello tag and just accept
15:43:10 <fao89> #info fao89 has joined triage
15:43:10 <fao89> !here
15:43:10 <pulpbot> fao89: fao89 has joined triage
15:43:12 <daviddavis> I'll accept and maybe ttereshc you can add the katello tag after speaking to jsherrill
15:43:18 <daviddavis> #agreed Leave the issue as-is, accepting its current state.
15:43:18 <daviddavis> !accept
15:43:18 <pulpbot> daviddavis: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:43:19 <daviddavis> #topic https://pulp.plan.io/issues/8306
15:43:19 <pulpbot> daviddavis: 4 issues left to triage: 8306, 8305, 8295, 8282
15:43:20 <pulpbot> RM 8306 - hyu - POST - Improve the speed of syncing repository
15:43:21 <pulpbot> https://pulp.plan.io/issues/8306
15:43:43 <ggainey> this is another pulp2
15:43:49 <ttereshc> daviddavis, will do
15:43:58 <ggainey> and ttereshc's remarks RE mongo versions def concern me :(
15:45:15 <ggainey> (comments on the PR, I mean)
15:45:16 <bmbouter> ttereshc: is this what you wanted input on yes?
15:45:23 <ttereshc> yes
15:45:34 <ttereshc> maybe we can skip it for now
15:45:43 <ttereshc> bmbouter, I pinged you since it's a Sat matter
15:45:57 <ipanova> +1 let's take a look but skip for now
15:46:00 <bmbouter> ack agreed
15:46:04 <daviddavis> !skip
15:46:05 <daviddavis> #topic https://pulp.plan.io/issues/8305
15:46:05 <pulpbot> daviddavis: 3 issues left to triage: 8305, 8295, 8282
15:46:06 <pulpbot> RM 8305 - dalley - NEW - Deleting a remote used as source for live content corrupts ContentArtifact records
15:46:06 <ggainey> +1
15:46:06 <bmbouter> +1
15:46:07 <pulpbot> https://pulp.plan.io/issues/8305
15:46:32 <bmbouter> I believe we should skip b/c dalley is getting more info and puplcore team will rediscuss next tuesday
15:46:32 <dalley> +1
15:46:37 <ipanova> +1
15:46:40 <dalley> I think we can mark triaged
15:46:45 <daviddavis> !skip
15:46:46 <daviddavis> #topic https://pulp.plan.io/issues/8295
15:46:46 <pulpbot> daviddavis: 2 issues left to triage: 8295, 8282
15:46:47 <daviddavis> oops
15:46:47 <pulpbot> RM 8295 - wibbit - NEW - Disc Usage during Repository Sync
15:46:48 <pulpbot> https://pulp.plan.io/issues/8295
15:46:52 <dalley> daviddavis, it's fine
15:46:56 <daviddavis> k
15:47:32 <dalley> I actually meant to bring this up at pulpcore meeting
15:48:05 <daviddavis> yea, I told wibbit to file this
15:48:17 <daviddavis> I didn't realize working dir held the entire repo until sync completed
15:49:10 <ttereshc> fwiw, it's a regression in comparison to pulp2
15:49:20 <ggainey> ouch, painful
15:49:38 <ggainey> esp if you're syncing multiple repos at once
15:49:52 <bmbouter> so the working dir is not expected to be on the same filesystem as artifact storage
15:50:01 <bmbouter> whoops s/is not/is/
15:50:28 <bmbouter> so I was expecting it not to use double also
15:50:42 <ggainey> acept and add to this?
15:50:46 <bmbouter> but hardlink it at save time instead
15:51:21 <ggainey> do we make that explicit in the docs?
15:51:35 <ttereshc> I'm not sure if the same fs is the safe expectation
15:53:20 <ipanova> ttereshc: i believe this is what we have been claiming in respect to pulp2
15:53:29 <ipanova> but we should at least have this documented
15:53:41 <ttereshc> regardless, +1 to accept
15:53:54 <bmbouter> +1 accept
15:54:09 <bmbouter> ttereshc: I expect it to hardlink if it can and fall back to copy if it's crossing filesystem
15:54:14 <daviddavis> #idea Proposed for #8295: Leave the issue as-is, accepting its current state.
15:54:14 <daviddavis> !propose accept
15:54:14 <pulpbot> daviddavis: Proposed for #8295: Leave the issue as-is, accepting its current state.
15:54:35 <daviddavis> #agreed Leave the issue as-is, accepting its current state.
15:54:35 <daviddavis> !accept
15:54:35 <pulpbot> daviddavis: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:54:36 <daviddavis> #topic https://pulp.plan.io/issues/8282
15:54:37 <pulpbot> daviddavis: 1 issues left to triage: 8282
15:54:38 <pulpbot> RM 8282 - dalley - NEW - Make "publish_settings" a mandatory parameter on Publication.create()
15:54:39 <pulpbot> https://pulp.plan.io/issues/8282
15:54:48 <daviddavis> #idea Proposed for #8282: convert to task
15:54:48 <daviddavis> !propose other convert to task
15:54:48 <pulpbot> daviddavis: Proposed for #8282: convert to task
15:54:58 <ttereshc> bmbouter, that makes sense, however in pulp 2 we would move it the moment a file is done downloading, which keeps it low regardless of the approach
15:55:33 <ttereshc> any new info for #8282 or still skipping?
15:55:53 <ttereshc> dalley, ^
15:57:09 <dalley> skip
15:57:18 <bmbouter> ttereshc: mmm I see, maybe that is something we should look at doing also
15:57:23 <bmbouter> the pipeline could facilitate that
15:57:28 <dalley> it still depends on what we do with auto-publish
15:57:35 <ggainey> ah, kk
15:57:56 <daviddavis> !skip
15:57:57 <pulpbot> daviddavis: No issues to triage.
15:58:08 <daviddavis> #endmeeting