14:32:24 <daviddavis> #startmeeting Pulp Triage 2021-03-16
14:32:24 <daviddavis> #info daviddavis has joined triage
14:32:24 <daviddavis> !start
14:32:24 <pulpbot> Meeting started Tue Mar 16 14:32:24 2021 UTC.  The chair is daviddavis. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:24 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:32:24 <pulpbot> The meeting name has been set to 'pulp_triage_2021-03-16'
14:32:24 <pulpbot> daviddavis: daviddavis has joined triage
14:32:34 <x9c4> #info x9c4 has joined triage
14:32:34 <x9c4> !here
14:32:35 <pulpbot> x9c4: x9c4 has joined triage
14:32:36 <ttereshc> #info ttereshc has joined triage
14:32:36 <ttereshc> !here
14:32:36 <daviddavis> fao89: I got you
14:32:36 <pulpbot> ttereshc: ttereshc has joined triage
14:32:37 <ppicka> #info ppicka has joined triage
14:32:37 <ppicka> !here
14:32:37 <pulpbot> ppicka: ppicka has joined triage
14:32:46 <gerrod> #info gerrod has joined triage
14:32:46 <gerrod> !here
14:32:46 <pulpbot> gerrod: gerrod has joined triage
14:32:54 <fao89> daviddavis++
14:32:54 <pulpbot> fao89: daviddavis's karma is now 455
14:33:04 <daviddavis> ok, open floor
14:33:13 <daviddavis> Pulp Python has moved all of its issues over to Github. What should happen to the pulp.plan.io page?
14:33:49 <daviddavis> we struggled with this in pulp-cli
14:34:16 <daviddavis> the options are basically: 1. archive the project and make it inaccessible
14:34:20 <daviddavis> 2. the the project as is
14:34:21 <x9c4> The changelog links to the issues there.
14:34:35 <daviddavis> and with 2, there may be some way to make the issues readonly?
14:35:05 <x9c4> can you repeat 2.?
14:35:20 <daviddavis> basically leave the project accessible to users
14:35:26 <daviddavis> but maybe try to make it readonly somehow
14:35:42 <x9c4> That would be ideal.
14:36:00 <daviddavis> I agree. I can look into how we can make it readonly
14:36:17 <ggainey> #info ggainey has joined triage
14:36:17 <ggainey> !here
14:36:17 <pulpbot> ggainey: ggainey has joined triage
14:37:03 <daviddavis> any objections?
14:37:20 <gerrod> +1 to readonly
14:37:42 <ggainey> I have seen projects that archived issues from "old tool" into a .tar.gz, that was then checked into the project. That way, if the old-tool goes away, you can still find the history/discussion contained in the old issues
14:37:55 <ggainey> but I would def start with 'readonly' if we can
14:38:00 <x9c4> Maybe we can shrink the permissions to a minimum as a backup plan
14:38:20 <ggainey> yeah, needs some investigation
14:39:09 <daviddavis> cool, I'll look into it
14:39:19 <ttereshc> +1 to readonly, I hoped that archiving means making it readonly
14:39:24 <bmbouter> #info bmbouter has joined triage
14:39:24 <bmbouter> !here
14:39:24 <pulpbot> bmbouter: bmbouter has joined triage
14:39:50 <bmbouter> all ^ sounds good to me
14:40:30 <daviddavis> ttereshc: no it makes it compleltely inaccessible
14:40:40 <ggainey> alas
14:40:48 <ggainey> (does plan.io have a project-export?)
14:40:50 <dalley> ironically
14:40:58 <bmbouter> it does
14:41:07 <bmbouter> and we can also request backups in addition to the redmine feature set
14:41:25 <ggainey> ah kk
14:41:30 <ggainey> so we have a number of options
14:42:08 <bmbouter> shall we put pulp_python and CLI into 'archive' and see what it does for us?
14:42:25 <dalley> fwiw... I don't know that the history for the Python plugin on plan.io is especially valuable anymore
14:42:30 <daviddavis> bmbouter: cli is already in archive
14:42:48 <ggainey> dalley: consider it a practice run for larger/older projects
14:42:52 <ggainey> :)
14:42:59 <bmbouter> it seems like archive vs close is really about including in search results or not https://luisblasco.com/en/redmine-delete-archive-or-close-projects/
14:43:15 <bmbouter> archive I think is probably better (it makes it really hidden but the data is still there)
14:43:58 <gerrod> i can't access issues for cli though
14:44:12 <gerrod> i get 403
14:44:28 <daviddavis> yea
14:44:28 <bmbouter> yes but we could unarchive it
14:44:40 <bmbouter> maybe closed is better? maybe we close pulp_python and compare?
14:44:45 <daviddavis> sure
14:44:58 <ttereshc> I agree that likely there is not much benefit for cli or python history however it would be good to come up with some readonly option when/if we migrate older projects like pulp_rpm
14:45:18 <ggainey> +1
14:46:03 <daviddavis> I just closed pulp_python
14:46:11 <bmbouter> I don't see the close option
14:46:12 <daviddavis> this seems like the way to go https://pulp.plan.io/projects/pulp_python
14:46:20 <daviddavis> bmbouter: it's on the project page in the top right
14:46:25 <bmbouter> ty
14:46:31 <bmbouter> nice that is looking good
14:46:47 <daviddavis> agreed
14:47:13 <daviddavis> I think this is what we want
14:47:19 <ggainey> perfect - I was about to ask "can we get a banner", and there it is :)
14:47:22 <ggainey> +1
14:47:27 <bmbouter> great job moving pulp_python to GHI
14:47:29 <ttereshc> great
14:47:30 <ggainey> +1
14:47:39 <bmbouter> at some point we should do pulp_ansible I think fao89 daviddavis gerrod
14:47:46 <bmbouter> was this automated or manual?
14:47:47 <daviddavis> +1
14:48:20 <gerrod> i manually moved it, there are automated scripts that use the redmine and github apis
14:49:11 <ttereshc> it would be good to move something which requires a link to a remote tracker
14:49:11 <ggainey> um
14:49:28 <ggainey> can we reopen it just long enough to remove the "meet girls now!" spam that is the current top entry? :)
14:49:29 <ttereshc> this was one of the obstacles to move for some projects
14:49:48 <daviddavis> ggainey: ha done
14:49:58 <ggainey> :)
14:50:00 <ttereshc> poor girls
14:50:27 <daviddavis> they're fine. they're vips
14:51:06 <x9c4> "very inaccurately posted spam"?
14:51:20 <ggainey> hehehe
14:51:23 <ttereshc> :D
14:51:58 <daviddavis> issue time?
14:52:32 <daviddavis> !next
14:52:33 <pulpbot> daviddavis: 1 issues left to triage: 8408
14:52:33 <daviddavis> #topic https://pulp.plan.io/issues/8408
14:52:34 <pulpbot> RM 8408 - alikins - NEW - global_access_conditions.has_obj_perms() triggers a DRF AssertError 'Expected view ContainerNamespaceViewSet to be called with a URL keyword argument named "pk"...'
14:52:35 <pulpbot> https://pulp.plan.io/issues/8408
14:53:11 <ipanova> #info ipanova has joined triage
14:53:11 <ipanova> !here
14:53:11 <pulpbot> ipanova: ipanova has joined triage
14:53:18 <ipanova> move to pulp_container for now
14:53:32 <daviddavis> ok
14:53:44 <daviddavis> #idea Proposed for #8408: move to pulp_container
14:53:44 <daviddavis> !propose other move to pulp_container
14:53:44 <pulpbot> daviddavis: Proposed for #8408: move to pulp_container
14:53:52 <ttereshc> +1
14:53:56 <ggainey> +1
14:54:12 <daviddavis> #agreed move to pulp_container
14:54:12 <daviddavis> !accept
14:54:12 <pulpbot> daviddavis: Current proposal accepted: move to pulp_container
14:54:13 <x9c4> I don't think it's a bug.
14:54:14 <pulpbot> daviddavis: No issues to triage.
14:54:18 <ggainey> whoa
14:54:24 <ggainey> how did *that* happen?!?
14:54:41 <daviddavis> ggainey: ?
14:54:54 <wibbit> ggainey: I'm sure I can think of some thing to put in there :)
14:54:55 <ggainey> daviddavis: only 1 issue - I've never seen that before :)
14:55:00 <daviddavis> hehe
14:55:00 <ggainey> wibbit: hush you :)
14:55:21 <daviddavis> #endmeeting
14:55:21 <daviddavis> !end