14:30:18 <fao89> #startmeeting Pulp Triage 2021-03-19
14:30:18 <fao89> !start
14:30:18 <fao89> #info fao89 has joined triage
14:30:18 <pulpbot> Meeting started Fri Mar 19 14:30:18 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:18 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:18 <pulpbot> The meeting name has been set to 'pulp_triage_2021-03-19'
14:30:18 <pulpbot> fao89: fao89 has joined triage
14:30:25 <fao89> Open floor!
14:30:37 <x9c4> #info x9c4 has joined triage
14:30:37 <x9c4> !here
14:30:37 <pulpbot> x9c4: x9c4 has joined triage
14:30:43 <ttereshc> #info ttereshc has joined triage
14:30:43 <ttereshc> !here
14:30:43 <pulpbot> ttereshc: ttereshc has joined triage
14:30:45 <daviddavis> #info daviddavis has joined triage
14:30:45 <daviddavis> !here
14:30:45 <pulpbot> daviddavis: daviddavis has joined triage
14:30:50 <ppicka> #info ppicka has joined triage
14:30:50 <ppicka> !here
14:30:51 <pulpbot> ppicka: ppicka has joined triage
14:30:59 <fao89> topic: Next pulpcore release date and release shepherd
14:31:54 <daviddavis> for the date, maybe march 30?
14:32:16 <bmbouter> #info bmbouter has joined triage
14:32:16 <bmbouter> !here
14:32:16 <pulpbot> bmbouter: bmbouter has joined triage
14:32:16 <x9c4> Not sure about the date, but i can take the legwork for the release.
14:32:37 <daviddavis> ok, I created a release rotation but if you want to volunteer, that's fine
14:32:40 <bmbouter> at least the 30th as our first date is ok
14:32:49 <ttereshc> it would mean we have 1 week + a couple of days to complete work
14:33:05 <ttereshc> so maybe it is worth looking at what needs to be done?
14:33:08 <fao89> march 30, 2022
14:33:11 <daviddavis> hehe
14:33:36 <ttereshc> I'm not against March 30, just not sure if it's ok or not for what needs to be done
14:34:16 <bmbouter> I'm also not really thinking we'll be ready by then
14:34:20 <bmbouter> but I think it's an ok goal
14:34:23 <ipanova> #info ipanova has joined triage
14:34:23 <ipanova> !here
14:34:23 <pulpbot> ipanova: ipanova has joined triage
14:34:31 <fao89> we are missing the opportunity, April 1st is a good date (ok, I stopped now)
14:34:54 <ttereshc> fao89, sure and a long weekend after it
14:35:09 <x9c4> I see 15 issues on the milestone. That's like 2 per day.
14:35:19 <ipanova> i was thinking to reach out to rhui team and ask whether to release before Easter of after
14:35:46 <ipanova> since they are main driver for the release as far as a i understood
14:35:55 <bmbouter> I agree they are main driver
14:36:00 <daviddavis> x9c4: half the issues are in progress or nearly done
14:36:06 <daviddavis> here's the issues https://tinyurl.com/3a7w9yd7
14:36:08 <bmbouter> also we're going to likely remove the other half lol
14:36:14 <bmbouter> see further down in agenda
14:36:20 <fao89> how about the release improvements on CI?
14:36:30 <ttereshc> what needs to be done for rhui? auto publish/distribute?
14:36:33 <fao89> can we have it before next release?
14:36:37 <bmbouter> yes auto publish / distribute
14:36:59 <daviddavis> fao89: I think some. at least the PR I have open.
14:37:03 <gerrod> #info gerrod has joined triage
14:37:03 <gerrod> !here
14:37:03 <pulpbot> gerrod: gerrod has joined triage
14:37:20 <fao89> daviddavis++
14:37:20 <pulpbot> fao89: daviddavis's karma is now 460
14:37:25 <bmbouter> daviddavis: maybe we should put thoseonto the 3.12 list? (just an idea)
14:37:47 <bmbouter> anyway back to the date convo
14:38:04 <daviddavis> bmbouter: put what onto the 3.12 list?
14:38:10 <ttereshc> then +1 to ask rhui about the date if it is feasible at all to finish the work they need by the end of month
14:38:37 <daviddavis> ttereshc: makes sense to me
14:39:31 <ipanova> i can ask rhui folks about the auto publish/distribute delivery deadline date
14:39:37 <ttereshc> bmbouter, when you said that we might not be ready by March 30, was it about auto distribute or it included some other work?
14:39:46 <fao89> does it mean defining a date on next open floor?
14:40:09 <daviddavis> there's also some import/export work we need for 3.11
14:40:21 <daviddavis> but I am hoping it'll only take a week
14:40:32 <ttereshc> you mean 3.12?
14:40:47 <daviddavis> I think we promised katello 3.11 but I can doublecheck
14:40:56 <daviddavis> either 3.11 or early april
14:41:16 <ttereshc> 3.11.0 is out, so isit 3.11.z?
14:41:23 <ipanova> daviddavis: will that work then end up in 3.11.z?
14:41:24 <ttereshc> I'm a bit confused
14:41:25 <daviddavis> ah, I meant 3.12
14:41:26 <daviddavis> ha
14:41:46 <daviddavis> I lost track of release #s when I went on vacation
14:41:52 <ttereshc> :D
14:41:54 <bmbouter> ttereshc: the auto distribute is mostly done in dalley's PR
14:42:06 <bmbouter> the real work I'm working on is for https://pulp.plan.io/issues/8384
14:42:38 <ttereshc> great, than +1 to ask rhui about the date
14:43:11 <fao89> does it mean defining a date on next open floor? after rhui feedback
14:43:24 <ttereshc> +1 from me
14:43:31 <daviddavis> sure
14:44:09 <fao89> any other topic before I start the triage?
14:44:19 <ttereshc> daviddavis, you said you created a release rotation
14:44:45 <daviddavis> I did. it's in reverse order of last to release pulpcore: dalley bmbouter mdellweg daviddavis dkliban ttereshc ipanova
14:44:45 <bmbouter> daviddavis: re 3.12 items I was wondering if the two release Prs may make sense to add to 3.12 milestone (the already open ones)
14:44:52 <daviddavis> but I think mdellweg volunteered
14:45:12 <ttereshc> ah ok, thanks
14:45:18 <x9c4> Would that put me at the front of that list?
14:45:24 <daviddavis> x9c4: sure. done.
14:45:30 <x9c4> TY!
14:45:55 <daviddavis> bmbouter: I think there's only one release PR and I'm hoping we can get it merged before 3.12 https://github.com/pulp/plugin_template/pull/357
14:46:08 <daviddavis> I may have another if time permits
14:46:11 <daviddavis> after I finish FIPS
14:46:18 <bmbouter> cool
14:46:33 <x9c4> great!
14:46:35 <bmbouter> no need to formally add, it shouldn't block anyway, let's keep them off
14:46:46 <daviddavis> +1
14:46:59 <ttereshc> +1
14:47:05 <daviddavis> I'm hoping to go over the items on the milestone but we can do that Tuesday at pulpcore meeting or whenever
14:47:16 <daviddavis> I think some work can be deferred
14:47:22 <ipanova> +1
14:48:04 <bmbouter> I put it on open floor which we do after triage?
14:48:26 <bmbouter> oh!
14:48:30 <bmbouter> I put on wrong date in agendaaaaaa
14:48:42 <bmbouter> whooops
14:48:47 <bmbouter> I moved it up now
14:48:53 <bmbouter> if you want to do at pulpcore instead I'm ok w/ that
14:49:01 <daviddavis> no, today is fine
14:49:08 <bmbouter> ok great shall we move to that then?
14:49:21 <daviddavis> +1
14:49:28 <daviddavis> this link might be easier to review https://tinyurl.com/3a7w9yd7
14:49:41 <bmbouter> +1
14:50:14 <ipanova> how do we proceed with this one? https://pulp.plan.io/issues/8048
14:50:32 <ipanova> i doubt we will have time to figure out how to properly address this in 3.12
14:50:42 <bmbouter> I agree which is why we shouldn't do it
14:51:12 <ipanova> like take it off completely from 3.12?
14:51:14 <bmbouter> I was just asking on slack if they even need it for 3.12, I heard a week ago they didn't have any time line they needed it on
14:51:25 <bmbouter> but they are off today so they can't confirm
14:51:31 <bmbouter> but yes I think take off 3.12 (my take)
14:52:01 <bmbouter> my hope is we dig more into why we can't make their objects representable given they haven't said yes we need this by X
14:52:34 <ipanova> ok
14:53:00 <ipanova> let's then confirm there is no need to deliver it in 3.12
14:53:34 <bmbouter> +1
14:53:47 <bmbouter> so let's leave on 3.12 for now because we can't confirm today w/ them
14:54:16 <bmbouter> I'd like us to consider moving https://pulp.plan.io/issues/8204 and https://pulp.plan.io/issues/8192 to 3.12
14:54:19 <bmbouter> 3.13 rather
14:54:26 <daviddavis> I think we can remove this from 3.12 entirely https://pulp.plan.io/issues/8204
14:54:36 <bmbouter> +1
14:54:39 <bmbouter> I was thinking the same
14:54:42 <daviddavis> or maybe defer to 3.13?
14:54:49 <bmbouter> can we remove entirely for now
14:54:53 <daviddavis> +1
14:54:57 <ipanova> +1 remove
14:54:59 <bmbouter> I'm not convinced this is what we should do to resolve the motivating issue really
14:55:11 <bmbouter> 8192 I'd like to move to 3.13
14:55:14 <daviddavis> x9c4: are you doing the bookkeeping?
14:55:15 <bmbouter> who is clicking buttons btw?
14:55:18 <daviddavis> hehe
14:55:20 <ipanova> how about this one https://pulp.plan.io/issues/8192
14:55:28 <ipanova> bmbouter: bet me to it
14:55:43 <daviddavis> defer 8192 to 3.13?
14:55:47 <daviddavis> sounds good to me
14:55:49 <bmbouter> we need to keep that on the schedule for "a soon release" it's an AWX galaxy_ng requirement
14:55:59 <ipanova> +1 defer to 3.13
14:56:04 <x9c4> trying to keep track.
14:56:11 <ipanova> i think main concern was addressed in 3.11
14:56:42 <x9c4> +1
14:56:53 <daviddavis> +1
14:57:03 <bmbouter> I think keeping https://pulp.plan.io/issues/7438 makes sense but I'm concerned that we're doing https://pulp.plan.io/issues/8146 too soon
14:57:26 <bmbouter> I don't think we should be making a backwwards compatible change and declaring it stable forever in the same release
14:57:57 <daviddavis> that's fine. we can postpone 8146.
14:58:05 <daviddavis> move it to 3.13
14:58:10 <bmbouter> yup 3.13 I think would be right
14:58:12 <ipanova> +1
14:58:22 <ipanova> there is one more related to import/export https://pulp.plan.io/issues/7904
14:58:24 <x9c4> move 8146 to 3.13
14:58:56 <bmbouter> +1
14:59:09 <daviddavis> +1
14:59:33 <daviddavis> I can doublecheck with katello on import/export but I think they'd like to have it in 3.12
14:59:52 <ipanova> ok, let's keep this in for now
15:00:02 <ttereshc> 7904 sounds quite bad, so if they need working imp/exp in 3.12 then we should fix it
15:00:03 <bmbouter> +1
15:00:10 <daviddavis> +1
15:00:13 <x9c4> +1
15:00:17 <ipanova> so there is one last left in new https://pulp.plan.io/issues/7316
15:00:38 <daviddavis> this is quite bad and we should fix it in 3.12 hopefully
15:00:49 <bmbouter> I agree
15:00:55 <bmbouter> +1 to keeping it
15:00:58 <bmbouter> I'm not sure what the plan is though
15:01:03 <bmbouter> maybe we can talk at pulpcore meeting about this?
15:01:21 <ttereshc> it is still better to not delete it than delete something in addition to it :)
15:01:26 <ipanova> +1
15:01:31 <ttereshc> so maybe it's not that bad
15:02:09 <ttereshc> +1 to discuss details at pulpcore meeting
15:02:22 <ipanova> i think dealing with this in 3.13 will be more realistic given the timeframes
15:02:31 <ipanova> but +1 to talk about it at the pulpcore meeting
15:02:56 <ttereshc> and it's been this way all the time (apart from the short django-cleanup period)
15:03:19 <fao89> triage?
15:03:25 <bmbouter> one more thing
15:03:34 <bmbouter> can someone add ^ to the pulpcore agenda? or I can lmk
15:03:51 <bmbouter> also if someone can do this simple thing soon that would be good https://pulp.plan.io/issues/8354
15:04:07 <ttereshc> I'll add
15:04:11 <bmbouter> from our retro we identified breaking changes (like deprecated removals) should occur early in the Y release cycle
15:04:13 <bmbouter> ttereshc: ty
15:04:15 <ttereshc> and +1 to keep 8354
15:05:19 <bmbouter> cool we can move to triage. if someone can implement 8354 woot
15:05:37 <x9c4> I'll do. It's about deleting code.
15:06:00 <ttereshc> yeah bmbouter  I wouldn't worry about it, anyone can do it last minute
15:06:12 <fao89> !next
15:06:13 <pulpbot> fao89: 4 issues left to triage: 8427, 8416, 8411, 8306
15:06:13 <fao89> #topic https://pulp.plan.io/issues/8427
15:06:14 <pulpbot> RM 8427 - ipanova@redhat.com - POST -  Fix azure artifacts path download
15:06:15 <pulpbot> https://pulp.plan.io/issues/8427
15:06:31 <daviddavis> accept and add to sprint
15:06:41 <fao89> #idea Proposed for #8427: accept and add to sprint
15:06:41 <fao89> !propose other accept and add to sprint
15:06:41 <pulpbot> fao89: Proposed for #8427: accept and add to sprint
15:06:57 <fao89> #agreed accept and add to sprint
15:06:57 <fao89> !accept
15:06:57 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:06:58 <fao89> #topic https://pulp.plan.io/issues/8416
15:06:59 <pulpbot> fao89: 3 issues left to triage: 8416, 8411, 8306
15:07:01 <pulpbot> RM 8416 - daviddavis - NEW - Have pulp_installer automatically install pulp-cli
15:07:02 <pulpbot> https://pulp.plan.io/issues/8416
15:07:22 <daviddavis> task
15:07:25 <ipanova> #idea Proposed for #8416: Leave the issue as-is, accepting its current state.
15:07:25 <ipanova> !propose accept
15:07:25 <pulpbot> ipanova: Proposed for #8416: Leave the issue as-is, accepting its current state.
15:07:26 <fao89> !propose other move to installer category
15:07:35 <ttereshc> +1
15:07:37 <ipanova> +1
15:07:55 <x9c4> +1
15:07:57 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:07:57 <fao89> !accept
15:07:57 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:07:58 <fao89> #topic https://pulp.plan.io/issues/8411
15:07:58 <pulpbot> fao89: 2 issues left to triage: 8411, 8306
15:07:59 <pulpbot> RM 8411 - binlinf0 - NEW - Inconsistent data in upstream remote repo causes inconsistent of pulp content
15:08:00 <pulpbot> https://pulp.plan.io/issues/8411
15:08:37 <fao89> #idea Proposed for #8411: Leave the issue as-is, accepting its current state.
15:08:37 <fao89> !propose accept
15:08:37 <pulpbot> fao89: Proposed for #8411: Leave the issue as-is, accepting its current state.
15:08:50 <daviddavis> accept and add to sprint?
15:09:08 <bmbouter> yeah I'm not sure what to do about it exactly but +1
15:09:09 <fao89> #idea Proposed for #8411: accept and add to sprint
15:09:09 <fao89> !propose other accept and add to sprint
15:09:09 <pulpbot> fao89: Proposed for #8411: accept and add to sprint
15:09:11 <ipanova> +1 add to sprint
15:09:12 <daviddavis> it sounds like bin li's system was hosed after it encountered this issue
15:09:24 <bmbouter> yup
15:09:24 <fao89> #agreed accept and add to sprint
15:09:24 <fao89> !accept
15:09:24 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:09:25 <fao89> #topic https://pulp.plan.io/issues/8306
15:09:25 <pulpbot> fao89: 1 issues left to triage: 8306
15:09:26 <pulpbot> RM 8306 - hyu - POST - Improve the speed of syncing repository
15:09:27 <pulpbot> https://pulp.plan.io/issues/8306
15:09:52 <ipanova> skip
15:10:05 <fao89> !skip
15:10:05 <ttereshc> +1
15:10:06 <pulpbot> fao89: No issues to triage.
15:10:10 <fao89> #endmeeting
15:10:10 <fao89> !end