14:30:23 <fao89> #startmeeting Pulp Triage 2021-03-26
14:30:23 <fao89> #info fao89 has joined triage
14:30:23 <fao89> !start
14:30:23 <pulpbot> Meeting started Fri Mar 26 14:30:23 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:23 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:23 <pulpbot> The meeting name has been set to 'pulp_triage_2021-03-26'
14:30:23 <pulpbot> fao89: fao89 has joined triage
14:30:43 <daviddavis> #info daviddavis has joined triage
14:30:43 <daviddavis> !here
14:30:43 <pulpbot> daviddavis: daviddavis has joined triage
14:30:44 <ppicka> #info ppicka has joined triage
14:30:44 <ppicka> !here
14:30:44 <pulpbot> ppicka: ppicka has joined triage
14:31:14 <ttereshc> #info ttereshc has joined triage
14:31:14 <ttereshc> !here
14:31:14 <pulpbot> ttereshc: ttereshc has joined triage
14:31:21 <fao89> topic: Would like to remove https://github.com/pulp/dummy
14:31:36 <fao89> +1 for me
14:32:09 <ttereshc> My main interest is whether we figured out how to associate issues with external trackers like BZ and what is the plan for custom queries
14:32:23 <ttereshc> I understand that we have python and cli in the github issues
14:32:32 <ttereshc> but they do not require/use this I think
14:32:48 <daviddavis> that's true
14:33:06 <ttereshc> I'm ok to remove or not remove the repo, just reminding that we need to figure something out for more comlex workflows
14:33:39 <bmbouter> #info bmbouter has joined triage
14:33:39 <bmbouter> !here
14:33:39 <pulpbot> bmbouter: bmbouter has joined triage
14:33:50 <bmbouter> +1 to remove dummy
14:33:58 <ggainey> #info ggainey has joined triage
14:33:58 <ggainey> !here
14:33:58 <pulpbot> ggainey: ggainey has joined triage
14:34:01 <ggainey> +1
14:34:16 <daviddavis> we can create a new dummy repo if someone needs it again
14:34:25 <ppicka> +1
14:34:38 <fao89> it is already created, the name is pulp_npm =P
14:34:43 <daviddavis> haha
14:35:01 <fao89> AKA pulp_ci_tester
14:35:10 <ggainey> heheh
14:35:12 <daviddavis> I would like to see the work move forward into investigating getting us off redmine but I don't know how
14:35:42 <daviddavis> maybe me or someone else will have time eventually
14:35:44 <bmbouter> I believe the next step would hopefully be done by gerrod. to use the scripts to migrate pulp_ansible to GHI instead of doing it by hand like we have been doing
14:35:56 <daviddavis> +1
14:36:08 <daviddavis> that sounds good
14:36:09 <gerrod> #info gerrod has joined triage
14:36:09 <gerrod> !here
14:36:09 <pulpbot> gerrod: gerrod has joined triage
14:36:24 <bmbouter> ttereshc: those scripts have a lot of features, so I believe it will port tags as labels and also comments
14:36:24 <daviddavis> ok, well I got my answer about the dummy repo
14:36:42 <bmbouter> ttereshc: not trying to say don't worry about it at all, just sharing info from what I heard
14:36:45 <fao89> we need to have "pulp budget" we usually delay things for us
14:37:22 <bmbouter> daviddavis: agreed on having the answer we need for now
14:37:32 <fao89> next topic?
14:37:34 <ttereshc> bmbouter, thanks, I understand, works for me
14:37:59 <daviddavis> yea, next topic
14:38:00 <fao89> topic: Any concern w/removing pulp-smash from pypi and using git repo instead?
14:38:43 <fao89> no concerns from me
14:38:48 <daviddavis> CI uses source now. plugins are split on their use of pulp-smash but I plan to send out an announcement and open PRs if we decide to go this route.
14:39:05 <ttereshc> do you know if anyone else uses it?
14:39:14 <ttereshc> e.g. we encouraged exd qe to use it
14:39:20 <daviddavis> I don't. kind of why I was asking.
14:39:29 <ttereshc> installing from source might still be fine
14:39:48 <ipanova> #info ipanova has joined triage
14:39:48 <ipanova> !here
14:39:48 <pulpbot> ipanova: ipanova has joined triage
14:39:57 <daviddavis> do you think an email to pulp-dev might suffice for feedback? not sure if exd qe reads that list.
14:39:58 <ttereshc> maybe when you send an announcement we can share that thread with exd and ask
14:40:03 <ttereshc> heh
14:40:34 <daviddavis> ok, I'll start sending out some emails
14:40:41 <daviddavis> do we have a contact for exd qe?
14:40:49 <ttereshc> ipanova, ^
14:41:12 <ttereshc> was there anyone using pulp-smash or am I dreaming?
14:41:21 <ipanova> pulp-smash is for pulp3
14:41:27 <ipanova> i don't think exd ever ran it
14:42:39 <bmbouter> +1 to removing it from pypi
14:42:44 <bmbouter> sorry I stepped away for a min
14:42:44 <ipanova> and probably very rarely ran pulp2 suit tests. idon't know any qe contact though
14:43:09 <ipanova> daviddavis: maybe drop an email rohan as na fyi
14:43:12 <ipanova> that would suffice, imo
14:43:16 <daviddavis> +1
14:43:25 <fao89> lost connection for a while, next topic?
14:43:35 <ipanova> fao89: you came just on time :D
14:43:36 <daviddavis> fao89: +1
14:43:38 <daviddavis> hehe
14:44:37 <ttereshc> ipanova, I believe you need pulp-smash to run pulp2 tests too, but +1 to the plan
14:44:54 <fao89> topic: Need a volunteer to release pulp_file compatible with 3.12
14:45:11 <ipanova> ttereshc: yes
14:45:36 <daviddavis> is this after the 3.12 release or does this need to happen sooner?
14:45:54 <ggainey> we need to coordinate pulp_file-3.12 w/ x9c4 - needs to happen pre-pulpcore-3.12 to let us address the export-api-change
14:45:54 <ttereshc> daviddavis, any time before 3.12
14:46:11 <daviddavis> ok, I can do it
14:46:25 <ggainey> daviddavis: coolio - sync up w/Matthias
14:46:28 <ttereshc> daviddavis++
14:46:28 <pulpbot> ttereshc: daviddavis's karma is now 462
14:46:31 <ggainey> (who is out today, yeah?)
14:46:31 <bmbouter> daviddavis++
14:46:31 <pulpbot> bmbouter: daviddavis's karma is now 463
14:46:36 <bmbouter> teamwork++
14:46:36 <pulpbot> bmbouter: teamwork's karma is now 22
14:46:36 <ggainey> daviddavis++
14:46:37 <ttereshc> ggainey, yes
14:46:37 <pulpbot> ggainey: daviddavis's karma is now 464
14:46:51 <fao89> !next
14:46:52 <pulpbot> fao89: 5 issues left to triage: 8454, 8447, 8445, 8444, 8438
14:46:52 <fao89> #topic https://pulp.plan.io/issues/8454
14:46:53 <pulpbot> RM 8454 - bmbouter - NEW - I can't delete RepositoryVersion.number==0
14:46:54 <pulpbot> https://pulp.plan.io/issues/8454
14:47:18 <ggainey> is that an issue? or should this be a story?
14:47:36 <ttereshc> +1 to a story, it's a change of behaviour
14:47:42 <daviddavis> +1
14:47:46 <ttereshc> currently it does what it meant to do
14:48:25 <ipanova> +1
14:48:36 <fao89> #idea Proposed for #8454: convert to story
14:48:36 <fao89> !propose other convert to story
14:48:36 <pulpbot> fao89: Proposed for #8454: convert to story
14:48:41 <ggainey> +1
14:48:46 <fao89> #agreed convert to story
14:48:46 <fao89> !accept
14:48:47 <fao89> #topic https://pulp.plan.io/issues/8447
14:48:47 <pulpbot> fao89: Current proposal accepted: convert to story
14:48:48 <pulpbot> fao89: 4 issues left to triage: 8447, 8445, 8444, 8438
14:48:49 <pulpbot> RM 8447 - daviddavis - NEW - LookupError: Could not determine ViewSet base name for model <class 'pulpcore.app.models.publication.PublishedMetadata'>
14:48:50 <pulpbot> https://pulp.plan.io/issues/8447
14:49:13 <daviddavis> accept and add to sprint?
14:49:22 <ggainey> yeah - wth is that about?!?
14:49:30 <fao89> #idea Proposed for #8447: accept and add to sprint
14:49:30 <fao89> !propose other accept and add to sprint
14:49:30 <pulpbot> fao89: Proposed for #8447: accept and add to sprint
14:49:31 <ggainey> nice reproducer daviddavis :)
14:49:45 <ttereshc> daviddavis, is it on the master?
14:49:48 <daviddavis> yes
14:50:22 <ttereshc> so potentially it's a bug introduced only on the master branch and not in any release
14:50:23 <bmbouter> I don't think 8454 is a story
14:50:40 <bmbouter> bugs change behavior that's not the criteria for a story exactly
14:50:45 <bmbouter> s/bugs/bugfixes/
14:51:03 <ggainey> bmbouter: but "you can't delete version 0" isn't a bug, it's (currently) a deliberate invariant
14:51:09 <daviddavis> ttereshc: possibly I suppose
14:51:16 <bmbouter> ggainey: is it documented?
14:51:28 <fao89> #agreed accept and add to sprint
14:51:28 <fao89> !accept
14:51:28 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:51:29 <fao89> #topic https://pulp.plan.io/issues/8445
14:51:29 <pulpbot> fao89: 3 issues left to triage: 8445, 8444, 8438
14:51:30 <pulpbot> RM 8445 - daviddavis - POST - Remote artifacts are being rejected by the artifact checksum check
14:51:31 <pulpbot> https://pulp.plan.io/issues/8445
14:51:35 <bmbouter> ^ is my 2 cents it's def debatable so can be left as a story is ok
14:52:20 <bmbouter> accept it's in POST and needed for 3.12
14:52:27 <daviddavis> +1
14:52:31 <ttereshc> +1
14:52:33 <daviddavis> add to sprint too
14:52:37 <ipanova> 3.12 is already set
14:52:46 <ipanova> +1
14:52:49 <fao89> #idea Proposed for #8445: Leave the issue as-is, accepting its current state.
14:52:49 <fao89> !propose accept
14:52:49 <pulpbot> fao89: Proposed for #8445: Leave the issue as-is, accepting its current state.
14:53:47 <ggainey> +1
14:54:17 <fao89> #idea Proposed for #8445: accept and add to sprint
14:54:17 <fao89> !propose other accept and add to sprint
14:54:17 <pulpbot> fao89: Proposed for #8445: accept and add to sprint
14:54:18 <fao89> #agreed accept and add to sprint
14:54:18 <fao89> !accept
14:54:18 <fao89_> note to myself, never run triage on element again
14:54:19 <fao89> #topic https://pulp.plan.io/issues/8444
14:54:19 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:54:20 <pulpbot> fao89: 2 issues left to triage: 8444, 8438
14:54:21 <pulpbot> RM 8444 - awcrosby - NEW - Backport Request for pulpore 3.11
14:54:22 <pulpbot> https://pulp.plan.io/issues/8444
14:55:05 <ipanova> i believe, accept?
14:55:18 <ipanova> and work on the 3.11.z schedule at our next pulpcore meeting?
14:55:28 <ggainey> sounds good to me
14:55:34 <bmbouter> +1
14:55:39 <fao89_> #idea Proposed for #8444: Leave the issue as-is, accepting its current state.
14:55:39 <fao89_> #info fao89_ has joined triage
14:55:39 <fao89_> !propose accept
14:55:39 <pulpbot> fao89_: fao89_ has joined triage
14:55:40 <pulpbot> fao89_: Proposed for #8444: Leave the issue as-is, accepting its current state.
14:55:46 <daviddavis> lol
14:56:20 <ttereshc> fao89 proposes from one account and accepts from the other :P
14:56:21 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:56:21 <fao89> !accept
14:56:21 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:56:21 <fao89> #topic https://pulp.plan.io/issues/8438
14:56:22 <pulpbot> fao89: 1 issues left to triage: 8438
14:56:23 <pulpbot> RM 8438 - awcrosby - POST - Allow plugins to unset attribute in NamedModelViewSet
14:56:24 <pulpbot> https://pulp.plan.io/issues/8438
14:56:39 <ipanova> #idea Proposed for #8438: Leave the issue as-is, accepting its current state.
14:56:39 <ipanova> !propose accept
14:56:39 <pulpbot> ipanova: Proposed for #8438: Leave the issue as-is, accepting its current state.
14:56:51 <ttereshc> this is what they asked a backport for
14:56:59 <ggainey> ahhh ok
14:57:16 <bmbouter> yup
14:57:17 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:57:17 <fao89> !accept
14:57:17 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:57:18 <pulpbot> fao89: No issues to triage.
14:57:22 * bmbouter dances
14:57:27 * bmbouter sings the friday song to daviddavis
14:57:31 <daviddavis> !friday
14:57:31 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:57:31 * ipanova cheers wildly
14:57:34 <bmbouter> !friday
14:57:34 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:57:34 <ggainey> woohoo!
14:57:41 <ggainey> friday is a fine, fine thing :)
14:57:46 <ggainey> !pulp
14:57:46 <pulpbot> 🍊 Yay, Pulp! 🍊 Go team go! 🍊
14:57:48 <fao89> !issue 8454
14:57:48 <fao89> #topic https://pulp.plan.io/issues/8454
14:57:49 <pulpbot> RM 8454 - bmbouter - NEW - I can't delete RepositoryVersion.number==0
14:57:50 <pulpbot> https://pulp.plan.io/issues/8454
14:58:10 <fao89> story or not?
14:58:12 <bmbouter> I've read a few folks desiring this to be as a story, I'm ok with that
14:58:28 <bmbouter> it's a judgement call and I think the majority want it as story
14:58:37 <bmbouter> s/judgement/subjective/
14:58:50 <fao89> #endmeeting
14:58:50 <fao89> !end