14:30:13 <fao89> #startmeeting Pulp Triage 2021-04-09
14:30:13 <fao89> #info fao89 has joined triage
14:30:13 <fao89> !start
14:30:13 <pulpbot> Meeting started Fri Apr  9 14:30:13 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:13 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:13 <pulpbot> The meeting name has been set to 'pulp_triage_2021-04-09'
14:30:13 <pulpbot> fao89: fao89 has joined triage
14:30:18 <ggainey> #info ggainey has joined triage
14:30:18 <ggainey> !here
14:30:18 <pulpbot> ggainey: ggainey has joined triage
14:30:23 <fao89> Open floor!
14:30:31 <fao89> https://hackmd.io/@pulp/triage/edit
14:30:58 <ggainey> def need more ppl
14:31:07 <fao89> yep
14:31:13 <ggainey> Modulemd is a pulp_rpm thing - PackageRelaseComponent is pulp_deb, yeah?
14:31:19 <jxsxs> yeh
14:31:24 <x9c4> #info x9c4 has joined triage
14:31:24 <x9c4> !here
14:31:24 <pulpbot> x9c4: x9c4 has joined triage
14:31:36 <ttereshc> #info ttereshc has joined triage
14:31:36 <ttereshc> !here
14:31:36 <pulpbot> ttereshc: ttereshc has joined triage
14:31:39 <daviddavis> #info daviddavis has joined triage
14:31:39 <daviddavis> !here
14:31:39 <pulpbot> daviddavis: daviddavis has joined triage
14:31:44 <fao89> topic: How to properly use `PackageReleaseComponent` and `Modulemd` for creating repositories/distributions that target multiple distros & distro versions
14:31:47 <ppicka> #info ppicka has joined triage
14:31:47 <ppicka> !here
14:31:47 <pulpbot> ppicka: ppicka has joined triage
14:32:07 <ggainey> is this in a debian context?
14:32:17 <ggainey> I think I'm confused here, sorry
14:32:24 <jxsxs> ok, so let me explain
14:32:37 <ttereshc> I think we need to tackle two different content types separately
14:32:48 <jxsxs> I upload Artifacts then map them to a Content:Package
14:33:20 <jxsxs> my ultimate goal is to have one distribution that handles different codestream (dist/debain/buster, dist/debian/stretch) etc
14:33:45 <jxsxs> so, to my understanding this is done via the Content:Release and the `Content:Package` directive
14:34:21 <jxsxs> Then there is a `Content:Release_Components`
14:34:43 <jxsxs> and a `PackageReleaseComponent`
14:35:10 <jxsxs> My main problem here is that I'm unsure which attributes they require
14:35:26 <jxsxs> especially those which are flagged with (string<uri>)
14:35:40 <jxsxs> Usually, I was fine with using the respective `pulp_href` from the referenced object
14:36:05 <jxsxs> But for these resources I always get  `"Invalid hyperlink - No URL match."`
14:36:33 <ggainey> hrm - I'm not familiar enough w/ pulp_deb to be able to talk to this
14:36:34 <jxsxs> soo, I guess the questions here is: Am I doing it wrong or is there a bug?
14:36:39 * ggainey digs into the models
14:36:45 <x9c4> As far as i know, those objects are used in the sync code to track which packages are part of which releases.
14:37:15 <jxsxs> Right, also when using the `simple` mode
14:37:18 <x9c4> I do not know, that there is enough interface to create those associations by hand.
14:37:38 <jxsxs> mh
14:37:46 <x9c4> When using simple they are completely ignored.
14:38:29 <x9c4> But in short, the Release unit us used to represent all releases (buster, stretch) in a repo
14:38:50 <jxsxs> Right, I can create those
14:38:55 <x9c4> the components are subdeviding them as (main, contrib, nonfree)
14:39:48 <x9c4> and the package_release_component is meant as a jointable to describe that a package belongs into a component (which is part of a release)
14:40:14 <jxsxs> This is basically what I want to achieve
14:40:38 <jxsxs> I'd be fine without the subdivision, though
14:40:45 <x9c4> As i said, i don't know if the viewsets are able to create those associations properly.
14:40:54 <ggainey> x9c4: question - in this code https://github.com/pulp/pulp_deb/blob/main/pulp_deb/app/serializers/content_serializers.py#L551-L567 - why are package and release_component defined w/the same query?
14:40:59 <ggainey> i feel like I'm missing something
14:41:23 <x9c4> Does not work without the components. That is the layout of a deb repo.
14:41:57 <x9c4> ggainey, i think you found a bug.
14:42:00 <x9c4> ggainey++
14:42:00 <pulpbot> x9c4: ggainey's karma is now 118
14:42:02 <ggainey> ...
14:42:04 <ggainey> well
14:42:08 <ggainey> I wasn't trying, honest! :)
14:42:37 <ggainey> shall I open a pulp_deb issue then?
14:42:51 <x9c4> Yes!
14:42:58 <ggainey> coolio, onnit
14:43:11 <fao89> ggainey++
14:43:12 <pulpbot> fao89: ggainey's karma is now 119
14:43:42 <x9c4> jxsxs, that might even explain your error message
14:44:05 <jxsxs> It may be also worth looking into `Content: Release_Components` the error message looks pretty similar
14:44:46 <jxsxs> to me it sounds like that the provided <uri>(pulp_href probably?)  isn't resolved properly
14:46:01 <ggainey> https://pulp.plan.io/issues/8533
14:46:46 <jxsxs> thanks ggainey!
14:47:04 <ggainey> no worries - might want to add yourself as a watcher to get updates
14:47:10 <x9c4> That one looks right to me.
14:47:28 <x9c4> And maybe add some of your error messages.
14:48:08 <jxsxs> will do!
14:48:23 <x9c4> jxsxs++
14:48:23 <pulpbot> x9c4: jxsxs's karma is now 1
14:48:25 <ggainey> +1
14:48:32 <ggainey> jxsxs++
14:48:32 <pulpbot> ggainey: jxsxs's karma is now 2
14:48:48 <jxsxs> Is this btw the official way doing what I was planning on doing?
14:49:13 <jxsxs> (as I wasn't able to find references for this in the docs)
14:49:28 <x9c4> More like the only way atm.
14:49:57 <x9c4> And it's not official.
14:50:04 <jxsxs> heh, got it
14:50:35 <jxsxs> ok, so since the RPM related questions is basically identical
14:51:01 <jxsxs> `Modulemd` is the way to go?
14:51:21 <ggainey> modules are...Special. And generally not in fun ways.
14:52:03 <ggainey> jxsxs: have you been to https://docs.fedoraproject.org/en-US/modularity/building-modules/fedora/defining-modules/ and related docs?
14:52:05 <jxsxs> alright, what'd be the best way to achieve distro/version type distributions in RPM land?
14:52:51 <jxsxs> ggainey no, not yet.. _puts on the list_
14:54:18 <ggainey> RPM repos (and clients) don't work like deb-repos/apt. If you had one repo that you wanted to have hold, say, F31/F32/F33 content, there isn't (that I can think of) any way to describe that in the debian buster/stretch/etc way
14:54:27 <ggainey> repos are assumed to be for one os-release
14:54:32 <ggainey> rpm repos, that is
14:54:34 <ggainey> same w/SUSE
14:55:07 <ggainey> (anybody noting anywhere I'm lying here, please jump in)
14:56:39 <ggainey> dalley: ttereshc: could we do this with distribution-paths? so the layout on-disk is more what jxsxs is thinking of?
14:57:13 <jxsxs> I tried this with `base_path` where I just set `fedora/6` etc
14:57:43 <ttereshc> ggainey, no, base_path overlap checks that no parts of other base paths are reused
14:57:46 <ttereshc> I think
14:57:49 <jxsxs> but it turns out that the content/link that is being created is not separate directories
14:57:58 <ggainey> hrm
14:58:58 <ggainey> yeah, we call that out explicitly as it turns out :)
15:00:15 <ggainey> I'm not sure you can get there from here in rpm-land, jxsxs
15:00:32 <jxsxs> dammit :>
15:00:42 <ggainey> I would def need to think hard before I could figure out a way, at any rate
15:00:49 <jxsxs> got you
15:01:05 <jxsxs> thanks to all of you though!
15:01:33 <hutchic> Is there a feature request / story for this by chance?
15:01:35 <ggainey> jxsxs: if you opened an RFE that had a detailed description of what you're envisioning, we might be able to noodle out something.
15:01:49 <ggainey> we might end up regretfully closing it as "cant' get there, from here" too, tho
15:02:18 <jxsxs> I can tinker something together
15:02:45 <ggainey> jxsxs: coolness - then you can just nag us w/a number until we do soemthing or close it, it'll be more efficient that way :)
15:03:08 <jxsxs> will do
15:03:10 <jxsxs> thanks again
15:03:17 <ggainey> ttereshc: I don't suppose you remember why base-Path can't overlap?
15:03:25 <ggainey> feels like there's a very good reason, I just don't know what it is
15:03:37 <ttereshc> ggainey, I do not remember specific rules, so worth checking
15:03:40 <ggainey> yeah
15:03:54 <ggainey> ok, well, something to look into in all the copious spare time :)
15:03:55 <ttereshc> maybe fedora/31, fedora/32 should work
15:04:01 <ggainey> yeah
15:04:50 * ggainey wonders if it's because of needing sometimes to climb up-and-over from, say, /os to /kickstart, or something like that
15:05:01 <ggainey> anyway, jxsxs good questions
15:05:07 <daviddavis> also, I think potential conflicts
15:05:10 <ggainey> yeah
15:05:13 <ttereshc> a/b/c and a/b are definitely not allow, so you do not break some other repo
15:05:27 <ttereshc> maybe it's a docker repo under that path, or ansible one
15:05:27 <daviddavis> a/b/c and a/b/d are allowed
15:05:36 <ggainey> hm
15:05:51 <ttereshc> daviddavis, what about a/b/c and a/b ?
15:05:58 <daviddavis> not allowed
15:06:01 <ttereshc> cool
15:06:08 <ttereshc> that's sounds right
15:06:14 <ggainey> daviddavis:     The ``base_path`` must have no overlapping components. So if a Distribution with ``base_path``
15:06:14 <ggainey> of ``a/path/foo`` existed, you could not make a second Distribution with a ``base_path`` of
15:06:14 <ggainey> ``a/path`` or ``a`` because both are subpaths of ``a/path/foo``.
15:06:38 <ggainey> so just the subpaths, interesting. maybe this will work
15:06:46 <ggainey> jxsxs: openm your rfe, and we can discuss therein
15:06:55 <ggainey> sorry all, I started designing off the top of my head
15:07:06 <ttereshc> ggainey, yeah, it will ensure that a and b are only directories in daviddavis's example
15:07:14 <ggainey> yyeeahhhh
15:07:23 <ggainey> ok, I''m confused again, but more hopeful :)
15:08:15 <ttereshc> I suggest to move on and we can have a discussion on the rfe
15:08:41 <fao89> triage?
15:08:42 <ggainey> +1
15:08:47 <ggainey> yupper, sounds good
15:08:54 <fao89> !next
15:08:55 <fao89> #topic https://pulp.plan.io/issues/8524
15:08:56 <pulpbot> fao89: 3 issues left to triage: 8524, 8521, 8514
15:08:57 <pulpbot> RM 8524 - ipanova@redhat.com - POST - Disable guardians' AnonymousUser
15:08:58 <pulpbot> https://pulp.plan.io/issues/8524
15:09:14 <x9c4> accept
15:09:16 <fao89> #idea Proposed for #8524: Leave the issue as-is, accepting its current state.
15:09:16 <fao89> !propose accept
15:09:16 <pulpbot> fao89: Proposed for #8524: Leave the issue as-is, accepting its current state.
15:09:19 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:09:19 <fao89> !accept
15:09:19 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:09:20 <fao89> #topic https://pulp.plan.io/issues/8521
15:09:20 <pulpbot> fao89: 2 issues left to triage: 8521, 8514
15:09:21 <pulpbot> RM 8521 - awcrosby - NEW - Allow plugins to retrieve backend storage url of artifact
15:09:22 <pulpbot> https://pulp.plan.io/issues/8521
15:09:51 <fao89> #idea Proposed for #8521: convert to task
15:09:51 <fao89> !propose other convert to task
15:09:51 <pulpbot> fao89: Proposed for #8521: convert to task
15:09:52 <ggainey> interesting. Story
15:09:55 <ggainey> task, yeah
15:10:13 <ttereshc> yeah, and I feel like we used to have it and then removed because no plugin used it
15:10:19 <ggainey> heh
15:10:36 <fao89> pulp_ansible is using it now
15:11:21 <ipanova> https://github.com/pulp/pulp_ansible/pull/550/files
15:11:50 <fao89> yep, that azure bug broke galaxy-importer
15:11:57 <ggainey> fun!
15:12:04 <daviddavis> phun
15:12:07 <ggainey> hehe
15:12:12 <ipanova> ouch
15:12:29 <daviddavis> been pheeling phunny since I got my vax
15:12:39 <daviddavis> pfeeling rather
15:12:40 <fao89> operator is using azure now, so we'll be finding issues like that in the future
15:12:47 <ipanova> daviddavis: lol
15:12:50 <ggainey> I worked on VAX, but it was a looooooooooooooooooooooooooooooooooooooong time ago
15:13:07 <daviddavis> +1 to convert to story
15:13:10 <daviddavis> or task
15:13:11 <ggainey> +1
15:13:19 <ggainey> story, it's an RFE
15:13:22 <daviddavis> +1
15:13:25 <fao89> #idea Proposed for #8521: convert to story
15:13:25 <fao89> !propose other convert to story
15:13:25 <pulpbot> fao89: Proposed for #8521: convert to story
15:13:26 <ipanova> daviddavis: we need to a new commane to pulpbot !pfriday
15:13:30 <fao89> #agreed convert to story
15:13:30 <fao89> !accept
15:13:30 <pulpbot> fao89: Current proposal accepted: convert to story
15:13:31 <fao89> #topic https://pulp.plan.io/issues/8514
15:13:31 <pulpbot> fao89: 1 issues left to triage: 8514
15:13:32 <pulpbot> RM 8514 - amblikmees - NEW - Foreman Katello: Unable to migrate pulp2 to pulp3
15:13:33 <pulpbot> https://pulp.plan.io/issues/8514
15:13:34 <daviddavis> ipanova: lol
15:13:51 <daviddavis> move to migration
15:13:59 <ipanova> fao89: good to hear operator uses azure
15:14:00 <ggainey> I commented on this - I think it's a dup of 8377, but not 100% certain
15:14:11 <ggainey> but yeah, move to migration, meant to do that yesterday and clearly did not
15:14:16 <ggainey> oh no wait
15:14:18 <ggainey> hang on
15:14:31 <ggainey> if it's a dup of 8377, it's the artifact_stages fix, which is in core
15:14:38 <ttereshc> +1
15:14:38 <ggainey> migration just exercises the problem
15:14:51 <daviddavis> ah ok
15:15:03 <ggainey> so - accept, leave in core, I'll close as dup once I hear back from user
15:15:05 <fao89> #idea Proposed for #8514: close as duplicate
15:15:05 <fao89> !propose other close as duplicate
15:15:05 <pulpbot> fao89: Proposed for #8514: close as duplicate
15:15:11 <fao89> ops
15:15:12 <ipanova> +1
15:15:13 <ggainey> heh
15:15:16 <fao89> #idea Proposed for #8514: Leave the issue as-is, accepting its current state.
15:15:16 <fao89> !propose accept
15:15:16 <pulpbot> fao89: Proposed for #8514: Leave the issue as-is, accepting its current state.
15:15:19 <daviddavis> +1
15:15:20 <ggainey> +1
15:15:25 <ttereshc> I'm backporting it today to 3.7
15:15:34 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:15:34 <fao89> !accept
15:15:34 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:15:35 <pulpbot> fao89: No issues to triage.
15:15:36 <daviddavis> ttereshc++
15:15:37 <pulpbot> daviddavis: ttereshc's karma is now 341
15:15:38 <ttereshc> ggainey, user would need 3 patches
15:15:40 <ttereshc> if they try
15:15:42 <ttereshc> not 1
15:15:46 <ggainey> ttereshc: fun!
15:15:51 <fao89> ttereshc++
15:15:51 <pulpbot> fao89: ttereshc's karma is now 342
15:15:57 <ggainey> yeah, that whole sequence was ugly
15:16:02 <ggainey> ttereshc++ indeed
15:16:13 <ggainey> ttereshc++
15:16:13 <pulpbot> ggainey: ttereshc's karma is now 343
15:16:18 <ggainey> silly pulpbot
15:16:19 <fao89> #endmeeting
15:16:19 <fao89> !end