14:31:04 <fao89> #startmeeting Pulp Triage 2021-04-23
14:31:04 <fao89> #info fao89 has joined triage
14:31:04 <fao89> !start
14:31:05 <pulpbot> Meeting started Fri Apr 23 14:31:04 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:05 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:05 <pulpbot> The meeting name has been set to 'pulp_triage_2021-04-23'
14:31:05 <pulpbot> fao89: fao89 has joined triage
14:31:12 <gerrod> #info gerrod has joined triage
14:31:12 <gerrod> !here
14:31:12 <pulpbot> gerrod: gerrod has joined triage
14:31:41 <fao89> https://hackmd.io/@pulp/triage/edit
14:31:53 <daviddavis> #info daviddavis has joined triage
14:31:53 <daviddavis> !here
14:31:53 <pulpbot> daviddavis: daviddavis has joined triage
14:32:01 <dalley> #info dalley has joined triage
14:32:01 <dalley> !here
14:32:01 <pulpbot> dalley: dalley has joined triage
14:32:20 <fao89> no items on the agenda so far
14:32:43 <fao89> should we start the triage?
14:33:11 <daviddavis> sure
14:33:28 <fao89> !next
14:33:29 <fao89> #topic https://pulp.plan.io/issues/8619
14:33:29 <pulpbot> fao89: 8 issues left to triage: 8619, 8615, 8610, 8609, 8608, 8607, 8606, 8603
14:33:30 <pulpbot> RM 8619 - wibbit - NEW - RPM Sync Issue - Duplicate content
14:33:31 <pulpbot> https://pulp.plan.io/issues/8619
14:34:30 <fao89> #idea Proposed for #8619: move to rpm project
14:34:30 <fao89> !propose other move to rpm project
14:34:30 <pulpbot> fao89: Proposed for #8619: move to rpm project
14:34:38 <ipanova> #info ipanova has joined triage
14:34:38 <ipanova> !here
14:34:39 <pulpbot> ipanova: ipanova has joined triage
14:35:20 <daviddavis> +1
14:35:23 <gerrod> +1
14:35:27 <ipanova> +1
14:35:29 <fao89> #agreed move to rpm project
14:35:29 <fao89> !accept
14:35:29 <pulpbot> fao89: Current proposal accepted: move to rpm project
14:35:30 <fao89> #topic https://pulp.plan.io/issues/8615
14:35:30 <pulpbot> fao89: 7 issues left to triage: 8615, 8610, 8609, 8608, 8607, 8606, 8603
14:35:31 <pulpbot> RM 8615 - wibbit - NEW - Improve error output
14:35:32 <pulpbot> https://pulp.plan.io/issues/8615
14:35:47 <ttereshc> #info ttereshc has joined triage
14:35:47 <ttereshc> !here
14:35:48 <pulpbot> ttereshc: ttereshc has joined triage
14:36:19 <fao89> #idea Proposed for #8615: move to rpm project
14:36:19 <fao89> !propose other move to rpm project
14:36:19 <pulpbot> fao89: Proposed for #8615: move to rpm project
14:36:22 <gerrod> same thing
14:36:24 <ipanova> +1
14:36:26 <daviddavis> this is in pulpcore though
14:36:32 <ttereshc> the error comes from pulpcore
14:36:35 <ttereshc> yeah
14:36:41 <daviddavis> https://git.io/JOM6f
14:36:49 <daviddavis> #idea Proposed for #8615: Leave the issue as-is, accepting its current state.
14:36:49 <daviddavis> !propose accept
14:36:49 <pulpbot> daviddavis: Proposed for #8615: Leave the issue as-is, accepting its current state.
14:37:07 <dalley> +1
14:37:09 <ttereshc> we maybe need to add values
14:37:16 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:37:16 <fao89> !accept
14:37:16 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:16 <fao89> #topic https://pulp.plan.io/issues/8610
14:37:17 <pulpbot> fao89: 6 issues left to triage: 8610, 8609, 8608, 8607, 8606, 8603
14:37:18 <pulpbot> RM 8610 - ggainey - NEW - PulpImporter assumes tempfiles can always go to /tmp
14:37:19 <pulpbot> https://pulp.plan.io/issues/8610
14:37:33 <ggainey> oops
14:37:34 <ggainey> #info ggainey has joined triage
14:37:34 <ggainey> !here
14:37:34 <pulpbot> ggainey: ggainey has joined triage
14:37:55 <ttereshc> fao89,  can we get back to 8619 at the end of triage pls
14:37:56 <ggainey> accept and add - this broke me yesterday, we need to do summat about it
14:38:08 <fao89> yep, we can
14:38:12 <ttereshc> ty
14:38:20 <fao89> #idea Proposed for #8610: accept and add to sprint
14:38:20 <fao89> !propose other accept and add to sprint
14:38:20 <pulpbot> fao89: Proposed for #8610: accept and add to sprint
14:38:35 <fao89> #agreed accept and add to sprint
14:38:35 <fao89> !accept
14:38:35 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:38:36 <fao89> #topic https://pulp.plan.io/issues/8609
14:38:36 <pulpbot> fao89: 5 issues left to triage: 8609, 8608, 8607, 8606, 8603
14:38:37 <pulpbot> RM 8609 - mdellweg - POST - Signing workflow docs is outdated
14:38:38 <pulpbot> https://pulp.plan.io/issues/8609
14:38:48 <ggainey> accept and add
14:38:56 <ggainey> x9c4 has already done work here
14:38:59 <daviddavis> +1
14:39:04 <fao89> #idea Proposed for #8609: accept and add to sprint
14:39:04 <fao89> !propose other accept and add to sprint
14:39:04 <pulpbot> fao89: Proposed for #8609: accept and add to sprint
14:39:05 <ipanova> +1
14:39:07 <fao89> #agreed accept and add to sprint
14:39:07 <fao89> !accept
14:39:07 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:39:07 <fao89> #topic https://pulp.plan.io/issues/8608
14:39:08 <pulpbot> fao89: 4 issues left to triage: 8608, 8607, 8606, 8603
14:39:09 <pulpbot> RM 8608 - hutchic - NEW - pulp_rpm is using deprecated signing service key index
14:39:10 <pulpbot> https://pulp.plan.io/issues/8608
14:39:17 <ggainey> accept and add
14:39:40 <ggainey> right now, publishing w/a signing-service enabled is broken because of this
14:39:47 <fao89> #idea Proposed for #8608: accept and add to sprint
14:39:47 <fao89> !propose other accept and add to sprint
14:39:47 <pulpbot> fao89: Proposed for #8608: accept and add to sprint
14:39:49 <ttereshc> move to pulp_rp,
14:39:55 <daviddavis> +1
14:40:01 <ttereshc> and rpm folks will decide
14:40:02 <fao89> #agreed accept and add to sprint
14:40:02 <fao89> !accept
14:40:02 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:40:02 <fao89> #topic https://pulp.plan.io/issues/8607
14:40:03 <ggainey> ah - yesyes, sorry, +1 to move
14:40:03 <pulpbot> fao89: 3 issues left to triage: 8607, 8606, 8603
14:40:04 <pulpbot> RM 8607 - ppicka - ASSIGNED - Basic views for ACS
14:40:05 <pulpbot> https://pulp.plan.io/issues/8607
14:40:22 <ipanova> !propose triage accept and add to sprint
14:40:22 <pulpbot> ipanova: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:40:26 <ttereshc> task?
14:40:30 <daviddavis> +1 to task
14:40:34 <ggainey> +1
14:40:47 <fao89> #idea Proposed for #8607: convert to task
14:40:47 <fao89> !propose other convert to task
14:40:47 <pulpbot> fao89: Proposed for #8607: convert to task
14:40:53 <fao89> #agreed convert to task
14:40:53 <fao89> !accept
14:40:53 <pulpbot> fao89: Current proposal accepted: convert to task
14:40:53 <fao89> #topic https://pulp.plan.io/issues/8606
14:40:54 <pulpbot> fao89: 2 issues left to triage: 8606, 8603
14:40:55 <pulpbot> RM 8606 - ppicka - ASSIGNED - Create models for ACS
14:40:56 <pulpbot> https://pulp.plan.io/issues/8606
14:41:03 <ttereshc> same
14:41:17 <ggainey> +1
14:41:19 <fao89> #idea Proposed for #8606: convert to task
14:41:19 <fao89> !propose other convert to task
14:41:19 <pulpbot> fao89: Proposed for #8606: convert to task
14:41:20 <ipanova> yeah, same, both are already on the sprint
14:41:35 <fao89> #agreed convert to task
14:41:35 <fao89> !accept
14:41:35 <pulpbot> fao89: Current proposal accepted: convert to task
14:41:36 <fao89> #topic https://pulp.plan.io/issues/8603
14:41:36 <pulpbot> fao89: 1 issues left to triage: 8603
14:41:37 <pulpbot> RM 8603 - jsherril@redhat.com - NEW - possible tasking race condition:  update or delete on table "core_reservedresource" violates foreign key constraint "core_taskreservedres_resource_id_ee0b7c62_fk_core_rese" on table "core_taskreservedresource"
14:41:38 <pulpbot> https://pulp.plan.io/issues/8603
14:41:59 <fao89> #idea Proposed for #8603: Leave the issue as-is, accepting its current state.
14:41:59 <fao89> !propose accept
14:41:59 <pulpbot> fao89: Proposed for #8603: Leave the issue as-is, accepting its current state.
14:42:19 <ttereshc> I would consider adding to the sprint
14:42:34 <ttereshc> tasking system issues are painful
14:42:39 <ipanova> agreed
14:42:41 <fao89> #idea Proposed for #8603: accept and add to sprint
14:42:41 <fao89> !propose other accept and add to sprint
14:42:41 <pulpbot> fao89: Proposed for #8603: accept and add to sprint
14:42:42 <ttereshc> and katello is definitely affected for a while
14:42:45 <ggainey> concur
14:42:51 <ttereshc> even if we move to the new system
14:43:06 <fao89> #agreed accept and add to sprint
14:43:06 <fao89> !accept
14:43:06 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:43:07 <ipanova> ttereshc: it will take us a while to move to the new system
14:43:08 <pulpbot> fao89: No issues to triage.
14:43:13 <ttereshc> +!
14:43:15 <ttereshc> +1
14:43:22 <ipanova> !friday
14:43:22 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
14:43:26 <ggainey> wooo!
14:43:30 <ggainey> !dance
14:43:30 <pulpbot> ♪┏(°.°)┛┗(°.°)┓┗(°.°)┛┏(°.°)┓ ♪
14:43:31 <fao89> what is the issue you mentioned ttereshc  ?
14:43:43 <gerrod> 8619?
14:43:43 <ttereshc> 8619
14:44:01 <fao89> !issue 8619
14:44:01 <fao89> #topic https://pulp.plan.io/issues/8619
14:44:01 <wibbit> What's the new tasking system?
14:44:01 <pulpbot> RM 8619 - wibbit - NEW - RPM Sync Issue - Duplicate content
14:44:02 <pulpbot> https://pulp.plan.io/issues/8619
14:44:31 <ttereshc> so I wanted to highlight that it's the problem of pulp2 producing bad repos
14:44:49 <ttereshc> and maybe we can treat it as a bad remote resource on pulp3 side
14:45:02 <gerrod> wibbit, https://github.com/pulp/pulpcore/pull/1261
14:45:05 <ttereshc> we might need to come up with some solutions for users who sync from pulp2 to pulp3
14:45:13 <ttereshc> and who migrate from pulp 2 to pulp 3
14:45:56 <ttereshc> and it cn potentially be with any content, here it is with rpm one
14:46:03 <fao89> wibbit: https://listman.redhat.com/archives/pulp-dev/2021-April/msg00002.html
14:46:20 <wibbit> cheers, shall have a read
14:46:23 <ggainey> and https://hackmd.io/Y0l9nBm9SFmPiIBXBz8lwQ
14:46:34 <ttereshc> I suggest to move it to migration plugin because we likely need to fix it there
14:46:38 <ttereshc> what do you think?
14:46:54 <ttereshc> + maybe docs on how to fix pulp2 repos
14:47:00 <ipanova> ttereshc: in the report it is being said that pulp-admin upload creates troubles, what exactly produces the bad repo?
14:47:08 <ggainey> ttereshc: I think we def need to handle it at migration-time
14:47:23 <daviddavis> so the migration plugin would dedupe content at migration time?
14:47:26 <ttereshc> 2 rpms with the same nevra but different checksums and different filenames
14:47:40 <ggainey> ipanova: upload and copy can both allow ^^ to happen to a repo
14:47:59 <ttereshc> daviddavis, yeah, we need to handle it somehow, choose random with a warning, I do not know yet :)
14:48:13 <daviddavis> yea, I remember there were holes in preventing duplicate content in repos in pulp 2
14:48:16 <daviddavis> I fixed some of the holes
14:48:17 <ttereshc> ipanova, purge_duplicates happens only at sync time :(
14:48:18 <ggainey> yupyup
14:48:36 <ipanova> i remember some oddity around this 2 rpms with the same nevra but different checksums and different filenames
14:48:41 <daviddavis> +1 to try to solve it in migration plugin
14:48:42 <ipanova> in rpm plugin for sure
14:48:46 <ggainey> ugh, even worse
14:48:49 <ggainey> that rings a bell tho
14:49:12 <daviddavis> a very distant bell in a mostly empty attic
14:49:17 <ggainey> zacly :)
14:49:20 <daviddavis> hehe
14:49:24 <ggainey> nothing up there but bats :)
14:49:25 <fao89> #idea Proposed for #8619: move to migration project
14:49:25 <fao89> !propose other move to migration project
14:49:25 <pulpbot> fao89: Proposed for #8619: move to migration project
14:49:31 <daviddavis> and some cobwebs
14:49:36 <ttereshc> ok, I'll move it to migration, but please think what kind of recipes or workaround we can offer for users who hit it with pulp2 to pulp 3 sync
14:49:49 <daviddavis> +1
14:49:55 <ggainey> yeah - we def need to Do Something in migration, but it can bite us in other places
14:49:59 <fao89> #agreed move to migration project
14:49:59 <fao89> !accept
14:49:59 <pulpbot> fao89: Current proposal accepted: move to migration project
14:50:00 <pulpbot> fao89: No issues to triage.
14:50:11 <daviddavis> "run this pclean command and start over"
14:50:15 <ggainey> ha!
14:50:16 <ipanova> +1
14:50:39 <ttereshc> wibbit synced it into a separate repo from pulp2  and removed old one + ran orphan cleanup and then sync cleaned it up
14:50:46 <ggainey> "sorry, the RPM you want is in a different repo"
14:50:50 <dalley> ipanova, you're probably talking about the Bin Li mailing list email
14:51:03 <ttereshc> tall this happening in pulp2 "fixed" the repo
14:51:17 <ttereshc> anyway, thanks for listening
14:51:19 <dalley> actually that was the same checksum
14:51:41 <wibbit> ttereshc actually all I did, was to set up a second repo, copy the content into it, *update* the original with a feed url, and ran a sync, I didn't need to delete any thing *OR* purge orphans on the Pulp3
14:52:03 <ggainey> ah right - because the sync runs purge
14:52:10 <ttereshc> yes, yes, all I described was in pulp2
14:52:21 <ggainey> gotcha
14:52:38 <ttereshc> but I thought you did it a bit differently, I'm glad you commented here
14:52:44 <ggainey> +1
14:54:18 <ipanova> both of the operations in pulp2 copy/orphan clean up are sort of expensive but probably there won't be much of the other workflows how to fix the problem
14:57:00 <fao89> #endmeeting
14:57:00 <fao89> !end