14:30:36 <daviddavis> #startmeeting Pulp Triage 2021-04-27
14:30:36 <daviddavis> #info daviddavis has joined triage
14:30:36 <daviddavis> !start
14:30:36 <pulpbot> Meeting started Tue Apr 27 14:30:36 2021 UTC.  The chair is daviddavis. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:36 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:36 <pulpbot> The meeting name has been set to 'pulp_triage_2021-04-27'
14:30:36 <pulpbot> daviddavis: daviddavis has joined triage
14:30:53 <gerrod> #info gerrod has joined triage
14:30:53 <gerrod> !here
14:30:53 <pulpbot> gerrod: gerrod has joined triage
14:32:41 <ttereshc> #info ttereshc has joined triage
14:32:41 <ttereshc> !here
14:32:41 <pulpbot> ttereshc: ttereshc has joined triage
14:32:43 <ggainey> #info ggainey has joined triage
14:32:43 <ggainey> !here
14:32:43 <pulpbot> ggainey: ggainey has joined triage
14:33:00 <daviddavis> open floor https://hackmd.io/@pulp/triage/edit
14:33:09 <daviddavis> Best way to go about extending a plugin's api? Through urls.py or extending content app urls?
14:33:15 <daviddavis> https://docs.pulpproject.org/pulpcore/plugins/plugin-writer/concepts/index.html#custom-api-url-routes
14:33:19 <daviddavis> Python publishes the simple api to the content app, good enough for sycing/pip but needs to support POST operations in order to support Twine
14:34:37 <gerrod> any preferred way to go about this?
14:35:45 <ggainey> I do not have an opinion on this
14:35:51 <ggainey> (if you can believe such a thing)
14:36:02 <gerrod> impossible
14:36:10 <daviddavis> does pulp_container handle something similar? I know they support docker pushes
14:36:42 <daviddavis> I'd say maybe email pulp-dev and ask
14:36:54 <ggainey> +1
14:37:00 <daviddavis> I'm guessing we don't have enough people with content app experience here right now
14:37:03 <ipanova> yes pulp-container has
14:37:48 <daviddavis> does pulp_container handle it in the content app or by adding endpoints to urls.py?
14:40:03 <daviddavis> am I muted right now? oh wait this isn't a video call
14:40:28 <gerrod> lol, aren't we waiting for ina to respond?
14:40:30 <ggainey> heheh
14:41:00 <ipanova> sorry guys i got distracted
14:41:06 <daviddavis> no worries
14:41:09 <ggainey> :)
14:41:11 <ipanova> so we have new endpoints in the urls.py
14:41:25 <ipanova> and we also have some subclassed content handler
14:41:45 <daviddavis> interesting
14:42:56 <gerrod> is the docker push handled by urls.py?
14:43:16 <gerrod> does it make sense to handle POST operations in the content app? my inclination is no
14:43:47 <daviddavis> I am not a content app expert but my gut feeling is that your inclination is correct
14:44:10 <daviddavis> the content app is really only meant to serve content
14:44:15 <gerrod> also, can RBAC be applied to subclassed content handlers or extended urls.py?
14:45:16 <ipanova> daviddavis: agreed on that
14:45:42 <ipanova> gerrod: well.. that is a complicated question
14:46:13 <ipanova> rbac can be applied on those viewsets that are subclassed from NamedModelViewset
14:46:35 <ipanova> we have some hacky way how to circumvent that problem
14:47:15 <ipanova> gerrod: i can paste some links if you want
14:47:27 <ipanova> we ended up faking the views
14:47:34 <gerrod> that would be helpful
14:49:13 <ggainey> if you do it twice, it's no longer A Hack, it's now A Pattern :)
14:49:49 <daviddavis> gerrod: were your questions answered?
14:50:02 <gerrod> yeah
14:50:14 <daviddavis> !next
14:50:15 <pulpbot> daviddavis: 3 issues left to triage: 8633, 8632, 8628
14:50:16 <daviddavis> #topic https://pulp.plan.io/issues/8633
14:50:16 <pulpbot> RM 8633 - ggainey - POST - PulpImport with overlapping content can fail with unique-constraint violation
14:50:17 <pulpbot> https://pulp.plan.io/issues/8633
14:50:29 <ggainey> accept and add please, I'm about to submit a PR
14:51:05 <daviddavis> #idea Proposed for #8633: accept and add to sprint
14:51:05 <daviddavis> !propose other accept and add to sprint
14:51:07 <pulpbot> daviddavis: Proposed for #8633: accept and add to sprint
14:51:18 <daviddavis> it looks like you did submit a PR?
14:51:34 <ggainey> daviddavis: yeah, was about to say - been A Lot this morning
14:51:38 <daviddavis> hehe
14:51:54 <daviddavis> #agreed accept and add to sprint
14:51:54 <daviddavis> !accept
14:51:55 <pulpbot> daviddavis: Current proposal accepted: accept and add to sprint
14:51:55 <daviddavis> #topic https://pulp.plan.io/issues/8632
14:51:56 <pulpbot> daviddavis: 2 issues left to triage: 8632, 8628
14:51:57 <pulpbot> RM 8632 - osapryki - NEW - Backport #8352 to pulp 3.11
14:51:58 <pulpbot> https://pulp.plan.io/issues/8632
14:52:24 <daviddavis> let's skip for now. seems like there is another tasking issue to backport as well to 3.11
14:52:40 <ttereshc> +1
14:52:50 <daviddavis> !skip
14:52:50 <daviddavis> #topic https://pulp.plan.io/issues/8628
14:52:51 <pulpbot> daviddavis: 1 issues left to triage: 8628
14:52:52 <pulpbot> RM 8628 - paji@redhat.com - NEW - Need better error message on invalid chunk-size for export
14:52:53 <pulpbot> https://pulp.plan.io/issues/8628
14:53:18 <ttereshc> +1 to add and accept
14:53:22 <dalley> daviddavis, potentially two, although the other one is of lesser importance and probably shouldn't block
14:53:34 <ttereshc> looks like a bad user experience and likely an easyfix
14:53:36 <daviddavis> dalley: +1
14:53:45 <daviddavis> #idea Proposed for #8628: accept and add to sprint
14:53:45 <daviddavis> !propose other accept and add to sprint
14:53:45 <pulpbot> daviddavis: Proposed for #8628: accept and add to sprint
14:53:48 <ggainey> interesting - accept-and-add for 8628
14:53:52 <ggainey> +1
14:54:04 <daviddavis> #agreed accept and add to sprint
14:54:04 <daviddavis> !accept
14:54:04 <pulpbot> daviddavis: Current proposal accepted: accept and add to sprint
14:54:05 <pulpbot> daviddavis: No issues to triage.
14:54:08 <daviddavis> #endmeeting
14:54:08 <daviddavis> !end