14:30:41 <fao89> #startmeeting Pulp Triage 2021-04-30
14:30:41 <fao89> #info fao89 has joined triage
14:30:41 <fao89> !start
14:30:41 <pulpbot> Meeting started Fri Apr 30 14:30:41 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:41 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:41 <pulpbot> The meeting name has been set to 'pulp_triage_2021-04-30'
14:30:41 <pulpbot> fao89: fao89 has joined triage
14:30:49 <ggainey> #info ggainey has joined triage
14:30:49 <ggainey> !here
14:30:49 <pulpbot> ggainey: ggainey has joined triage
14:31:02 <fao89> https://hackmd.io/@pulp/triage/edit
14:31:35 <x9c4> #info x9c4 has joined triage
14:31:35 <x9c4> !here
14:31:35 <pulpbot> x9c4: x9c4 has joined triage
14:31:42 <gerrod> #info gerrod has joined triage
14:31:42 <gerrod> !here
14:31:42 <pulpbot> gerrod: gerrod has joined triage
14:32:11 <ppicka> #info ppicka has joined triage
14:32:11 <ppicka> !here
14:32:11 <pulpbot> ppicka: ppicka has joined triage
14:32:14 <fao89> topic: Does Pulp have a color scheme/theme? If so, can we modify the DRF templates to match?
14:32:20 <ggainey> heh, nice
14:32:33 <ggainey> I mean, blue/orange/green, per the logo, yeah?
14:32:37 <gerrod> i want pretty colors
14:32:48 <ggainey> would be nice to get the docs looking more unified, there's def work we can do here
14:33:08 <fao89> it would be cool
14:33:51 <ggainey> I'm for it - maybe open a task for this, with the links, and it's something we can pick during a docs-day, say
14:34:00 <ggainey> or if someone can't sleep :)
14:34:04 <fao89> +1
14:34:19 <gerrod> +1
14:35:22 <gerrod> i'll create a task for it
14:35:23 <fao89> I'll start the triage
14:35:39 <ggainey> gerrod++
14:35:39 <pulpbot> ggainey: gerrod's karma is now 66
14:36:28 <fao89> !next
14:36:29 <fao89> #topic https://pulp.plan.io/issues/8670
14:36:29 <pulpbot> fao89: 6 issues left to triage: 8670, 8669, 8656, 8637, 8633, 8628
14:36:30 <pulpbot> RM 8670 - dannysauer - POST - URL escaping in yarl alters escaped characters
14:36:31 <pulpbot> https://pulp.plan.io/issues/8670
14:37:12 <fao89> #idea Proposed for #8670: accept and add to sprint
14:37:12 <fao89> !propose other accept and add to sprint
14:37:12 <pulpbot> fao89: Proposed for #8670: accept and add to sprint
14:37:18 <ggainey> huh, interesting
14:37:21 <ggainey> yeah, sounds fine
14:37:25 <ggainey> +1
14:37:45 <x9c4> +1
14:37:52 <fao89> #agreed accept and add to sprint
14:37:52 <fao89> !accept
14:37:52 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:37:52 <fao89> #topic https://pulp.plan.io/issues/8669
14:37:53 <pulpbot> fao89: 5 issues left to triage: 8669, 8656, 8637, 8633, 8628
14:37:54 <pulpbot> RM 8669 - iballou - NEW - Temp files are showing up in /var/lib/pulp instead of under /var/lib/pulp/tmp
14:37:55 <pulpbot> https://pulp.plan.io/issues/8669
14:38:54 <ggainey> iballou asked about this yesterday
14:39:49 <fao89> not sure if we should add to sprint
14:39:57 <gerrod> could be a katello thing
14:40:08 <ggainey> is this a dup of one of the other tempdir/cleanup-related issues?
14:40:57 <ggainey> gerrod: well, the files in ques are owned-by pulp. Settings look sane.
14:41:00 <gerrod> i found this one yesterday that we already fixed https://pulp.plan.io/issues/7319
14:41:34 <gerrod> what i mean is that it could be a katello setup issue, like it's using a version of pulp that still has this problem
14:41:34 <ggainey> gerrod: yeah - but that was fixed in 3.7, and the user is on 3.9.1
14:42:33 <ggainey> I'd say accept-and-add, at a minimum we can investigate enough to figure out if this is a dup or if there's work to be done, yeah?
14:42:42 <x9c4> Are those tempfiles from tasks, or is this upload related?
14:43:09 <ggainey> we don't know (yet)
14:43:12 <fao89> #idea Proposed for #8669: accept and add to sprint
14:43:12 <fao89> !propose other accept and add to sprint
14:43:12 <pulpbot> fao89: Proposed for #8669: accept and add to sprint
14:43:17 <x9c4> +1
14:43:34 <ggainey> +1
14:43:49 <daviddavis> hey
14:44:03 <daviddavis> they said it happened when downloading on-demand content through the content app
14:44:08 <daviddavis> I'll get iballou to add a note
14:44:15 <ggainey> coolio
14:44:33 <fao89> #agreed accept and add to sprint
14:44:33 <fao89> !accept
14:44:34 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:44:35 <pulpbot> fao89: 4 issues left to triage: 8656, 8637, 8633, 8628
14:44:35 <fao89> #topic https://pulp.plan.io/issues/8656
14:44:36 <pulpbot> RM 8656 - osapryki - NEW - Remove external call from 0061_call_handle_artifact_checksums_command
14:44:37 <pulpbot> https://pulp.plan.io/issues/8656
14:44:52 <ggainey> hrm
14:45:27 <fao89> #idea Proposed for #8656: accept and add to sprint
14:45:27 <fao89> !propose other accept and add to sprint
14:45:27 <pulpbot> fao89: Proposed for #8656: accept and add to sprint
14:45:30 <daviddavis> we discussed this at pulpcore.
14:45:32 <daviddavis> +1
14:45:34 <x9c4> +1
14:45:42 <fao89> #agreed accept and add to sprint
14:45:42 <fao89> !accept
14:45:42 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:45:42 <fao89> #topic https://pulp.plan.io/issues/8637
14:45:43 <pulpbot> fao89: 3 issues left to triage: 8637, 8633, 8628
14:45:44 <pulpbot> RM 8637 - daviddavis - NEW - Possible race condition where task's reservations get deleted
14:45:45 <pulpbot> https://pulp.plan.io/issues/8637
14:46:32 <fao89> #idea Proposed for #8637: accept and add to sprint
14:46:32 <fao89> !propose other accept and add to sprint
14:46:32 <pulpbot> fao89: Proposed for #8637: accept and add to sprint
14:46:46 <ggainey> +1
14:47:11 <x9c4> Can a transaction or select_for_update help there?
14:47:15 <x9c4> +1
14:47:36 <fao89> #agreed accept and add to sprint
14:47:36 <fao89> !accept
14:47:36 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:47:37 <fao89> #topic https://pulp.plan.io/issues/8633
14:47:37 <pulpbot> fao89: 2 issues left to triage: 8633, 8628
14:47:37 <ggainey> maybe adda  comment to the issue w/that
14:47:38 <pulpbot> RM 8633 - ggainey - POST - PulpImport with overlapping content can fail with unique-constraint violation
14:47:39 <pulpbot> https://pulp.plan.io/issues/8633
14:47:43 <ggainey> accept and add, pliz
14:47:54 <fao89> #idea Proposed for #8633: accept and add to sprint
14:47:54 <fao89> !propose other accept and add to sprint
14:47:54 <pulpbot> fao89: Proposed for #8633: accept and add to sprint
14:47:59 <ggainey> this is half of the import-concurrency fix
14:48:04 <x9c4> +1
14:48:06 <fao89> #agreed accept and add to sprint
14:48:06 <fao89> !accept
14:48:06 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:48:07 <fao89> #topic https://pulp.plan.io/issues/8628
14:48:07 <pulpbot> fao89: 1 issues left to triage: 8628
14:48:08 <pulpbot> RM 8628 - paji@redhat.com - NEW - Need better error message on invalid chunk-size for export
14:48:09 <pulpbot> https://pulp.plan.io/issues/8628
14:48:21 <ggainey> accept and add, paji has a good point here
14:48:30 <fao89> #idea Proposed for #8628: accept and add to sprint
14:48:30 <fao89> !propose other accept and add to sprint
14:48:30 <pulpbot> fao89: Proposed for #8628: accept and add to sprint
14:48:30 <ggainey> should be an easy fix too
14:48:50 <x9c4> +1
14:48:58 <fao89> #agreed accept and add to sprint
14:48:58 <fao89> !accept
14:48:58 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:49:00 <pulpbot> fao89: No issues to triage.
14:49:09 <fao89> #endmeeting
14:49:09 <fao89> !end