14:35:06 <fao89> #startmeeting Pulp Triage 2021-05-07
14:35:06 <fao89> #info fao89 has joined triage
14:35:06 <fao89> !start
14:35:06 <pulpbot> Meeting started Fri May  7 14:35:06 2021 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:35:06 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:35:06 <pulpbot> The meeting name has been set to 'pulp_triage_2021-05-07'
14:35:06 <pulpbot> fao89: fao89 has joined triage
14:35:33 <daviddavis> #info daviddavis has joined triage
14:35:33 <daviddavis> !here
14:35:33 <pulpbot> daviddavis: daviddavis has joined triage
14:35:37 <ipanova> #info ipanova has joined triage
14:35:37 <ipanova> !here
14:35:37 <pulpbot> ipanova: ipanova has joined triage
14:35:51 <ppicka> #info ppicka has joined triage
14:35:51 <ppicka> !here
14:35:51 <pulpbot> ppicka: ppicka has joined triage
14:36:03 <ggainey> #info ggainey has joined triage
14:36:03 <ggainey> !here
14:36:03 <pulpbot> ggainey: ggainey has joined triage
14:36:23 <fao89> no items for open floor
14:36:24 <dalley> #info dalley has joined triage
14:36:24 <dalley> !here
14:36:24 <pulpbot> dalley: dalley has joined triage
14:36:26 <x9c4> #info x9c4 has joined triage
14:36:26 <x9c4> !here
14:36:26 <pulpbot> x9c4: x9c4 has joined triage
14:36:37 <fao89> I'll start triage
14:36:54 <daviddavis> +1
14:36:57 <fao89> !next
14:36:57 <fao89> #topic https://pulp.plan.io/issues/8715
14:36:58 <pulpbot> fao89: 4 issues left to triage: 8715, 8712, 8707, 8695
14:36:59 <pulpbot> RM 8715 - alikins - NEW - openapi generation replaces entire url of endpoints with path_params with {*_href} urls
14:37:00 <pulpbot> https://pulp.plan.io/issues/8715
14:37:12 <ttereshc> #info ttereshc has joined triage
14:37:12 <ttereshc> !here
14:37:12 <pulpbot> ttereshc: ttereshc has joined triage
14:37:28 <daviddavis> this seems valid in cases where there are path params other than pks?
14:37:29 <fao89> this is complicated
14:37:33 <daviddavis> yea
14:38:12 <fao89> it would require changing some APIs, bindings, CLI, squeezer
14:38:22 <bmbouter> it's kind of tough because the openapigenerator is one thing and it expects hrefs to be the way
14:38:50 <alikins> I can work around it by creating a GalaxySchemaGenerator that has a convert_endpoint_path_params() that just returns the path
14:38:51 <daviddavis> are these pulp_hrefs though?
14:39:03 <bmbouter> they aren't, so that's the valid part I agree w/ that
14:39:10 <daviddavis> +1
14:39:12 <bmbouter> the challenge is that openapigenerator doesn't know that
14:39:25 <alikins> though I'm 98% sure doing a custom SchemaGenerator will break the default CI tests
14:39:43 <bmbouter> yeah this is the challeng it has to extend the xisting one and just do that for specific urls
14:40:08 <bmbouter> I could see accepting this (back to triage convo)
14:40:25 <daviddavis> +1 to accept
14:40:35 <fao89> #idea Proposed for #8715: Leave the issue as-is, accepting its current state.
14:40:35 <fao89> !propose accept
14:40:35 <pulpbot> fao89: Proposed for #8715: Leave the issue as-is, accepting its current state.
14:40:48 <ggainey> +1
14:40:54 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:40:54 <fao89> !accept
14:40:54 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:40:55 <fao89> #topic https://pulp.plan.io/issues/8712
14:40:55 <pulpbot> fao89: 3 issues left to triage: 8712, 8707, 8695
14:40:57 <pulpbot> RM 8712 - ekohl - NEW - Backport "Database access is needed during collectstatic" to 3.11
14:40:57 <alikins> previsouly I had the best results with just doing both.  one url's for the un-convert_endpoint_path_params()'ed and one modified.  It's doubles the endpoints but much more useful for my uses
14:40:58 <pulpbot> https://pulp.plan.io/issues/8712
14:42:04 <daviddavis> skip. sounds like we will probably need to backport the django fix to 3.11 as well.
14:42:13 <fao89> !skip
14:42:14 <fao89> #topic https://pulp.plan.io/issues/8707
14:42:14 <pulpbot> fao89: 2 issues left to triage: 8707, 8695
14:42:15 <daviddavis> probably better to wait and see
14:42:16 <pulpbot> RM 8707 - gripson - NEW - Nuget Support
14:42:17 <pulpbot> https://pulp.plan.io/issues/8707
14:42:20 <ttereshc> +1
14:42:21 <ggainey> story
14:42:25 <daviddavis> +1
14:42:28 <ipanova> +1
14:42:30 <ttereshc> +1
14:42:39 <fao89> #idea Proposed for #8707: convert to story
14:42:39 <fao89> !propose other convert to story
14:42:39 <pulpbot> fao89: Proposed for #8707: convert to story
14:42:51 <fao89> #agreed convert to story
14:42:51 <fao89> !accept
14:42:51 <pulpbot> fao89: Current proposal accepted: convert to story
14:42:51 <fao89> #topic https://pulp.plan.io/issues/8695
14:42:52 <pulpbot> fao89: 1 issues left to triage: 8695
14:42:53 <pulpbot> RM 8695 - bmbouter - NEW - FileSystemExporter cannot cross os boundary
14:42:54 <pulpbot> https://pulp.plan.io/issues/8695
14:43:09 <daviddavis> accept?
14:43:13 <ggainey> oh right - accept and add, esp since this breaks tests
14:43:20 <daviddavis> +1
14:43:28 <fao89> #idea Proposed for #8695: accept and add to sprint
14:43:28 <fao89> !propose other accept and add to sprint
14:43:28 <pulpbot> fao89: Proposed for #8695: accept and add to sprint
14:43:31 <ttereshc> +1
14:43:34 <ipanova> +1
14:43:34 <ggainey> (and, yay for tests finding problems!)
14:43:42 <x9c4> +1
14:43:45 <fao89> #agreed accept and add to sprint
14:43:45 <fao89> !accept
14:43:45 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:43:46 <pulpbot> fao89: No issues to triage.
14:44:11 <fao89> #endmeeting
14:44:11 <fao89> !end