14:30:15 <fao891> #startmeeting Pulp Triage 2021-05-14
14:30:15 <fao891> #info fao891 has joined triage
14:30:15 <fao891> !start
14:30:15 <pulpbot> Meeting started Fri May 14 14:30:15 2021 UTC.  The chair is fao891. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:15 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:15 <pulpbot> The meeting name has been set to 'pulp_triage_2021-05-14'
14:30:15 <pulpbot> fao891: fao891 has joined triage
14:30:57 <daviddavis> #info daviddavis has joined triage
14:30:57 <daviddavis> !here
14:30:57 <pulpbot> daviddavis: daviddavis has joined triage
14:31:08 <gerrod> #info gerrod has joined triage
14:31:08 <gerrod> !here
14:31:08 <pulpbot> gerrod: gerrod has joined triage
14:33:02 <dkliban> #info dkliban has joined triage
14:33:02 <dkliban> !here
14:33:02 <pulpbot> dkliban: dkliban has joined triage
14:33:04 <ggainey> #info ggainey has joined triage
14:33:04 <ggainey> !here
14:33:04 <pulpbot> ggainey: ggainey has joined triage
14:33:19 <fao891> topic: Dependabot is suggesting upgrading major versions of dependencies a lot.
14:33:34 <daviddavis> I have a PR to fix this hopefully https://github.com/pulp/pulpcore/pull/1325
14:33:57 <fao891> daviddavis++
14:33:57 <pulpbot> fao891: daviddavis's karma is now 505
14:34:09 <ggainey> ahhh, nice
14:34:14 <ggainey> daviddavis++
14:34:14 <pulpbot> ggainey: daviddavis's karma is now 506
14:34:18 <ggainey> lg2m
14:34:47 <fao891> next topic: Would like to remove the Single Container category since issues are now on Github
14:34:55 <fao891> +1
14:34:57 <daviddavis> Unlike tags, removing the category will remove it from older issues
14:35:02 <daviddavis> Options: (1) that's ok (2) create a SC tag, add it to older issues, then remove it
14:35:08 <daviddavis> any pref?
14:35:30 <fao891> no pref
14:35:40 <dkliban> hmm
14:35:44 <ggainey> I hate losing data, so 2 - unless it's onerous
14:36:02 <ggainey> how many affected issues?
14:36:08 <dkliban> 2 would be good ... but would it be confusing for the future
14:36:09 <dkliban> ?
14:36:21 <dkliban> meaning that we would still have this tag out there that we dont' use
14:36:28 <ggainey> yeah that too
14:36:32 <daviddavis> like you couldn't actually use it though right
14:36:39 <dkliban> i'd rather go through the issues and leave a comment on them
14:36:43 <daviddavis> it's just on the issues
14:36:57 <daviddavis> when you remove a tag, it sticks the issues that have it already
14:37:08 <daviddavis> but you can't add it to new issues, etc
14:37:12 <ggainey> ah, ok
14:37:19 <ggainey> I missed that
14:37:26 <dkliban> daviddavis: let's do that
14:37:30 <daviddavis> +1
14:37:34 <ggainey> cool
14:37:35 <ggainey> +1
14:38:10 <fao891> next topic: Please update and test your dev environment with https enabled
14:38:34 <gerrod> link for instructions? or just update pulp_installer?
14:38:37 <fao891> I tested some plugins and it seems to work now
14:39:19 <fao891> update the pulp_installer and drop pulp_webserver_disable_https: true from your local config
14:39:41 <gerrod> ok
14:39:47 <ggainey> +1
14:40:30 <fao891> moving to triage!
14:40:34 <ggainey> +1
14:40:47 <fao891> !next
14:40:48 <pulpbot> fao891: 8 issues left to triage: 8758, 8757, 8754, 8750, 8744, 8733, 8712, 8689
14:40:48 <fao891> #topic https://pulp.plan.io/issues/8758
14:40:49 <mikedep333> #info mikedep333 has joined triage
14:40:49 <mikedep333> !here
14:40:50 <pulpbot> RM 8758 - newswangerd - NEW - Backport 8691 to pulpcore 3.11
14:40:51 <pulpbot> https://pulp.plan.io/issues/8758
14:40:52 <pulpbot> mikedep333: mikedep333 has joined triage
14:41:16 <fao891> #idea Proposed for #8758: accept and add to sprint
14:41:16 <fao891> !propose other accept and add to sprint
14:41:16 <pulpbot> fao891: Proposed for #8758: accept and add to sprint
14:41:16 <daviddavis> let's skip but I believe bmbouter is working on this
14:41:27 <ttereshc> #info ttereshc has joined triage
14:41:27 <ttereshc> !here
14:41:27 <pulpbot> ttereshc: ttereshc has joined triage
14:41:41 <fao891> wasn't it merged?
14:41:42 <ttereshc> should we assign bmbouter?
14:41:45 <ttereshc> and triage
14:42:39 <ttereshc> fao891, the fix is merged. I believe the backports are not done yet
14:43:21 <fao891> I proposed to accept and add, and daviddavis proposed to skip
14:43:53 <gerrod> +1 accept
14:43:58 <ggainey> +1 to accept and add
14:43:59 <ttereshc> anything works for me
14:44:05 <fao891> #agreed accept and add to sprint
14:44:05 <fao891> !accept
14:44:05 <pulpbot> fao891: Current proposal accepted: accept and add to sprint
14:44:06 <fao891> #topic https://pulp.plan.io/issues/8757
14:44:06 <pulpbot> fao891: 7 issues left to triage: 8757, 8754, 8750, 8744, 8733, 8712, 8689
14:44:07 <pulpbot> RM 8757 - jsherril@redhat.com - NEW - backport 7316 to 3.11:  Files are not being deleted from storage when calling the method delete()
14:44:08 <pulpbot> https://pulp.plan.io/issues/8757
14:44:13 <ggainey> since bmbouter is actively investigating/doing the work right now :)
14:44:30 <ttereshc> then this should follow the same path
14:44:38 <ttereshc> it's also for 3.11
14:44:49 <fao891> #idea Proposed for #8757: accept and add to sprint
14:44:49 <fao891> !propose other accept and add to sprint
14:44:49 <pulpbot> fao891: Proposed for #8757: accept and add to sprint
14:45:00 <fao891> #agreed accept and add to sprint
14:45:00 <fao891> !accept
14:45:00 <pulpbot> fao891: Current proposal accepted: accept and add to sprint
14:45:00 <ggainey> +1
14:45:00 <fao891> #topic https://pulp.plan.io/issues/8754
14:45:01 <pulpbot> fao891: 6 issues left to triage: 8754, 8750, 8744, 8733, 8712, 8689
14:45:02 <pulpbot> RM 8754 - ttereshc - NEW - cherrypick.sh script does not support all of the commit message keywords
14:45:03 <pulpbot> https://pulp.plan.io/issues/8754
14:45:07 <daviddavis> my only issue with accept and add is that it might get overlooked
14:45:22 <daviddavis> ie no one is looking at the sprint
14:45:26 <ttereshc> that's why I suggested to assign them right away
14:45:40 <ttereshc> but I think those ones won't be missed
14:45:45 <ttereshc> in this particular case
14:45:45 <ggainey> heh
14:45:56 <daviddavis> assigning them works for me as well
14:46:15 <fao891> I'm assigning them
14:46:27 <fao891> #idea Proposed for #8754: Leave the issue as-is, accepting its current state.
14:46:27 <fao891> !propose accept
14:46:27 <pulpbot> fao891: Proposed for #8754: Leave the issue as-is, accepting its current state.
14:46:32 <daviddavis> +1
14:46:41 <ggainey> +1
14:46:43 <fao891> #agreed Leave the issue as-is, accepting its current state.
14:46:43 <fao891> !accept
14:46:43 <pulpbot> fao891: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:46:44 <fao891> #topic https://pulp.plan.io/issues/8750
14:46:44 <pulpbot> fao891: 5 issues left to triage: 8750, 8744, 8733, 8712, 8689
14:46:45 <pulpbot> RM 8750 - wibbit - NEW - Deadlock on rpm repository sync
14:46:46 <pulpbot> https://pulp.plan.io/issues/8750
14:46:54 <ggainey> this one might need to go to pulp_rpm
14:47:06 <ggainey> because it's deadlocking on the rpm_package table specifically
14:47:22 <fao891> #idea Proposed for #8750: move to rpm project
14:47:22 <fao891> !propose other move to rpm project
14:47:22 <pulpbot> fao891: Proposed for #8750: move to rpm project
14:47:23 <gerrod> maybe we should have assigned 8754 to dkliban since he is working on release automation
14:47:56 <ttereshc> not sure, it seems to happen in stages
14:47:58 <dkliban> gerrod: not yet ... but i will take a look at it when i am done with the current ticket
14:48:50 <ttereshc> we can move to rpm and investigate there, fine with me
14:48:55 <ggainey> coolio
14:49:00 <fao891> #agreed move to rpm project
14:49:01 <fao891> !accept
14:49:01 <pulpbot> fao891: Current proposal accepted: move to rpm project
14:49:01 <fao891> #topic https://pulp.plan.io/issues/8744
14:49:02 <pulpbot> fao891: 4 issues left to triage: 8744, 8733, 8712, 8689
14:49:03 <pulpbot> RM 8744 - equipe_serveurs@exane.com - NEW - Pulp3 database migration broken with newly release click 8
14:49:04 <pulpbot> https://pulp.plan.io/issues/8744
14:49:32 <fao891> click hell everywhere
14:49:37 <ggainey> ugh
14:50:04 <ttereshc> yeah maybe this is what needs a backport as well
14:50:09 <ttereshc> pinning 7.1
14:50:21 <fao891> rq plans to release on monday
14:50:48 <fao891> I think we can skip and decide on tuesday
14:50:56 <fao891> or accept
14:50:59 <daviddavis> this is a dupe of https://pulp.plan.io/issues/8743
14:51:30 <daviddavis> or I guess one is against the installer but same cause
14:51:53 <daviddavis> +1 to accept
14:52:06 <daviddavis> or maybe skip and revisit on tuesday after rq releases
14:52:07 <fao891> I have faith rq release will solve everything
14:52:09 <daviddavis> and then close it out
14:52:16 <ttereshc> let's skip
14:52:16 <ggainey> sworks4me
14:52:23 <fao891> !skip
14:52:24 <pulpbot> fao891: 3 issues left to triage: 8733, 8712, 8689
14:52:24 <fao891> #topic https://pulp.plan.io/issues/8733
14:52:25 <pulpbot> RM 8733 - jlanda - NEW - Can't set '' as storageClassName on operator produced PVCs
14:52:26 <pulpbot> https://pulp.plan.io/issues/8733
14:52:47 <daviddavis> hmm maybe we should skip operator issues during triage
14:52:56 <fao891> this query needs to ignore operator issues
14:53:00 <fao891> yep
14:53:05 <fao891> !skip
14:53:05 <fao891> #topic https://pulp.plan.io/issues/8712
14:53:06 <pulpbot> fao891: 2 issues left to triage: 8712, 8689
14:53:07 <pulpbot> RM 8712 - ekohl - NEW - Backport "Database access is needed during collectstatic" to 3.11
14:53:08 <pulpbot> https://pulp.plan.io/issues/8712
14:53:30 <daviddavis> assign to bmbouter
14:53:33 <fao891> backport party!
14:53:36 <ggainey> heh
14:53:37 <daviddavis> :)
14:53:42 <daviddavis> the fun never ends
14:53:44 <daviddavis> it lasts weeks
14:53:46 <ttereshc> well, we are collecting htem on purpose
14:53:51 <ggainey> yus
14:53:52 <fao891> #idea Proposed for #8712: accept and add to sprint
14:53:52 <fao891> !propose other accept and add to sprint
14:53:52 <pulpbot> fao891: Proposed for #8712: accept and add to sprint
14:53:52 <ttereshc> so it's not a coincidence
14:54:02 <fao891> #agreed accept and add to sprint
14:54:02 <fao891> !accept
14:54:02 <pulpbot> fao891: Current proposal accepted: accept and add to sprint
14:54:02 <fao891> #topic https://pulp.plan.io/issues/8689
14:54:03 <pulpbot> fao891: 1 issues left to triage: 8689
14:54:04 <pulpbot> RM 8689 - simon_t - POST - adding custom connection headers to debian remote causes repository syncs to always fail
14:54:05 <pulpbot> https://pulp.plan.io/issues/8689
14:54:13 <daviddavis> accept and add to sprint
14:54:15 <ggainey> +1
14:54:24 <ttereshc> +1
14:54:32 <fao891> #idea Proposed for #8689: accept and add to sprint
14:54:32 <fao891> !propose other accept and add to sprint
14:54:32 <pulpbot> fao891: Proposed for #8689: accept and add to sprint
14:54:36 <fao891> #agreed accept and add to sprint
14:54:36 <fao891> !accept
14:54:36 <pulpbot> fao891: Current proposal accepted: accept and add to sprint
14:54:37 <pulpbot> fao891: No issues to triage.
14:54:46 <fao891> #endmeeting