14:33:36 <ttereshc> #startmeeting Pulp Triage 2021-05-18
14:33:36 <ttereshc> #info ttereshc has joined triage
14:33:36 <ttereshc> !start
14:33:36 <pulpbot> Meeting started Tue May 18 14:33:36 2021 UTC.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:36 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:33:36 <pulpbot> The meeting name has been set to 'pulp_triage_2021-05-18'
14:33:36 <pulpbot> ttereshc: ttereshc has joined triage
14:33:45 <bmbouter> #info bmbouter has joined triage
14:33:45 <bmbouter> !here
14:33:45 <pulpbot> bmbouter: bmbouter has joined triage
14:33:51 * bmbouter since the song of traige
14:34:01 * bmbouter also sings it
14:34:16 <ttereshc> open floor
14:34:21 <ttereshc> first and only topic
14:34:23 <ttereshc> We have incompatible releases for upcoming 3.13 (used in oci-images) (https://github.com/pulp/pulp-oci-images/blob/latest/pulp/Containerfile#L14)
14:34:23 <ttereshc> pulp_ansible
14:34:24 <ttereshc> pulp-certguard
14:34:24 <ttereshc> pulp_container
14:34:24 <ttereshc> pulp_maven (?)
14:34:25 <ttereshc> pulp_python
14:34:27 <ttereshc> pulp_rpm
14:34:29 <dkliban> #info dkliban has joined triage
14:34:29 <dkliban> !here
14:34:30 <pulpbot> dkliban: dkliban has joined triage
14:34:56 <dkliban> pulp_maven has the needed changes merged already
14:35:02 <dkliban> so it's a matter of doing the release
14:35:07 <bmbouter> so what needs to happen for this, do these plugins need to release prior to 3.13, or just be ready to release very soon after?
14:35:42 <dkliban> ideally they would release prior to 3.13
14:35:43 <ttereshc> it can be done soon after I think, but it will block release of the fresh oci images
14:36:02 <dalley> I think that's what Matthias meant - the changes are there (for most of these) they just need releases
14:36:13 <dalley> I'm not sure about certguard though
14:36:43 <ttereshc> dkliban releases maven, I will release rpm later this week when all prs are merged.
14:36:50 <ttereshc> what about other plugins?
14:36:58 <bmbouter> can we have an example, e.g. pulp_ansible the next release would be xxxx and it would declare compatability with pulpcore as what?
14:37:20 <ggainey> #info ggainey has joined triage
14:37:20 <ggainey> !here
14:37:20 <pulpbot> ggainey: ggainey has joined triage
14:38:02 <ipanova> #info ipanova has joined triage
14:38:02 <ipanova> !here
14:38:02 <pulpbot> ipanova: ipanova has joined triage
14:38:31 <ttereshc> bmbouter, pulp_rpm the next release 3.12 will declare compatibility with pulpcore>=3.12,<3.14
14:39:40 <ipanova> i will release pulp_container, next release 2.6.0 and will be compat with pulpcore>=3.12, <314
14:40:26 <ttereshc> ggainey, bmbouter, what about certguard release plans?
14:40:52 <ggainey> ttereshc: I'm just looking at certguard now - no changes there, we'd just need to bump requirements to be compat
14:41:27 <ttereshc> ok, so it needs a release this week
14:41:34 <ggainey> yupyup
14:41:36 <bmbouter> ttereshc: ty
14:41:54 <ttereshc> ok, we have ansible and python which are not covered yet
14:42:05 <bmbouter> ggainey: for pulp-certguard it so infrequently requires compatability updates maybe we don't need to version restrict it?
14:42:21 <ggainey> lemme check a thing
14:42:23 <ggainey> one sec
14:42:25 <bmbouter> this is roughly what we did for many of the 3.0 - 3.9 releases...
14:42:52 <bmbouter> but maybe that's a bad idea because technically someone could install an "old unrestricted pulp-certguard" against any-way-newer pulpcore and it would not work
14:42:58 <ggainey> so certguard is pulpcore>=3.10
14:43:14 <bmbouter> the downside is that we end up releasing pulp-certguard with 0 changes over and over
14:43:54 <bmbouter> ggainey: so on master we always leave them unrestricted
14:44:05 <ttereshc> I think releasing it over and over is more user friendly
14:44:22 <bmbouter> ggainey: but notice the actual release has it restricted https://github.com/pulp/pulp-certguard/blob/1.2/requirements.txt
14:44:23 <ttereshc> it should encourage to improve our automation
14:44:28 <ggainey> bmbouter: oh gorrammit, I know that. sorry
14:44:42 <ttereshc> so it's just one click to release
14:44:43 <bmbouter> ttereshc: I'm ok with that
14:44:46 <bmbouter> +1
14:44:52 <ggainey> works4me
14:45:01 <ttereshc> We can ping later fao891 and gerrod for the pulp_ansible and pulp_python, maybe. They might have a conflict with this meeting
14:45:24 <fao891> I'm here
14:45:50 <fao891> I'm not finding the question
14:45:52 <ttereshc> any plans to release pulp_ansible and what it will be compatible with?
14:45:53 <bmbouter> ggainey: so pulp-certguard needs a release, it would be 1.3 and pulpcore>=3.10,<3.14 is that right?
14:46:05 <ggainey> bmbouter: that is my understanding, yessir
14:46:08 <bmbouter> ggainey: would you possibly be able to do ths release?
14:46:10 <ttereshc> fao891, which pulpcore versions
14:46:11 <ggainey> yah, can do
14:46:16 <bmbouter> woooooot
14:46:19 <bmbouter> you da man
14:46:23 <gerrod> pulp_python 3.3.0 will be compatiable with pulpcore>=3.13,<3.15 i think
14:46:31 <fao891> yes, dalley has a PR addressing pulpcore 3.13 deprecations
14:46:50 <fao891> we plan to release as soon as we merge this
14:46:56 <bmbouter> gerrod: these releases are for the 3.12+3.13 compat though what about a python release for that?
14:47:00 <dalley> yeah that already merged
14:47:19 <ttereshc> fao891, dalley is on PTO starting tomorrow, so maybe now is a good time to figure it out.
14:47:50 <gerrod> bmbouter, i guess I can do a 3.12, 3.13 release, i'll need to revert the autopublish commit
14:47:59 <fao891> bmbouter: knows more about the state of that PR
14:48:32 <bmbouter> or python could skip that release? it's really up to you all
14:48:37 <gerrod> pulp_python 3.2.0 is compatiable for 3.12
14:49:01 <bmbouter> gerrod: great and is it also declare <3.14 in its version restriction?
14:49:02 <dalley> I don't think we need to do 2 releases, unless I'm missingsomething
14:49:29 <bmbouter> you may not be, it's starting to sound like python is already released with 3.12+3.13 declared as compatible...
14:49:41 <gerrod> bmbouter, no. it contains deprecated code so it is <3.13
14:49:49 <ttereshc> bmbouter, gerrod, sometimes plugin needs to bump a pulpcore dependency to the upcoming one. It means that this specific plugin needs to release right after pulpcore not to be block oci images for long.
14:50:26 <ttereshc> we had similar situation/problem with pulp_container I think
14:50:56 <dalley> no we definitely need a new releases for 3.13, but there was a mention of 2 releases and reverting commits, I'm not sure we need to do that
14:51:06 <bmbouter> dalley: mmm I see
14:51:11 <dalley> *a new release
14:51:34 <ttereshc> +1 for one release only
14:52:02 <bmbouter> +1
14:52:06 <gerrod> i can do it in one release
14:52:09 <ipanova> +1
14:52:39 <bmbouter> gerrod: can you recap the python release plan and the pulpcore versions it will depend on?
14:52:40 <gerrod> is autopublish supported in 3.12 though?
14:53:39 <ttereshc> dalley, ^
14:53:41 <ttereshc> I think it is
14:54:37 <dalley> on_new_version() is in pulpcore 3.12, yes
14:55:43 <gerrod> because i'm changing the 'api' for auto-distribute https://github.com/pulp/pulpcore/pull/1328 which will be in 3.13, but not 3.12 so it is hard to have the plugin be fully compatiable with both versions
14:57:15 <ttereshc> I think it's ok to require >=3.13, sometimes plugins need it
14:57:32 <bmbouter> yeah this is kind of the "skip the python release" approach?
14:57:40 <gerrod> so either i revert the autopublish commit on pulp_python and release 3.3.0 to be compatiable with 3.12>=,<3.15 or keep it and have 3.3.0 only be 3.13>=
14:57:54 <bmbouter> dalley: ^?
14:58:00 <dalley> gerrod, the latter
14:58:14 <ttereshc> It seems to me that everything is more or less planned or sorted with regards to 3.13 compatible releases, the only item is the pulp_ansible, and iiuc it is for dalley and bmbouter to sort out https://github.com/pulp/pulp_ansible/pull/563. Is my understanding correct?
14:58:29 <dalley> ttereshc, yes that's basically correct
14:58:52 <bmbouter> I think so, and we need someone to release pulp_ansible
14:59:59 <dkliban> i can do the pulp_ansible release
15:00:18 <bmbouter> that would be way cool
15:00:30 <ttereshc> yeah, just this specific pr needs to be sorted out today if dalley's feedback is needed (because of pto), that's the main reason I brought it up
15:00:56 <ttereshc> ok, are we ready to move on to triage?
15:01:17 <fao891> #info fao891 has joined triage
15:01:17 <fao891> !here
15:01:17 <pulpbot> fao891: fao891 has joined triage
15:02:15 <ttereshc> ok, let's say yes
15:02:19 <ttereshc> !next
15:02:20 <pulpbot> ttereshc: 1 issues left to triage: 8744
15:02:20 <ttereshc> #topic https://pulp.plan.io/issues/8744
15:02:21 <pulpbot> RM 8744 - equipe_serveurs@exane.com - NEW - Pulp3 database migration broken with newly release click 8
15:02:22 <pulpbot> https://pulp.plan.io/issues/8744
15:02:40 <ggainey> the rq release fixed this I think?
15:02:53 <fao891> +1
15:03:13 <ttereshc> yeah, I agree
15:03:18 <ttereshc> close as worksforme?
15:03:34 <bmbouter> I *think* so?
15:03:38 <fao891> yep
15:03:43 <ipanova> works for me
15:03:45 <bmbouter> we should look for a sec to see what pulpcore is declaring..
15:04:08 <bmbouter> actually it is resolved so yes closed WFM
15:04:19 <bmbouter> the thing that I'm thinking of is that pulpcore is now version pinning https://github.com/pulp/pulpcore/blob/master/requirements.txt#L6
15:04:24 <fao891> oh yeah, depending on the pulpcore it will be broken, 3.11.1 for example
15:04:37 <bmbouter> true, but 3.11.2 will fix
15:04:38 <ttereshc> I look at the 3.12 https://github.com/pulp/pulpcore/blob/3.12/requirements.txt#L26
15:04:41 <ttereshc> and it's fine
15:04:52 <bmbouter> oh nice
15:05:02 <bmbouter> so yeah we just need to fixup master prior to 3.13....
15:05:15 <bmbouter> because if we release from master we're going to be downgrading RQ
15:05:25 <bmbouter> let me file a quick issue for this
15:05:44 <ttereshc> +1
15:05:58 <ttereshc> #idea Proposed for #8744: close as worksforme
15:05:58 <ttereshc> !propose other close as worksforme
15:05:58 <pulpbot> ttereshc: Proposed for #8744: close as worksforme
15:06:15 <bmbouter> +1
15:06:15 <ipanova> +1
15:06:36 <ttereshc> #agreed close as worksforme
15:06:36 <ttereshc> !accept
15:06:36 <pulpbot> ttereshc: Current proposal accepted: close as worksforme
15:06:37 <pulpbot> ttereshc: No issues to triage.
15:06:50 <ttereshc> #endmeeting