14:31:57 <daviddavis> #startmeeting Pulp Triage 2021-05-25
14:31:57 <daviddavis> #info daviddavis has joined triage
14:31:57 <daviddavis> !start
14:31:57 <pulpbot> Meeting started Tue May 25 14:31:57 2021 UTC.  The chair is daviddavis. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:57 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:57 <pulpbot> The meeting name has been set to 'pulp_triage_2021-05-25'
14:31:57 <pulpbot> daviddavis: daviddavis has joined triage
14:32:09 <daviddavis> open floor https://hackmd.io/SVCMjpwXTfOMqF2OeyyLRw
14:32:12 <ipanova> #info ipanova has joined triage
14:32:12 <ipanova> !here
14:32:12 <pulpbot> ipanova: ipanova has joined triage
14:32:17 <ttereshc> #info ttereshc has joined triage
14:32:17 <ttereshc> !here
14:32:17 <pulpbot> ttereshc: ttereshc has joined triage
14:32:18 <ppicka_> #info ppicka_ has joined triage
14:32:18 <ppicka_> !here
14:32:18 <pulpbot> ppicka_: ppicka_ has joined triage
14:32:24 <mcorr> #info mcorr has joined triage
14:32:24 <mcorr> !here
14:32:24 <pulpbot> mcorr: mcorr has joined triage
14:32:25 <ggainey[m]> #info ggainey[m] has joined triage
14:32:25 <ggainey[m]> !here
14:32:26 <pulpbot> ggainey[m]: ggainey[m] has joined triage
14:32:27 <daviddavis> Any incompatible releases for upcoming 3.13 left? (except pulp_python which can be released only after 3.13 is out)
14:32:30 <dalley> #info dalley has joined triage
14:32:30 <dalley> !here
14:32:30 <pulpbot> dalley: dalley has joined triage
14:32:36 <gerrod> #info gerrod has joined triage
14:32:36 <gerrod> !here
14:32:36 <pulpbot> gerrod: gerrod has joined triage
14:32:41 <fao89> sorry, I got distracted discussing a PR with Bruno
14:32:46 <fao89> #info fao89 has joined triage
14:32:46 <fao89> !here
14:32:46 <pulpbot> fao89: fao89 has joined triage
14:33:20 <dkliban> #info dkliban has joined triage
14:33:20 <dkliban> !here
14:33:20 <pulpbot> dkliban: dkliban has joined triage
14:33:39 <ttereshc> I'm not aware of any, pulp_rpm is out for sure
14:34:21 <bmbouter> #info bmbouter has joined triage
14:34:21 <bmbouter> !here
14:34:21 <pulpbot> bmbouter: bmbouter has joined triage
14:34:21 <dkliban> pulp_ansible and pulp_maven
14:34:58 <dkliban> i believe pulp_ansible and pulp_maven still need to be released for compatibility with 3.13
14:35:43 <fao89> dkliban: do you think your release automation will be ready?
14:36:06 <dkliban> i am trying to fully finish it this afternoon
14:36:16 <fao89> I didn't release pulp-ansible, so you could have a plugin to test
14:36:19 <ggainey[m]> dkliban++
14:36:19 <pulpbot> ggainey[m]: dkliban's karma is now 594
14:36:33 <fao89> dkliban++
14:36:33 <pulpbot> fao89: dkliban's karma is now 595
14:37:17 <ttereshc> those releases are not blocking pulpcore one, right? just oci images can't be pushed right away
14:37:24 <dkliban> that's right
14:37:28 <fao89> yep
14:37:32 <ttereshc> great
14:38:00 <daviddavis> next topic?
14:38:04 <dkliban> yes
14:38:06 <fao89> but if the release automation script is successful with pulp-ansible and pulp-maven, may be worth to use on pulpcore
14:38:50 <daviddavis> Topic: Does it make sense to start doing regular Z releases (for the latest Y stream) and not wait with bugfixes for the next Y release.
14:39:13 <bmbouter> I think it may if we had it fully automated
14:39:18 <ttereshc> I added this one, mostly based on user's struggles and expectations
14:39:23 <ttereshc> I have an example
14:39:25 <bmbouter> as it is now though I don't think we can afford it
14:39:28 <fao89> I think this is kind of chicken & egg with release automation
14:39:49 <ggainey[m]> yeah, if release-auto is solid, I could see us just auto-backporting anything that doesn't need a migration every week or two
14:39:54 <ttereshc> this was backported to 3.11 but never released in 3.12 and is waiting on 3.13 https://github.com/pulp/pulpcore/commit/52bb2ab94be24652ca12ad27daa56328832fc8a7
14:40:06 <dkliban> that's not good
14:40:10 <ggainey[m]> ouch
14:40:14 <ttereshc> a user upgraded from 3.11 with a fix to the latest - 3.12.z
14:40:22 <ttereshc> and hits the issue
14:40:26 <bmbouter> it isn't but also ... things in open source aren't fixed because someone out there hasn't fixed it yet
14:40:28 <ttereshc> it is very unexpected
14:40:44 <dkliban> i agree that it's unexpected
14:40:51 <bmbouter> me too
14:40:53 <ipanova> ttereshc:  i agree
14:40:59 <fao89> upgrade tests will help with that
14:41:11 <ttereshc> the user is our great wibbit1 who was going live withpulp that week and had to pacth their system
14:41:37 <bmbouter> yup and users had to downgrade django also on the list
14:41:40 <ggainey[m]> I would think, at a minimum, anything backported to older releases (3.7, 3.11) need to automatically go into latest-released-version, to avoid this exact issue
14:41:57 <ttereshc> I just want to raise the awareness and increase the priority to produce Z releases for the latest Y
14:42:03 <dkliban> yeah ... but we need to have better automation in place.
14:42:08 <ggainey[m]> +1
14:42:13 <dkliban> so let's come back to this topic again next week
14:42:24 <bmbouter> agreed
14:42:25 <ggainey[m]> heh, sounds like a fine plan :)
14:42:30 <ttereshc> thank you
14:42:44 <bmbouter> I think we should continue to invest in release automation over almost all things until it's literally click-to-release
14:42:50 <ggainey[m]> +100
14:43:17 <daviddavis> Topic: libera.chat and Project registering
14:43:29 <ggainey[m]> fun
14:43:32 <daviddavis> I think mcorr submitted an application to register pulp on libera
14:43:35 <mcorr> I sent an email to express our interest in registering Pulp
14:43:37 <mcorr> snap
14:43:40 <daviddavis> hehe
14:43:58 <ggainey[m]> daviddavis: you have a doc answering the project-questions yeah?
14:44:13 <mcorr> What do people think about matrix as primary with a Libera bridge?
14:44:30 <ggainey[m]> I would really like to see us off of freenode as soon as there's a matrix-bridge to libera - we have a growing matrix community
14:44:34 <bmbouter> I'm really hoping we use matrix as primary
14:44:48 <fao89> matrix++
14:44:48 <pulpbot> fao89: matrix's karma is now 1
14:44:53 <ggainey[m]> mcorr: that's exactly what I'm experimenting with, for me personally
14:44:55 <bmbouter> and I'm also not sure we need a secondary (just saying)
14:45:01 <mcorr> There's this beta called Matrix Spaces that is an evolution on from Community and it looks very nice.
14:45:05 <ggainey[m]> bmbouter: do we know how bots work on matrix?
14:45:10 <bmbouter> we do
14:45:22 <mcorr> ggainey:  I can look into that
14:45:28 <bmbouter> oh how... yeah there are do
14:45:29 <ggainey[m]> @mcorr
14:45:32 <ggainey[m]> oops, bah
14:45:33 <bmbouter> docs
14:45:57 <ggainey[m]> mcorr: I'm thinking about pulpbot and karma and meetings like, say, this one :)
14:45:59 <ggainey[m]> yeah
14:46:09 <mcorr> Sure, ggainey  let me take that as an item
14:46:20 <bmbouter> we will need to move our meeting-bot over at the least. mcorr ty!
14:46:28 <ggainey[m]> +1
14:46:38 <mcorr> Karma is good for the soul also
14:46:39 <bmbouter> we could move to matrix for all the rooms except #pulp-meeting until the bot is in place
14:47:04 <mcorr> I will set up a space and Pulp rooms and advertise. What do you think?
14:47:18 <mcorr> We currently only have bridges
14:47:32 <ggainey[m]> I mean, works4me, but that's partially because I've spent the last hour getting set up on matrix :)
14:47:52 <mcorr> survivor bias
14:47:54 <mcorr> :)
14:48:01 <dkliban> i am +1 on moving everything to matrix except meeting
14:49:17 <daviddavis> ok, next topic?
14:49:28 <ggainey[m]> sure
14:49:33 <bmbouter> +1
14:50:09 <daviddavis> Topic [combined]: Should we move our user mailing lists to Github Discussions or Discourse?
14:50:13 <fao89> +1 for github discussions
14:50:31 <ggainey[m]> huh, interesting
14:50:37 <ttereshc> what's the reason for moving?
14:50:40 <mcorr> daviddavis:  can we have Discussions on an organization level rather than repo level?
14:50:49 <ipanova> so we have 2 mailing list pulp-list and pulp-dev how we decouple those?
14:51:04 <fao89> mcorr: I think they are all ported to organization level
14:51:14 <ggainey[m]> from a "lowering impedance" POV, having everything next to the code (discussions,  GH issues) makes sense
14:51:18 <daviddavis> no, they are on the repo level I believe
14:51:24 <bmbouter> yes on repo level
14:51:32 <bmbouter> I think pulpcore would be the primary one in that case
14:51:48 <mcorr> I find the repo level issue the biggest detractor from them.
14:51:51 <ggainey[m]> oh bleah - yeah, def pick one instead one-per-plugin
14:51:58 <daviddavis> yea agreed
14:52:02 <ttereshc> could anyone state the goals or the problems we are solving with the move?
14:52:05 <bmbouter> yes
14:52:10 <mcorr> ttereshc:  the logic would be to make it easier for users to ask and answer questions, not sign up to a ML to ask one question
14:52:21 <bmbouter> yup what mcorr said
14:52:33 <mcorr> with Foreman, for example, we have data to show how engagement increased on RFCs after the move to Discourse
14:52:33 <daviddavis> also, things like searching mailing lists aren't possible (or are difficult)
14:52:59 <ggainey[m]> (well, our mailing lists anyway. Mailman is...kinda suboptimal, alas :( )
14:53:14 <ttereshc> ok, thx
14:53:21 <bmbouter> it's also not browser native which creates more friction
14:53:42 <mcorr> Discourse is plugin based, which would allow us to centralise more of our activities around it
14:54:05 <mcorr> the negative would be either we pay for hosting, or self host, which would require some initial setup
14:54:09 <ttereshc> any example of known projects which use github discussions? (to see how it looks at scale)
14:54:31 <bmbouter> we avoid self-hosting at pretty much all costs
14:54:32 <ggainey[m]> ttereshc: good question
14:54:33 <daviddavis> yea, I have an example at https://github.com/daviddavis/pulpcore/discussions but also https://github.com/vercel/next.js/discussions
14:54:34 <mcorr> It's so new I've yet to see it in action but +1 to ttereshc 's point
14:54:44 <bmbouter> we also avoid pay-for services at basically any cost
14:54:47 <ggainey[m]> yeah, self-hosting is a non-starter, we have too much to do already
14:55:04 <mcorr> Can we change the categories daviddavis ?
14:55:17 <daviddavis> yea, they're customizable
14:55:31 <ttereshc> ty daviddavis , that helps
14:55:32 <fao89> it is possible to have discussions at org level: https://github.com/github
14:55:41 <bmbouter> oh nice
14:55:48 <ggainey[m]> awesome!
14:55:48 <mcorr> niccceee
14:55:54 <fao89> it gathers discussions from all repos: https://github.com/orgs/github/discussions
14:56:00 <daviddavis> ah nice
14:56:07 <bmbouter> also I think there is a big benefit to just using tooling from one provider as much as possible (github in this case)
14:56:10 <ggainey[m]> RE categories - that would also answer the "differentiate between -list and -dev", yeah?
14:56:21 <mcorr> +1 to this from me if we can host on an org level
14:56:32 <daviddavis> ggainey[m]: I think so
14:56:41 <daviddavis> we could have a Development category
14:56:56 <daviddavis> and then an Announcement category and Help category?
14:56:57 <bmbouter> if we look at the real reason we have two mailing lists it's because people didn't want to constantly be emailed for one or the other...    with people not receiving email I'm not sure it really matters anymore
14:57:08 <daviddavis> +1
14:57:09 <bmbouter> +1 to these categories
14:57:11 <ggainey[m]> maybe we can make this That Summer When Pulp Got All Its Comms In One Place :)
14:57:22 <mcorr> lol
14:57:33 <bmbouter> yes please!
14:57:53 <ipanova> my probably one of arguments would be to move to discussions once we move to github issues. it will be very un logical to have this spread
14:58:10 <ggainey[m]> I mean, there's a bunch of work to do to get there - but even Grant The Curmudgeon thinks we should do this (or at least something a lot like this)
14:58:12 <mcorr> what is blocking us moving to github issues?
14:58:21 <bmbouter> a well thought out, prioritized plan
14:58:22 <daviddavis> the amount of work
14:58:24 <bmbouter> yup
14:58:27 <ggainey[m]> yeah, zacly
14:58:30 <mcorr> lol
14:58:31 <bmbouter> which is why I don't want to connect these things
14:58:36 <ggainey[m]> and priorities
14:58:39 <bmbouter> we need to retire the mailing lists ... and soon
14:58:49 <ttereshc> +1 not to connect those
14:59:01 <daviddavis> +1 to not connect
14:59:22 <mcorr> is there a roadmap or timeline or is it just a hope atm to move to GH issues?
14:59:25 <ipanova> bmbouter: i would like to avoid frequent explanations of  why i need to start a discussion on github but i still cannot file a github issue..
14:59:35 <ggainey[m]> mcorr: it's Aspirational still
14:59:54 <ttereshc> github discussions seemed to improved from what I saw few months ago, it looks quite convenient, so +1 to move there
15:00:15 <daviddavis> ipanova: I'm happy to handle those conversations :)
15:00:41 <ipanova> we already have feedback from users that our workflows are very much spread/decentralized.
15:00:56 <daviddavis> yea, but issue tracking and mailing lists are already spread IMO
15:01:03 <fao89> on pulpkhan we announce to the world we going full github
15:01:10 <bmbouter> agreed, I don't think this makes it any worse
15:01:18 <bmbouter> oh I was thinking switch to discussions like in a few days...
15:01:19 <ipanova> i am excited about how GH discussions look regardless the argument i have previously stated
15:01:24 <ggainey[m]> I think ppl will put up with decentralized if/when we have a plan for how/when we're fixing that
15:01:36 <ggainey[m]> heheh
15:01:56 <daviddavis> what if we set up pulpcore discussions as a trial for a month or so and then we decommision the mailing list if everyone is happy?
15:02:07 <mcorr> can we not do repo level though ever
15:02:16 <ggainey[m]> +1 to both of the above
15:02:19 <bmbouter> wait can't we do repo level? (I'm confused)
15:02:25 <fao89> full github: actions (x)  discussions (loading), issues (loading)
15:02:31 <mcorr> We can but I really don't think we should
15:02:41 <daviddavis> I think we have to do repo level although you can access discussion across repos at the org level
15:02:54 <mcorr> Ah
15:03:02 <daviddavis> the example fao89 shared (https://github.com/orgs/github/discussions) shows discussions across repos
15:03:10 <daviddavis> but we can just standardize and do only pulpcore
15:03:24 <fao89> from what I saw, org level == gather all repo level
15:03:39 <bmbouter> oic yup, that's fine pulpcore can default, other plugins for other plugin-specific topics
15:03:41 <mcorr> can someone raise an issue from the org view?
15:03:41 <ggainey[m]> yeah - let's not make users guess which plugin they think they're having an issue with
15:03:52 <ggainey[m]> (esp since I don't think you can move a GH discussion from one repo to another? is that correct?)
15:03:59 <bmbouter> can we recap this as a proposal with an AI?
15:03:59 <daviddavis> mcorr: a discussion? no
15:04:13 <mcorr> hmmm
15:04:23 <mcorr> that's a major detractor imv
15:04:31 <ggainey[m]> yeah the one downside w/ GH issues vs plan.io, is you can't move issues
15:04:48 <bmbouter> we can't continue with plan.io tho
15:05:10 <ggainey[m]> yeah, it's a downside, but I think the downsides of "where we are" outweighs it
15:05:17 <bmbouter> and part of the issues is that NextThing will always have one thing maybe not as great, which creates a huge advantage for our current status quo
15:05:36 <bmbouter> yeah exactly, so instead of thinking about one specific thing we loose think about it as a balance of what we get versus loose
15:05:42 <mcorr> fair point, just Discourse does this better
15:05:46 <bmbouter> also lose
15:05:51 <bmbouter> versus loose
15:05:53 <bmbouter> english is hard
15:05:55 <ggainey[m]> heh
15:06:07 <ggainey[m]> bmbouter: in Matrix, you can edit your typos
15:06:11 <ggainey[m]> (which I hate, actually :) )
15:06:16 <daviddavis> ha
15:06:17 <bmbouter> oh I know, 3 year matrix user over here
15:06:22 <ggainey[m]> ha! kk
15:06:31 <daviddavis> so does anyone object to setting up a pulpcore discourse and trying it out?
15:06:35 <daviddavis> err discussion
15:06:41 <mcorr> ololol
15:06:44 <bmbouter> ggainey[m]: I love that feature!
15:06:44 <daviddavis> hehe
15:07:04 <ggainey[m]> hehe
15:07:11 <mcorr> can we admit to the community that we want off plan.io
15:07:21 <bmbouter> I think so
15:07:26 <daviddavis> absolutely, it was a topic at the last pulpcon
15:07:26 <mcorr> Perfect
15:07:44 <daviddavis> ok, I'll take an AI and email the lists
15:07:47 <daviddavis> with a proposal
15:07:51 <ggainey[m]> I think I'd like to see a list of actions/steps, even if it's just a list of bullet points
15:07:59 <ggainey[m]> there we go
15:08:04 <ggainey[m]> daviddavis++
15:08:04 <pulpbot> ggainey[m]: daviddavis's karma is now 517
15:08:06 <bmbouter> daviddavis: +! and ty
15:08:12 <ipanova> thanks daviddavis
15:08:21 <daviddavis> Topic: What to replace freenode with?
15:08:39 <fao89> matrix
15:08:41 <mcorr> Matrix
15:08:43 <bmbouter> so I didn't realize we had agenda undone from last time
15:08:45 <bmbouter> Matrix
15:08:59 <bmbouter> so this is a duplicate agenda item accidentally put by me
15:09:03 <daviddavis> +1
15:09:04 <ggainey[m]> I would like to see us go matrix-primary. I think it's going to take time to get users off of IRC, that aren't already on Matrix. I really want us off of freenode asap
15:09:31 <mcorr> +1
15:09:34 <daviddavis> triage time?
15:09:43 <daviddavis> !next
15:09:45 <fao89> +1
15:09:45 <pulpbot> daviddavis: 13 issues left to triage: 8810, 8803, 8801, 8798, 8797, 8796, 8793, 8791, 8789, 8782, 8781, 8779, 8744
15:09:45 <daviddavis> #topic https://pulp.plan.io/issues/8810
15:09:46 <pulpbot> RM 8810 - fao89 - NEW - Operator fails to deploy pulp-api
15:09:47 <pulpbot> https://pulp.plan.io/issues/8810
15:09:58 <daviddavis> !skip
15:09:59 <daviddavis> #topic https://pulp.plan.io/issues/8803
15:09:59 <pulpbot> daviddavis: 12 issues left to triage: 8803, 8801, 8798, 8797, 8796, 8793, 8791, 8789, 8782, 8781, 8779, 8744
15:10:00 <pulpbot> RM 8803 - bmbouter - NEW - As a user, I have docs on how to integrate with a Keycloak server
15:10:01 <pulpbot> https://pulp.plan.io/issues/8803
15:10:06 <fao89> we need to change triage query
15:10:10 <daviddavis> +1
15:10:16 <daviddavis> #idea Proposed for #8803: convert to user story
15:10:16 <daviddavis> !propose other convert to user story
15:10:16 <pulpbot> daviddavis: Proposed for #8803: convert to user story
15:10:25 <fao89> +1
15:10:31 <daviddavis> #agreed convert to user story
15:10:31 <daviddavis> !accept
15:10:31 <pulpbot> daviddavis: Current proposal accepted: convert to user story
15:10:32 <daviddavis> #topic https://pulp.plan.io/issues/8801
15:10:32 <pulpbot> daviddavis: 11 issues left to triage: 8801, 8798, 8797, 8796, 8793, 8791, 8789, 8782, 8781, 8779, 8744
15:10:33 <pulpbot> RM 8801 - bmbouter - NEW - Move existing Webserver Auth docs to new Authenticaiton top-level section
15:10:34 <pulpbot> https://pulp.plan.io/issues/8801
15:10:42 <daviddavis> !propose task
15:10:42 <pulpbot> daviddavis: Error: "propose" is not a valid command.
15:10:44 <ggainey[m]> same
15:10:50 <daviddavis> #idea Proposed for #8801: convert to task
15:10:50 <daviddavis> !propose other convert to task
15:10:50 <pulpbot> daviddavis: Proposed for #8801: convert to task
15:10:55 <daviddavis> #agreed convert to task
15:10:55 <daviddavis> !accept
15:10:55 <pulpbot> daviddavis: Current proposal accepted: convert to task
15:10:56 <daviddavis> #topic https://pulp.plan.io/issues/8798
15:10:56 <pulpbot> daviddavis: 10 issues left to triage: 8798, 8797, 8796, 8793, 8791, 8789, 8782, 8781, 8779, 8744
15:10:57 <pulpbot> RM 8798 - daviddavis - NEW - Content summary shows incorrect numbers when previous version is deleted
15:10:58 <pulpbot> https://pulp.plan.io/issues/8798
15:10:59 <fao89> +1
15:11:10 <ipanova> accept
15:11:17 <bmbouter> +1
15:11:19 <ttereshc> +1
15:11:27 <daviddavis> #idea Proposed for #8798: Leave the issue as-is, accepting its current state.
15:11:27 <daviddavis> !propose accept
15:11:27 <pulpbot> daviddavis: Proposed for #8798: Leave the issue as-is, accepting its current state.
15:11:35 <daviddavis> #agreed Leave the issue as-is, accepting its current state.
15:11:35 <daviddavis> !accept
15:11:35 <pulpbot> daviddavis: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:11:36 <pulpbot> daviddavis: 9 issues left to triage: 8797, 8796, 8793, 8791, 8789, 8782, 8781, 8779, 8744
15:11:36 <daviddavis> #topic https://pulp.plan.io/issues/8797
15:11:37 <pulpbot> RM 8797 - wibbit - NEW - Pulp location of CSS etc for API browser (and/or dependancies)
15:11:38 <pulpbot> https://pulp.plan.io/issues/8797
15:12:16 <ggainey[m]> that sceenshot tho :)
15:12:26 <ggainey[m]> welcome to 1996
15:13:34 <ggainey[m]> accept?
15:13:44 <bmbouter> +1
15:13:56 <daviddavis> #idea Proposed for #8797: Leave the issue as-is, accepting its current state.
15:13:56 <daviddavis> !propose accept
15:13:56 <pulpbot> daviddavis: Proposed for #8797: Leave the issue as-is, accepting its current state.
15:14:04 <daviddavis> #agreed Leave the issue as-is, accepting its current state.
15:14:04 <daviddavis> !accept
15:14:04 <pulpbot> daviddavis: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:14:05 <daviddavis> #topic https://pulp.plan.io/issues/8796
15:14:05 <pulpbot> daviddavis: 8 issues left to triage: 8796, 8793, 8791, 8789, 8782, 8781, 8779, 8744
15:14:06 <pulpbot> RM 8796 - xzhang1 - NEW - `pulpcore-manager` failed for AttributeError: 'Settings' object has no attribute 'CONTENT_ORIGIN'
15:14:07 <pulpbot> https://pulp.plan.io/issues/8796
15:14:24 <ggainey[m]> user's found the solution and asked to close - close notabug
15:14:27 <bmbouter> +1
15:14:37 <ipanova> +1
15:14:38 <daviddavis> #idea Proposed for #8796: close notabug
15:14:38 <daviddavis> !propose other close notabug
15:14:38 <pulpbot> daviddavis: Proposed for #8796: close notabug
15:14:43 <ttereshc> +1
15:14:48 <ipanova> err works for me rather
15:14:54 <daviddavis> #agreed close notabug
15:14:54 <daviddavis> !accept
15:14:54 <pulpbot> daviddavis: Current proposal accepted: close notabug
15:14:55 <daviddavis> #topic https://pulp.plan.io/issues/8793
15:14:55 <pulpbot> daviddavis: 7 issues left to triage: 8793, 8791, 8789, 8782, 8781, 8779, 8744
15:14:56 <pulpbot> RM 8793 - gerrod - POST - Retained_versions doesn't properly keep all content present in repository
15:14:57 <pulpbot> https://pulp.plan.io/issues/8793
15:15:00 <ipanova> actually, does not really matter
15:15:06 <daviddavis> oh ok
15:15:12 <ttereshc> in post
15:15:18 <ttereshc> accept and add to the sprint
15:15:19 <ipanova> accept, add to sprint
15:15:20 <bmbouter> +1
15:15:21 <daviddavis> #idea Proposed for #8793: accept and add to sprint
15:15:21 <daviddavis> !propose other accept and add to sprint
15:15:21 <pulpbot> daviddavis: Proposed for #8793: accept and add to sprint
15:15:22 <daviddavis> #agreed accept and add to sprint
15:15:22 <daviddavis> !accept
15:15:22 <pulpbot> daviddavis: Current proposal accepted: accept and add to sprint
15:15:23 <pulpbot> daviddavis: 6 issues left to triage: 8791, 8789, 8782, 8781, 8779, 8744
15:15:23 <daviddavis> #topic https://pulp.plan.io/issues/8791
15:15:24 <pulpbot> RM 8791 - wibbit - NEW - Usability of "fields" when querying rpm content types
15:15:25 <pulpbot> https://pulp.plan.io/issues/8791
15:15:51 <ggainey[m]> oh yeah, we had some discussion w/wibbit on this one
15:15:53 <ttereshc> I remember discussing this one
15:16:31 <ttereshc> I think fields require full list, including the required ones
15:16:34 <ggainey[m]> yeah - you can limit fields, but if you don't include mandatory ones (which aren't documented anywhere/clearly), you're going to have a Bad Time
15:17:06 <ttereshc> it's very painful, +1 to fix this ux issue
15:17:22 <ggainey[m]> I'd say accept, I don't know that I'd add to the sprint - but yeah, we def want to do "something" here
15:17:50 <ipanova> ttereshc: i think i recall something similar lubos fixed once already..
15:18:03 <ipanova> but yeah +1 to accept
15:18:22 <daviddavis> #idea Proposed for #8791: Leave the issue as-is, accepting its current state.
15:18:22 <daviddavis> !propose accept
15:18:22 <pulpbot> daviddavis: Proposed for #8791: Leave the issue as-is, accepting its current state.
15:18:31 <daviddavis> #agreed Leave the issue as-is, accepting its current state.
15:18:31 <daviddavis> !accept
15:18:31 <pulpbot> daviddavis: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:18:32 <daviddavis> #topic https://pulp.plan.io/issues/8789
15:18:32 <pulpbot> daviddavis: 5 issues left to triage: 8789, 8782, 8781, 8779, 8744
15:18:33 <pulpbot> RM 8789 - wibbit - NEW - Take down readthedocs sites
15:18:34 <pulpbot> https://pulp.plan.io/issues/8789
15:18:40 <ggainey[m]> task
15:18:44 <daviddavis> dkliban: can you work on this ^?
15:18:54 <ggainey[m]> and add - this is confusing :(
15:19:05 <daviddavis> #idea Proposed for #8789: convert to dkliban task
15:19:05 <daviddavis> !propose other convert to dkliban task
15:19:05 <pulpbot> daviddavis: Proposed for #8789: convert to dkliban task
15:19:07 <bmbouter> yes please!
15:19:10 <dkliban> yeah i can
15:19:13 <daviddavis> dkliban++
15:19:13 <pulpbot> daviddavis: dkliban's karma is now 596
15:19:16 <daviddavis> #agreed convert to dkliban task
15:19:16 <daviddavis> !accept
15:19:16 <pulpbot> daviddavis: Current proposal accepted: convert to dkliban task
15:19:16 <daviddavis> #topic https://pulp.plan.io/issues/8782
15:19:17 <pulpbot> daviddavis: 4 issues left to triage: 8782, 8781, 8779, 8744
15:19:17 <bmbouter> also I think python never moved maybe?
15:19:18 <ggainey[m]> dkliban++
15:19:18 <pulpbot> RM 8782 - alikins - NEW - Intermittent psycopg2.errors.AdminShutdown errors in galaxy_ng dev env and pulp-all-in-one
15:19:19 <pulpbot> https://pulp.plan.io/issues/8782
15:19:20 <pulpbot> ggainey[m]: dkliban's karma is now 597
15:19:40 <ttereshc> it would be also good to agree how we do it, since they show up in google search
15:19:42 <bmbouter> yeah https://docs.pulpproject.org/pulp_python/
15:19:55 <bmbouter> gerrod: fyi ^
15:20:03 <ttereshc> can we have a redirect or some announcement and not just put it down
15:20:09 <ggainey[m]> +1
15:20:20 <bmbouter> we aren't in control of redirects
15:20:54 <bmbouter> we could post an announcement
15:21:05 <ipanova> ttereshc: we should also take down docs for the migration plugin
15:21:22 <daviddavis> these sites are already on docs.pulpproject.org?
15:21:23 <ttereshc> ipanova, it's there, in the list
15:21:41 <ipanova> ttereshc: ok
15:21:48 <bmbouter> I think each one needs to be checked... I just happened to notice pulp_python wasn't but I didn't check every one (just the ones for my prezi)
15:21:57 <daviddavis> +1
15:22:05 <fao89> pulp-installer and pulp-operator are on readthedocs
15:22:26 <fao89> maybe we need to move them for consistency
15:22:32 <ggainey[m]> sounds like we need an epic, to clean up all the pieces parts
15:22:36 <ggainey[m]> yeah
15:22:40 <daviddavis> I see. well hopefully dkliban will do all this and send out an announcement.
15:22:47 <ggainey[m]> 2021: The Summer Pulp Got Consistent :)
15:22:52 <daviddavis> hehe
15:22:54 <fao89> (both use mkdocs which deploys differently than plugins)
15:23:06 <ggainey[m]> ahhhh
15:23:38 <ggainey[m]> so, 8782 - accept?
15:23:55 <fao89> +1 to accept
15:24:02 <ttereshc> convert to a task
15:24:09 <ttereshc> to an epic task
15:24:12 <ggainey[m]> 8782?
15:24:19 <ttereshc> oops, sorry
15:24:21 <ttereshc> no :)
15:24:27 <daviddavis> #idea Proposed for #8782: Leave the issue as-is, accepting its current state.
15:24:27 <daviddavis> !propose accept
15:24:28 <pulpbot> daviddavis: Proposed for #8782: Leave the issue as-is, accepting its current state.
15:24:29 <bmbouter> yeah so re 8782 ... I have also seen this
15:24:37 <bmbouter> I propose we leave untriaged
15:24:42 <daviddavis> ttereshc: I'll tell dkliban to convert it to an epic ;)
15:24:44 <bmbouter> we have no reproducer and it needs resolution
15:24:49 <daviddavis> #idea Proposed for #8782: Skip this issue for this triage session.
15:24:49 <daviddavis> !propose skip
15:24:49 <pulpbot> daviddavis: Proposed for #8782: Skip this issue for this triage session.
15:24:54 <ggainey[m]> ah kk
15:24:58 <bmbouter> +1
15:25:05 <daviddavis> bmbouter: is alikins aware?
15:25:13 <bmbouter> aware of ?
15:25:20 <daviddavis> that we need a reproducer from him
15:25:35 <bmbouter> so I think I have to best reproducer actually
15:25:40 <daviddavis> oh ok
15:25:41 <bmbouter> he said he couldn't reproduce it, same with @himnel
15:25:46 <daviddavis> +1
15:25:47 <bmbouter> but it only happens about 25% of the time
15:25:54 <bmbouter> I can post what I have on it
15:25:57 <alikins> re 8782, yeah. I haven't had a chance to reproduce it well. But bmbouter as seen it.
15:26:06 <daviddavis> +1
15:26:12 <bmbouter> let's skip now and I'll post what I have on it
15:26:17 <daviddavis> #agreed Skip this issue for this triage session.
15:26:17 <daviddavis> !accept
15:26:17 <pulpbot> daviddavis: Current proposal accepted: Skip this issue for this triage session.
15:26:19 <daviddavis> #topic https://pulp.plan.io/issues/8781
15:26:19 <pulpbot> daviddavis: 3 issues left to triage: 8781, 8779, 8744
15:26:21 <pulpbot> RM 8781 - newswangerd - NEW - /pulp/api/v3/ throws a 500
15:26:22 <pulpbot> https://pulp.plan.io/issues/8781
15:26:32 <ggainey[m]> huh, that's rude
15:26:56 <daviddavis> it's not happening for me though
15:26:59 <bmbouter> me neither
15:27:19 <daviddavis> let me ask about what plugins and pulpcore version they're using
15:27:28 <ttereshc> the traceback leads  to the galaxy_ng
15:27:35 <daviddavis> yea
15:27:35 <bmbouter> agreed
15:27:43 <daviddavis> I'll comment
15:27:48 <daviddavis> #idea Proposed for #8781: daviddavis to comment
15:27:48 <daviddavis> !propose other daviddavis to comment
15:27:48 <pulpbot> daviddavis: Proposed for #8781: daviddavis to comment
15:27:59 <ttereshc> and this endpoint should return schema I think, and not 404
15:28:08 <daviddavis> yea, that's what it does for me
15:28:12 <daviddavis> but I don't have galaxy ng
15:28:17 <ggainey[m]> yeah, I just tested and that's what I see
15:28:30 <ttereshc> +1 to proposal
15:28:35 <ggainey[m]> but yeah, I'm on pulp2-pulp3-centos
15:28:58 <ggainey[m]> +1
15:29:13 <daviddavis> #agreed daviddavis to comment
15:29:13 <daviddavis> !accept
15:29:13 <pulpbot> daviddavis: Current proposal accepted: daviddavis to comment
15:29:14 <daviddavis> #topic https://pulp.plan.io/issues/8779
15:29:14 <pulpbot> daviddavis: 2 issues left to triage: 8779, 8744
15:29:16 <pulpbot> RM 8779 - adam.winberg@smhi.se - NEW - Task started on removed worker
15:29:17 <pulpbot> https://pulp.plan.io/issues/8779
15:30:01 <ggainey[m]> oh wow - I think this is the problem we've seen several times now, when something catastrophic happens on pulp3
15:30:16 <ttereshc> yup
15:30:23 <ggainey[m]> trying to recover from "tasks assigned to a worker that doesn't exist any more"
15:30:28 <ttereshc> have we seen it on 3.12+?
15:30:37 <ggainey[m]> hrm
15:30:39 <bmbouter> so we made a series of "improvements" I'd have to look at versions but I think as far back as 3.9
15:31:21 <bmbouter> dalley: I think we should consider reverting anything on 3.11+ ...
15:31:24 <bmbouter> or do nothing
15:31:32 <bmbouter> and recommend users use the new tasking system with 3.14
15:32:37 <ttereshc> user is on 3.11, there were fixes in 3.12, so I'm not sure if they affect this behavior but they might
15:32:44 <ggainey[m]> this is going to bite us , esp on systems under heavy load (since that's where "I ran out of RAM/disk" is most likely to happen)
15:32:51 <dalley> that's potentially the correct thing for users, but "downstream" needs a working tasking system one way or another
15:32:58 <ggainey[m]> yeah
15:33:12 <bmbouter> I don't think we can make the split data over postgresql and redis reliable
15:33:14 <dalley> it's not like the tasking system was working properly prior to these fixes even if they're incomplete
15:33:16 <bmbouter> or transactionally safe
15:33:43 <bmbouter> I think the only way to solve this is to have downstream (or anyone) switch to the new system with 3.14
15:34:16 <bmbouter> but we can tackle this in #pulp-dev, for triage what do we want to do?
15:34:28 <daviddavis> skip?
15:34:33 <bmbouter> I'm ok w/ skip
15:34:37 <dalley> try to collect all of these issues and figure which are dups
15:34:37 <daviddavis> or accept
15:35:05 <ggainey[m]> dalley: +1 to that
15:35:10 <dalley> personally, we know this is an issue, we should probably accept
15:35:23 <daviddavis> #idea Proposed for #8779: Leave the issue as-is, accepting its current state.
15:35:23 <daviddavis> !propose accept
15:35:23 <pulpbot> daviddavis: Proposed for #8779: Leave the issue as-is, accepting its current state.
15:35:38 <bmbouter> that's ok w/ me, my concern is that after accepting we don't act
15:35:39 <ggainey[m]> yeah, +1
15:35:52 <bmbouter> also I don't know how to use commas
15:35:53 <fao89> +1
15:35:53 <dalley> yeah, no, we absolutely need to get this figured out
15:36:00 <bmbouter> dalley does tho :)
15:36:08 <dalley> lol
15:36:08 <ggainey[m]> heheh
15:36:08 <ttereshc> :)
15:36:28 <daviddavis> #idea Proposed for #8779: Skip this issue for this triage session.
15:36:28 <daviddavis> !propose skip
15:36:28 <pulpbot> daviddavis: Proposed for #8779: Skip this issue for this triage session.
15:36:36 <dalley> whichever issue is left standing afterwards should probably be high sev / high prio
15:36:37 <bmbouter> I'm ok w/ either, let's convo about it in #pulp-dev
15:36:41 <bmbouter> agreed
15:36:43 <daviddavis> #agreed Skip this issue for this triage session.
15:36:43 <daviddavis> !accept
15:36:43 <pulpbot> daviddavis: Current proposal accepted: Skip this issue for this triage session.
15:36:44 <pulpbot> daviddavis: 1 issues left to triage: 8744
15:36:44 <daviddavis> #topic https://pulp.plan.io/issues/8744
15:36:45 <pulpbot> RM 8744 - equipe_serveurs@exane.com - NEW - Pulp3 database migration broken with newly release click 8
15:36:46 <pulpbot> https://pulp.plan.io/issues/8744
15:36:54 <daviddavis> is this one fixed?
15:36:57 <ggainey[m]> this fixed now yeah?
15:37:13 * daviddavis hears an echo
15:37:14 <ggainey[m]> ^fixed^is fixed
15:37:36 <bmbouter> it'll be fixed on 3.11 and upcoming 3.13
15:37:45 <fao89> depends on the pulpcore version
15:37:53 <ggainey[m]> ah
15:37:56 <fao89> 3.12 may break for example
15:37:57 <bmbouter> pulpcore==3.11.2, pulpcore==3.13.0+
15:38:14 <bmbouter> yup and recalling our convo from earlier, we can't afford to do better right now
15:38:23 <fao89> yep
15:38:35 <bmbouter> in fact I'm still trying to get 3.11.2 out the door :/
15:38:43 <daviddavis> fun times
15:38:46 <bmbouter> ja
15:39:03 <ggainey[m]> accept and add, then close when 3.13 goes out?
15:39:22 <bmbouter> I can also comment on it now indicating which pulpcore will resolve it...
15:39:30 <bmbouter> or that they can manually downgrade click and upgrade RQ
15:39:42 <daviddavis> #idea Proposed for #8744: bmbouter to comment on issue
15:39:42 <daviddavis> !propose other bmbouter to comment on issue
15:39:42 <pulpbot> daviddavis: Proposed for #8744: bmbouter to comment on issue
15:39:46 <ggainey[m]> +1
15:39:52 <daviddavis> #agreed bmbouter to comment on issue
15:39:52 <daviddavis> !accept
15:39:52 <pulpbot> daviddavis: Current proposal accepted: bmbouter to comment on issue
15:39:53 <pulpbot> daviddavis: No issues to triage.
15:39:55 <daviddavis> #endmeeting
15:39:55 <daviddavis> !end